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Tutorials

Tutorial 1: with a grain of salt

According to any freshmen's textbook in NaCl one electron is transferred from the Sodium to the Chlorine.
The occupied 3p states form the valence band, while the empty sodium states hybridize into a conduction
band. We will put these idealized ideas to the test.

This tutorial will learn you how to:

¥ define the geometry of a NaCl crystal
¥ run the calculation
¥ view the band structure
¥ view an orbital for a particular band and k-point
¥ view the (partial) density of states
¥ view the deformation density
¥ view the atomic charges

The BAND-GUI has been designed to be a lot like the ADF-GUI. This makes it much easier for users to use
both programs. To avoid repetition, the BAND-GUI tutorial assumes that you are familiar with some basic
usage of the ADF-GUI. If you do not know how to rotate, translate, zoom etc within the ADF-GUI, please
read through the first ADF-GUI tutorial before starting with this BAND-GUI tutorial. Even better: try using the
ADF-GUI yourself. You can get a demo-license for this purpose if needed.

Step 1: Start BANDinput

On a Unix-like system, enter the following command:

bandinput &

On Windows, one can start BANDinput by double-clicking on the BANDinput icon on the Desktop:

double click the BANDinput icon on the Desktop

On Macintosh, use the ADFLaunch program to start BANDinput:

double click on the ADFLaunch icon
click the 'BAND Input' button
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The BANDinput window consists of the following main parts:

¥ the menu bar with the menu commands
¥ the drawing area of the molecule/crystal editor (the area with the cubes on the middle left side)
¥ the status field (on the bottom left of the black area, currently empty)
¥ toolbar (at the bottom)
¥ a set of selected other options (currently 'Main Options') occupying the right half of the window

Step 2: Create the unit cell

Select the coordinates tab

Choose the 'Coordinates' panel with the pull-down menu on the right (currently set to 'Main Options')
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Select periodicity

You can select the dimension of the lattice:

Select periodicity "Bulk"

The colored lines that you see in the drawing area are the lattice vectors. The first lattice vector is colored
red, the second green, and the third blue. Because a number of neighboring cells are displayed you see a
collection of cubes. You can enable/disable this:

Use the 'Periodic>Unit Cell Only' menu command from the 'View' menu to toggle the periodic display
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Without the unit cell only you see the more clearly the three lattice vectors.

Enter lattice vectors

Salt has an fcc lattice. First we need to set the lattice vectors:

Enter the lattice vectors, as shown in the next picture

Step 3: Add the atoms

Now we will add the Na and Cl atoms:

Make sure periodic display is turned off
Select the Sodium (Na) element tool from the periodic system that appears when you click the 'X' element on the toolbar
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After this you see at the bottom of the screen "Na tool" in the status field:

Click once in the drawing area, near the origin
Click once on the created atom to stop bonding

As you can see the atom is not exactly in the origin. This can be fixed if you wish:
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Use the 'Set Origin' command from the 'Edit' menu

To add the Cl atom you can proceed the same way.

Select the Cl tool
Click once somewhere in the unit cell
Click on the new Cl atom to stop bonding

Next you should edit the Cl coordinates and change the Cl color:
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Change the Cl coordinates to be (2.75,2.75,2.75) in the 'Coordinates' panel
Click and hold on a the Cl atom
In the pop-up menu, use the 'Define Cl Color' command and choose a new green Cl color
Turn on periodic display (in the 'View' menu)

Now your system looks like:

Step 4: Running the calculation

It is a good idea to give your calculation a description.

Go back to the "Main options" panel
Enter something appropriate in the "Title" field
Save the result with the menu "File>Save", and name it "NaCl"
Choose "File>run".

First, adfjobs will start and asks you
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Accept "Yes", and a window will appear showing the progress of the BAND calculation (the 'logfile'). After a
few minutes the calculation has finished, and it looks like:
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Wait for the text 'Job ... has finished' in the logfile (... will be the name of your run script)

The calculation has produced two files: "NaCl.out", which contains the result of the calculation in text format,
the second is"NaCl.runkf" which is a binary result file.

Step 5: Examine the band structure

Select the 'Band Structure' command from the 'SCM' menu
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This will open the bandspectra window:

The red line is the fermi level, which is always set to zero in a bulk calculation. There are four occupied
bands. You can see this more clearly by resizing the window (making it higher):

Resize the window showing the bandstructure (make it higher)

The bottom part of the resulting window will look like:
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In most k-points you see now four bands below the fermi level. In some k-points you see less because they
are degenerate.

Step 6: Visualizing the results

Plotting the orbitals

Now what is the character of the bands? Let us first examine this narrow band at about -0.5 Hartree.

Open ADFview with the menu 'View' command from the 'SCM' menu.
In ADFview: select the 'Isosurface Double (+/-)' command from the 'Add' menu.

In the bar at the bottom of the window, you can select which field to show.

Select the lowest band (k=0,0,0)
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From the label you can see that it has an energy of -0.4641 and the coordinates are (0,0,0). The cursor will
go to the busy state, and after a while you will see the orbital:
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If you rotate it a bit and toggle the isosurface on and off, you can convince yourself that this orbital is located
around the small atom, which is the Chlorine.

Toggle the periodic view (the menu 'Periodic>Show Periodic' command from the 'View' menu).

Obviously this is the 3s band of Cl. The strange truncated spheres are due to contributions of neighboring
cells.

Let us now take a look at the orbital with the lowest energy of the second band (the first one with an energy
not around -0.4):

15



Select the lowest orbital of the second band (with energy about -0.08)

This orbital looks like:

and it clearly consists of a p orbital on the Cl. The part near the Na comes from Chlorine atoms in
neighboring cells.

It is generally easier to interpret orbitals at k=(0,0,0). The second band at this point looks like

From these orbital pictures we can conclude that the valence band is indeed mainly of Chlorine-p character.

You may want to check the lowest orbitals of the (unoccupied) conduction band.
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Check the lowest orbitals of the conduction band
Do you see a strong Na character in them?

Plotting the partial density-of-states

There is in fact a much more easy way to conclude that the valence band is mainly of Chlorine-p character.

Open from the SCM menu the 'BAND Dos' module.

and a window like this will appear

The fermi energy is at zero, and there is clearly a gap. Just below it there is a valence band, and at 0.2
Hartree starts the conduction band.

Select from the 'View' menu 'Add Graph'

(Now you see two plots of the total DOS)

Select with the mouse the Chlorine atom (the small one)
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It is already immediately clear that the valence band comes from the Chlorine, and the conduction band from
the Sodium.

Right-click with the mouse on the selected Cl atom and check the 'P-DOS' check box in the pop up menu.
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This shows that the valence band is clearly made of Chlorine p-orbitals.

Plotting the deformation density

Naively you might expect that the charge of Na should be +1 and from the Cl -1. This can be best seen by
making a cutplane:

Delete the double isosurface with the 'Isosurface: Double' pull-down menu in the bar on the bottom
Select 'Cutplane (+/-)' from the 'Add' menu command.
Select the deformation density

The result is a bit disappointing, because the plane is perpendicular to the atoms

19



To get it right enable at the bottom the "Position plane" toggle:

You will now see a white frame. Drag it to the right until you see an arrow in it

Now you can "grab" the arrow head and turn it to point towards you
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Indeed we see that charge is added (blue) near the Cl and removed (red) from the Na atom. The trend is
good, but what is the total amount of charge transferred?

Step 7: Check the charges

Open the textual output with the 'Output' command from the 'SCM' menu.
Scroll down until you see:

So the amount of charge transferred is only about 0.2. This is of course due to the fact that the Cl p-band
overlaps quite significantly with the Na region.

The conclusion of this tutorial: we should take the idea that one electron is transferred from Na to Cl with a
grain of salt.

Tutorial 2: using the builder

In the previous tutorial you learned how to enter the coordinates and lattice vectors directly. In this tutorial
we demonstrate the possibilities of the builder to make bulk systems, and in particular slabs.

This tutorial will learn you how to:

¥ build an NaCl crystal with a few clicks
¥ make a larger unit cell
¥ build a 111 surface
¥ switch default views
¥ change perspective

example 1: NaCl crystal

The first thing that needs to be done is to select the builder. You do is by selecting the "coordinates" tab, and
then select from the "Edit method" selector the "Builder" button

Now you are presented with a sort of form that allows you to build periodic structures.
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It basically consists of three parts: a part where you define the original crystal lattice, a part to define a
surface, and a part to change the size of the unit cell. At the bottom is the button to generate the
coordinates. Only the relevant parameters are enabled. For instance, because we are building a bulk
system, all entries in the Surface frame are disabled.

To make the NaCl crystal, you should select as the bravais lattice "Sodium Chloride"

Next you should enter the two elements that comprise such crystals. Choose Na and Cl.

Enter the lattice constant, which is experimentally 5.64

Finally, push the "generate coordinates" button, and you are ready. You can switch back to the "Normal"
Edit method to see the lattice vectors and atom coordinates that you could also have entered directly as
explained in the previous tutorial.
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example 2: A three layer slab of the Cu(111) surface

We now want to build a slab, so change the periodicity to "Slab", and select the "Builder" edit method

Cu has an fcc lattice with a lattice parameter of 3.61. Make sure the Lattice part of the builder looks like

We are interested in a three layer 111 surface so we specify the Miller indices and the slab thickness

Now push the generate coordinates button. If you already had defined some atoms the program will warn
you

Accept with Yes. In my case the result looks like
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But this may depend on whether you did some turning. Let us switch to a well defined view position. Push
the "Top view(z)" toolbar button and you will see

Due to the perspective it looks a bit asymmetric. Use the "Perspective" toggle button to switch to

parallel projection. Now it looks perfectly symmetric
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To convince ourselves that we have built a three layer slab click on the "Side view (x)" toolbar button

and clearly we have three layers.

Finally, let us make a larger unit cell, using the supercell transformation. Select the "sqrt(3) x sqrt(3)" preset

The unit matrix will now change to

The supercell transformation matrix is in terms of the primitive lattice vectors, you could also have entered
them by hand. Now generate the coordinates, switch to "Top view", and you will see
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Tutorial 3: a transition state search

This tutorial will learn you how to:

¥ do a geometry optimization
¥ watch the geometry optimization as a movie
¥ do a frequency calculation
¥ examine the eigen modes
¥ perform a transition state search
¥ make a few mistakes and fix them

Throughout we will consider the toy system of a periodic chain with three atoms in the unit cell.

Step 1: Create the H3 toy system

We are going to enter the geometry manually, just as in the first tutorial.

Select in the 'Coordinates' panel as periodicity 'Chain' and make a lattice vector in the x-direction with length 10.
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Add with the mouse three hydrogen atoms somewhere in the cell.
Change the coordinates in the table to this

You have now created the cylinder symmetric toy system.

Step 2: Optimize the geometry

Go back to the 'Main Options' panel
Choose as task 'GeometryOptimization'.
Save the project as 'H3_geo'
Run it.

After it has finished the program asks you

Answer 'Yes'.

Now let us look at the progress as a movie.

From the SCM menu select 'Movie'

A small movie pops up ending like this
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The geometry looks a bit odd. Now take a look how the energy changed during the optimization.

Choose from the 'View' menu 'Add Graph'

to achieve this
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It shows the energy at the four steps: 0, 1, 2, and 3. Since the energy does not change anymore from step 2
to three it should be OK? Well, maybe, but maybe not. Let us check whether we were fully converged.

Select from the SCM menu 'Logfile'. Scroll from the end a bit upwards and you will see
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You see the final geometry and status of the five convergence criteria. Because they are all satisfied you
see the log message 'Geometry Converged'

Maybe we are dealing with a shallow minimum. Let us retry with a more strict criterion.

Close the logfile and movie windows and go back to 'BAND input'.
Go to the 'Optimization' panel and set the convergence criterion to 1e-4.

Save the project and run it
Open adfmovie afterwards and add the graph
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Now that looks more like an optimal geometry!

Step 3: Calculate the Hessian

Select in the 'Main Options' panel the task 'Frequencies'

Save the project as H3_freq and run it.

After the calculation has finished

choose the SCM menu the 'Spectra' app.
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There appear to be three peaks, whereas you would expect 3N degrees of freedom. With three atoms (N=3)
we should have nine modes. We can examine this a bit closer

click on the 'NormalMode' menu.

So there are indeed nine vibrational modes. Only two are nonzero because only symmetrical modes are
calculated by default. To see what a mode looks like

Select the mode at 1700 cm-1, either  from the 'NormalMode' menu, or by clicking on it directly in the graph.

A new movie window pops up visualising the vibrational mode.
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Step 4: Search the transition state

A minimum has vanishing gradients and only positive eigen modes. A (first-order) transition state (saddle
point) is characterized by having one negative mode. With a transition state search the optimizer will go
uphill in the direction of the lowest (nonzero) eigenmode and downhill in all other degrees of freedom. In our
example it would follow mode 8. Let us give it a try from the minimum.

Choose in the 'Main Options' panel the task 'TransitionState'

We have just calculated a Hessian (with the frequency run) so we'd better use it.

Go to the 'Optimization' panel, click on the plus button next to 'Initial Hessian From:'
Select with the file dialog 'H3_freq.runkf'.
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Save the  project as 'H3_ts' and run it.

The most likely outcome, however, is that the optimizer stops immediately, because the gradients are zero.
Therefore, we need to help the optimizer a bit.

Move the rightmost atom a tiny bit to the right (increase the x value by 0.01).

(Here I increased the values next to H(3)).

Run it again, and now it will run for more cycles.
After it has finished, open adfmovie

The last frame looks like
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The third H atom ends up exactly in the middle of the (repeated) H1 and H2 atoms. Let us finally check that
we are indeed in the transition state.

In the 'Main Options' panel select the task 'Frequencies'
Save the project as 'H3_ts_freq' and run it.
Afterwards, open adfspectra and click on the 'NormalModes' menu

You should see
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We have found a geometry with vanishing gradients with one weak negative vibrational mode. We have
succeeded in finding a transition state.

Tutorial 4: a transition state search with a partial
Hessian*

This tutorial will learn you how to:

¥ calculate a partial Hessian
¥ do a constrained TS search using the partial Hessian

In this "advanced" tutorial we consider a slightly more realistic system. Some of the calculations may require
20 minutes to run on a two core machine.

Step 1: Create the system

We are going to make a one layer Li slab with a 2x2 unit cell

Select the 'Coordinates' panel.
Select as Periodicity 'Slab'
Choose 'builder'
Set 'Bravais lattice' to 'Body-Centered Cubic'
Set 'Element' to Li
Set the lattice parameter to 3.49
Set 'Thickness' to 1
Select the 2x2 preset
Press 'Generate Coordinates'

Your screen should look like
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Add with the mouse two hydrogen atoms anywhere in the screen
Select the 'Normal' edit mode
Set in the table the coordinates of the first hydrogen atom to (0, -0.5, 2)
Set the second H atom coordinates to (0, 0.5, 2)

The final geometry looks like this
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Step 2: Calculate a partial Hessian

Select the 'Main Options' panel
Set 'Task' to 'Frequencies'
Set 'Basis Set' to 'SZ'
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Go to the 'Frequencies' panel
Select with the mouse the two tiny Hydrogen atoms
Click on the '+' button next to 'Partial Hessian For:'

Save the project as 'H2onLi_freq' and run it. (On my computer this takes 3 minutes)
Say 'No' when asked to update the coordinates
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Let us examine the eigenmodes that we have found for the Hydrogen molecule

Select from the SCM menu 'Spectra'
Open the 'NormalMode' menu

Now you will see that there is an eigenmode at 448 cm-1 and one at 2164. Convince yourself that the 448
mode moves the H2 perpendicular to the service and that the 2164 more is essentially an H2 stretch mode.
The lowest mode looks like a promising start to find the transition state for dissociation over the Li surface.

Step 2: Transition state search with a frozen substrate

We have just found the vibrational modes of the Hydrogen molecule, assuming that the Li substrate remains
fixed. Let us now find the transition state under the same assumption.

Close the 'Spectra' window and go back to BandInput.
Select the 'Main Options' panel and set 'Task' to 'TransitionState'

Select the 'Geometry Constraints' panel
I assume that the two hydrogen atoms are still selected. If not select them again
Select from the 'Edit' menu 'Invert Selection'
Click on the '+' button next to 'freeze selected atoms'
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Goto the 'Optimization' panel
Set the initial Hessian to 'H2onLi_freq.runkf'

Save the project as 'H2onLi_ts' and run it. (On my computer this takes 19 minutes)

After running it

Open 'Movie' from the SCM menu
From the 'View' menu select 'Add Graph'
Select 'View > View Direction > Along x axis'

It should look like
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