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Introduction
This document will provide a hands-on tutorial demonstrating the COSMO-RS GUI. Its purpose is to give a
quick tour of the main features of the COSMO-RS GUI.

The first tutorial describes how to create COSMO result files that are needed as input for the COSMO-RS
calculation. The second tutorial describes the use of the COSMO-RS GUI.

Additional information may be found in the COSMO-RS GUI Reference manual and COSMO-RS manual

The COSMO-RS GUI module ADFcrs
The COSMO-RS GUI module is:

ADFcrs

This utility ($ADFBIN/adfcrs) enables ADF users to easily select compounds, create COSMO-RS jobs,
run the jobs, and visualize the results.

ADF installation
We will assume that you have installed the ADF package on your machines.

Depending on your platform, you start the COSMO-RS GUI module in a slightly different way:

UNIX (such as Linux) users

In this tutorial we assume that you have added $ADFBIN to your PATH. We advise you to do this if you have
not already done so. If you do not wish to add $ADFBIN to your PATH, you must start the utilities using

$ADFBIN/adfcrs &

instead of just

adfcrs &

On all UNIX platforms, including Mac OS X, the ADF-GUI programs are XWindow programs. Your
environment should have been set up correctly to run such programs. In particular, you need to make sure
that your DISPLAY environment variable has been set properly.

You can test this easily by starting a simple X program from your shell:

xcalc &

Assuming the xcalc program is in your $PATH, a small window should appear with the image of a calculator.
If not, please consult your local system administrator for additional help. Typical problems have to do with
your DISPLAY variable, and with security issues when trying to connect to the X server.

Windows users

In this tutorial we will assume that you have installed the ADF packaged using the Installer with all default
options.

3

http://www.scm.com/Doc/Doc2008.01/CRS/CRSGUI_reference/page1.html
http://www.scm.com/Doc/Doc2008.01/CRS/CRS/page1.html


You can start the COSMO-RS GUI (adfcrs) by double-clicking its icon on the desktop.

Macintosh users

Macintosh users have several easy ways of starting the ADF-GUI modules:

• double click the 'ADFLaunch' program, and use that to start the COSMO-RS GUI module, or
• follow the instructions for UNIX users (as MacOS X is just another UNIX version)

Macintosh users who are not used to the 'Terminal' should use the ADFlaunch program. Once you have
launched it, you will see several buttons to start the ADF-GUI modules and the COSMO-RS GUI module. To
start the COSMO-RS GUI, click the COSMO-RS button.
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Tutorials
Tutorial 1: COSMO result files
If you already have COSMO result files for all the compounds that you are interested in you can skip this
tutorial, without problems of continuity.

The purpose of this tutorial is to teach you how to make data for a compound using the ADF program such
that it can be read by COSMO-RS. COSMO-RS expects so called COSMO result files, which are results of
quantum mechanical calculation using COSMO. In ADF such a COSMO result file is called a TAPE21 (.t21)
file, or a COSKF (.coskf) file. In other programs such a file can be a .cosmo file. For example, at
http://www.design.che.vt.edu/VT-Databases.html a database of .cosmo files can be found, which were made
with a different program. Note that the optimal COSMO-RS parameters may depend on the program
chosen.

Please read through the first ADF-GUI tutorial before starting with this tutorial, see ADF-GUI tutorial.
Even better: try using the ADF-GUI yourself, especially Tutorial 1

Step 1: Start ADFinput

For this tutorial we prefer to work in a separate directory, for example the Tutorial directory, as was
explained in ADF-GUI Tutorial 1.

You know how to start ADFjobs (in your home directory), and move to the Tutorial directory:

cd $HOME
Start adfjobs
Click on the Tutorial folder icon

Next start ADFinput using the SCM menu. Notice that currently no job is selected. If a job is selected, the
SCM menu will open the selected job, which is not what we want now. You can toggle the selection in
ADFjobs using the right mouse button (or control-left). To clear the selection, click anywhere in the search
bar on the bottom (except in the input fields).

Make sure no job is selected in ADFjobs Select the first Input command from the SCM menu

Step 2: Create the molecule

First we construct a water molecule, and preoptimize its geometry:

Select the O-tool by clicking on the button with the 'O'
Click somewhere in the drawing area to create an oxygen atom
Select the select-tool by clicking on the button with the arrow
Click once in empty space so nothing is selected
Select the 'Add Hydrogen' command from the 'Edit' menu
Click the optimizer button

Your water molecule should look something like this:
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Step 3: Optimize the gas phase geometry

The next step is to optimize the geometry using ADF. In this case we will use the Becke-Perdew functional
and a TZP basis set, since those are used for the optimization of the COSMO-RS parameters.

Enter a proper title in the Title field (like 'water')
Select the 'Geometry Optimization' preset
Select 'GGA-BP' for the 'XC potential in SCF'
Select 'TZP' for the 'Basis Set'

With the proper options selected, now run ADF:
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Select the 'Run' command from the 'File' menu
Click 'Yes' in the pop-up to save the current input
In the file select box, choose a name for your file (for example 'water') and click 'Save'
Click 'Yes' when ADFjobs asks you 'Continue using ...?'

Now ADF will start automatically, and you can follow the calculation using the logfile that is automatically
shown.

Wait until the optimization is ready (should take very little time)
Click 'Yes' in the pop-up to read the coordinates from a .t21 file.

Now the geometry of the water molecule is the optimized one.

Step 4: Set up the COSMO calculation

First set up the COSMO calculation with the COSMO parameters as they were used in the ADF
parametrization of COSMO-RS. The calculation will be a 'Fragment Analysis' calculation, in which the
fragment is the gas phase molecule, and final molecule is in a solvent, represented in the COSMO model by
a dielectric medium with a dielectric constant. This dielectric constant is infinite in the COSMO-RS model.

Select the 'Solvent CRS' preset
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Note for charged molecules: the charge of the molecule can be entered in the 'Total charge' field. The
charge should also be specified for the 'Untitled' gas phase fragment if one selects 'Task: FragmentAnalysis'
in the 'Properties' Menu.

Part of the COSMO parameters that are set can be found if one selects 'Solvation' in the 'Model' Menu. The
dielectric constant is infinite if one chooses 'CRS' for the Solvent. The so called 'Klamt' radii are used for the
construction of the molecular cavity.

Another part of the COSMO parameters that are set can be found in the 'Solvation Details' in the 'Details'
Menu:
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Step 5: Perform the COSMO calculation and obtain the COSMO
result file

With the proper options selected, now run ADF:
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Select the 'Run' command from the 'File' menu
Click 'Yes' in the pop-up to save the current input
Click 'Yes' in the pop-up to replace water.adf.
Click 'Yes' when ADFjobs asks you 'Calculations for water are found

and will be deleted. Continue with Run Command?'

Now ADF will start automatically, and you can follow the two calculations using the logfiles that are
automatically shown. The first calculation is the fragment calculation, which is the gas phase water
calculation, named water.Untitled. The second one is the COSMO calculation for water which was called
water.

After the calculation has finished the file water.t21, which is a COSMO result file, can be used as input for a
COSMO-RS calculation.

In a COSMO-RS calculation the 'COSMO' part of this water.t21 file is needed. In the COSMO-RS manual it
is explained how one can use a command-line utility to make a file called water.coskf, which consists only of
the 'COSMO' part. Note that such a .coskf file is not a complete .t21 anymore, and can not be viewed with
ADFview, for example. It is useful only for COSMO-RS calculations.

Step 6: Visualize the COSMO surface: ADFview

You can use ADFview to have a look at the COSMO surface, and the COSMO surface charge density.

Select 'View' from the 'SCM' menu
Select 'COSMO: Surface Charge Density on COSMO surface (reconstructed)'

from the 'Add' Menu

Then you will see something like:
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The red part represents positive COSMO charge density (which is the opposite of the underlying molecular
charge), the blue part negative COSMO charge density. You can also look at the COSMO surface points
themselves.

Select 'COSMO: Surface Charge Density on COSMO surface points'
from the 'Add' Menu

The small spheres represent the COSMO surface points that are used for the construction of the COSMO
surface.

Tutorial 2: COSMO-RS overview: analysis

Step 1: Copy COSMO result Files

For this tutorial it is convenient to start with an empty directory, for example, with the name Tutorial.

In tutorial 1 it was shown how to make ADF COSMO result files. In this tutorial we will use some ADF
COSMO result files that were made before. These files can be found the directory $ADFHOME/examples/
crs/Tutorial2. Copy these COSMO result files (water.coskf, methanol.coskf, ethanol.coskf, and
benzene.coskf) to the directory Tutorial. As the name suggests these are COSMO result files of water,
methanol, ethanol, and benzene, respectively.

Note that these COSKF (.coskf) files contain only the part of an ordinary TAPE21 (.t21) file which is needed
in a COSMO-RS calculation. These COSKF files can not be used in ADFview, for example.

11



Step 2: Start ADFcrs

On a Unix-like system, enter the following command:

$ADFBIN/adfcrs &

On Windows, one can start ADFcrs by double-clicking on the ADFcrs icon on the Desktop:

double click the ADFcrs icon on the Desktop

On Macintosh, use the ADFLaunch program to start ADFcrs:

double click on the ADFLaunch icon
click the 'COSMO-RS' button

Alternatively if you know how to start ADFjobs (in your home directory), and move to the Tutorial directory:

cd $HOME
Start adfjobs
Click on the Tutorial folder icon
Make sure no job is selected in ADFjobs
Select 'COSMO-RS' from the 'SCM' menu

This ADFcrs window consists of the following main parts:

• the menu bar with the menu commands
• on the left: a list of compounds
• on the right: for the selected compound some properties
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This is the so called 'Compounds' window, which is the window you will get if you select 'Compounds' from
the 'View' Menu.

Step 3: Add Compounds

Select 'Add Compound' from the 'File' menu

A file select box will open

Select 'COSMO kf file (*.coskf)' in the popup menu 'Files of type'
Select water.coskf

On the right side of the 'Compounds' window one finds some data that was written from the file water.coskf.
Here it is also possible to add some pure compound input data. We will not do so now since there is no
need. For some other types of compounds user input is required at this point, however. We will encounter an
example of that in the next step.
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Repeat these instructions to add methanol.coskf, ethanol.coskf, and benzene.coskf.

Step 4: Set pure compound parameters

In the COSMO-RS model in Ref.[2] there is a ring correction term. This is important for, for example, the
benzene molecule, which has 6 ring atoms. However, it is really required only when the vapor pressure of
the compound is going to be computed (either because that is explicitly requested or because it is used in
predicting partial vapor pressures in a mixture or gas/liquid partitioning coefficients).

Select 'Compounds' from the 'View' Menu
Click on the left side benzene.coskf
Enter '6' without quotes in the 'Nring' field
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For some properties, like solubility of a solid, one can include some pure compound properties in the left
window of the 'Compounds' window for a selected compound.

Step 5: Set the COSMO-RS parameters

Select 'Parameters' from the 'CRS' Menu

Default 'COSMO-RS 98 ADF' parameters are selected, which are ADF optimized COSMO-RS parameters. If
one selects the 'COSMO RS 98 Klamt' option for 'Use: ... parameters', the optimized parameters are
chosen, which are optimized by Klamt et al., see Ref [2] and the the COSMO-RS manual.
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Step 6: Analysis: The sigma profile

Select 'Sigma Profile' from the 'CRS' Menu
In the left part of the window select 'water' for compound '1'
Select 'ethanol' for compound '2'
Select 'benzene' for compound '3'
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'
Enter the name 'tutorial2' in the 'File name' field

The sigma profiles (σ-profile) of the three pure compounds will be shown in a graph and in a table in the
right part of the window. The whole window can be resized. The relative size of the left part of the window
compared to the right part can be changed if one moves the sash that is in between these parts. In the right
part of the window one can also change the relative size of the upper part compared to the lower part if one
moves the sash that is in between these parts.

The σ-profile shows the amount of surface area for a given COSMO charge density. If the default settings
are used, the red curve is the water σ-profile, the blue curve the methanol σ-profile, and the green curve is
the benzene σ-profile. If one clicks in the graph one can zoom (right mouse, or Command-Left (drag up or
down)), or translate (left mouse) the graph. If one clicks in the graph window at the left or below the axes, a
popup window will appear in which one can set details for the graph window.

Note that the σ-profile depends on the actual value for r_av (rav), which is one of the COSMO-RS
parameters, see previous step.

Step 7: Analysis: The sigma potential

Select 'Sigma Potential' from the 'CRS' Menu
In the left part of the window select 'water' for compound '1'
Select 'ethanol' for compound '2'
Select 'benzene' for compound '3'
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

The sigma potentials (σ-potential) of the three pure compounds will be shown in a graph and in a table in the
right part of the window. The σ-potential depends on the temperature of a compound. Here the temperature
is set to 25°C (298.15 K).
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If the default settings are used, the red curve is the water σ-potential, the blue curve the methanol σ-
potential, and the green curve is the benzene σ-potential. In the details for the graph window the line width
was set to '3'.

Note that the σ-potential is not calculated for values of the COSMO charge density that are non-existent on
the COSMO surface of a certain compound.
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Tutorial 3: COSMO-RS overview: properties
How the properties are calculated and definitions used can be found in the section Calculation of properties
in the COSMO-RS manual.

Step 1: Start ADFcrs

For this tutorial we assume that you know how start ADFcrs and how to add compounds. Like in tutorial 2
we ask you to add the compounds water, methanol, ethanol, and benzene. One can do this, for example, by
opening the .crs file that was created in tutorial 2. Save the file as tutorial3.crs.

Start ADFcrs
Select 'Open...' command from the 'File' menu
Select 'tutorial2.crs' in the 'File name' field
Select 'Save As' command from the 'File' menu
Enter the name 'tutorial3' in the 'File name' field

Alternatively on a Unix like system one may copy the COSMO result files (water.coskf, methanol.coskf,
ethanol.coskf, and benzene.coskf) in the directory $ADFHOME/examples/crs/Tutorial2 to an empty directory
and enter the following command in this directory where the COSMO result files are present:

$ADFBIN/adfcrs water.coskf methanol.coskf ethanol.coskf benzene.coskf &

Note that one has to set the number of ring atoms for the benzene compound.

Select 'Compounds' from the 'View' Menu
Click on the left side benzene.coskf
Enter '6' without quotes in the 'Nring' field
Select 'Save As' command from the 'File' menu
Enter the name 'tutorial3' in the 'File name' field

In the compounds window one can also set the vapor pressure of the pure compounds at a given
temperature, or set the Antoine parameters. If these values are not specified (if they are zero) then the pure
compound vapor pressure will be approximated using the COSMO-RS method. This is relevant, for
example, for the calculation of the (partial) vapor pressures of mixtures, calculation of boiling points of
mixtures, and calculation of Henry's law constants.

Step 2: Calculate a solvent vapor pressure

Warining: up to and including the 2008.01c version ADF COSMO-RS contains a bug in case more than 1
temperature is calculated, which can happen in solvent vapor pressure calculations, solubility calculations,
or boiling point calculations.

Select 'Solvent Vapor Pressure' from the 'Properties' Menu
Select 'methanol' for the first component in the Solvent
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'
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In this case the result is a table with one entry:

Select 'Celsius' for the scale of the 'Temperature'
Enter '0.0' without quotes in the 'from:' field
Enter '100.0' in the 'to:' field
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

In this case the result is a graph and a table. If one clicks in the graph window at the left or below the axes, a
popup window will appear in which one can set details for the graph window. After some manipulation in the
details of the graph, the graph can look like:
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In this case COSMO-RS predicts a vapor pressure of about 0.59 bar (around 440 Torr) at 323.15 K (50.0°C)
for the pure liquid methanol.

Step 3: Calculate the boiling point of a solvent

Warning: up to and including the 2008.01c version ADF COSMO-RS contains a bug in case more than 1
temperature is calculated, which can happen in solvent vapor pressure calculations, solubility calculations,
or boiling point calculations.

Select 'Solvent Boiling Temperature' from the 'Properties' Menu
Select 'methanol' for the first component in the Solvent
Select 'ethanol' for the first component in the Solvent
Enter '0.5' for the 'Mole fraction' of methanol
Enter '0.5' for the 'Mole fraction' of ethanol
Select 'atm' for the scale of the 'Pressure'
Enter '0.1' in the 'from:' field
Enter '1.0' in the 'to:' field
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Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

In this case the result is a graph and a table.

The red curve is the total vapor pressure, the blue curve the partial methanol vapor pressure, and the green
curve is the partial ethanol vapor pressure. The table gives the numerical values.

Thus in this case COSMO-RS predicts a boiling point of 340.9 K (67.8°C) at 1 atm. for this mixture of 50%
mole fraction methanol and 50% mole fraction ethanol. At this temperature COSMO-RS predicts that the
vapor consists about 70% of methanol.
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Step 4: Calculate partition coefficients (log P)

Select 'Solvent Log Partition Coefficients' from the 'Properties' Menu
Select 'benzene' for the first component in Solvent 1
Select 'water' for the first component in Solvent 2
Click 'Yes' in the 'Use input volume quotient' field
Enter '4.93' in the 'Input volume solvent/solvent 2' field
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

In case of partly miscible liquids, like, for example, the octanol-rich phase of octanol and water, both
components have nonzero mole fractions.

Here an input value is used for the volume quotient of the two solvents. If one does not include such value,
the program will use the COSMO volumes to calculate the volume quotient. The COSMO volumes can be
found in the 'Compound' window.

The result of the calculation is given in the form of a table.
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Step 5: Calculate activity coefficients

Select 'Activity coefficients' from the 'Properties' Menu
Select 'water' for the first component in Solvent
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

If one does supply a density of the solvent in the input the program calculates the density of the solvent by
dividing the mass of a molecule with its COSMO volume. Note that the activity coefficients do not depend on
this density.

The result of the calculation is given in the form of a table.
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Relevant for the calculation of ΔG is the reference state, used here is 1 mol/L both in the gas and solution
phase.

Step 6: Calculate solubility

Warining: up to and including the 2008.01c version ADF COSMO-RS contains a bug in case more than 1
temperature is calculated, which can happen in solvent vapor pressure calculations, solubility calculations,
or boiling point calculations.

Select 'Solubility coefficients' from the 'Properties' Menu
Select 'benzene' for the first 'Solute'
Enter '273.15' without quotes in the 'Temperature Kelvin from:' field
Enter '373.15' in the 'to:' field
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

First the solubility of benzene in water for a range of temperatures.

If a range of temperatures is requested a graph is shown.

Next the solubility of water in benzene for a range of temperatures.
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Again a graph (and table) is shown.

For the solubility of a solid compound it is necessary to include the melting point, the enthalpy of fusion, and
optionally, since it is often not so important, the Δ heat capacity of fusion of the pure compound. These
values can be given for each compound when 'Compounds' is selected from the 'View' menu.

Step 7: Calculate binary mixtures VLE/LLE

Isothermal

A binary mixture is calculated in which the pure compound vapor pressures are approximated using the
COSMO-RS method. The binary mixture will be calculated for a list of molar fractions between zero and one.

Select 'Binary Mixture VLE/LLE' from the 'Properties' Menu
Select 'water' for the first compound
Select 'methanol' for the second compound
Enter '298.14' in the 'Temperature Kelvin from:' field
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Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

An activity coefficient plot for water(1) and methanol(2) will be shown.

The results of the calculation are also given in the form of a table, which shows the molar fraction of each
compound, the activity coefficients, the activities, the temperature, the total and partial vapor pressures, the
molar fraction of each compound in the vapor, the excess Gibbs free energy GE, the excess enthalpy HE,
and the Gibbs free energy of mixing Gmix.
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These values can also be shown in a graph. The property for the x- and y-axes can be selected from the
'View' Menu. For example, a graph of the excess energies can be shown by:

Select 'excess energies G^E, H^E Gibbs energy of mixing' for 'Graph Y Axes' from the 'View' Menu

A plot of the excess energies will be shown.
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The red curve is the excess Gibbs free energy GE, the blue curve is the excess enthalpy HE, and the green
curve is the Gibbs free energy of mixing Gmix.

Isothermal, input pure compound vapor pressure

A binary mixture is calculated with input data for the pure compound vapor pressures. These can be, for
example, experimentally observed pure compound vapor pressures. Note that the calculated partial and
total vapor pressures will now depend on these input pure compound vapor pressures.

Select 'Compounds' from the 'View' Menu
Click on the left side water.coskf
Enter '0.123416' in the 'Pure compound vapor pressure:' field
Enter '322.45' in the 'at temperature:' field
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Click on the left side ethanol.coskf
Enter '0.294896' in the 'Pure compound vapor pressure:' field
Enter '322.45' in the 'at temperature:' field
Select 'Binary Mixture VLE/LLE' from the 'Properties' Menu
Select 'water' for the first compound
Select 'ethanol' for the second compound
Enter '322.45' in the 'Temperature Kelvin from:' field
Select 'x2: molar fraction 2' for 'Graph X Axes' from the 'View' Menu
Select 'total and partial vapor pressures' for 'Graph Y Axes' from the 'View' Menu
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

A vapor liquid equilibrium (VLE) diagram for water(1) and ethanol(2) will be shown.

The red curve is the total vapor pressure, the blue curve is the partial water vapor pressure, and the green
curve is the partial ethanol vapor pressure. One can also change the x axes, for example:

Select 'y2: molar fraction 2 in vapor phase' for 'Graph X Axes' from the 'View' Menu
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Isobaric

A binary mixture is calculated in which the pure compound vapor pressures are approximated using the
COSMO-RS method if the input values for the pure compound vapor pressures are zero.

Select 'Compounds' from the 'View' Menu
Click on the left side ethanol.coskf
Enter '0.0' in the 'Pure compound vapor pressure:' field
Enter '0.0' in the 'at temperature:' field
Click on the left side methanol.coskf
Enter '0.0' in the 'Pure compound vapor pressure:' field
Enter '0.0' in the 'at temperature:' field
Select 'Binary Mixture VLE/LLE' from the 'Properties' Menu
Select 'methanol' for the first compound
Select 'ethanol' for the second compound
Select 'isobar' for 'Isotherm or isobar:'
Select 'x1: molar fraction 1' for 'Graph X Axes' from the 'View' Menu
Select 'Temperature' for 'Graph Y Axes' from the 'View' Menu
Select 'Run' command from the 'File' menu
Click 'Yes' when asked to 'Save changes (required to run)?'

The calculated boiling points for a binary mixture of methanol(1) and ethanol(2) will be shown.
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