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CHAPTER

ONE

GENERAL

1.1 Introduction

This document will provide background information for the Graphical User Interface (GUI, ADF-GUI, BAND-GUI
and so on), part of the ADF package.

The purpose of this document is to give more detailed background information on how the GUI operates. It will not
explain how to use it in detail. For that reason, we strongly suggest that before reading this document, you first check
the GUI tutorials.

The current version of the GUI was developed by O. Visser, with many contributions from L. Groot and O. Carstensen.
Other authors include M. Luppi (artwork) and the SCM developer team. Thanks to M. Mouthaan for testing and
documentation.

1.2 Release 2017

In comparison to ADF-GUI 2016, the ADF-GUI 2017 release offers the following new functionality:

• General GUI features:

– Support most of the new features in the computational codes

– Many small improvements and bug fixes

– Much faster for big systems and for periodic systems

– Quantum ESPRESSO support (QE binary installation, input, running, visualization of results in all mod-
ules)

– MacOS: native mac application (no more XQuartz, and much faster and better quality)

• ADFinput:

– Improved handling of periodic systems

– Run script is visible (and editable)

– Framework builder (Autografs)

– DRF options to calculate charges

– NEGF

– Ligand Field DFT

– Constrained DFT

– CV(n)-DFT

1
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– Dielectric function TD-CDFT

– ReaxFF Nose-Hoover chains

– Molecule Gun with ReaxFF

• ADFview:

– Spin polarized DFTB fields

– Conceptual DFT descriptors (reactivity indices)

– Open any .vtk file and visualize scalar fields from it

• ADFspectra:

– VCDtools integration to analyze VCD spectra

– Visualization of all new spectra types supported via ADFinput (NEGF transmission and current, Ligand
Field DFT, ...)

• BANDstructure:

– DOS graphs next to band structure

– Total DOS, partial DOS

– Band character in band structure

– Labels for symmetry points in BZ

• ADFmovie:

– ReaxFF Chemtrayzer suppport and extended tools for trajectory analysis, including RDF

– Improved handling of files where the number of atoms changes

– Much faster for big systems

• ADFjobs:

– Job list faster

– Right-click on job to get SCM menu

2 Chapter 1. General



CHAPTER

TWO

SET UP

2.1 Mouse

A three-button mouse is also very convenient for using the ADF-GUI, and on a Mac you can use a Magic mouse for
this purpose. To get three buttons (instead of the standard one or two), download and install one of the free utilities
BetterTouchTool or MagicPrefs, and configure it to add a middle click.

2.2 Running Remotely

To use ADFjobs with remote machines, you need to set up ssh first. You should take care to configure things such that
you do not need to type a password when you access your remote machine. To do this you need to:

• create keys,

• run an ssh agent,

• add your public key to the authorized_keys file on the remote machine.

• set up a ssh config file, if needed. This allows you to automatically set options, like the user name to use on the
remote machine.

Thus, users (and ADFjobs) should be able to use ssh to log in to the remote machine without ever needing to enter a
password.

If you are using OpenSSH (typically on Linux machine or MacOSX) you can make the communication with the
remote machine much more efficient by setting the SCM_SSH_MULTIPLEXING environment variable to yes (in the
GUI Preferences module).

ADFjobs does not store passwords, it always uses the ssh command to communicate with remote systems.

For more information, consult your ssh documentation or one of the many guides on the internet.

2.3 ADFjobs Queues

Defining proper queues in ADFjobs will making the GUI much easier. For example, you can run as easily on a remote
compute cluster that you have access to as on your local desktop. ADFjobs will handle all the details like transferring
input and output files, and you can even monitor the progress of running jobs as if they were running on your local
machine.

So you should take some time to set up the queues correctly. It is possible that there are predefined queues on your
remote machine. Then you can configure ADFjobs to automatically use those queues.You can find a description of the
ADFjobs queues and how to set them up later in this manual (page 37).

3



GUI Manual, Release 2017

2.4 MOPAC

MOPAC (Molecular Orbital PACkage) is a semi-empirical quantum chemistry program based on Dewar and Thiel’s
NDDO approximation. It is available from OpenMOPAC (http://openmopac.net/). The documentation for MOPAC
(http://openmopac.net/manual/index.html) is also available on that site.

MOPAC is included with the ADF distribution. However, it needs to be enabled in your license file. If it is not
enabled, please contact SCM to get more information. Note that MOPAC is free for academic users. The MOPAC that
is included with the ADF distribution is the standard MOPAC from OpenMOPAC, except it uses the license checking
system by SCM. It is updated regularly.

If you wish to use a MOPAC version different from the one included with the ADF distribution, you can do this by
setting the SCM_MOPAC environment variable, either in your shell startup script or via the SCM → Preferences
command:

• do not set SCM_MOPAC when you want to run the MOPAC included with the ADF package, in most situations
this is the easiest solution

• set SCM_MOPAC to the complete path to the Mopac executable

• set SCM_MOPAC it to some command if want to run MOPAC on a different machine, the command must
pass the arguments and standard input, and should start the mopac.scm script on the other machine (located in
$ADFHOME/bin) For example: to run the MOPAC included with the ADF distribution on the machine called
mopac.domain.com, use the command:

export SCM_MOPAC="ssh mopac.domain.com adfhome/bin/mopac.scm"

2.5 Quantum ESPRESSO

Quantum ESPRESSO is an open source package that can perform plane wave SCF calculations, among other things.
See www.quantum-espresso.org (http://www.quantum-espresso.org) for details.

Quantum ESPRESSO is not included in the ADF distribution. The GUI works with the standard Quantum ESPRESSO
distribution (version 6.0), no changes have been made.

The easiest way to install it is just to open ADFinput and go to the Quantum ESPRESSO section. Then it will
be installed in $ADFBIN and $ADFHOME/atomicdata for the pseudo potentials, or in "$HOME/Library/
Application Support/SCM" (on a mac). The binaries will be in a folder qe6.0, and the pseudo potentials
will be in a folder upf_files.

To force installation of Quantum ESPRESSO (for example to re-install it to make sure you have a clean version), use
the Help → (Re)Install Quantum ESPRESSO command as available in most of the GUI modules. Another way is
to run the $ADFBIN/get_QuantumEspresso.sh shell script.

Alternatively, the precompiled Quantum ESPRESSO binaries are available
(https://www.scm.com/support/downloads/quantum-espresso-binaries/) from the SCM web site.

The search path for Quantum ESPRESSO by the GUI and by the run scripts made by the GUI is:

1. $QEBIN (and $PSEUDO_DIR for the pseudo potentials)

2. "$HOME/Libaray/Applicaton Support/SCM"

3. $ADFBIN (and $ADFHOME/atomicdata for the pseudo potentials)

4. "/Libaray/Applicaton Support/SCM"
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On a mac you can make the Quantum ESPRESSO installation available to all users by moving it from the $HOME/
Library/Application Support/SCM folder to the global /Library/Application Support/SCM
folder. Obviously all users need proper permissions to access these files.

2.5. Quantum ESPRESSO 5
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CHAPTER

THREE

SCM MENU

All GUI modules have an SCM menu. The SCM menu is the leftmost menu in all modules, and is represented by
either the SCM-logo or the text SCM.

In general, when you select a command from the SCM menu you will switch to the selected module, showing the
same job as you have open in the current module. If such a module is already running with that particular job open,
it will be brought to the front. If you use the SCM menu to open the same module as is currently active, it will start
another blank copy of this module. Thus the SCM menu is very convenient to quickly switch between the already
open windows belonging to the same job.

As a shortcut you can also right-click on a job name in ADFjobs, and the SCM menu will appear with the job you
clicked on selected.

In ADFjobs the currently selected job will be used with the SCM menu. Thus, if you have one job selected, using the
SCM → View command will start or switch to ADFview, showing the results of the selected job. If you have no job
selected, or more then one, the selected module will start blank.

One important exception within ADFjobs: the Input module will always start a new blank version. If you wish to show
the input GUI for the selected job you need to click in the icon in front of it (reading ‘ADF’, ‘BAND’, or some other
job type).

The SCM menu also allows you access to preferences for that are used by all GUI modules: SCM → Preferences

In some cases a GUI module is able to open several file types. For example, ADFmovie can open the logfile or the .t21
file of a calculation. By selecting a file in ADFjobs (after opening the job by clicking on the triangle) you can force
ADFmovie to open the .t21 or the .logfile. In a similar way, you can force ADFview to open a .t21 or a .t41 file.

The SCM → Quit and SCM → Quit All menu commands will close windows: the Quit command will close all
windows belonging to the current job, the Quit All command will close all open GUI windows, as well as any invisible
background processes belonging to the GUI (scmd and scmjobd).
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CHAPTER

FOUR

BACKGROUND PROCESSES WITH NO INTERFACE

4.1 scmd: communication between GUI modules

The scmd process should always be running when any of the GUI modules is active. You should have one scmd
process (per user, if you are working with multiple users). The scmd process has no window, it should normally be
invisible to the user.

The purpose of the scmd process is to handle all communication between GUI modules. For example, if you use the
SCM menu to start a GUI module, that command is actually handled by the scmd process. It will figure out if a new
module needs to be started, or if an already open module with that particular job should be activated.

Starting jobs, and handling the local Sequential queue is also done by scmd.

Communication between the GUI modules and scmd is done using TCP/IP within the local machine. If such commu-
nications are blocked, for example by a firewall, this will make the GUI non-functional! So in case of trouble, make
sure you are not blocking TCP/IP traffic within the local machine. The GUI will never accept any TCP/IP connection
from outside, only from within the local machine.

4.2 scmjobd: monitor running jobs

The scmjobd processes are also faceless background processes that belong to the GUI. They are started and terminated
as needed, normally one per queued or running job. Their task is to monitor the progress of jobs, updating the status if
it changes, getting logfile results for remote jobs, and killing jobs (if you use the Kill command in ADFjobs). Even if
all windows of the GUI are closed they may still continue to be present if you have queued or running jobs.

The scmjobd processes communicate with the other GUI components using TCP/IP, via the scmd process. To monitor
remote jobs they will use ssh to connect to the remote machines.

9
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CHAPTER

FIVE

VIEWING YOUR MOLECULE

5.1 Molecule style: Balls and Sticks, Sticks, or Wireframe

The molecule style can be selected via the View menu (View → Molecule → ...). You can select Balls and Sticks,
Sticks, Wireframe or Hidden. This choice will affect the whole molecule. Note that if you use anything else then Balls
and Sticks it will become much more difficult to select an atom (as there is no ball representing it).

You can also use different styles at the same time, for different regions. To do that, go to the Regions panel, make
regions as you like, and set the molecule style from the pop-up menu per region in the Regions panel (the downward
pointing triangle at the end of each region line).

5.2 Camera position: view direction

You can use the mouse to view your molecule from a different position.

In some situations you may want to view your molecule from some very specific angle. There are a couple of ways to
do this:

• View → View Directions → Along X-axes

• View → View Directions → Along Y-axes

• View → View Directions → Along Z-axes

These commands need no further explanation.

• View → Align Screen

Using this command, you can align the screen parallel to some plane in your molecule. You need to select three atoms
first which will define the plane to align to.

• View → Camera → Save... / Load...

First view your molecule from your favorite position (or use one of the just mentioned commands). Next, you can
store the camera position by selecting one of the Save 1-5 commands. That will store the current view in the selected
slot. To switch to one of the stored views, use one of the Load 1-5 commands.

The camera positions are saved for all GUI modules to use. Thus, if you start ADFinput (or any other GUI module
with a View menu) the stored camera positions are available everywhere. This makes it possible to force the use of the
same camera position in different GUI modules.

The Camera menu can be torn off, which is very convenient if you have several views that you wish to switch between
frequently. To tear off the menu, select the dashed line in the Camerae menu.

11
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5.3 3D

The GUI modules do have support for real 3D viewing. Use the View → 3D menu to select what kind of stereoscopic
display you have. The simplest version is having none, but using colored glasses (like the Red-Cyan). The other
options are for special hardware. Just try out what works for you. This is a rather new and not completely stable
feature, so it may not work for you.

One known but at the moment this is written unsolved problem is that the 3D view does not work on Mac OS X using
Lion (it does work with Snow Leopard).

5.4 Fly to selection

When you have a big system, it often make sense to zoom in to some particular region. To do this, use the View →
Fly To Selection menu command.

Not only will this zoom in to the selected atoms, but the center of the selected atoms will also become the new center
of rotation when you use the mouse to get a different view.

5.5 Reset View

You can reset the view using the View → Reset View menu command. This is especially useful after flying to the
selection. Or when the view gets distorted for some reason.
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CHAPTER

SIX

MOUSE INTERACTION

6.1 Rotate, Translate and Zoom

In the modules that provide a 3D view of your molecule (like ADFinput, ADFview and ADFmovie) you can rotate,
translate and zoom using the mouse.

Drag with the mouse: press a mouse button, and move it while holding it down. A one-button mouse button is the
same as a Left mouse button. Which mouse button, and which modifier key you press at the same time, determines
what will happen:

Rotate Left mouse button
Rotate
in-plane

Ctrl with Left mouse button

Translate Right mouse button
Zoom Use the scroll wheel on your mouse, or Middle mouse button, or (not on windows) Alt with Left

mouse button

The rotate, translate and zoom operations change how you look at the molecule. They do not change the coordinates.

In ADFinput operating with the mouse on the selection will move the selection only. In that case the geometry of
your molecule (and thus the coordinates) will change. Zooming the selection will move it perpendicular to the screen,
unless you are using the mouse-wheel. You operate on the selection by starting the drag operation with the mouse
above a selected object.

In the View menu you can select either ‘Mouse as trackball’ or ‘Mouse as joystick’. If ‘Mouse as trackball’ is selected,
you need to drag with the mouse (move the mouse with a button pressed down). If ‘Mouse as joystick’ is selected you
just need to press and keep the button pressed down. The direction of movement etc will depend on the position of the
mouse with respect to the center of the 3D view area.

The mouse handling has changed in the 2013 release: the middle and right buttons have been switched. The right
mouse button was used for zooming, now by default it is for translating (and zooming is much more convenient using
the scroll wheel). Via the SCM → Preferences you can switch the mouse handling back to the previous style (use the
“Right mouse button” option).

6.2 Selecting

In the modules that provide a 3D view of your molecule (like ADFinput, ADFview and ADFmovie) you can make
selections using the mouse.

Click on an object: make a new selection with it

Click in space: clear selection

13
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Shift-Click on object: add or remove it from the selection

Shift-Drag in space: add all objects within the rectangle to the selection

In some modules there are additional ways to select objects using menu commands. Furthermore, in ADFinput one
can select atoms from the list in the coordinates window.
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CHAPTER

SEVEN

KEYBOARD SHORTCUTS

Many tools and menu commands have keyboard shortcuts associated. For menu command shortcuts, the shortcut is
listed in the menu.

In many modules the shortcut to open or add a result file can be combined with the shift key. That allows selection of
any file (otherwise a filter will be applied).

On most UNIX systems (including Linux) and Windows you need to use the control key together with some letter. On
a Macintosh (running locally) you need to use the key (command key) together with a letter.

If you are using a Mac, the GUI uses the X11 program to run. The X11 program itself may intercept the menu-
shortcuts like -C, -H, and so on. You can change this using the Preferences command from the X11 menu (Enable key
equivalents under X11 should NOT be checked).

The following table lists all keyboad shortcuts, per module. If no or ctrl is specified Just press the indicated key
without any modifier keys. On a mac, should be used as shown, on other systems use the control key (ctrl).

7.1 ADFinput

Key Function
arrow-up/down in search results highlight the previous or next search result
backspace Delete selection
delete Delete selection
Return in search results open the currently highlighted search result
Esc Select-tool (end other tool), clear search, active Main page
1 Single bond
2 Double bond
3 Triple bond
4 Aromatic bond
-1 View Direction → Along X-axis
-2 View Direction → Along Y-axis
-3 View Direction → Along Z-axis
-a Select → Select All
-b Edit → Builder...
-c Edit → Copy
-d Select → Select Connected
-e Atoms → Add Hydrogens
-f Search
-g Atoms → New Region From Selected Atoms
-j Transparency Periodic Cells → Increase Transparency Periodic Cells

Continued on next page
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Table 7.1 – continued from previous page
-k Transparency Periodic Cells → Decrease Transparency Periodic Cells
-l Bonds → Add Bond
-m Select → Select Molecule
-n File → New
-o File → Open...
-q Quit
-r File → Run
-s File → Save
-v Edit → Paste
-w File → Close
-x Edit → Cut
-z Edit → Undo
--B Generate Super Cell...
--e Atoms → Remove Hydrogens
--g Atoms → Remove Selected Atoms From Regions
--z Edit → Redo
Space Structure Tool
c Carbon
f Florine
h Hydrogen
n Nitrogen
o Oxygen
p Phosphorus
s Sulfer
x Element (type to select element and then return)
- Molecule Smaller
= Molecule Bigger
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7.2 ADFview

-1 View Direction → Along X-axis
-2 View Direction → Along Y-axis
-3 View Direction → Along Z-axis
-a Select → Select All
-d Add → Isosurface: Double (+/-)
-d Select → Select Connected
-f Fields → Calculated
-i Add → Isosurface: Colored
-j Transparency Periodic Cells → Increase Transparency Periodic Cells
-k Transparency Periodic Cells → Decrease Transparency Periodic Cells
-l Add → Add Bond
-m Select → Select Molecule
-n File → New
-o File → Open...
-p Add → Cut Plane: Colored
-q Quit
-s File → Save Picture...
-w File → Close
--o File → Open... (no filter)
- Molecule Smaller
= Molecule Bigger

7.3 ADFmovie

-1 View Direction → Along X-axis
-2 View Direction → Along Y-axis
-3 View Direction → Along Z-axis
-a Select → Select All
-j Transparency Periodic Cells → Increase Transparency Periodic Cells
-k Transparency Periodic Cells → Decrease Transparency Periodic Cells
-k Scale Displacements → Smaller
-l Scale Displacements → Bigger
-o File → Open...
-q Quit
-s File → Save Geometry...
-t File → Update Geometry In Input
-w File → Close
--o File → Open Any... (no filter)
- Molecule Smaller
= Molecule Bigger

7.2. ADFview 17
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7.4 ADFlevels

– Interactions → Decrease # Significant
-= Interactions → Increase # Significant
-a View → Hide/Show All Fragments
-i File → Add...
-o File → Open...
-p File → Save Postscript...
-q Quit
-w File → Close
--i File → Add Any... (no filter)
--o File → Open Any... (no filter)

7.5 ADFtail (Logfile)

-c Edit → Copy
-o File → Open...
-q Quit
-w File → Close

7.6 ADFoutput

-c Edit → Copy
-o File → Open...
-p File → Print...
-q Quit
-w File → Close

7.7 ADFspectra

-i File → Add...
-o File → Open...
-p File → Save Postscript...
-q Quit
-w File → Close
--i File → Add Any... (no filter)
--o File → Open Any... (no filter)
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7.8 BANDstructure

-1 View Direction → Along X-axis
-2 View Direction → Along Y-axis
-3 View Direction → Along Z-axis
-j Transparency Periodic Cells → Increase Transparency Periodic Cells
-k Transparency Periodic Cells → Decrease Transparency Periodic Cells
-o File → Open...
-p File → Save Postscript...
-q Quit
-w File → Close
--o File → Open Any... (no filter)
- Molecule Smaller
= Molecule Bigger

7.9 ADFdos

-1 View Direction → Along X-axis
-2 View Direction → Along Y-axis
-3 View Direction → Along Z-axis
-a Edit → Select All
-d Edit → Select Connected
-j Transparency Periodic Cells → Increase Transparency Periodic Cells
-k Transparency Periodic Cells → Decrease Transparency Periodic Cells
-m Edit → Select Molecule
-o File → Open...
-q Quit
-w File → Close
--o File → Open... (no filter)
- Molecule Smaller
= Molecule Bigger

7.10 ADFjobs

-a Tools → Add To SDF...
-b Edit → Clear
-c Edit → Copy
-q Quit
-r Job → Run
-s Queue → Status
-v Edit → Paste
-w File → Close
-x Edit → Cut

7.8. BANDstructure 19
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CHAPTER

EIGHT

INPUT

This version of the GUI has unified the input modules for ADF, BAND, ReaxFF and other packages. The new input
module, typically called ADFinput, can now prepare the input for all of the old methods, as well as for new methods
like DFTB, Mopac, UFF and so on.

After starting ADFinput, you will notice a bright colored menu ‘ADF’ on the left of the panel bar. Depending on your
license, it might read ADF, or BAND, or one of the other methods. If you click there, you will get a pull-down menu
that allows you to switch the method. Thus effectively you can turn ADFinput into BANDinput, or ReaxFFinput, and
so on.

In the SCM menu you will a New Input command. This command will start ADFinput. Next you can switch to BAND
mode, etc, as just described.

The unified interface makes it possible to do things like reading a crystal structure file (which will cause ADFinput to
switch one of the methods supporting periodicity automatically). Next you can build super cells, cut out clusters, and
switch back to ADF without periodicity. No need for extra licenses, and no need to copy/paste between GUI modules.

The Main panel for some methods (like DFTB and UFF) contain a ‘Run’ button. If you press that, the current method
will be started interactively, with the geometry of your system updating on the fly. The main use for this is as a
pre-optimizer, no files will be saved and only the geometry will be updated.

8.1 Input: buttons

8.1.1 Searching

At the top right in the panel bar you will find a Search tool. You can activate it by clicking on it, or by using the
ctrl/cmd-F shortcut.

After activating it, a small field will pop-up that allows you to enter your search text.

When you enter some text in the search field, the search will start immediately and the results will be presented below
the search text. The results are divided in several sections:

Panels: a list of all panels that match the search text. All texts on a panel will be searched: titles, menus, help text and
associated keys. When you click on one of the panel search results that panel will be activated, and the items matching
your search query will be marked. This is a very convenient way to find a particular input option. The search is
restricted to panels belonging to the currently active method (thus, while in ADF input mode you will not find BAND
input panels).

Documentation: a list of matching documentation pages. If you click on it, that page will be shown in your browser.
Note that this uses the local documentation, it does not contact the SCM web site. Again, the search is restricted to
documentation that belongs to the currently active method.

Molecules: a list of matching molecules. The match may for example be in the name or in the molecule formula. If you
click on a match, that molecule will be imported. The list of molecules is a mix of some ADF optimized molecules,
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and of results taken from the NCI-Open database (see http://cactus.nci.nih.gov). Again, all information is contained in
the ADF distribution, the search will not contact external sources. In total about 35000 molecules are included.

Crystals: a list of matching crystals. The match may be in the name or formula. Most of the crystals are simple com-
mon crystals are found in many textbooks. On the MOPAC web site there is a list of crystals that have been optimized
using MOPAC. Those are also included. Finally, the zeolite frameworks from the IZA-SC database (http://www.iza-
structure.org/databases/) are available.

When starting, at most five matches will be shown in each section. At the right side of the section headers (Panels,
Documentation, Molecules) you will spot a triangle pointing to the right. If you click on it, you will open that particular
section and many more results will be shows, if available.

Pressing the “i” (to the right of the search text field) will bring up a detailed description of the search facility. It will
explain how to do more complex searches.

If you move your mouse above one of the search results, without clicking on it, a balloon will pop up showing more
details about that particular match. For the documentation matches it will tell you from what manual the result is, and
from which chapter. For molecules it will give some more information about that molecule, like names, sometimes a
CAS number, and what the source of the data is (for example, optimized using ADF, or from the NCI-Open database).

After typing a search text, you can also use the up and down arrow keys to select a particular search result, and then
press the Return key to open that result. When starting with ctrl/cmd-F this means you can perform the search and
accept result without using the mouse.

8.1.2 The ”...” details buttons

In many panels in ADFinput you will find white oval buttons with three dots in them. These buttons will activate a
panel showing more details for some particular feature.

For example, the ”...” button to the right of the Task option in ADFinput will activate a panel that allows you to set
details for the current task. Thus details for a geometry optimization, or details for a transition state search.

It depends on the context and sometimes on the active options to which panel the buttons link. In all situations it
should be intuitive, just try it out.

8.1.3 Using the “i” info buttons

Some panels in ADFinput have an “i” button (just as the search pop-up). When you press the “i” button, a new page
will open with much more background information on some feature.

For example, the “i” button in the search pop-up will show a description of the search syntax. And the “i” button next
to the basis set (in the Basis detail panel) will show more information about the basis sets.

8.2 Searching

In ADFinput there is a search icon in the top-right corner. Click on it to bring up a search box. Searching will be
performed automatically when you enter text in the search box.

You will search multiple things at the same time:

• matching panels with input options in ADFinput (from the panel bar)

• documentation

• molecules
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The search will be restricted to panels and documentation that belong to the currently selected program (ADF, BAND,
DFTB, ...). In these panels, it will find any panel that contains your search string, including the matching program key.

Prefix: key

If you start your search with “key ” (without quotes), you will restrict your search to fields related to matching input
keys only. This will allow you to locate an input option very quickly.

Prefix: all

If you start your search with “all ” (without quotes), the search will be global for both the panel search and documen-
tation search. Thus it will not be restricted to the currently selected program.

The molecule search will search a (local) database with some common molecular structures. Currently it consists
of a roughly 1800 molecules optimized with ADF for use with COSMO-RS, and of the molecules found in the NCI
database (NCI-Open_09_03.sdf, see http://cactus.nci.nih.gov). The molecules in the NCI database have been filtered
to include only molecules with names and xyz coordinates, and most CAS numbers have been removed for legal
reasons. Also periodic structures are available: zeolites (from the Database of Zeolite Structures (http://www.iza-
structure.org/Databases)), many simple crystal structures, and a set of complex crystals included with the MOPAC
distribution.

As the structures come from an external source we can not guarantee that the found structures will be correct. So
please check them!

In total roughly 35000 molecules are available.

To clear the search results at any time, also when the search box is no longer visible, use the Escape key.

Only the locally included documentation and molecule structures will be searched. No internet search will be per-
formed.

8.2.1 Panel search details

All text belonging to the panels will be searched: panel titles, labels for input options, headers, text in pull-down
menus, and text in help balloons.

You can use the * and ? wildcards: the * matches anything, the ? matches any single character. The search string will
be broken into words, and only results containing all words will be found. Use double quotes (”) around text to search
for exactly that phrase. The words to search for are implicitly surrounded by * wildcards, so text matching will happen
even in the middle of a word.

The names of the found panels will be listed. When you click on one of them, it will be activated. Options not
matching the search string will be dimmed. If an option is not dimmed, it matches either directly, by it’s help text, or
by the page title.

Use the arrows next to the search loupe to quickly loop through the found panels.

8.2.2 Key search details

To search for input fields that have to do with a particular input key, you can use the key search. To do this, start your
search string with “key ” (without the quotes). This will restrict the panel search to find only items that set or change
the matching key.

You can use the * and ? wildcards: the * matches anything, the ? matches any single character. The search string will
be broken into words, and only results containing all words will be found. Use double quotes (”) around text to search
for exactly that phrase. The words to search for are implicitly surrounded by * wildcards, so matching will happen
even in the middle of a word.

For example, searching for
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key integration

will show you what input options in the GUI will set the INTEGRATION key.

The names of the found panels will be listed. When you click on one of them, it will be activated. Options not
matching the search string will be dimmed. If an option is not dimmed, it matches either directly, by it’s help text, or
by the page title.

Use the arrows next to the search loupe to quickly loop through the found panels.

8.2.3 Documentation search details

The included documentation (in html format) will be searched using the Swish-e search engine. You will be searching
for words. If you specify more you will get matches that contain both words, in any order.

The (shortened) titles of the found documentation pages will be listed. If you point at an item with your mouse, it
will show the full title. Click on it to open that item with your default browser. Note that you will be viewing local
documentation, not the SCM web site.

When staring, only the first 5 documentation matches will be shown. To view all results, click on the arrow on the
right side of the ‘Documentation’ header in the search results. Click on the same arrow again to show only the first 5
results again.

You can use the * wildcard to match anything, but only at the end of an word. You can use the ? wildcard to match a
single character, but NOT at the beginning of an word. You can also perform complex searches using logical operators
(and, or, not) and parenthesis. If no operator is specified between words, the and operator is used (both words need to
be found) Finally, you can search for an exact phrase using quotes.

For example: integration and not accuracy integration or accuracy integration key “integration key”

The search will be restricted to the parts of the documentation relevant to the module you are using. Thus, when
searching from ADFinput with ADF active, the BAND documentation will not be searched.

If you prefix your search with “all ” (without the quotes), all documentation will be searched.

For more information on Swish-e: http://swish-e.org/

8.2.4 Molecule search details

The included database of molecules will be searched. You can search for the IUPAC name, the molecule formula, the
CAS number, and sometimes alternative names. Note that the CAS number search will often fail as only a few CAS
numbers are included.

You can use the * and ? wildcards: the * matches anything, the ? matches any single character. The search string will
be broken into words, and only results containing all words will be found. Use double quotes (”) around text to search
for exactly that phrase. The words to search for are implicitly surrounded by * wildcards, so text matching will happen
even in the middle of a word.

When you start your search string with “=” (an equal sign, no quotes), no wild cards will be added automatically.

When you move the mouse over one of the found molecules, you will get full details including the origin of the entry
(optimized by ADF, or from the NCI database).

When you click on the desired search result, that particular molecule will be imported.
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8.3 Crystals and Slabs

8.3.1 Periodicity

Many GUI modules support periodicity. Some menu commands (like the Edit → Crystal command in ADFinput)
will only by available when you have a periodic system.

To set up periodicity you first need to switch to a method that supports periodicity. For example BAND, DFTB,
Mopac, or UFF. Some of these, like UFF, are currently available without extra license.

On the Main panel of a method that supports periodicity, you will find a ‘Periodicity’ pull-down menu. Use it to use
periodicity in 1 (Chain), 2 (Slab) or 3 (Bulk) dimensions. Once periodicity is enabled, menus like the Crystal menu
will also be enabled.

The tool bar below the molecule editor also changes when you have a periodic system. The structures tool gets replaced
by the crystal tool (represented by a snowflake), followed by the Slice tool. At the right side of the tool bar you find
buttons to orient the camera, toggle perspective and toggle the display of periodic images.

To set up the lattice vectors, press the ”...’ details button next to periodicity, or go to the Lattice panel (in the Model
section).

When editing the lattice vectors: changing the 1,1 element also adjusts the 2,2 and 3,3 element. Changing the 2,2
element also adjusts the 3,3 element (but leaves the 1,1 as it is).

8.3.2 Building crystals

After setting the periodicity and lattice vectors, you can build your own crystal by adding atoms at the proper position.
For many crystals this is a lot of work.

You can also build crystals using the** Edit → Crystal** command. The first list of options (Cubic, Hexagonal and so
on) have sub-menus for some common crystals. If your crystal is not in there, you can use the “From Space Group...”
command in the same menu. This brings up a dialog that will help you build any crystal.

The crystal tools are not only available from the Edit menu, you can also press the ‘Snowflake’ button in the molecule
editor tool bar (next to the element button, if periodicity is enabled). It has the same options as the Edit → Crystal
menu.

8.3.3 Build slabs

Building a slab is done most conveniently using the Slice tool: first build a crystal, next use the “Generate Slab...”
command from the Crystal menu to make a slab. Next you will need to enter the Miller indices of the plane that will
define your slab.

The Slice tool is available from the Edit → Crystal menu, or in the periodic toolbar (next to the snowflake).

8.3.4 Crystal menu

Generate Super Cell...

In the dialog that appears when using this command you determine how the super cell should be created.

When editing the setup: changing the 1,1 element also adjusts the 2,2 and 3,3 element. Changing the 2,2 element also
adjusts the 3,3 element (but leaves the 1,1 as it is).
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Map Atoms To (-0.5..0.5)

Edit → Crystal → Map Atoms To (-0.5..0.5)

Using the translational symmetry, the atoms are mapped to the cell centered around the origin. Thus with fractional
coordinates between -0.5 and 0.5 for each lattice direction.

Map Atoms To (0..1)

Edit → Crystal → Map Atoms To (0..1)

Using the translational symmetry, the atoms are mapped to the cell in the positive quadrant. Thus with fractional
coordinates between 0 and 1 for each lattice direction.

Set (0.5, 0.5, 0.5)

Edit → Crystal → Set (0.5, 0.5, 0.5)

The selected atoms define some point. This point will be translated to the point with fractional coordinates 0.5, 0.5,
0.5. All atoms will be adjusted according to this translation.

Related, to shift the point defined by the selected atoms to the origin use the Set Origin command.

8.4 Builder (packmol)

To build systems consisting of many different molecules, randomly put together, the GUI includes the Builder. This is
a graphical interface to the packmol program, using only a few possibilities of it. The most common use will be to set
up a big system for Molecular Dynamics with ReaxFF or DFTB.

If you find using the Builder (and thus packmol) useful, please give proper credit via the following reference

L.Martínez, R. Andrade, E. G. Birgin, J. M. Martínez. Packmol: A package for building initial configurations for
molecular dynamics simulations. Journal of Computational Chemistry, 30(13):2157-2164, 2009.

The Builder allows you to compose your system of many replicas of some predefined molecules. These molecules are
replicated as often as you want, giving a simulation box full with these molecules. Thus it is very easy to generate a
liquid or a gas.

To activate the Builder, use the Edit → Builder menu command.

First you need to define the box into which the molecules will be generated. In the Builder panel you define the lattice
vectors that define the unit cell.

Next you define what molecules to add to your system. Press the + button to add more molecules, or press the - button
in front of a line to remove that particular molecule.

The ‘Current’ option will include whatever you have manually created on the left side. For example, some molecules
to be solvated. Or some slab imported from BANDinput.

The ‘Fill box with’ option allows you to select what molecule to use for filling. The geometry of the molecule must be
available in a file with .xyz extension, and it should contain the coordinates and atom types of your molecule in XYZ
format. Many typical molecules are included with ReaxFFinput. When you press the folder button at the right side
you will be able to select your molecule via a file-select browser. Or you can start typing a text in the field, and below
it matching molecules will be shown (similar to the molecule search).

As you may have more then one kind of molecule, you can also make mixtures of different molecules.
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Once you press the ‘Generate Molecules’ button, the actual packing of the molecules is done using Packmol
(http://www.ime.unicamp.br/~martinez/packmol/).

8.5 Building molecules

Building molecules with ADFinput is very simple, just draw them with the appropriate tools. Please check the tutorials
for extensive description of this.

Here we will just note some details that may not be obvious.

8.5.1 Bonding mode

After creating an atom, it will be selected (the ‘bond atom’). When you still have an atom tool and one atom is selected,
you are in bonding mode. This is indicated by a line from the bond atom to the mouse cursor. If you next click to
create a new atom, it will automatically be bonded to the bond atom.

To stop bonding mode, click once on the bond atom. This will switch to the select tool, and as a result you are no
longer in bonding mode.

8.5.2 Atom Details: Connectors (valency) and Lone Pairs, Atom mass

Each atom you make has the possibility to connect to other atoms. The number of connections depends on the atom
type. Some of the ‘connectors’ may be used by lone pairs and not be available for bonding to other atoms.

For example, carbon has 4 connectors and no lone pairs, oxygen has 4 connectors and 2 lone pairs.

When you use the Add Hydrogen menu command, all unsaturated connectors will be saturated with hydrogen atoms.
The number of connectors will determine the geometry (2 linear, 3 flat, 4 tetrahedral). So if you plan to use this
command it is essential that the number of connectors and the number of lone pairs is correct.

You can view and change these via the Atoms → Details (Color, Radius, Mass...) menu command. It will activate
the Atom Details panel, in which you an change the number of connectors and lone pairs for each atom. Note that
only selected atoms will be visible in the Atom Details panel.

You can also see and change other atom properties like the type, screen radius, nuclear charge, mass, color, Amber
and Tripos atom types and more.

8.5.3 Pre-optimization

After drawing a molecule you will typically run a pre-optimization.

On the right end of the molecule editor tools you will see a cog wheel. If you click it your system will be optimized
using the UFF method.

If you right-click the cog wheel you will get a pop-up menu that allows you to specify which method to use as a
pre-optimizer: UFF, Mopac, DFTB or SimpleMM. UFF, Mopac and DFTB are identical to these methods within
ADFinput, SimpleMM is a very primitive force field like method that used to be the only available pre-optimizer. It is
mainly included for compatibility.

Alternatively you can just switch ADFinput into UFF, Mopac or DFTB mode (by using the orange method menu in
the panel bar). For each of these you will find a ‘Run’ button on the Main panel. If you press it, it will run the current
set up interactively, updating the coordinates and possibly the bonds on screen automatically. This is very similar to
clicking the cog wheel, but it allows you to set details of the calculation. For example, for DFTB you can select what
parameter set to use.
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8.5.4 Geometry adjustments

Sliders

Select two, three, four or five atoms.

Below the molecule, a horizontal slider will appear, just above the toolbar.

You can drag the thumb inside the slider to change the distance, angle, dihedral, or plane angles.

By default, The smallest group of atoms will move, keeping the rest of the molecule unchanged. However, if you press
the control key and then move the slider, the order in which you select the atoms determines what atoms will move.
The last atoms you select will move in that case. You can force this behavior (so you do not need to press the control
key) by setting the SCM_GEOMODSBYORDER environment variable (via the Preferences or via the command line).

You can use regions to group atoms. Atom in a region will move together when using a slider to change distance or
angle.

Edit box

Select two, three, four or five atoms.

Above the slider on the right side you will get an text entry box next to the atom labels. For example, after selecting
two atoms it might look like H(8)-C91) (pm): 149. The 149 in this example is editable. Instead of using the slider,
you can type some specific number in this box instead.

Move an atom (possibly perpendicular to the screen)

First select the atom that you want to move.

Next, translate (middle mouse button, or alt left mouse button), but start with the mouse on the atom that you want to
move.

If you wish to move the atom perpendicular to the screen: use the right mouse button (or command left mouse button)
and move the mouse up or down). This is equivalent to zooming.

Rotate or translate the selection

First make your selection.

Next rotate, translate or zoom as usual, but start with the mouse in the selection. So if you click and drag the selection,
ONLY the selection will be rotated or translated. If you click and drag anywhere else the whole molecule will be
rotated or translated (actually, only your viewpoint).

If you ‘zoom’ the selection you are really moving the selected objects perpendicular to the screen (in or out the screen).

Coordinates

In some situations you want to set the coordinates of the atoms exactly to some value. You can do this via the
Coordinates panel (in the Model part of the panel bar).

If you first select the atoms of interest, they will be highlighted in the Coordinates panel. The coordinates in that panel
can be edited, and the molecule on the left side will immediately reflect the changes.
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Z-Matrix

In some situations you want to set the coordinates of the atoms via a Z-Matrix. You can do this via the Z-matrix panel
(in the Details part of the panel bar).

If you first select the atoms of interest, they will be highlighted in the Z-Matrix panel. The values for the distances and
angles in that panel can be edited, and the molecule on the left side will immediately reflect the changes.

The connectivity can not be edited, but you can effectively do this by reordering the atoms. That way you normally
can create the Z-Matrix coordinate that you are after.

Set Center Of Mass

The Edit →Set Center Of Mass command translates all atoms so that the mass-weighted center of the selection will
be the new origin. If nothing is selected, the center of mass of the whole molecule will be the new origin.

The atoms are really translated, thus the coordinates are changed. It is not a change of the camera.

When symmetry is used, the origin will also be the origin of symmetry.

Set Origin

The Edit →Set Origin command translates all atoms so that the center of the selection will be the new origin. If
nothing is selected, the center of all atoms will be the new origin.

The atoms are really translated, thus the coordinates are changed. It is not a change of the camera.

When symmetry is used, the origin will also be the origin of symmetry.

Symmetry

To symmetrize your molecule, clock on the star tool in the tool bar below the molecule editor. This is equivalent of
the Edit → Symmetry → Symmetrize Using Symmol menu command. In most cases this just works, and is the
preferred method of symmetrizing your molecule.

The Edit → Symmetry menu gives access to a less automatic but more power-full symmetry code. Using it is
somewhat complicated, and sometimes it does not work as expected.

To use it, follow this procedure:

• Select the symmetry group

• Set the (symmetry) origin of your molecule via the SetOrigin menu command

• Define one or two operators for the selected group. In the symmetry menu you can see what operators you need
to define.

• Use one of the symmetry commands:

Rotate 90

The Edit → Rotate 90 commands (select an axes via the submenu) will rotate your system around some axes.

Not only the coordinates of the atoms, but also the lattice vectors (if any) will be rotated.

Thus, for example, if you get some .cif file with a nanotube structure and want to treat it with BAND as a one-
dimensional periodic structure (a chain), you must ensure it is oriented along the x axes. If the structure in the .cif file
is oriented along another main axes, these commands make it very easy to fix that.
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Align

The Edit → Align command contains commands to align your molecule to the indicated axes or plane.

If you are aligning to an axes, you need to select which atoms to align. If you select one atom, the molecule is rotated
around the origin such that the selected atom is on the specified axes. If you select two atoms, first the molecule is
translated such that one of the selected atoms is on the origin. Next, the molecule will be rotated such that the other
selected atom is on the specified axes.

If you are aligning to a plane, you need to select a plane to align. If you select two atoms, these will define the normal
of the plane to be aligned. If you select three atoms, these define the plane to be aligned.

This Align command does change the coordinates of your atoms, unlike the Align Screen command in the View menu.

Not only the coordinates of the atoms, but also the lattice vectors (if any) will be rotated.

Typically the Align command will change your origin. You can always set the origin as you like after-wards.

Mirror

The Edit → Mirror command contains commands to mirror the selected atoms (or all atoms if no atoms selected) in
a plane parallel to the indicated plane, through the center of the selected atom(s), or through the center of the molecule
if no atoms selected.

The Mirror command does change the coordinates of your atoms. Also the lattice vectors (if any) will be mirrored.

Update coordinates via ADFmovie

If you have performed a calculation that saves multiple geometries, for example a geometry optimization or a linear
transit run, you can use ADFmovie to see how the geometry changes. You can go to a particular geometry, and then
use the ‘File → Update Geometry in Input menu command in the Movie window to adjust the geometry in the
matching ADFinput window.

8.5.5 Bonds

Bonds are normally made while drawing the molecule. There are several other options to handle bonds:

• Make a bond via an atom tool: Take one of the atom tools. Next click once on the first atom you want to connect.
You will enter the bonding mode (the line to the mouse position from the atom you just clicked on will be your
visual cue for the bonding mode). Next click on the atom you want to make the bond to. The bond will be
created, and you will revert to the normal select mode.

• Make a bond using the Add Bond command: Select the two atoms that you wish to be bonded together, and then
use the Bonds → Add Bond command.

• Via Guess Bonds Use the Bonds → Guess Bonds menu command. This command uses an algorithm that looks
at bond distances to guess the bonds and bond orders. The bond orders are adjusted based on the known number
of connectors and lone pairs.

8.6 Importing your molecule

Importing from file: .adf, .t21, .xyz, .mol, .mol2, .pdb, .runkf, .band, .cif, .dmol, .rkf, .rxi, .rxkf ...

You can also import your molecule from a file using the File → Import Coordinates... command.

Many formats are handled explicitly. They are typically recognized by the file extension:
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.adf, .band, .rxi These files have been saved by ADFinput, BANDinput or ReaxFFinput. Every detail be-
longing to atoms or bonds will be imported: not only the coordinates and bonds, but also things like atom
properties (for example the color, the force field atom type, number of connectors, bond orders, and so on).

.t21, .runkf, .rxkf, .rkf These are all results files produced by the ADF package. The coordinates and
bond information will be read, if present. The files are binary, and will be recognized even if having a different
extension.

.pdb, .mol2 Importing from a .pdb or .mol2 file will get the coordinates and the protein information (residues,
PDB atom names and so on). For PDB files, only the ATOM information is read, thus no bond information. For
MOL2 files, also the bond information is read.

.mol Importing from a .mol file will get the coordinates and bond information.

.cif Importing from a .cif file (Crystallographic Information File) will import the proper crystal structure. No bonds
will be read.

.dmol Files from the DMol program can also be read, and atom positions and periodic information is properly
handled. No bond information will be read.

.xyz, any file type not recognized Importing from an unknown text file, or a file with .xyz extension
is rather flexible: ADFinput needs three real numbers next to each other. These will be interpreted as x, y and z
coordinate. One additional integer or the abbreviation of an element is also needed to identify the kind of atom.

To be recognized as real, the real number must contain a ‘.’ (dot), and at least one digit before or after the dot.
Real numbers with exponents (E or D) are not recognized.

If an integer is used to specify the element (the nuclear charge), it may not contain a ‘.’ (dot).

No bond information is read.

If no bond information has been read, ADFinput tries to guess the bonds between the imported atoms. Guessed bonds
might be completely wrong, or have the wrong bond order.

Z-matrix import (internal coordinates) is not available.

After using the ‘Import Coordinates...’ command the newly imported atoms are selected. This makes it easy to
reposition them with respect to other atoms that may already be present, remove the automatically guessed bonds, or
use other operations on the newly imported atoms and bonds.

If you are importing many atoms, the molecule visualization will switch to wire-frame for the newly imported atoms.
By default this happens when importing 50 atoms or more. You can change this limit via the SCM → Preferences.

8.6.1 Copy/Paste between GUI modules, XYZ coordinates, SMILES or InChI strings

When Copying or Pasting with ADFinput, you need to make sure that the molecule editor has focus. Otherwise you
will be copying or pasting one of the text input fields. To be sure, just click once in the drawing area before pasting.

You can copy an XYZ-formatted geometry (for example from an ADF output file), and use the Edit → Paste command
to import coordinates. Pasted text will be handled as when it had been import as .xyz or .cif file via the Import
Coordinates command.

Copy/Paste also works between the GUI modules, for example if you have several ADFinput windows. This will copy
all information about your molecule: xyz, bonds, but also things like color of atoms or number of connectors. Only
selected atoms will be copied.

If you have the SMILES or InChI string of your molecule on your clipboard (for example, from wikipedia) you can
just paste it in ADFinput. It will automatically be converted to a 3D structure (via OpenBabel). It works often, not
always, so be sure to check your structure.
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8.7 Regions

A Region in ADFinput is defined as a collection of atoms. Atoms may be present in one or more region.

Within the GUI they are used for many purposes. For example to change the visualization style for part of the molecule,
to set up fragment calculations, or to set up other multilevel calculations like QUILD, QMMM or FDE.

When using the slider to change distances or angles you can use regions to group atoms (so they move as one).

When you select the Regions panel (in the panel bar Model section) you will find that one region has already been
defined: All. This region consists of all atoms of your molecule, and is always present.

To add a new region, click the + button. If any atoms are selected when you press this button, they will automatically
be added to this new region. With this new region you can do a couple of things:

• Click the - button: delete the region. Note that only the region is deleted, not the atoms in it.

• The check box: this selects all atoms currently in the region. In your molecule display you can easily see what
atoms are in it, and it will also tell you how many atoms are contained in this region.

• Click in the region name to change the name

• Click the check box (the V-like shape) to show the region graphically

• The + button (on the right hand side): add the currently selected atoms to this region

• The - button (on the right hand side): remove the currently selected atoms from this region

• Click the triangle to get access to a pop-up menu with a number of commands that apply to that region.

The pop-up menu per region has the following options:

• Split By Molecule: split the region in many regions, based on the connectivity. Thus parts that are not bonded
together will all be put in a separate region. The typical use is for solvents: first add a solvent with explicit
molecules. The solvent molecules will automatically be put in their own region. Next, use the Split By Molecule
command to split this into many small regions. If all your solvent molecules are identical, this leads to a very
big time saving with fragment or FDE calculations. As the typical use is for replicated fragments, the naming
of the newly generated regions will use the /n name, with n a number. Currently ADFinput does not check if the
fragments are really identical!

• Invert Selection Within Region: perform an invert selection command, but just within the atoms part of this
region.

• Region Color: set the color used to visualize the region

• Balls And Sticks: show the atoms and bonds in this region using Balls and Sticks

• Sticks: show the atoms and bonds in this region using Sticks only (that is, atoms not visible)

• Wireframe: show the atoms and bonds in this region using a wire frame only (again, no atoms visible)

• Hidden: do not show the atoms and bonds in this region

Regions can also be used in the Numerical Quality and Basis panel: you can change the basis per atom type per region.
For example, give all carbon atoms in an outer region a smaller basis. Or you can set the Quality per region (the Becke
/ Zlm fit options and/or Basis and Core).

A quick and easy way to make a new region containing the current selection is to use the Atoms → New Region From
Selected Atoms menu command (cmd/ctrl-G).
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8.8 Proteins (from PDB or mol2 files)

ADFinput can read a protein from a PDB file for from a mol2 file.

The atom information is read (element type, coordinates, PDB name, residue to which the atom belongs, and chain
information).

The PDB atom names are also essential to properly add hydrogens, in case your PDB or mol2 file does not have any
hydrogens.

In the Regions panel for each chain detected in the PDB file, there will be a new line. This gives you a couple of
visualization options (Ribbon, or all C, CA, N or O atoms connected). If you click on the triangle to the right you get
a pop-up menu with some additional commands:

• New Region From Chain: make a new region, and put all atoms belonging to this chain into the new region

• Select Residue: select all atoms in a given residue (which you select from the menu)

• Residue Protonation: change the protonation state of some residues

• Add Hydrogen: add hydrogen atoms to this chain

• Add Selection To Chain: the selected atoms are marked as belonging to this chain

• Add Selection To Residue: the selected atoms are added to the specified residue

Many of these features depend on the proper PDB names and residue information for the atoms. If they are not correct,
or non-standard, ADFinput may for example add hydrogens to the wrong positions, or visualize things incorrectly.

For the protonation state of some residues it is essential that their proper names are used: LYN/LYS, ASP/ASH,
GLU/GLH, HID/HIE/HIP.

You can use the Atoms → Details (Color, Radius, Mass, ...) command to check and change the PDB names of the
atoms.

Having the proper PDB atom names and residue types (including the proper protonation state) is essential. The atom
types generated for MM (Amber95) depend on them, as well as the algorithm that adds hydrogens (if needed).

The hydrogens that are added by ADFinput do not use a very advanced algorithm. For the protein itself it should be
correct in most cases, assuming you have made sure that you have the proper protonation state of the residues. How-
ever, if you have solvent molecules in your PDB file the hydrogens will be added properly but the solvent molecules
will be oriented randomly. So no hydrogen bond structure in water for example.

To avoid problems with the primitive algorithm ADFinput uses to add hydrogens you can obviously use some other
tool to first make a proper PDB or mol2 file for your protein including hydrogens.

Once read in, you can use in principle all tools within the GUI as you like. For example, perform MM, QMMM or
QUILD calculations for the protein structure.

8.9 Presets and Defaults

All input options have default values. ADFinput presets are simply a collection of input values to be used.

A preset may set all or just a few input options. After you have selected a preset, fields that are set by the selected
preset will be show with a green color.

If you next use another preset, only the input options included in the preset will be changed. Other input options will
remain as they are. Thus the order in which you apply presets is important.
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8.9.1 Using a preset

ADFinput always first uses the Defaults preset as included by SCM. Next the Defaults preset defined by the user (if
any). Finally, a preset matching the current task will be loaded (either from SCM or defined by the user).

When you switch the Task, ADFinput will try to load a matching preset.

If you have saved matching presets yourself these will be used instead of the standard presets, thus allowing you to
set your own defaults as you like them. A matching preset is a preset that has the same name as the Task selected,
user-defined presets are searched first. If no matching preset is found, ADFinput will load a preset matching the Single
Point task (which is always available). For presets to match, spaces and minus signs are ignored.

You can also load any preset you like using the Preset command from the File menu. This preset will be applied just
as the other presets, so it does make a difference when you load the preset.

8.9.2 Color Code

The input fields use a color coding to warn you they have been modified:

• No special color: the field has its original default value.

• Yellow: the field has been changed by the user (only).

• Green: the field has been changed by the preset (only).

• Red: the field has been changed by the preset, and next by the user.

The pull-down menus in the panel bar use a similar color-coding to point you to fields that have been changed:

• No special color: all fields in the panel have their original default value.

• Yellow: some fields have been changed by the user.

• Green: some fields has been changed by the preset.

• Red: some fields has been changed by the preset, and some (possibly also) by the user.

8.9.3 Make your own presets

It is very easy to make your own presets, collecting all or a few default values for the typical jobs you like to perform.

By default presets are saved in the $HOME/.scmgui/Tpl directory. This can be changed by setting the SCM_TPLDIR
environment variable.

To make your own preset, follow these steps (in ADFinput):

• edit all the fields as you would like them to be stored in a preset.

• select ‘Save as preset...’ from the Preset menu, or ‘Save as full preset...’

• specify a name

• click on Save

If you now check your Preset menu you will find a new entry.

The name of the preset is the file name you have chosen, but without the .tpl extension.

The difference between a Full Preset and a ‘normal’ Preset is that a Full Preset will save all input options, and a
‘normal’ preset will save only the yellow, green or red fields (options that have been changed by the user or by the
active template).

If you wish to store only fields that you have changed yourself in the preset, make sure you start with the None preset.
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If you save a preset with the same name as one of the default presets, it will effectively replace that preset. One
exception: the SCM supplied Defaults are always read first, and thus cannot be replaced.

Some presets are only available for specific methods. For example, the Fragment Analysis preset is only available
for ADF. You can get this behavior for your own presets by pre-pending the name of your preset by the name of the
method for which it should be available. For example “ADF_My_Defaults”, or “BAND_My_band_Defaults”.

To delete your own preset(s), use the ‘Delete Preset’ command from the Preset menu.

8.9.4 Multiple presets are used

The default values that are used when you start ADFinput are generated as follows:

• Use the Defaults preset supplied by SCM

• Use the Defaults preset that the user has defined, if any

• Use the ‘Single Point’ preset, either supplied by SCM or one that is defined by the user (if any)

• Any user selected preset, directly or implicitly (by changing the Task).

8.9.5 Input options remarks

Empty fields

Some input fields do not have a value from the default Preset. In those cases ADFinput does not specify the value, but
leaves the value to be determined by the ADF program.

You can use the ‘Explicit Defaults’ preset to see the typical values. However, depending on details of your calculation
the actual default used by ADF may be different.

Spin and Occupation

The spin and occupation panel allows you to specify the occupations of the orbitals per symmetry. In case of an
unrestricted calculation you can also specify the occupations per spin type.

To show the available symmetries, ADFinput needs the result of an ADF calculation. If a previous calculation is
available (without specifying the occupations), it will use the information from that calculation to generate the proper
options in this panel. If such results are not available, ADFinput will suggest to run a short guess calculation: a
preliminary run with an inaccurate grid, only a few SCF cycles and stopping immediately after the SCF. Hopefully
this guess calculation will allow you to generate sensible occupation.

The energy levels of the guess calculation (or previous calculation if available) will be shown using ADFlevels. Be
aware that it is the result of the guess calculation, and not your proper results!

User Input

You can use the User Input field to specify any kind of text. The text will be put without any change at the beginning
of the ADF input. This way, you may access some keys that are not (yet) available in ADFinput.

Alternatively, and more flexible, you can obviously edit the .run file after saving it with ADFinput.
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CHAPTER

NINE

ADFJOBS

9.1 Jobs

9.1.1 Job list: per folder or global

When ADFjobs starts, it will generate a list of jobs for you by scanning the local directory. All files that have the
same file name, with only a different extension, will be considered to be one job. A job may also contain a directory,
it should have the .results as extension.

ADFjobs can also show a global list of jobs. All recent jobs that it knows about (by previously scanning a directory,
or by running them) are shown. This typically can be a huge list, and it is limited (currently) to 500 most recent jobs.
The big advantage is that you do not need to remember where you saved a job, it will automatically show in the global
list. To switch between the two modes (showing only jobs in the current directory, or showing all known jobs) use the
toggle switch at the right bottom corner.

If you are viewing the global list of jobs, you can use the View → Job Location menu command to show where on
your disk the jobs are located. For each job one extra line will be displayed with this information.

The job list refreshes automatically when needed. You can force a refresh via the Job → Refresh List menu command,
or by pressing F5. For each job you will see:

The Filter command determines what kind of jobs will be shown. For example, you can choose not to show directories,
or only ADF jobs.

At the bottom right you will find a toggle button. This button will toggle between the two modes of ADFjobs: show
all jobs, or show the jobs per folder.

9.1.2 Job status (including WARNING and ERROR info)

The status icon is the icon on the right side of the job. It tells you if the job is a new, queued, running, terminated,
ready, ready with a warning, or ready with an error condition.

The warning and error condition is determined from the logfile of the job. If it contains a WARNING, the icon will
display a warning triangle. If the logfile contains ERROR, the status icon will change into a red stop sign. If the
standard error output of a job contains unexpected information this will also be reported as an ERROR.

The details of the error or warning will be shown in a color just below the job. Obviously, when a job has ended with
an error you will normally not have useful results. If a warning has been printed, you should make sure you understand
the warning, and that the ADF did perform the calculation that you intended.

9.1.3 Selecting Jobs

You can select one or more jobs with:
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• left click - select that job

• shift left click - select a range of jobs

• right click (or control left click) - toggle that job to be selected or not selected

• click on the search icon - clear the selection

To clear the selection, press the ESC key, use the Job → Clear Selection menu command, or click somewhere in
white space on the bottom or in the selected job (thus not on the name, queue, or one of the icons).

9.1.4 Running a job: .run and .job

When saving your job, ADFinput saves a .adf file and a .run file. The .adf file contains all information for ADFinput,
and if you wish to make changes to your job use ADFinput to make them. ADFinput will read the .adf file.

The .run file contains the basic commands and input to run your calculation. It is intentionally kept as simple as
possible.

However, typically some more administrative things need to be done: make empty working directories, make some
links to follow a running calculation, etc. This used to be done by the run script, but not any more. If you wish to use
the run script yourself you are responsible of taking care of such details.

To run your calculation, use the Run command from the File menu. This will tell ADFjobs to run your job. Alterna-
tively, you can switch to ADFjobs, select your job (that you should have saved from ADFinput), and select Run from
ADFjobs Job menu.

ADFjobs will create the real job script (with .job extension). This is a the .run script as saved by ADFinput, with the
administrative things included at the front and at the end.

As the .run script is simply included, you may edit it if you wish, and ADFjobs will automatically include your
changed .run script.

If the environment variable SCM_RESULTDIR has been set, the job script will change into that directory. Next it will
run from there, and all result files will be stored in that directory.

If the environment variable SCM_RESULTDIR has not been set, the job script will execute in the directory where it
is located, and the result files will also be located in that place.

The exact command given to run the job depends on the queue configuration.

9.1.5 Job files

Local files

The local files section lists all files that ADFjobs found. They all have the same name (the name of the job), and
different extensions. Here you can see what files belong to a job, including modification date and time, and the size of
the files.

Double clicking on some of the extensions will open that file. For example, double clicking a .adf file will open it in
ADFinput. Double clicking a KF results file will open it in the KFbrowser.

Double clicking while holding the control key will open the file as a plain text file. This is only a good idea if it is
actually a text file. On Linux, the EDITOR environment variable determines what program to use to open the text file.

One useful application is double click on the .run file. This will open the .run file in a text editor, depending on your
operating system. In this editor you can actually make changes to the .run file. When you save it this modified run file
will be used when you run the job. The .job file will be overwritten, thus you need to change the .run file if you wish
to make manual changes.
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You can also first select a local file. Next select one of the GUI modules from the SCM menu, and the selected file
will be opened by that GUI module, if possible.

Within the local files you may also find a directory called ‘results’. This will be created when result files are present
other then the standard result files. For local jobs they will always be present, for remote jobs it will be created when
using the Transfer from Remote command or when you click on one of the remote files in the remote .results folder,
as displayed in ADFjobs.

Remote files

This is a similar list of files as the local files list, but these files reside on a the remote machine as specified in the job
details. If you are preparing a new calculation it will be empty. When a calculation is complete, it will show all the
result files on the remote machine.

At the top of the list the name of the directory in which the files live on the remote machine is shown.

You can select a remote file by clicking on it. This will cause the file to be transferred to the local machine, replacing
any local file with the same name. If you click on any of the remote files in the .results directory all remote files
belonging to the job will be transferred (overwriting local files with the same names).

After selecting the remote file it will be used by GUI modules started from the SCM menu.

9.1.6 Clean Up

After a calculation many files may be saved. Some of them might not be of interest for you, or only temporarily. You
can use the Job → Clean Up command to remove files no longer needed. It will present a dialog where you can select
exactly what files to remove. The most important result files will by default be saved.

9.1.7 Archive jobs

You can use the Job → Archive command to collect most files belonging to a job and put them in a gzipped tar
archive. This will significantly reduce the amount of space used by the job. The command will operate on all selected
jobs.

If you use an archived job in ADFjobs (or any GUI module) will recognize it as archived, and automatically unarchive
it before using. So in practice you can just archive many (or all) of your jobs and forget about it. This will save a lot
of disk space.

9.1.8 Import / Export jobs

If you want to share jobs with other users (or SCM support) there is an easy way to do this. Just select your job in
ADFjobs, and use the Job → Export... command. A dialog will appear that allows you to specify where to save the
packaged job. The packaged job is in principle just a gizpped tar file containing all job files, with some extra data so
that ADFjobs recognizes it as a packaged job.

Use the Job → Import... command to open such a packaged job and add it to your ADFjobs listing.

9.1.9 Find job files

After some time you may have a lot of result files collected in the same folder. The Job → Show Files command will
show the files belonging to the selected job on your computer. How it does this exactly depends on your operating
system. Typically a window will open showing the files in the directory, with the files of the job selected.
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9.1.10 Test Job

When you have trouble running jobs, either locally or via some queue you have defined, it is sometimes not easy to
figure out what the problem is. To help you (or us, when you ask for support) diagnose the problem ADFjobs can
make a test job.

Use the Job → Generate Test Job, select it in your ADFjobs window, assign the queue you want to use (or skip this
step if you want to test the default queue), and use the Job → Run command.

The logfile of that job will contain a lot of diagnostic information, like the environment, license details, adf version
details and more. Some consistency checks are performed. This information might help you to solve the problem. If
not, contact us, explain the problem and include the output of the test job.

9.2 Queues

A queue tells ADFjobs how to run the selected job: where (possibly on a remote system!), how and by whom.

In the Queue menu you see a list of queues. Select one of them to use that queue when running the selected jobs.

If you have configured queues for remote machines, you will be able to use those remote machines just as easily as
your local machine. ADFjobs will take care of copying files to and from the remote machine. It will also start or
submit your job, and inform you of the progress of your job.

If you have defined your own queue, for example to run on some remote cluster, you can make that the default queue
(instead of the Sequential queue) by using the Queue → Set Default menu command.

For each job, you can specify some extra text in the options field next to the name of the queue (with the gray rectangle
around it). How this text is used depends on how your queues are set up. For example, the Interactive queue uses it
to specify the number of tasks to use in your job. For batch systems, it might be the number of nodes to use, or some
time limit or batch queue name.

When starting ADFjobs the first time, you will see the Interactive and the Sequential queue. Both will run jobs on
your local machine, using as many tasks as possible. You can enter a number in the options field of the job (with the
gray rectangle) to set the number of tasks use explicitly.

Via the GUI Preferences, you can also configure ADFjobs to automatically pick up queues stored in a central location.
They need to be defined once, and any ADFjobs user can import them. Such queues are called ‘Dynamic queues’.

9.2.1 Interactive Queue

When you run ADFjobs for the first time, it will make sure that an Interactive queue exists. If not, it will automatically
create such a queue for you.

When you use the interactive queue to run a job, your job will run immediately on the local machine. Thus you can
run many jobs at the same time.

To specify how many tasks to use, enter a number in the options field. If you leave it empty all cores will be used.

As you could be overloading your machine it may not be what you want, but it is great if you have some job running
and want another small on to run at the same time. Another use would be to run several single-core jobs on a multi-core
desktop machine at the same time.

9.2.2 Sequential Queue

When you run ADFjobs for the first time, it will also make sure that a Sequential queue exists. If not, it will automati-
cally create such a queue for you.
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When you use the Sequential queue to run a job, your job will run interactively on the local machine as soon as no
other job is running. Thus you can give the run command in ADFjobs for many jobs at the same time, but they will
actually run one after the other.

To specify how many tasks to use, enter a number in the options field. If you leave it empty all cores will be used.

Normally, this is the most convenient and efficient way to run jobs on your local machine. For that reason it is the
default queue (unless you change that).

9.2.3 Setting up your own Queues

You can define a queue in several ways:

• Queue → New... based on one of the included example queues,

• Queue → Edit... change details of a queue (or make a new one if you change the queue name as well),

• SCM → Preferences → ADFjobs → Dynamic Queues import queues stored on some central system

When using the Queue → New... command, you can select what configuration to start with:

• Interactive: make a new Interactive queue. For example, to make a special version that will force your job to
use only 1 task.

• LSF, PBS, SGE: make a new queue that will submit your job to the selected batch system. The configuration of
these batch systems can be quite different. The included examples should server as an example only, you will
need to fix the details. In the included examples the options field is used to specify the number of nodes to be
used.

When using the Queue → Edit... command, you select what queue configuration to edit.

Using either of these commands, a dialog will appear requesting you to set the details of the queue you are creating
(or modifying).

Often it requires some experimentation to set up all the details correctly. You can use the Help → Trace Commands
To Remote menu command in ADFjobs to trace the commands given to communicate with the remote host (typically
the ssh or putty command with arguments), and to see the responses to these commands received from the remote host.
This trace will be shown in via ADFtail.

The following details may be set when configuring a queue:

Remote host Name of the machine on which you wish to issue the command to run (or submit) your job. You
should be able to connect to that machine using ssh, and the host name as specified here. If you wish to run on
your local machine, leave this field empty or specify localhost.

Remote user The username that you need to specify in the ssh command, if any. Typically, this is your username
on the remote machine. If you have configured ssh to log in on your remote machine without specifying a user
name, you can just leave this field empty. That is also the most convenient way to set up a queue that is to be
used by other people as well (with their own accounts on the remote machine).

Remote job directory On the remote machine, ADFjobs needs to set up your input files and run script, and
needs to collect the results. For that purpose ADFjobs will make its own directories within the directory you
specify. A typical value would be something like $HOME/jobs.

Run command The command on the remote host to be executed. ADFjobs will always first ssh into the Remote
machine, and then issue the Run command. The run command should start the job interactively, or submit the
job using some batch system. If the remote host field is empty or localhost, the run command will be executed
on the local machine.

$job will be replaced by the full path to your job script on the remote machine.

$jobname will be replaced by a jobname based on the value of $job, but truncated and with spaces removed.
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$options will be replaced by the contents of the Options field. The Options typically will be used to specify the
number of tasks, a time limit, or a batch queue name.

If you use the run command to submit a job to some batch system, it should return a number. This number will
be assigned to $jid, and may be used by the kill and job status commands.

To run interactively, just enter “sh $job”. To submit your job to a queue, specify the submit command (for
example, qsub, or some other special submit tool). For example, check the pre-configured queues for Interactive
and batch systems (via the Queue → New... menu command).

The job script that is automatically generated accepts an optional parameter. This parameter is ‘eval-ed’ at the
start of the script. Thus, you can use it to set environment variables (like NSCM) or other things.

When the run command is issued, the working directory will be $SCM_RESULTDIR or the location of the
.job script if no SCM_RESULTDIR has been defined. The results (output file and so on) will also be saved in
that location. Note that the computational engines (ADF, BAND, ...) will automatically change their working
directory when started to $SCM_TMPDIR. You should make sure that SCM_TMPDIR points to the proper
location as you want to make sure you are writing to a fast local disk, and not to the (typically shared) disk
where the results are stored.

Use Local Batch If yes, jobs will be queued on the local machine. Only one job will be running at a time. This
is set for the Sequential queue (which is default). Currently this value is ignored when the job will be queued or
run on a remote system.

Kill command The command to use to kill a queued or running job. In this command $jid will be replaced by the
job id (from the output of the run command), or by the process id. For interactive jobs, killall $pid should work
fine. This killall is actually replaced by a special script that takes care to kill adf and all child processes.

Job status command This command will be used to determine if a job is still queued or running. If a job is no
longer queued or running, it should return an empty string. Anything else will server as indication that the job
is alive. For interactive jobs ps -p $pid | grep $pid works fine.

System status command The command to use to determine the system status. This might be uptime, or some
qstat command for batch systems.

Prolog command The command to execute by the job script, just before the included .run script. This will be used
to set up the environment properly. For example, you would source a script file to set all environment variables
for ADF like ADFHOME, ADFBIN etc. This is especially important if you are working with different versions
of ADF at the same time. Note that the job script is started using /bin/sh, so you should use sh-like syntax
(an not csh-like). If your environment is already set up correctly for running ADF on the remote host, without
issuing any commands, you can leave this field empty.

In your prolog command you can use environment variables that are defined by the job script. Most importantly,
the environment variable SCM_OUT points to the output file of the job, SCM_LOG points to the logfile, and
SCM_ERR points to the error output. This makes it easy to print some additional information to those files.

You can put multiple commands here separated by ”;”. However, in most cases it is easier to source a file with
commands. By sourcing it you make sure that changes in the environment defined in the sourced file will also
be available by the job script.

Epilog command This is the command to run by the job script, just after the included .run script. You can use it to
copy save result files, or to perform some cleanup action. Again, use sh-style syntax, and the same environment
variables are still defined..

Synchronize jobs If this field is set to ‘yes’, jobs on the corresponding remote host will be used for job syn-
chronization (via the ADFjobs Synchronize Jobs command).

9.2.4 Dynamic queues

Dynamic queues are updated automatically when ADFjobs starts.
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ADFjobs will check with the hosts that you have specified in the Preferences:

Open GUI preferences: SCM → Preferences
Panel bar Module → ADFjobs
Click the + button in front of Dynamic Queues
Enter the host name of the host on which to look for dynamic queues
Optionally: enter the username of the remote machine on which to look for dynamic
→˓queues
Click the 'Save' button at the bottom of the panel, and restart ADFjobs

If the username is left empty (or to the value (username)), no username will be used when connecting to the remote
machine. Then your ssh configuration determines what username to use.

On the remote hosts listed, ADFjobs first checks the $SCM_QUEUES environment variable. If it is set, it will
import the queues defined in the $SCM_QUEUES directory. If it is not defined it will try to import queues from
$HOME/.scm_gui. This is the location where ADFjobs stores the queue information.

To define the dynamic queues, first figure out what queue settings you (and/or others) want to use. You can do this
by configuring a normal queue with ADFjobs as described. As dynamic queues typically will be used by many users,
you should not specify a username (unless you want all users to use the same account on some system). Make sure it
works properly.

Next make a directory on the remote system where you want to store the dynamic queue definitions.

Set the SCM_QUEUES environment variable system wide on remote system for all users. If SCM_QUEUES is not
defined, ADFjobs will search the $HOME/.scmgui directory on the remote platform. This way users can set up their
own dynamic queues.

Locate the files that define your queue: you can find these files in the $HOME/.scm_gui directory. They have the name
of the queue, with a .tid extension, and are plain text files. Next, copy these files into the $SCM_QUEUES directory
on the remote system. Make sure all users have permissions to read the $SCM_QUEUES directory and the files in it.

Note: the server that stores the dynamic queues need not be the same machine on which the jobs will run.

Note: the ADFjobs user needs to have access to the server via ssh

9.2.5 Example Queue configurations for SGE and PBS

Here you will find example .tid files for SGE and PBS. They will not work without change, you need to set at least the
proper hostname and runcmd, and most likely the prolog needs to be changed (or just made empty).

The contents of the .tid file for a SGE queue might look something like this:

# hostname: machine.domain
# username:
# jobscript:
# prolog: source $HOME/setup/adf2017
# epilog:
# jobdir: $HOME/jobs
# runcmd: qsub -pe s3_mpich $options -q short3.q "$job"
# batch: no
# options: 2-2
# killcmd: qdel $jid
# jobstatuscmd: qstat | grep " $jid "
# sysstatuscmd: qstat
# label: My SGE queue
# logfile: logfile

Similar, for a PBS queue it might look something like this:
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# hostname: machine.domain
# username:
# jobscript:
# prolog: source $HOME/setup/adf2017
# epilog:
# jobdir: $HOME/jobs
# runcmd: qsub -lnodes=2:ppn=2:infiniband -lwalltime=$options "$job"
# batch: no
# options: 0:15:00
# killcmd: qdel $jid
# jobstatuscmd: qstat | grep $jid
# sysstatuscmd: qstat -q
# label: My PBS queue
# logfile: logfile

9.3 Tools: set up many jobs and collect data from many jobs

You can use the Prepare tool to set up batches of jobs. For example, first set up an ADF calculation with your preferred
basis set, XC potential and so on using ADFinput. Next, use the Prepare tool to generate a batch of similar jobs, but
for different molecules (taken from .xyz files for example). Or you could set up a calculation for your molecule, and
generate a set of jobs with different XC potentials and / or integration accuracies.

The Reporting tool is to generate a report of one or more calculations. This report will contain the information that
you select when you define a ‘report template’. Most of the properties that have been saved to .t21 will be available.
And you can generate images as will (like HOMO or SCF density). These results will typically be collected in an
HTML table: one row for each molecule, and one columns for each property.

A report template defines what information to put into the report.

9.3.1 Prepare: set up many jobs at once

You activate the Prepare tool via the Tools → Prepare... menu command.

A window will appear that you can use to specify how to generate a set of jobs.

Three main list fields are presented: the Run field, the coordinates field, and the input options field. In each of these
lists you can specify multiple options. When pressing ‘OK’ ADFjobs will generate the jobs by combining the options
in all possible ways.

Run list Select one or more .adf files to run. A .adf file is just a calculation that has been set up using ADFinput
before. Alternatively, one may use one of the predefined .adf files as present in the pull-down menu when you press
the ‘+’ button. To add a .adf file, use the pull-down menu, or specify a file name in the text field and press return. You
may use wild card in the text field, so the default value (*.adf) will expand to all .adf files in the current directory. To
remove something from the list, select it and press the ‘-‘ button.

Coordinates list When this list is empty, the molecule as found in the .adf files will be used. When one or more sets
of coordinates is present in this list, the molecule in the .adf file(s) will be replaced by the molecules as defined in
the coordinate files. You may use .adf files, .xyz files, .t21 results files, .mol files, .pdb files or whatever other format
ADFinput can use with the ‘Import Coordinates’ function. By listing multiple files here your .adf files (that you listed
in the Run: list box) will all be executed with each of the molecules in turn. Thus, if you specified two run files (for
example a Single Point calculation, and a Geometry Optimization), and three molecules, you will end up with 6 jobs.

Input options list In this list you may define alternative input options. The corresponding input options in the .adf
file will be replaced by the values that you specify here. So if you specify two different basis sets, each job will be
replaced by two new jobs, one with each basis set that you specify. You may also specify other things, like integration
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accuracy and so on. If you specify only one value, that value will be used in all jobs. If you specify multiple values
(by repeatedly adding the option) you will generated multiple jobs.

The text field may be used to add additional keywords, or replace existing ones, with the value specified. These options
will be added to the list of options by pressing return in the text field. The values will be used as the ‘-k’ argument to
the adfprep command. For detailed information about this please check the adfprep documentation.

Produce jobs options The final fields will tell the prepare tool where to generate the jobs (the directory is relative
to the current directory, and will be created if it does not yet exists). Also one big job will be created that is just a
concatenation of all the individual jobs. When running interactively it might be more convenient to run this job instead
of all the individual jobs. The results should be identical, the big job will produce files that look as if they have been
produced by the individual jobs.

9.3.2 Report: collect data from many jobs

To make a report of calculation results, you first have to set up a ‘Report Template’ that defines what information
should be collected for the report. You manage these report templates via the New, Edit and Delete Report Template
menu commands in the Tools menu.

When editing a report template, a dialog box will appear with many options. Just check the options for the information
that you wish to collect in your report. Note that you can also include images (of orbitals, and so on) in the report.

If you wish to include something that is not present in the dialog, you can use the last field: Extra ADFreport command
line options. Whatever you specify here will be passed to ADFreport to generate the report. This allows you to get
any information that is available on a .t21 result file into your report. Check the ADFreport documentation for syntax
details.

Once you have your Report template set up, you can use the Build command to actually generate a report. The data
for the report will be taken from the currently selected jobs. You can update the report with new data from other jobs
by using the Update Last Report command, with one or more different jobs selected. These jobs may even be located
in a different directory. This allows you to collect information from jobs a few at a time.

9.4 Series of jobs depending on each other

In ADFinput you can specify (in the Coordinates panel) that it should use the molecule from some other file or job.
Then a job is created that depends on another job or on some other file (for example a .sdf file).

ADFjobs shows such dependencies when you select a job.

To run such a series of jobs that depend upon each other, you can just run the last job in the series. ADFjobs will
determine what other jobs need to be run as well, and automatically start them (using the same Queue as the job you
started yourself).

In the Tutorials you will find several examples of such jobs.
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TEN

ADFVIEW

The ADFview module of the GUI is used mainly to visualize field data like orbitals, densities and potentials. Addi-
tionally, it can also visualize some scalar atomic data, tensor data, and Bader (AIM) results.

10.1 Visualization methods

Via the Add menu you can select a visualization tool. This tool (an isosurface, or a cut plane for example) can be used
with any kind of field. After selecting the command to add the visualization tool you will get a new extra control bar
at the bottom of the window.

The following visualization tools are available:

• Isosurface: a simple isosurface through a scalar field

• Colored Isosurface: an isosurface through a scalar field colored by a second field

• Double Isosurface: two simple isosurfaces through a scalar field, for both a negative and a positive iso-value
(typically used for orbitals)

• Multi Isosurface: multiple isosurfaces colored by isovalue

• Colored cut plane: a plane through some field, colored by the values of the field

• Contours cut plane: a plane through some field, with contour lines on the plane to show the values of the field

• Contours(+/-) cut plane: a plane through some field, with contour lines on the plane to show the values of the
field, with negative contours using dashed lines

• Vector Field: many vectors on a grid, pointing as directed by some vector field. You can get a vector field
by calculating the gradient of some other field for example. You can do this via the Calculated Fields menu
command.

In the control bar you select what field to visualize. The fields will be calculated on the fly. The leftmost field of the
control bar (containing the name of the visualization method) also is a pull-down menu that you can use to access
details, or to delete that particular visualization tool.

10.1.1 Spinor: spin magnetization density

Spinors are a result of spin-orbit coupled calculations. Visualization of spinors is more difficult than visualization of
orbitals. A spinor Ψ is a two-component complex wave function, which can be described with four real functions 𝜑:
real part 𝛼 𝜑𝑅

𝛼 , imaginary part 𝛼 𝜑𝐼
𝛼 , real part 𝛽 𝜑𝑅

𝛽 , imaginary part 𝛽 𝜑𝐼
𝛽 :

Ψ =

(︂
𝜑𝑅
𝛼 + 𝑖𝜑𝐼

𝛼

𝜑𝑅
𝛽 + 𝑖𝜑𝐼

𝛽

)︂
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The density 𝜌 is:

𝜌 = Ψ†Ψ

The spin magnetization density 𝑚 is:

𝑚 = Ψ†𝜎Ψ

where 𝜎 is the vector of the Pauli spin matrices 𝜎𝑥, 𝜎𝑦 , and 𝜎𝑧 . A spinor is fully determined by the spin magnetization
density and a phase factor 𝑒𝑖𝜃, which both are functions of spatial coordinates.

The (square root of the) density and spin magnetization density are visualized as a double isosurface and a vector field
respectively. The phase factor 𝑒𝑖𝜃 , reduced to a plus or minus sign, is visualized with the double isosurface and with
the color of the vector field.

The main control bar is identical to the control bar of a normal isosurface. If you show the details, you will find that in
addition to the controls available for a normal isosurface, you can also specify coloring information. In this case, the
two numbers for the HSV colors define the colors of the minus and plus sign.

10.2 Fields

Fields can be things like orbitals or densities. You select them from the field pull-down menu in the control bars. In
the Fields menu the Grid option determines on what kind of grid the field will be calculated.

As a convenient short-cut, you can switch fields using the up/down arrow keys

For many fields, like orbitals, transition densities etc selecting the option from the field pull-down menu brings up
a window where you can select the field of interest. As an example, selecting ‘Occupied Orbitals’ will bring up a
window that lists all occupied orbitals.

In these field select windows you can sort the fields by clicking on a column header. Clicking again on the same
column header will reverse the sort order. When you use another command from the field pull-down menu the select
window will close, unless you check the ‘Keep Open’ check box. That allows you, for example, to show all orbitals
(both occupied and virtual) at the same time.

You can also create new fields out of these basic fields by combining them (calculated fields, for example the difference
between two fields), or by interpolating them to get a finer or less dense field.

10.2.1 Steric Interaction

The Steric Interaction field is generated using Van der Waals radii to visualize steric bulk. The field is the minimum
distance to the Van der Waals surface of the selected atoms. The radii are taken from the MM3 method by Allinger
(N.L. Allinger, X. Zhou, J. Bergsma, Molecular mechanics parameters, Journal of Molecular Structure: THEOCHEM
312, 69 (1994) (http://dx.doi.org/10.1016/S0166-1280(09)80008-0)). An isovalue of 0 corresponds to the Van der
Waals surface.

10.3 Properties

In the Properties menu you find commands to visualize scalar atomic info. Either by displaying the numbers, scaling
the atom radii by these numbers, of by using the scalar values to color the atoms.

You also find some short-cuts to generate orbital plots: HOMO-1, HOMO, LUMO, LUMO+1, Density and
Spin=Density. These commands will generate a double isosurface, and select the appropriate field for it.
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Next are commands to visualize some tensor data, depending on what tensor data is available. The tensor is visualized
as a sphere scaled in the directions of the eigen-vectors of the tensors by the eigenvalues of the tensors. For each
visualized tensor type you will get a control bar that allows you to tune the visualization.

Finally, the properties menu allows you to visualize some Bader results. The Bader sampling shows you the integration
grid, but with all the grid points colored that are together in the same Bader basins. The AIM (Bader) command
visualized the critical points and critical paths.

10.4 Comparing data from several molecules

ADFview can handle more than one molecule at the same time. You can show fields for different molecules in the
same window, you can create calculated fields to see differences, and so on.

The different molecules may come from different files, or from one result file containing multiple geometries. An
example of the first situation would be two different calculations, with different XC potential, resulting in two different
.t21 files. An example of the second would be the .t21 file from a NEB calculation. That file contains the information
for all images, so you can see how (for example) the HOMO changes from image to image.

To add a new molecule from a different file, just open an additional file using the Open menu command from the File
menu.

ADFview has a ‘current’ geometry. The molecule shown will be the one for the current geometry only.

To change the ‘current’ geometry, use the horizontal slider below the molecule window.

The visualization items (surfaces) might be filtered in such a way that only items related to the current geometry are
shown. This is the default when visualizing NEB results: you want to see how the density or an orbital changes going
from one image to the next (using the slider). If you open different files the default is to show visualization items for
all geometries at once. Thus you might compare orbitals from one fragment with those from another. You can switch
this behavior using the ‘Show All Geometries’ menu command from the View menu.

You can easily compare calculations on the same molecule that differ in something else then geometry. Just open both
result files (.t21). Next, you can calculate differences between similar things. If you add a calculated field, you will
find that the first command in the field select menu is used to select the geometry from which to take the data. Thus,
you can select the same property from different files and compute the difference.

Warning: The current implementation has no possibility to adjust the orientation or the grid. In practice this means
that you need to take care that the fields that you compare actually make sense to compare. This is only the case
if the geometry of the molecules is identical and thus the grid is identical. Though this is very restrictive, you can
make interesting comparisons for a given molecule: change due to different XC, basis sets or integration accuracy for
example.

10.5 Temporary Files

ADFview normally will run DENSF or BAND in the background. This means that it needs scratch space to store
inputs and result files to be visualized. After normal termination of ADFview (using Quit) all scratch files will be
removed.

The scratch files will be created in the following location:

• If $SCM_TMPDIR is defined : use the $SCM_TMPDIR directory

• else, if $HOME is defined: use the $HOME directory

• else, if $TMPDIR is defined: use the $TMPDIR directory

• else try to use the current working directory.
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10.6 Calculating Fields

ADFview will show you a progress dialog with some options when calculating fields.

In front of the progress bar you will notice a right-pointing arrow. If you click on it the progress dialog window will
enlarge, and you can follow the progress of the field calculation (by DENSF) in detail. If you scroll back in that
window you can also examine the input given to DENSF. Obviously this output is also very useful when there is some
problem calculating the field. Click the Close button at the right of the progress bar to close the progress dialog.

You will also see a Run button, and before it a pull-down menu that you can use to select a queue. When the calculation
of a field is slow (for a fine grid or big molecule) you can press Run, and the calculation will be saved as a job in
ADFjobs, and will then automatically be started to run in the specified queue. After the calculated has started you may
quit ADFview if you wish, the results should automatically be picked up when you start ADFview again (and when
the fields are available). As you can select the queue to used, you can also calculate the fields on some remote machine
if you wish. See the ADFjobs documentation about the use of queues.

While a field is being calculated via ADFjobs, it will be visible in ADFjobs as a new job. The results will be stored with
that job. When you start ADFview for your original molecule it will detect the newly available fields automatically. It
will move the newly calculated fields to it self, and delete the job that was used to calculate the fields.

When you close ADFview after calculating some fields, ADFview may ask you to save the field. If you save the field
it will automatically be available the next time you start ADFview (for this job). Be warned that saving many fields
may take a lot of disk space. You can use the Clean Up command in ADFjobs to delete them.
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ELEVEN

KFBROWSER

WIth the KFbrowser you can inspect all KF files produced by the ADF package. It has two modes: the default
non-expert mode, and the expert mode.

11.1 Non-expert mode

You will see a sub-set of the data contained on the KF file. It may be empty, depending on the KF file. For KF files
that the KFbrowser knows about (t21, runkf, rkf and rxkf) it will show the results that may be of use for users.

If you select values you can use double click on the selection or use the Selection As Graph menu command to see
the values in a graph.

You can use Copy/Paste to copy the selected data and paste it in a different program, for example Excel. The data will
be copied as tab-separated so it will be pasted nicely formatted in your editor or spreadsheet.

11.2 Expert mode

In expert mode you will see all data on the KF file. This is mainly intended for developers. You should not assume
any meaning to anything shown here unless you are familiar with the code that produced the KF file.
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TWELVE

CONFORMERS

The GUI has an option to handle multiple conformers of molecules.

Conformers may be created using RDKit (see www.rdkit.org (http://www.rdkit.org)) via ADFinput. There is now
a Conformers job method (just like ADF, BAND, DFTB etc) that will show a panel with options to generate the
conformers. The algorithm used by RDKit for conformer generation will only work properly for single molecules,
and the proper connectivity needs to be present.

After setting the proper options, just run the job like any other job. So it may also be running in the background.

The conformer geometries are stored in an .sdf file. This is in principle a series of xyz structures, with bond information
and some other data. The energy is stored in the comment line, and in the extra fields there is also information like
what program calculated the energy, and sometimes a pointer to the matching input file (.adf file) and results file (.t21
file).

You can use ADFmovie to open the .sdf file and see the molecules in there. Open the Energy Graph in ADFmovie to
get a graph of the corresponding energies.

With ADFinput you can set up your calculation as usual (single point, geometry optimization, or anything else). In
the Coordinates panel (in the Model section) you can specify that you want to use the molecules from the .sdf file
(Use Selected File, and specify the .sdf file generated by the Conformers job). You can select what entries to use
from the .sdf file using the SDF Filter panel (click on the ... button after Use Selected File, or go to the SDF Filters
panel in the Details section directly). You can filter based on count or energy. In this panel you can also select what
post-processing options will be aplied to new sdf files generated by a calculation.

When you save your setup in ADFinput, a run script is created that will execute your job for all the conformers. Results
of the individual calculations will be saved in the .results directory, and the original .sdf file will also be put there (with
a time stamp). After running a new .sdf file will be created that has the results of the calculations, with pointers to the
result files. Technically this is done using adfprep and adfreport in the run script.

Based on this new sdf file you can now do other things, if you want. Thus you can chain a series of calculations, for
example first optimizing with DFTB or MOPAC, next optimizing with ADF, and finally calculating some property
with ADF.

If you have calculated some spectrum (IR, NMR, UV/Vis) for all conformers in this way, you can visualize the
averaged spectrum via ADFspectra. If it finds an .sdf file with the job, it will use it and the pointers in it to calculate
averaged spectra. In ADFspectra there will be extra controls on how this averaging is done, most importantly the
Temperature. In the View menu in ADFspectra you can also show all individual spectra, put together in one plot.

As the individual result files are present in the results directory, you can also visualize results from any specific
conformer by selecting that t21 result file in ADFjobs, and then using the tools in the SCM menu as usual.
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THIRTEEN

FUKUI FUNCTION

The Fukui function describes the electron density after adding or removing some amount of electrons. It can predict
where the most electrophilic and nucleophilic sites on a molecule are.

Fukui functions can be easily calculated using the GUI, as shown in the Fukui tutorial.

The Fukui function is implemented as a finite charge change. By default a whole electron is added or removed,
however the calculation is not restricted to this amount. Fractional amounts of electrons are allowed.

The Fukui equation for the electrophilic attack, 𝑓−, is given for when 1 electron is removed.

𝑓− = 𝜌(𝑁) − 𝜌(𝑁 − 1)

Equally, the Fukui function for the nucleophilic attack, 𝑓+, is given for when 1 electron is added.

𝑓+ = 𝜌(𝑁 + 1) − 𝜌(𝑁)

Do note that in all cases the geometry of the neutral state is used to get the electron density.

The Dual Descriptor is a way to combine the two Fukui functions. It has a positive value where it is electrophilic
and negative where it is nucleophilic. It is implemented as the difference between the Fukui plus and Fukui minus
functions.

𝑓(𝑟) = 𝑓+ − 𝑓−

The Fukui function can be used to describe local chemical reactivity. This can even be done per atom by using the
condensed Fukui function.

𝑓−
𝑘 = 𝑞𝑘(𝑁) − 𝑞𝑘(𝑁 − 1)

𝑓+
𝑘 = 𝑞𝑘(𝑁 + 1) − 𝑞𝑘(𝑁)

Atomic charges are used to get the condensed Fukui function. There are several ways to partition the atomic charges.
The Fukui calculation prints the condensed Fukui functions for Hirshfeld, Mulliken, Voronoi, and if calculated, Bader
charges.

The condensed Fukui function is normalized, so that atomic Fukui values sum to one.

𝑁𝑎𝑡𝑜𝑚𝑠∑︁
𝑘=1

𝑓𝑘(r) = 1

The local softness can be calculated as the product of the condensed Fukui function and the global softness. An
approximation for the global softness is given as the inverse of the HOMO-LUMO gap.

𝑆 =
1

𝐸𝐿𝑈𝑀𝑂 − 𝐸𝐻𝑂𝑀𝑂
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The local softness is then simply

𝑠−𝑘 (r) = 𝑆𝑓−
𝑘 (r)

𝑠+𝑘 (r) = 𝑆𝑓+
𝑘 (r)
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FOURTEEN

MINIMUM ENERGY CROSSING POINT

The Minimum Energy Crossing Point (MECP) is the lowest point where two potential energy surfaces cross. These
two potential energy surfaces can be any two orthogonal states. The situation for different spin states is implemented
in the GUI, which takes the current state and the next spin state, e.g. singlet and triplet. This can be used to find the
most likely location for a spin forbidden chemical reaction.

The model menu in ADFinput has the option to calculate the MECP. The same convergence criteria as for ADF is used
for the MECP optimization.
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FIFTEEN

QUANTUM ESPRESSO

The GUI also supports setting up, running and visualizing results from Quantum ESPRESSO. For installation of
Quantum ESPRESSO see the Set up (page 3) section in this manual.

The Quantum ESPRESSO code has not been developed by SCM. We cannot give support for Quantum ESPRESSO
issues other then use via our GUI.

15.1 Input

ADFinput can make run scripts for Quantum ESPRESSO. To do that just go to the Quantum ESPRESSO section in
ADFinput, it should be self-explaining how to run jobs.

On the Main panel you can set the task type (with Geometry Optimization doing the same as the relax and vc_relax
options in Quantum ESPRESSO).

The XC, Type and Relativity options are used to select pseudo potentials. They work by filtering all pseudo potentials
available to match the selected options, for your current system. Thus it depends on your system what options are
available in the XC and Type menus. Click on the ... next to Type, or go to the Pseudopotentials details page to have
ultimate control: select any file as a pseudo potentical file.

When you save your setup, ADFinput will generate a run script. You can preview this script in the Run Script panel
(in Details). You can even edit it, and then your editted run script will be used (note that this will block other changes
you may make in ADFinput until you turn Auto update back on).

15.2 Running

You should run the job preferably via ADFjobs, in the usual way.

That way you can also run on remote machines, and ADFjobs takes care to copy the files needed to the remote machine.
The selected pseudo potential files will also be copied to the remote machine, unless they live in upf_files (then it is
assumed they are already on the remote machine). Obviously you should install Quantum ESPRESSO on the remote
machine as well if you want to run jobs there.

Note that while the job is running you can monitor its progress in ADFjobs, or via the logfile (which in this case is
identical to the output file).

15.3 Visualization of results

After the calculation the Quantum ESPRESSO results are parsed to generate an RKF file. Preferably data from the
data-file.xml is used, but many pieces of information are taken from the standard output file as they are not available
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on the xml file. For that reason there is a chance that things will fail to use if you use a different version of Quantum
ESPRESSO.

The RKF result file can be used by all the SCM GUI modules to visualize results. Thus you can use the SCM menu
to:

• View: visualize the system and fields (density, potential, deformation potential, spin density, ...). ADFview uses
the post processing tools from Quantum ESPRESSO to generate the fields. For that the Quantum ESPRESSO
results need to be available (in the .results folder), not just the RKF file. When your calculation is a remote
calculation ADFview will automatically generate jobs to calculate fields as needed on the remote machine (thus
no need to transfer the ofther big .results directory)

• Movie: the geometry changes during your calculation (for geometry optimizations with or without lattice opti-
mization). As usual you can plot the energy as function of the geometry step, or any geometric data (distances,
angles, cell axes, etc).

• Logfile: the standard text output.

• Output: the standard text output.

• Band Structure: visualize the band structure and (partial) DOS, if calculated

• DOS: visualize the (partial) DOS

• KF Browser: many pieces of output results collected, ready to copy to some spreadsheet or make graphs inside
KF Browser

15.4 Scripting support

Using Quantum ESPRESSO via adfprep and adfreport is fully supported.

Use $ADFBIN/adfprep -h and $ADFBIN/adreport -h for details. For more information on what QE results
are available via adfreport, specify the result file name (the .rkf file) as well.

For example: $ADFBIN/adfreport -h qejob.rkf
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SIXTEEN

ADFCRS: COSMO-RS

ADFcrs is a utility program ($ADFBIN/adfcrs), which enables ADF users to easily create COSMO-RS jobs. You
can use ADFcrs to add compounds, choose the desired property, and to set details of your COSMO-RS job using an
easy-to-use graphical user interface. ADFcrs will generate the complete job script for you. This script takes care of
running COSMO-RS. You can also use ADFcrs to run these script files and visualize the results.

The description of a compound that you want to use should be on a file, and should be a result file of quantum
mechanical calculations using COSMO. In ADF such a COSMO result file is called a TAPE21 (.t21) file, or a COSKF
(.coskf) file. ADFcrs might also be able to read a result file, for example a .cosmo file, from other programs.

If you have installed the ADF package correctly, the adfcrs command is located in $ADFBIN.

If $ADFBIN is included in your PATH environment variable, you can start the ADFcrs program with the following
command:

adfcrs [filename filename2 ...]

The file names are optional. ADFinput handles files that were created by ADFinput before (which have a .crs or
.crskf extension), use only one file name in these cases. One can add multiple files, which correspond to different
compounds, if these files contain results of quantum mechanical calculations including COSMO on these compounds.
these result files should have .t21, .coskf, or .cosmo extension. The file can also be a plain text file with a list of file
names (.compoundlist), which contains on each line the filename of a .t21, .coskf, or .cosmo file.

An alternative method to start ADFcrs: select the COSMO-RS command from the SCM menu, or use ADFjobs to
start ADFcrs.

Under windows you can start ADFcrs by double-clicking the icon on the desktop.

16.1 Menu Commands

16.1.1 File menu

New Same as quitting ADFcrs and starting again without specifying a file name.

Open... Open an existing ADFcrs file (with .crs) or an ADFcrs result file (with .crskf).

Same as quitting ADFcrs and starting again with specifying a file name. When you open a .crs file ADFcrs also
tries to add all compounds that are specified in this .crs file and tries to open all .crskf files that belong to this
.crs file. If you open a .crskf file only this file is read.

Save Save the current state of what is present in ADFcrs. If you have not saved before, ADFcrs will ask you to
specify a file name.

A run file will not be saved.
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Save As... Save the current state of what is present in ADFcrs in a file with a name of your choice.

A run file will not be saved.

Save Runfile Not only the .crs file will be saved, but also a matching .run file which is a run script corresponding
to your input (for the selected property).

Run Start the COSMO-RS calculation as selected in all the input options.

You will first be asked to save the changes. The run script (with the .run extension) for the selected property is
created. Next your job is run. When the run is finished the results will be visualized by ADFcrs and the .run file
will be deleted.

Kill Kill the COSMO-RS calculation if one is running. The .run file will be deleted.

Close Stop ADFcrs, ask you to save changes if you made any.

16.1.2 Compounds menu

List of Added Compounds Shows a list of all the added compounds, including a possibility to set some input
parameters, specific for a certain compound.

On the left side of the window the list of the compounds is given with the full path name to the file from which
the quantum mechanical results data are read. Part of this quantum mechanical data is given in the right window
for the selected compound. In this right window one can also write some pure compound input data. For ring
compounds it is important to write the number of ring atoms. For example, this number should be 6 for benzene.

Add Compound(s) Use this menu command to add one or more compounds to the list of compounds. The selected
files should be of type:

• .compoundlist: List of compounds

• .coskf: COSMO kf file

• .t21: ADF result file

• .cosmo: COSMO file

The added file(s) should be either ADF result files (.t21), COSMO kf files (.coskf), or ASCII COSMO files
(.cosmo). These files should be result files of a quantum mechanical calculation including COSMO, which
contains COSMO segment data. In case of ADF the ADF result file (.t21 or .coskf) will contain COSMO data if
the ADF calculation was done with COSMO. The added file can also be a plain text file with a list of file names
(.compoundlist), which contains on each line the filename of a .t21, .coskf, or .cosmo file.

Install COSMO-RS database... Download and install the COSMO-RS database ADFCRS-2010.

Show Selected Compound Starts ADFview for the selected compound. This is possible if the COSMO result
file of the compound is a .coskf file or a .t21 file.

Save Data Selected Compound Save data selected compound in a .coskf or .cosmo file. This will also save
the pure compound input data for the selected compound, like the number of ring atoms.

16.1.3 Method menu

The methods and its parameters are described in the COSMO-RS manual.

COSMO-RS Select this menu command to set the method that will be used in the calculation to COSMO-RS.

COSMO-SAC Select this menu command to set the method that will be used in the calculation to COSMO-SAC.
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Parameters Change the COSMO-RS or COSMO-SAC parameters and technical parameters that are used in the
calculation. The COSMO-RS and COSMO-SAC model have general and element specific parameters. Techni-
cal parameters are, for example, convergence critiria and thresholds.

16.1.4 Properties menu

How the properties are calculated and definitions used can be found in the COSMO-RS manual.

Vapor Pressure Pure Solvents Vapor Pressure Mixture In case of a mixture, the mixture can be
composed of of up to five compounds, and the mole fraction of each compound of the solvent should be given,
and it should add up to 1.

It is possible to calculate the vapor pressure for a temperature range, if the first temperature (from:) is different
than the last temperature (to:).

One can use input values for the vapor pressure of the pure compounds at a given temperature. These input
values can be set by selecting Compounds → List of Added Compounds, select the desired compound, and
set input values for the pure compound in the right window. If these values are not specified (if they are zero)
then they will be approximated using the COSMO-RS method.

Boiling Point Pure Solvents Boiling Point Mixture In case of a mixture, the mixture can be
composed of of up to five compounds, and the mole fraction of each compound of the solvent should be given,
and it should add up to 1.

It is possible to calculate the boiling point for a pressure range, if the first pressure (from:) is different than that
the last pressure (to:).

One can use input values for the vapor pressure of the pure compounds at a given temperature. These input
values can be set by selecting Compounds → List of Added Compounds, select the desired compound, and
set input values for the pure compound in the right window. If these values are not specified (if they are zero)
then they will be approximated using the COSMO-RS method.

Solvent Flash Point The mixture can be composed of of up to five compounds. The mole fraction of each
compound of the solvent should be given, and it should add up to 1.

One can use input values for the vapor pressure of the pure compounds at a given temperature. These input
values can be set by selecting Compounds → List of Added Compounds, select the desired compound, and
set input values for the pure compound in the right window. If these values are not specified (if they are zero)
then they will be approximated using the COSMO-RS method. However, for the compounds in the solvent the
flash points of the pure compounds should be given as input, since COSMO-RS does not calculate these.

Activity coefficients The solvent can be a mixture of up to five compounds. The mole fraction of each
compound of the solvent should be given, and it should add up to 1. One can use an input value for the density
of the solvent instead of a calculated value, which can influence the calculated Henry constants.

The activity coefficients will be calculated for the selected compounds in the listbox, on the bottom-left side of
the window. Compounds not present in the solvent are considered to be infinitely dilute.

Log partition coefficients The log of the partition coefficient (logP) of a solute in 2 phases of a solvent.
Both phase 1 and phase 2 can be a mixture of up to three compounds. The mole fraction of each compound in
phase 1 and phase 2 of the solvent should be given, and for both phases it should add up to 1. For example, if
one wants to calculate partition coefficients for Benzene/Water, which are 2 immiscible liquids, phase 1 of the
solvent will be purely Benzene, and phase 2 will be purely Water. Another example is the calculation of partition
coefficients for 1-Octanol/Water, which are partly miscible liquids, phase 1 of the solvent will be a mixture of
1-Octanol and Water, and phase 2 will be purely Water (the solubility of 1-Octanol in Water is small).

One can use an input value for the quotient of the molar volumes of phase 1 and phase 2 instead of calculated
values.
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The logP will be calculated for the selected compounds in the listbox, on the bottom-left side of the window.
Compounds not present in the solvent are considered to be infinitely dilute.

Solubility in Pure Solvents Solubility in Mixture In case of pure solvents one can select any
number of different pure solvents, but only 1 solute.

In case of a mixture, the mixture can be composed of of up to five compounds, and the mole fraction of each
compound of the solvent should be given, and it should add up to 1. In this case can select any number of
different solutes, but they should not be present in the solvent. In case of a mixture one can also use an input
value for density of the solvent.

It is possible to calculate the vapor pressure for a temperature range, if the first temperature (from:) is different
than the last temperature (to:).

For the solubility of a gas in a solvent one has to set the vapor pressure of the gas.

For the solubility of a solid compound it is necessary to include the melting point, the enthalpy of fusion, and
optionally, since it is often not so important, the ∆ heat capacity of fusion of the pure compound (default ∆
heat capacity of fusion is zero). These input values can be set by selecting Compounds → List of Added
Compounds, select the desired compound, and set input values for the pure compound in the right window.

Binary mixture VLE/LLE Exactly two compounds should be selected. One can select an isothermal, an iso-
baric, or a flash point calculation of the binary mixture. The binary mixture will be calculated for a list of molar
fractions between zero and one.

One can use input values for the vapor pressure of the pure compounds at a given temperature. These input
values can be set by selecting Compounds → List of Added Compounds, select the desired compound, and
set input values for the pure compound in the right window. If these values are not specified (if they are zero)
then they will be approximated using the COSMO-RS method.

Ternary mixture VLE/LLE Exactly three compounds should be selected. One can select an isothermal, an
isobaric, or a flash point calculation of the ternary mixture. The ternary mixture will be calculated for a list of
compositions.

One can use input values for the vapor pressure of the pure compounds at a given temperature. These input
values can be set by selecting Compounds → List of Added Compounds, select the desired compound, and
set input values for the pure compound in the right window. If these values are not specified (if they are zero)
then they will be approximated using the COSMO-RS method.

Solvents s1 - s2 Composition Line Linear interpolation between the compositions of solvent 1 and sol-
vent 2, which both could be mixtures. The solvents s1 and s2 can be a mixture of up to five compounds. The
mole fraction of each compound of the solvent s1 and s2 should be given, and it should add up to 1. One can
select an isothermal, an isobaric, or a flash point calculation.

One can use input values for the vapor pressure of the pure compounds at a given temperature. These input
values can be set by selecting Compounds → List of Added Compounds, select the desired compound, and
set input values for the pure compound in the right window. If these values are not specified (if they are zero)
then they will be approximated using the COSMO-RS method.

16.1.5 Analysis menu

Sigma Profile Pure Solvents Sigma Profile Mixture The 𝜎-profile is calculated for COSMO
charge densities between minus the maximum value for sigma and the maximum value for sigma. In case
of pure solvents one can select any number of different pure solvents. In case of a mixture, the mixture can be
composed of of up to five compounds.

Sigma Potential Pure Solvents Sigma Potential Mixture The 𝜎-potential is calculated for
COSMO charge densities between minus the maximum value for sigma and the maximum value for sigma.
In case of a mixture, the mixture can be composed of of up to five compounds.
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16.1.6 Graph menu

Graph X Axes Use one of the submenu commands to change the X axes of your graph.

Graph Y Axes Use one of the submenu commands to change the Y axes of your graph.

Graph Z Colormap Use one of the sub-menu commands to change the colormap of your graph. Only available
for Properties → Ternary Mixture.

Save As PostScript If you have any graphs, you can select one of the graphs. It will be saved in a postscript
file.

Save As XY If you have any graphs, you can select one of the graphs. It will be saved in a text file as XY pairs.
Next you can use most other plotting programs to make the graph just as you want it to be.

16.1.7 Help Menu

The help menu provides an easy way to get to information about the ADF-GUI. It will start a browser on your local
machine, and opens a local copy of the documentation on the SCM web site.
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SEVENTEEN

GUI ENVIRONMENT VARIABLES

As of the 2016.102 version, if you start the MacOSX ADF-GUI application the environment defined by your shell
startup scripts is ignored. Instead the bundled ADF is used, and environment variables may be defined in a file
$HOME/.scmenv and/or /Library/Application Support/SCM/scmenv.

In the following list the environment variables that are specific for the ADF-GUI are listed (the normal environment
variables like ADFHOME, ADFBIN and SCMLICENSE are also used by the ADF-GUI):

DISPLAY: X-window display to use, when using ssh normally you should NOT set it manually. It is required (for all
X11 programs) except on Windows.

PSEUDO_DIR: Path to the folder containing Quantum ESPRESSO pseudo potential files. If not set, a standard
search path (page 4) is used.

SCM_ADFREPORT_PLAIN: No labels or units in adfreport output. Not set by default.

SCM_BROWSER: The HTML browser used for both local and remote documents (not for Windows or Mac). Default
value: none (the PATH will be searched).

SCM_DEBUG: Turn on many debug items in ADF and avoid clean-up by GUI. Not set by default.

SCM_DEBUG_SSH: Set to yes to debug communication issues: all non-multiplexed ssh commands will be printed
to stderr. Set to all to see all SSH commands, even if multiplexed. Not set by default.

SCM_ERROR_MAIL: E-mail address for error reports. Default value: errors@scm.com.

SCM_DOCINDEXDIR: Location of the directory in which the index for the documentation will be stored. Setting it
makes it possible to share this index and save some space. Default value: $HOME/.scm_gui/doc.index.

SCM_FFMPEG: The ffmpeg program to use to generate movies. Default value: none (the PATH will be searched).

SCM_FFMPEG_ARGS: The arguments to pass to ffmpeg. Default value: none. The -i and -t (for looping movies)
will always be added automatically.

SCM_GEOMODSBYORDER: The geometry slider will always move the last group of atoms. Default value: none
(the smallest group will move).

SCM_GUIRC: Location of the preferences file. Default value: $HOME/.scm_guirc.

SCM_GUIPREFSDIR: Location of the preferences directory. Default value: $HOME/.scm_gui.

SCM_SCMJOBD_RESTART: Force a restart of the scmjobd job monitors every this many milliseconds. Not set by
default (600000 which is every 10 minutes).

SCM_KFBROWSER_EXPERT: Define it to make the expert mode in the KFbrowser the default. The non-expert
mode will be the default mode.

SCM_LOG: Set to the full path of a file to log some stuff the GUI does (mainly invocation of other modules/programs).
Not set by default.

SCM_LOG_SCMJOBD: Set to the full path of a file to log some what scmjobd is doing. Not set by default.
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SCM_MOPAC: full path to the MOPAC executable. Not set by default (the MOPAC included with the ADF distribu-
tion will be used via the ADFBIN/mopac.scm script).

SCM_NO_SSH_MULTIPLEXING: If set SSH multiplexing (bundle multiple ssh connections in one) will be
avoided. Not set by default.

SCM_OFFSCREEN: Set it to some value to force the GUI modules to run offscreen. Used for testing.

SCM_OLD_TRANSFERS: If set files are transferred one by one instead of in a tar archive (turn on when you run
into tar compatibility issues). Not set by default.

SCM_PACKMOL: The packmol program to used by the Builder. Default value: none (the PATH will be searched).

SCM_RESULTDIR: Location of the results directory. Default value: none (directory where the .adf files etc live is
used).

SCM_SSH_MULTIPLEXING: Set to yes to use SSH multiplexing (bundle multiple ssh connections in one if possi-
ble), only has effect when using OpenSSH (thus NOT on windows). Not set by default (no multiplexing).

SCM_STRUCTURES: Location of the structures directory. Default value: none.

SCM_TITLEVERSION: Show SVN revision number in title. Not set by default (show only version number).

SCM_TMPDIR: Temporary files will be made in this directory (should exists if set). Default value, if not set $TM-
PDIR $TMP /tmp $HOME or the current directory is used (in that order).

SCM_TPLDIR: Location of the presets directory. Default value: none.

SCM_QUEUES: Path to the dynamic queues directory. Default value: none (ADFjobs will search the remote
$HOME/.scmgui).

SCM_QEDIR: Path to the folder containing Quantum ESPRESSO installation (binaries and pseudo potentials). Set
it to force the installation of QE somewhere outside your $ADFHOME. If not set, a standard search path (page 4) is
used.
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REQUIRED CITATIONS

When you publish results in the scientific literature that were obtained with programs of the ADF package, you are
required to include references to the program package with the appropriate release number, and a few key publications.

18.1 General References

The current version of the GUI was developed by O. Visser, with many contributions from L. Groot and O. Carstensen.
Other (past) authors include M. Luppi (artwork) and the SCM developer team. Thanks to M. Mouthaan for testing and
documentation.

If you used the GUI you may optionally include the reference: GUI 2017, SCM, Amsterdam, The Netherlands,
http://www.scm.com

18.2 External programs and Libraries

Click here for the list of programs and/or libraries used in the ADF package. On some platforms optimized libraries
have been used and/or vendor specific MPI implementations.
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