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• Introduction

o SCM & AMS

o Computational chemistry& materials science 

• Molecules: builder, database, import SMILES, xyz

o Spectroscopy

o Advanced: bonding analysis, charge transfer, SOCME

• Periodic structures: database, cif, surfaces 

o Advanced: bonding analyses (PEDA-NOCV, COOP)

• COSMO-RS: properties, optimizing mixtures

• ReaxFF: acceleration, fitting parameters (tomorrow)

Program
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Background: SCM & ADF

• ADF = first DFT code for chemistry (1970s)

Baerends@VU (>’73), Ziegler@Calgary✝ (>’75)

• SCM: Spin-off company 1995

• 15 people (10 senior PhD’s) + 5 EU fellows

• Many academic collaborators / EU networks

o ~120 authors

o New functionality

• SCM: development, debug, port, optimize, 

docs & support

articles &patents in materials science with
“density functional theory”, Nat. Mat. 4619
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Amsterdam Modeling Suite

• ADF: powerful molecular DFT 
o Spectroscopy: NMR, EPR, VCD, UV, XAS

o Advanced solvation / environments

• BAND: periodic DFT
o (2D) Materials

• DFTB: fast approximate DFT

• ReaxFF: Reactive MD
o Dynamics of large complicated systems

• COSMO-RS: fluid thermodynamics
o VLE, LLE, logP, solubility

• Integrated GUI – use out of the box

• Scripting: workflows & automation
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Computational chemistry & materials modeling

• Accelerate research, reduce costs & environmental impact
o Reduce experimental search space

o Analyze structure-property-reactivity

• Models: physics & empiricism
o Accuracy?

• Synergy experiment-calculations
o Ask relevant questions

o Limitations model

o Constraints experiments

Best catalyst? => mechanism? lowest Ea ? best ligand? side reactions?

Best battery? => discharge? voltage? interaction with electrolyte? 

Best OLED? => charge & exciton mobility? emission speed & color?

???

Why bother with calculations?
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http://www.donbot.com/Futurebot/NewTech/NT01370MoravecsGraphUpdated2020.html

Compute power (r)evolution
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Computational Chemistry & Materials

Electronic structure methods: Schrödinger equation

Electrons in molecules & materials

Expand y: atomic orbitals / plane waves 

Solve self-consistently 

Pragmatic: DFT

Properties: energies (gradients), MOs, densities & related, 

spectroscopy (EPR, NMR, IR, UV/VIS, ….)

Hy=Ey
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Computational Chemistry & Materials

Molecular dynamics: Newton’s equations of motion 

Movement of atoms: solve numerically + propagate, 

Properties: reaction rates, diffusion coefficients, stress-strain, …. 

d2x/dt2 = F(x)
F(x) = − dV(x)/dx
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Electronic Structure methods

• ab initio (basis set dependencies!)
o Hartree-Fock (HF): mean field (no explicit e-e interaction)

o MP2: perturbation theory (if HF = good guess)

o CC: coupled cluster

o CI: configuration interaction (full CI = max. Accuracy)

o Multi-reference / active space 

• Density Functional Theory (DFT)
o ‘first principle’ functionals (physics)

o empirical functionals (fit to data)

• DFT-based tight binding (DFTB)
o Fit to DFT data

o Nearest neighbor, minimal basis

• Semi-empirical (MOPAC: PM7)
o Fit to exp. Data

o Nearest neighbor, minimal basis

Hy=Ey

(Houk, 2011)
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Computational Methods

Method ~ max atoms ~ relative cost scaling Typical

Accuracy*

Classical force field

(UFF, Amber, … )

1,000,000 0.0005 N1 <20 kcal/mol

Reactive force field 

(ReaxFF)

500,000 0.001 N1 <15 kcal/mol

Semi-empirical 

methods (e.g. AM1, 

PM7)

5,000 1 N1~2 <10 kcal/mol

DFTB 5,000 1 N1~2 <10 kcal/mol

DFT 500 500 N3~4 <5 kcal/mol

MP2 100 2000 N5 <5 kcal/mol

CCSD(T)/cc-pVTZ 30 100000 N7 ~1 kcal/mol

Relative costs, scaling & accuracy for computational methods

(* depending also strongly on the system & property!)
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Density Functional Theory

• Density r = central quantity

• Density functional r gives E

E[r] = T[r] + Eee[r] + Ene[r] 

• Usually expanded in orbitals

o Linear combination of atomic orbitals

▪ Basis set 

o Kohn-Sham DFT

o ‘Non-interacting’ reference Ts

E[r] = Ts[r] + Eee[r] + J[r] + Exc[r] 

o Solve self-consistently

o vxc[r] = Exc[r]/dr = ‘functional’ 

▪ approximate: LDA, BP86, PBE, M15L, ...  

• Which basis & functional?

Check literature or benchmark!

See technical ADF slides

https://www.scm.com/wp-content/uploads/TCCM--ADF_tech_overview--Franchini.pdf
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Getting started with the GUI
Starting ADFjobs: job bookkeeping tool

• Win: dbl-click desktop item

• Mac: open Application

• Linux: run $ADFBIN/adfjobs

• Other GUI modules: (Input, View, Levels, Movie, Spectra, Band 

Structure, COSMO-RS, …)

o Can be opened by dbl-clicking ‘.exe’ (Win) or opening e.g. ‘$ADFBIN/adfinput’ 
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ADFjobs: job bookkeeping

all jobs / folder view

job status

reports & templatesswitch GUI functionality define & switch queues

queue

change default

e.g. cores / nodessee files for this job

search
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Basic calculations & settings

job type

charge/spin

functional &

relativistic appr

… = more details

basis & numerical

accuracy

searchjob types & set upswitch modules

builder tools preoptimize

symmetryze
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Building molecules

www.scm.com/doc/Tutorials/GUI_overview/Building_Molecules.html

• NB: tutorials also offline with your ADF!

• Import: SMILES, xyz, cif, pdb, …

• Included library + building

• Excercise 1: Build acetophenone

o By searching for it in the GUI

o By starting from the benzene template (press 2 for double bond, Ctrl+E to add Hs)

o By importing smiles CC(=O)c1ccccc1 (e.g. from Wikipedia or Chemspider)

• Exercise 2: Symmetrize, pre-opt & optimize: SR-ZORA-PBE-D3(BJ)/DZP

https://www.scm.com/doc/Tutorials/GUI_overview/Building_Molecules.html
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Spectra: IR

www.scm.com/doc/Tutorials/ADF/ADF-GUI_tutorials.html#spectroscopy

• Excercise 3: Calculate & visualize frequencies

o NB analytical frequencies available for most GGAs, not for hybrids

o Go to spectra, visualize the CO stretch at ~1690cm-1 

o Increase the line width to ~20

o Compare to NIST data

https://www.scm.com/doc/Tutorials/ADF/ADF-GUI_tutorials.html#spectroscopy
http://webbook.nist.gov/cgi/cbook.cgi?ID=C98862&Type=IR-SPEC&Index=0#IR-SPEC
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Spectra: UV/VIS

• Exercise 4: Calculate 10 allowed excitations with the SAOP model potential

o See also UV/VIS FAQ for more tips

o Go to spectra, change x-axis to nm

o Increase the line width to ~10

o Visualize the pi-pi* NTOs at ~250 & 285nm

o Compare to NIST data

o Now rerun with method ‘sTDA’ and tick TDA

o Compare timings & spectra (File -> add spectra)

o AMS2018: optimize excited states also with

▪ Range-separated hybrids

▪ COSMO solvation

https://www.scm.com/faq/adf-faq/#how-do-i-calculate-uvvis-spectra-with-adf
http://webbook.nist.gov/cgi/cbook.cgi?Spec=C98862&Index=0&Type=UVVis&Large=on
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ADF tutorial online

Phosphorescent OLED emitters

K. Mori, T. P. M. Goumans, E. van Lenthe,

F. Wang, PCCP 16, 14523 (2014)

• Optimize OLED performance

o Phosphorescence T1→ S0

o TADF: min. S-T, max. SOCME

o Fast ISC: Sn→T1

o High charge mobility

• ADF features

o SOC-TDDFT: kphos

o SOCME: kISC

o Transfer integrals (mobilities)

o Other couplings (FDE)

o Vibrationally resolved abs/em

23 Ir, Rh, Ru, Os, Pt, 

Re complexes

https://www.scm.com/adf-modeling-suite/wizard/organic-electronics/vibrational-progression-of-an-oled-phosphorescent-emitter/
https://www.scm.com/adf-modeling-suite/wizard/organic-electronics/modeling-phosphorescent-lifetimes-of-oled-emitters/
http://dx.doi.org/10.1039/C3CP55438D
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Intersystem crossing: spin-orbit coupling

Phys. Chem. Chem. Phys. 16, 26184-26192 (2014)

NB: See also full kISC Paul et al. JPCL, 2017, 8, 4893

lexc-dependent quantum yield
SOCME negligible for S1-Tn

ISC from higher Sn states

El-Sayed for organometallics: 

SOC is largest when:

• both S (1dπ*) and T (3d’π*) are MLCT

• different d-orbitals are involved (d ≠ d’).

Surface-Hopping Dynamics Ru(bpy)3
2+

• Interface SHARC-ADF with ISC (SOC)

• ISC from higher Sn states within 26 ± 3 fs

Atkins & Gonzalez

J. Phys. Chem. Lett.,, 8, 3840–3845 (2017)

http://pubs.rsc.org/en/content/articlelanding/2014/cp/c4cp03540b
http://dx.doi.org/10.1021/acs.jpclett.7b02148
http://dx.doi.org/10.1021/acs.jpclett.7b01479
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Thermally Activated Delayed Fluorescence

Optimize radiative rate

• Minimize S1-T1 gap

• Maximize SOC

• Maximize  kphos & kTADF

Z.-M. su et al. Dyes & Pigments 145, 277-2847 (2017)

Bredas et al. J. Am. Chem. Soc. 139, 4042−4051 (2017)
ADF tutorial  in progress

http://dx.doi.org/10.1016/j.dyepig.2017.04.001
http://dx.doi.org/10.1021/jacs.6b12124
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Spin-orbit coupling TDDFT

• Exercise 5: Calculate the SOC spectrum and the SOCME

o Switch to perturbative Spin-Orbit and tick SOCM

▪ ADF can do full and perturbative SOC

▪ SOCME useful for (R)ISC, e.g. TADF/OLEDs

o Visualize the spectrum: any effect? 

▪ SOC small for purely organic

o Check SCM -> Output

o Go to Response Properties -> All Singlet-Singlet Excitations. Compare with All Spin-Orbital 

Coupling Excitation Energies. Go to -> SO Matrix. This is the full matrix. Further down you will 

find the averaged spin-orbit coupling matrix elements (SOCMEs)
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Speeding it up: DFTB

www.scm.com/doc/Tutorials/DFTB/DFTB-GUI_tutorials.html

• Exercise 6: Switch to DFTB and re-run the spectra

o The default SCC-DFTB method is fine

o Chose the 3ob-3-1 parameter set

o Re-optimize, recalculate frequencies, recalculate UV/VIS spectrum

o How do the spectra compare: TDDFT, sTDA, TDDFTB? Timings?

o Also try the IR spectrum with DFTB & MOPAC 

• To visualize DFTB MOs: single point SCC-DFTB/QuasiNano15 !

https://www.scm.com/doc/Tutorials/DFTB/DFTB-GUI_tutorials.html
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Going periodic with DFTB

• Exercise 7: Acetophenone crystal

o Make a new input, search for acetophenone, select the crystal (optimized with MOPAC)

o Switch from BAND to DFTB and choose D3-BJ dispersion and the 3-ob-3-1 parameter set

o Ignore the small unit cell warning

▪ NB: consider to go to a larger supercell instead of k-point sampling (will use FIRE)

▪ You may also consider optimizing the lattice (slow)

o Check progress with SCM -> Movie
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• Hopping transport:

o Charge transfer integrals (FO) - easy

o Electronic couplings from FDE

• Band transport: effective mass tensors in BAND
o AMS2018: for any k-point & also for DFTB

o Simulating excited state: create a core hole

• Non-equilibrium Green’s Function (NEGF)

o transmission probabilities for single-molecule junctions

o quick calculation: wide-band limit

o also in BAND (periodic structures, fully self-consistent, bias) and in DFTB

▪ See online tutorials

h+

Methods to calculate charge mobilities

https://www.scm.com/doc/BAND/Input/Expert_options.html#excited-states
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Effective transfer integral Jeff = electronic coupling V 

extract 

dimers

( )
2
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S

HHSJ
V

−

+−
=

ADF tutorial online, ADF prints V / Jeff => 

use with Marcus theory for hopping rates

Anisotropic mobility:

S.-H. Wen et al., J. Phys. Chem. B 113, 8813 (2009)

https://www.scm.com/adf-modeling-suite/wizard/organic-electronics/electron-and-hole-mobilities-in-organic-electronics/
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Charge transfer integrals & recombination

• Exercise 8: 1st Select the dimer for the charge transfer event

o Update the geometry from your DFTB run

o Make a 2x2x2 supercell (Edit-> Crystal -> Generate Supercell)

o Switch from DFTB to ADF

o Select 1 atom from the middle ‘flat’ acetophenone and one from the molecule above 

o Press Ctrl+M to select both molecules
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Charge transfer integrals & recombination

• Exercise 8: Calculate the charge transfer integral

o Select -> Invert selection. Delete all other atoms

o In the Model Region Panel select each molecule as a new region (delete the crystal region):

o Select PW91 functional (often used) with a DZP basis

▪ Frozen cores are incorrect in principle; in practice usually fine

o Find ‘transfer integral’ in the GUI search, and tick it.

o In Multilevel -> Fragments pane, tick ‘Use fragments’

o SCM-> Output; Properties -> Charge transfer integrals

o ADF tutorial: how to get mobilities

o AMS2018: charge recombination

https://www.scm.com/adf-modeling-suite/wizard/organic-electronics/electron-and-hole-mobilities-in-organic-electronics/
https://www.scm.com/doc/ADF/Input/Charge_transfer_integrals.html#transferintegrals
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(Charge transfer) analysis excited state

• Exercise 9: Calculate the excitations with SFO analysis + CT descriptors

o Untick charge transfer integrals 

o Properties -> Excitations: select Allowed only;

o Tick SFO Analysis + CT descriptors

o Save as a different file & run

o Visualize the spectrum and NTOs of two lowest states (CT)

o In output search for Plasser (see paper with Lischka)

o CT = 1 & POS = 1.5 and CTNET = 0 => Charge resonance

o Very small exciton splitting 

o LAMBDA = 0.4655 => perhaps use hybrid or RSH (Tozer)

https://www.scm.com/doc/ADF/Input/Excitation_energies.html#sfo-analysis
https://www.scm.com/doc/ADF/Input/Excitation_energies.html#charge-transfer-descriptors
https://doi.org/10.1021/ct300307c
https://doi.org/10.1063/1.2831900
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BAND & QE : Periodic DFT
bias = 0.1bias = 0

Dielectric function ML ZnO STM PtGe(100)

Band structure, pDOS, fat bands ZnS Polarizing MoS2 with an electric field
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BAND vs. Plane Wave codes (QE)
• Atom centered basis functions, STO or NAO

o Compare cluster with periodic

o No pseudopotentials, all elements

o Core spectroscopy (core holes)

o Easy (orbital, density) analysis with GUI

o Fast for empty (1D, 2D, porous)

o xc: SCAN, MN15-L, HSE06, GLLB-sc, D3(BJ), ...

o Self-consistent NEGF

▪ Gate & bias potential

▪ Spin transport

• True 2D surfaces, 1D polymers

o Het. catalysis: polarization, COSMO

o 2D electronics (homogeneous E field)

o Nanotubes

• Integrated Graphical Interface: 
o Easy set up & analysis

o Switch: ADF, BAND  & Quantum Espresso

crystal orbitals,  periodic energy decomposition analysis

M. Raupach and M. Tonner, J. Chem. Phys. 142, 194105 (2015)

http://dx.doi.org/10.1063/1.4919943
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Band structure, pDOS, fat bands, COOP

• Exercise 10: ZnS bulk  

o New input, go to BAND

o click on the ‘crystal’ builder tool in the bottom

o select cubic -> Zincblende and accept the default

o Settings: BP, SR-ZORA, and DZP 

o Select DOS and Bandstructure (default interpolation)

o Run it!
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Band structure, pDOS, fat bands, COOP

• Exercise 10: ZnS bulk  

o Visualize the band structure (SCM Menu). You will automatically see the pDOS and ‘fat bands’

o ZnS is a direct band gap semiconductor (p-s transition)

▪ Check the logfile and output for band gap info and kmesh

▪ Low band gap: try model potentials (TB-mBJ, GLLB-sc) and HSE06? see benchmark study.

▪ Should also be converged wrt kpoints, basis, etc.

o Restart the calculation from SCF and in the DOS details tick ‘COOP’

▪ Visualize the crystal orbital overlap population between the Zn s and S p orbitals

recent JACS study by Hoffmann: 

COOP in perovskites (tutorial)

https://www.scm.com/news/benchmark-density-functionals-settings-band-gaps/
https://pubs.acs.org/doi/10.1021/jacs.8b08038
https://www.scm.com/tutorialcoop_perovskites/
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Band structure, pDOS with QE

• Exercise 10: ZnS bulk with QE

o Switch from BAND to Quantum ESPRESSO

o Choose the same k-mesh (5x5x5), functional and Vanderbilt pseudopotentials

o You will see a similar band structure, but they aren’t colored according to character

▪ DOS can be projected by QE
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Surfaces, dielectric function 

• Exercise 11: ZnS monolayer: 2D-TDCDFT

o Cut the 111 surface with the slicer tool, and choose 1 layer

o From properties -> dielectric function choose NewResponse

o Calculate 30 frequencies between 2-5 eV

o Set the SCF convergence criterion to 0.01 and switch off the z-component

o Run it (you will prompted Nosymm is used)
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Surfaces, dielectric function 

• Exercise 11: ZnS monolayer: 2D-TDCDFT

o SCM -> Spectra will show the averaged dielectric function

o Look at the susceptibility, polarizability and refractive index in Spectra->TDCDFT

o You could use a ‘scissor’ shift to upshift the virtuals

o Converge with respect to k-points!

o Geometry of the ions should be optimized, this will effect electronic properties

▪ For free-standing ML, also optimize lattice ?!
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∆E = ∆Eprep + ∆Eint

∆Velstat +   ∆EPauli +   ∆Eoi +  ∆Edisp

Extensions: 

• Periodic EDA: M. Raupach & R. Tonner, J. Chem. Phys. 142, 

194105 (2015)): molecule-surface interactions

• Ziegler, Michalak, Mitoraj: ETS-NOCV

Energy decomposition analysis

• ∆Esteric = ∆Velstat +  ∆Epauli

• ∆Eoi = decomposed in irreps.

• ∆Eprep = geometry ’deformation’ energy

Chem. Soc. Rev. 2014, 43, 4953; 

WIRES Comput. Mol. Sci. 2015, 5, 324

Oline tutorial & teaching materials
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EDA/ETS-NOCV: bond & density decomposition

• Molecule built from fragments

• Bond analysis with meaningful terms:

• Combine with NOCV (webinar)

o Orbital interactions / charge transfer

• Also periodic 1D, 2D, 3D  (tutorials)

o (Ad)sorption nanotbues, surfaces, MOFs etc.

o Raupach &Tonner, J. Chem. Phys. 142, 194105 (2015) ΨAB

ΨA
GS ΨB

GS

ΨA ΨB

ΨAΨB

Ψ0 = NA ΨAΨB

ΔEprep

ΔEelstat

ΔEPauli

ΔEorb

ΔEint

https://www.scm.com/wp-content/uploads/Videos/ETS-NOCV.webm
http://www.scm.com/doc/Tutorials/BAND/BAND-GUI_tutorials.html#bonding-analysis
http://dx.doi.org/10.1063/1.4919943
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Catalyst design: activation strain model

Chem. Eur. J. (communication) 2009, 15, 6112

Org. Biomol. Chem. 2010, 8, 3118

Nature Chem. 2010, 2, 417

EDA along the reaction path

Bite-Angle Effect: Activation Strain analyses:

• HOMO–LUMO interaction marginally improved

• But: strain reduced by building it into catalyst

TS

Latest reviews: 

Chem. Soc. Rev. 2014, 43, 4953

WIRES Comput. Mol. Sci. 2015, 5, 324
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Catalyst natural selection: survival of the weakest
Increased bite angle dppe → dppb

• Improved electronic interaction and larger repulsive strain

• Strain outweighs electronic interactions → dppb most destabilized → best catalyst

J. Wassenaar, et al. Catalyst selection based on intermediate stability 
measured by mass spectrometry. Nature Chem. 2, 417 (2010)

http://dx.doi.org/10.1038/NCHEM.614
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CO on MgO: COOP
• Exercise 13: First do the PEDA-NOCV tutorial

• New input with same coordinates

• Scalar, PBE, DZP/small, basic, DOS, BandStructure

o DOS details (…) => COOP, -20 to + 20eV

• Visualize the band structure and various COOPs

o DOS-> COOP… Try different Mg (s) + Mg (pz) and C (pz) + C (s) combo’s

o What is the biggest contribution to the -10 eV band? Mg(s)+C(s-pz); Mg’s pz helps a bit

• Show MO of that band with ADFview, improve grid & tweak cut-off 

o choose the G point (-10 eV = -0.3666 Hartree)

https://www.scm.com/doc.2018/Tutorials/BAND/PEDA_with_NOCV.html


AMS hands-on workshop, 22+23 October, Tsinghua © SCM        42

AMS: Powerful driver
• Scan multiple coordinates for any periodicity

o Works with ADF, BAND, DFTB, MOPAC, UFF, ReaxFF

o Can be extended/interfaced with other codes

• Advanced MD barostats and thermostats

o Also with DFT(B): AIMD

o Other ’ReaxFF’ functionality to be ported: 

▪ fbMC, CVHD, Molecule Gun, GCMC

• Reuse PES information

• Task farming (double parallelization)

o Elastic tensors, phonons, frequencies
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AMS: PES scan & TS search
• Exercise 14: H2 on graphene

o Find graphite (or build it), slice a 1L 001 surface & remove top layer to get graphene

o Create 3x3 super cell and build H2 somewhere in the input window

o Adjust Model -> Coordinates to put it atop, 2.4 above surface

o Go to DFTB, choose DFTB3-D3BJ/3ob-3-1 and set Task: PES Scan, click ‘…’

o In the PES Scan panel set the Scan coordinates by selecting atoms and clicking +:

▪ Set SC-1 to H2 from 0.74-1.4 (7 points)

▪ Set SC-2 both H-C coordinates from 2.4-1.8 (7 points)

o Lower convergence criteria in Details -> Geometry Optimization

o Save & Run
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AMS: PES scan & TS search
• Exercise 14: Explore the 2D PES

o When Finished: SCM -> Movie

o Find a plausible TS start point (x=1.18, y = 2.0)

o File -> Save Geometry

o Make a New input & import that geometry

o Now we calculate the Hessian:

o Go to DFTB, choose DFTB3-D3BJ/3ob-3-1

▪ Task: Single point, followed by frequencies

o Save & Run

o Visualize the Spectra and check that there is 1 large imaginary mode
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AMS: PES scan & TS search
• Exercise 14: Find the TS

o Change Task to Transition State

o In Details -> Geometry Optimization: Initial Hessian -> From file -> find dftb.rkf

o Save as a different file & Run

o Check the TS geometry and it’s normal mode spectrum

o Calculate the activation energy as E(TS) – E (graphene + H2) (you can put H2 at 50A) 


