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Modeling chemical reactions with the Amsterdam 
Modeling Suite and the ReaxFF engine 
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Downloads and setting-up AMS 
 
We will use the Chemistry_with_ReaxFF directory as the root for AMS jobs. All required files 
should already be in there. 
 
If you are working on your local machine, you can download the files from the link: 
https://www.scm.com/wp-content/uploads/Structures.zip 

Chemical vapor deposition of silica on a silicon surface 
 
The overall reaction for silica deposition is as follow: 
 
SiH4 + O2 → SiO2 + 2 H2 
 

The simulation described below was inspired from the tutorial Simulating Chemical Vapor 
Deposition. 

 

1. Setting-up the Si substrate 
 
First, you will download and import the starting structure, visualize it, and create two regions. 
One region will be used to fix the bottom two layers of atoms in order to model that the 

https://www.scm.com/doc.2023/Tutorials/MolecularDynamicsAndMonteCarlo/MoleculeGunSimulationCVD.html
https://www.scm.com/doc.2023/Tutorials/MolecularDynamicsAndMonteCarlo/MoleculeGunSimulationCVD.html
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substrate is connected to a support. The second region will be used to control the 
temperature of the simulation. 
 
a) Start the AMS program. This will open AMSjobs. 
b) Open a new input window by clicking on SCM → New Input. 
c) Import the Si100 structure from File → Import System. Then browse to the location of the 
file you just downloaded and click Open. 
 

You can orient (translate) the structure by left-clicking (right-clicking) on the molecule area 
and by moving the mouse. You can zoom in and out with the scroll wheel of the mouse. 
Furthermore, you can orient the molecule in the yz, xz, and xy planes with the shortcuts 
ctrl+1, ctrl+2, and ctrl+3, respectively (cmd for MacOS).  

 
a) Select the ReaxFF engine from ADF → ReaxFF. The periodicity should be set to Slab, if not 
already set. 
b) Define 2 regions as follow: 
Open the Regions panel from Model → Regions. Orient the molecule in the xz plane (cmd+2) 
for a better view. Then select the 2 bottom layers of Si: hold the shift key then left-click and 
drag the pointer over the atoms you want to select. Click the + button on the Region panel. 
Rename Region_1 to fixed. 
 

Before you make a new selection, be sure to unselect all atoms by left-clicking an empty 
area next the molecule. 

 
Proceed similarly to select the atoms of the 2 layers right above the fixed region. Rename this 
region to thermo. Atoms in the fixed and thermo regions should not overlap! Now we can 
apply the constraint to the fixed atoms. 
 
a) Click Model → Geometry Constraints and PES Scan. 
b) Select an atom of the bottom fixed group. 
c) Click the + button left of fixed (fixed position). 
 

2. Equilibration 
 
We will now setup the system and perform a short equilibration of the substrate. 
 
a) From the Main tab, select Task Molecular Dynamics. 
b) Click the folder button next the Force field and search for CHONSi.ff 
c) Click the > button next Molecular Dynamics and set the number of steps to 20000. 
 

Note that this a rather short equilibration and a more reasonable equilibration would be of 
hundreds of ps (i.e. 400000 steps). 

 
d) Set the Sample frequency to 1000, the Initial temperature to 500 K, and the Checkpoint 
Frequency to 1000000. 
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Now we can add the thermostat to the thermo region to control the temperature of the 
simulation. 
 
a) Click the > symbol next Thermostat. 
b) Click the + button. Select NHC, set the Temperature to 500 K, and the Damping constant to 
100 fs. 
c) Select the thermo region next to Atoms in region. 
 
Save and run the simulation. Click File → Save, give it a name (e.g. Si100_ReaxFF_equil). Select 
the simulation on AMSjobs and click Job → Run. When the simulation finishes, a pop-up 
window will ask you to update the coordinates, select use MD velocities and click Yes, new 
job. From the updated AMSinput, save the settings for the next simulation from File → Save 
as… and give it a name (e.g. Ge100_ReaxFF_CVD). 
 

3. Molecule Gun 
 
To model the CVD simulation, we will throw reactant molecules to the surface with an initial 
speed at regular time intervals during an MD/fbMC simulation. In order to project particles 
to the surface, we will use the Molecule Gun, as implemented in AMS. Let’s start by setting 
the MD and by importing the reactants i.e. SiH4 and O2. 
 
a) Go to Model → MD and increase the number of steps to 3000000. 
 
To import the reactants, do the following. 
 
a) Download SiH4.xyz. 
b) Go to Model → Regions, click File → Import System and select the SiH4.xyz file 
 

If the imported molecule appears in the slab, you can move it above the surface by right 
clicking on it and moving the mouse up. The initial position of the reactants is not 
important. 

 
c) With the atoms of the SiH4 molecule selected, click the + button and rename the region as 
SiH4. 
d) Repeat the steps above to import O2.xyz and create the O2 region. 
 
Now we can setup the molecule gun. 
 
a) Go to Model → Molecule Gun, click the + button. 
b) Select SiH4 next the System, set Mole fraction to 1, Frequency to 5000, Start Step to 1. 
c) Set the Fractional coords box to 0, 1, 0, 1, 45 , 50. 
d) Enable Rotate. 
e) Click the + next to Velocity dummies. Two dummy atoms should appear in the slab region, 
one blue and one white. 
f) Click the - button next to Velocity direction to remove the preset. 
g) Select the top dummy atom, hold shift, select the bottom dummy, release shift, and click 
the + button next the Velocity direction. You should see Xx(297),Xx(296) appear. 
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These last few steps define the direction of the velocity for the molecule gun. It is important 
that the velocity direction, defined by the dummy atoms, go from the top dummy to the 
bottom dummy, in the z-direction. You can verify that the indices next the Xx symbols (here 
297 and 296) indicate the top dummy (index 297) and second dummy (index 296). 

 
h) set the Energy to 0.05 eV, the Atom Temperature to 450 K, and the Contact distance to 3 
Å. 
 
Proceed similarly to setup the molecule gun for the O2 molecule. Click the + button to add a 
molecule, select the O2 group, and provide the same settings as above but the Mole fraction 
should be set to 2. To set the velocity direction, skip the step (d) and (e), as we can reuse the 
dummy atoms created above. Just select the dummies in the right order and set the velocity 
direction (as in step f). 
 

With these settings, the molecule gun will try to add a molecule every 5000 steps in the 
direction defined by the dummies, with an energy of 0.05 eV and an internal temperature 
of 450 K. The molecules will be inserted at 3.0 Å from the highest z-coordinates of the atoms 
underneath the random xy position. 

 
Finally, some molecules can eventually bounce back to the vacuum, or some gases will escape 
the surface, hence it is a good idea to remove these molecules as they cross a given xy plane. 
This can be achieved by adding a molecule sink. 
 
a) Switch to Model → Molecule Sink. 
b) Click the + button, set the Formula to * in order to include all types of molecules. 
c) Set Safe box to 0, 1, 0, 1, -100, 100, Frequency to 5000, and Start step to 1. 
 
These last settings will define a molecule sink in the xy planes located at 100 Å and -100 Å in 
the z direction. The molecule sinks will delete all molecules that cross these limiting planes 
every 5000 steps starting at step 1. 
 

Note that we also put a molecule sink at -100 Å because some molecules can cross the thin 
slab toward large negative z direction. 

 

4. Running the simulation 
 
Save and run the simulation. Click File → Save. Select the simulation on AMSjobs and click Job 
→ Run. This simulation might take a while so we will be moving on to the second example 
and we will get back to the results later. 

Combustion reaction of methane 
 
In this second example, we will simulate the combustion of methane in oxygen. The general 
chemical reaction is as follow: 
 
CH₄[gas] + 2O₂[gas] → CO₂[gas] + 2H₂O[steam] + ΔE 



 5 

 
The simulation described below was inspired from the tutorials Combustion simulation with 
ReaxFF and Detecting reactions from MD trajectories: ChemTraYzer2. 
 

1. Building the structure 
 
We will start by setting up the atomistic system by randomly inserting O2 and CH4 molecules 
in a simulation box. This can be easily achieved with the Packmol interface of the Builder. 
 
a) Open a new input window by clicking on SCM → New Input. 
b) Switch to the ReaxFF engine from ADF → ReaxFF. 
c) Click Edit → Builder. 
 
With the Builder you can define the size of the simulation box, the type of molecules to fill 
the box, and the number of each molecule in the box. The tool will display the corresponding 
density (at the bottom). 
 

For full combustion we need at least 2 oxygen molecules for each methane molecule. We 
will use 50 molecules of CH4 for 120 molecules of O2 in order to boost the combustion. 

 
a) Fill box with 50 copies of methane i.e. type methane and select CH4: Methane (ADF). 
b) Click the + button next to Molecules to add a second field and Fill box with 120 copies of 
oxygen molecules i.e. type O2 and select O2 (ADF). 
 
This should correspond to a density of 0.9632 g/mL, which is high but is required to observe 
the combustion reaction in the short timescale of the simulation. 
 

Note that right above the density information, there are some advanced settings related to 
the Packmol algorithm. 

 
To generate the atomic structure, click Generate Molecules. You can then Close to exit the 
builder. 
 

2. Setting-up the combustion reaction 
 
We will now define the settings for the MD simulation. We will perform an NVT simulation 
(i.e. in the canonical ensemble) at high temperature, in order to speed-up the combustion 
reaction. 
 
a) From the Main tab, select the CHO.ff Force field. 
b) Click the > button next to Molecular Dynamics. 
c) Set the Number of steps to 30000. 
d) Increase the Checkpoint frequency to a large number e.g. 100000. 
 
Now we can setup the thermostat to control the temperature of the simulation. 
 
a) Click the > button next to Thermostat. 

https://www.scm.com/doc.2023/Tutorials/MolecularDynamicsAndMonteCarlo/BurningMethane.html
https://www.scm.com/doc.2023/Tutorials/MolecularDynamicsAndMonteCarlo/BurningMethane.html
https://www.scm.com/doc.2023/Tutorials/MolecularDynamicsAndMonteCarlo/ChemTrayzer2.html
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b) Add a thermostat with the + button. 
c) Select the NHC Thermostat and set the Temperature to 3500 K. 
d) Set the Damping constant to 100 fs. 
 
Save and run the simulation. Click File → Save and find a good name for your simulation. 
Select the simulation in the AMSjobs window and click Job → Run. 
 

3. Analysis 

3.1.  Energies 
 
No need for the simulation to be finished to start the analysis.  
 
a) From AMSjobs, click SCM → Movie to observe the simulations as it goes. 
 

From AMSmovie, you can rotate, translate, orient the molecules as in AMSinput. Use the 
sliding bar to advance the simulation and to select a desired frame. You can also play and 
pause the movie with the corresponding buttons. 

 
Let’s have a look at some graphs. The total energy is shown by default. We can add in a 
separate graph the Kinetic and Potential energy. 
 
a) Click Graph → Add graph. 
b) Click MD Properties → Kinetic energy. 
c) Click MD Properties → Potential energy. 
d) Graph → Curve on Right Axes. 
 
You can verify that the sum of the Kinetic plus the Potential energy is equal to the Total 
energy. Since the reaction is exothermic, the reaction releases energy and consequently, the 
total energy is decreasing. 
 

3.2.  Molecules 
 
We will now analyze the various molecules created during the reactive simulation. 
 
a) From AMSmovie click MD Properties → Molecules. 
 
The molecule window is composed of a few buttons at the top to sort the molecules either 
alphabetically (Molecules), by maximum number (Max#), or by averaged number (Ave#). Next 
there are two additional headers Graph and Show. All checkboxes under the Show column 
are checked meaning that all molecules are currently shown in the movie panel. You can 
display only certain molecules, all, or none by checking the corresponding boxes. If you check 
a box in the Graph column, this will display the graph corresponding to the number of 
occurrences of that specific molecule as a function of MD step. 
 
As a reminder, the combustion reaction is as follow: 
 
CH₄[gas] + 2O₂[gas] → CO₂[gas] + 2H₂O[steam] + ΔE 
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As we can see from the long list of molecules based on the simulation, there are an ensemble 
of additional (intermediate) species that have been created. 
 
a) Select from the Show column only the reactants and products of the reaction. 
 
We can see that indeed, CH4 and O2 are consumed, while CO2 and H2O are produced.  
 

Note that it is possible that you did not produce some of the products. This could be 
because the simulation is not yet finished, and you should keep running the simulation. 

 

3.3.  Chemical reactions and mechanisms 
 
In order to get further insights in the combustion reaction, we will use the ChemTraYzer2 tool. 
ChemTraYzer2 will analyze all molecules formed along the simulation, keep track of the 
events, and provide a summary of the reactions, including statistics and rate constants for the 
reactions. 
 
a) From AMSmovie, select MD Properties → Reaction detection ChemTraYzer2. 
 
We will keep all defaults settings and hit Run ChemTraYzer2 at the bottom. A new window 
opens with a list of the reactions identified by ChemTraYzer2. This window is split into two 
sections. The upper one lists all reactions by name, while the lower one lists each reaction’s 
individual occurrences ordered by time. In the top section, reactions are reported in SMILES 
format as well as in molecular format. 
 
a) Click the upper search field and type in CO2. 
b) Select the first reaction in the upper panel. 
c) Click the top line of the bottom panel. 
 
Now only the corresponding molecules from the selected reaction are shown in the movie 
panel of AMSmovie. You can observe the full reaction step-by-step by clicking on the left and 
right arrow keys on the keyboard. 
 

In the case the molecules of the reaction you observe are crossing the periodic boundaries, 
you can display the entire molecule from View → Periodic → Periodic View Type → 
Complete Molecules. 
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