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Introduction
This document will provide a hands-on tutorials demonstrating the ADF-GUI, BAND-GUI and so on. All of
these (ADF-GUI, BAND-GUI, DFTB-GUI, ReaxFF-GUI and so on) are very similar and share a lot of options.
So collectively these will just be called the GUI.
The first five tutorials provide an overview over all GUI modules, using ADF as computational engine. If you
are new to the GUI, we advise you to study the tutorials in the order presented.
The advanced ADF-GUI tutorials focus on particular features of the ADF-GUI, or on some particular
application.
Next there are some specialized tutorials that show you how to use the GUI with BAND, DFTB, MOPAC or
ReaxFF.
We estimate that you will need about half an hour for each part of the tutorial, for reading and performing the
hands-on activities. Typically the calculations should give results that are very close to the results shown in
the tutorials. However, in some cases minor changes may occur depending on hardware and software
versions.
Many tutorials are also available as videos. The current videos are actually the tutorial videos for ADF2009,
so there will be differences with the current tutorials.
Additional information may be found in the GUI manual

Starting the GUI: start ADFjobs
We will assume that you have installed the full ADF package on your machines.
The most convenient way to start the GUI is to first start ADFjobs, one of the GUI modules. Using the SCM
menu in ADFjobs (either the text SCM, or the SCM logo) you can next start any other GUI module that you
have a license for.
Depending on your platform, you start ADFjobs in a slightly different way:

UNIX (such as Linux) users
In this tutorial we will assume that you have added $ADFBIN to your PATH. We advise you to do this if you
have not already done so. If you do not wish to add $ADFBIN to your PATH, you must start the utilities using
$ADFBIN/adfjobs &
instead of just
adfjobs &
On all UNIX platforms, including Mac OS X, the GUI modules are XWindow (X11) programs. Your
environment should have been set up correctly to run such programs. In particular, you need to make sure
that your DISPLAY environment variable has been set properly.
You can test this easily by starting a simple X program from your shell:
xcalc &
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Assuming the xcalc program is in your $PATH, a small window should appear with the image of a calculator.
If not, please consult your local system administrator for additional help. Typical problems have to do with
your DISPLAY variable, and with security issues when trying to connect to the X server.
When you log in to a remote linux UNIX system using ssh, make sure you are using X11 forwarding. You
can force this by using the -X (sometimes with the -Y) flag to the ssh command. As ssh is taking care of
setting your DISPLAY variable, you should make sure not to set it yourself.
Most GUI modules use OpenGL to render the 3D images. With X11 this is done using the GLX X11
extension. You can test if GLX is working propely by running the glxgears command:
glxgears
In case of troubles, the glxinfo command might also give useful information.

Windows users
In this tutorial we will assume that you have installed the ADF package using the Installer with all the options
set to default.
You can start the GUI (adfjobs) by double-clicking its icon on the desktop.

Macintosh users
Macintosh users have several easy ways of starting the GUI modules: just like on any other UNIX system
(thus, using the command line), or using the ADF2013.01 program.
The easiest way is using the ADF2013.01 program. When you start it, ADFjobs will be started automatically.
Next you can use the SCM menu to start the other ADF-GUI modules.

GUI modules (for the ADF-GUI, BAND-GUI, COSMO-RS GUI,
ReaxFF-GUI, and so on)
The ADF-GUI is the Graphical User Interface for the ADF package. It consists of several modules for
specific tasks. Those modules work together and exchange information. You should make sure you have no
firewall blocking TCP/IP communications inside your machine.
All of the ADF-GUI (and BAND-GUI etc) modules have one common SCM menu on the top left of the
window. On most systems it is represented by a small SCM logo. You can use the commands inside the
SCM menu to start other GUI modules (or switch to them).
In general when selecting a GUI module from the SCM menu it will start and open the current job. If that
module is already open with the current job, it will be activated (brought to the foreground). The current job is
the selected job in ADFjobs, or the job open in some other GUI module if you use the SCM menu in that
module.
The most important exception is opening the New Input module (ADFinput) or ADFcrs (COSMO-RS) in
ADFjobs. In that case the selected job will be ignored, and you can start working on a new calculation. To
open the selected job in ADFinput, you need to click the icon in front of the job.
SCM → Preferences
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GUIprefs ($ADFBIN/guiprefs) allows you to adjust and save numerous GUI preferences, such as color
schemes, environmental variables, etc. The preferences will be used by all ADF-GUI modules.
SCM → New Input
ADFinput ($ADFBIN/adfinput) helps users to easily create ADF jobs. You can use ADFinput to define
your molecule (geometry), pre-optimize it, and to set details of your ADF job using an easy-to-use
graphical user interface. ADFinput will generate the basic job script for you. This script takes care of
running ADF and property programs as required.
The same module can actually create jobs using different methods: ADF, BAND, DFTB, MM, MOPAC,
Open Babel, QMMM, QUILD, ReaxFF and UFF. After starting it, you can simply change the method to
use without starting a different module. Depending on your license, not all options might be available.
SCM → COSMO-RS
ADFcrs ($ADFBIN/adfcrs) enables ADF users to easily select compounds, create COSMO-RS jobs, run
the jobs, and visualize the results.
SCM → View
ADFview ($ADFBIN/adfview) displays volume data, such as electron densities, orbitals, electrostatic
potentials and more. You can also use it to visualize scalar atomic data like charges, some tensor data,
and AIM (Bader) results.
SCM → Movie
ADFmovie ($ADFBIN/adfmovie) follows geometry steps as performed by ADF during geometry
optimizations, IRC calculations, etc. It can be used during the calculation to monitor the progress (based
on information from the logfile), or it can be used to analyze the geometry changes after a calculation. It
is also used to display normal modes calculated with a frequency calculation.
SCM → Levels
ADFlevels ($ADFBIN/adflevels) generates a diagram showing the energy levels of a finished
calculation. You can interact with it: show an interaction diagram (how the molecular orbitals are
constructed from fragment orbitals), show labels, occupations, orbitals, etc.
SCM → Logfile
ADFtail ($ADFBIN/adftail) shows the contents of a text file, updating when the text file grows (like the
UNIX tail -f command). It is typically used to monitor the 'logfile'. The progress of an ADF calculation is
always written to this file.
SCM → Output
ADFoutput ($ADFBIN/adfoutput) shows the output of ADF (or any other text file). It will analyze the
output and provide quick links to sections of interest.
SCM → Spectra
ADFspectra ($ADFBIN/adfspectra) shows spectra calculated by ADF. It can show IR, Raman, excitation
and CD spectra, as well as a DOS plot. For some spectra it can also perform additional tasks (using
other ADF-GUI modules), like displaying normal modes or orbitals.
SCM → Band Structure
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Bandstructure ($ADFBIN/bandstructure) shows dispersion spectra like the band structure of solids, or
phonon spectra, as calculated by for example Band or DFTB.
SCM → Dos
ADFdos ($ADFBIN/adfdos) shows DOS-like results. You can easily select which partial DOS to show by
selecting atoms, and you can even select to show the GPDOS for select atoms and L-shells.
SCM → Jobs
This utility ($ADFBIN/adfjobs) manages your ADF jobs: run a job on your local machine or on remote
machines. It also serves as a interface to all files belonging to your job, and it serves as a convenient
launcher of the other ADF-GUI modules.

Keyboard shortcuts
Some keyboard shortcuts for menu commands used in the tutorials are platform specific. For example:
• Undo: ctrl-Z on Linux/Windows, cmd-Z on Macintosh
• Save: ctrl-S on Linux/Windows, cmd-S on Macintosh
In general, on Linux and Windows machines use the ctrl key to access these shortcuts for the menu
commands, on a Mac use the cmd key. In the tutorials, these command keys may be mentioned as for
example cmd/ctrl-S
If you are using a Mac, the GUI uses the X11 program to run. The X11 program itself may intercept the
menu-shortcuts like Cmd-C, Cmd-H, and so on. You can change this using the Preferences command from
the X11 menu (Enable key equivalents under X11 should NOT be checked).
A three-button mouse is also very convenient for using the ADF-GUI, and on a Mac you can use a Magic
mouse for this purpose. To get three buttons (instead of the standard one or two), download and install the
free utility BetterTouchTool, and configure it to add a middle click.
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ADF-GUI overview tutorials
Tutorial 1: Geometry optimization of ethanol
This tutorial will help you to:
•
•
•
•
•
•

create a simple molecule
view the molecule from all sides and save a picture
make a couple of changes to the molecule with different tools
set up your ADF calculation
perform the actual ADF calculation
visualize some results: energy levels, geometry, electron density, orbitals, ...

Step 1: Preparations
Start ADFjobs
On a Unix-like system, enter the following command:
cd
adfjobs &
On Windows, one can start ADFjobs by double-clicking on the ADF-GUI icon on the Desktop:
double click the ADF-GUI icon on the Desktop
On Macintosh, use the ADF2013.01 program to start ADFjobs:
Double click on the ADF2013.01 icon
Make sure X11 allows you to use keyboard shortcuts (you only need to do this
once):
Press Cmd-,
If nothing happens everything is fine.
If the X11 Preferences dialog appears:
uncheck the "Enable key equivalents under X11" check box and close
that dialog.
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Note that the directory in which ADFjobs depends on how you start ADFjobs, so your screen might look
different.

Make a directory for the tutorial
We prefer to run the tutorial in a new, clean, directory. That way we will not interfere with other projects.
ADFjobs not only manages your jobs, but also has some file management options. In this case we use
ADFjobs to make the new directory:
Select the File → New Directory command (thus, the New Directory command from the
File menu)
Rename the new directory by typing 'Tutorial' and a Return
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Change into that directory by clicking once on the folder icon in front of it

Start ADFinput
Now we will start ADFinput in this directory using the SCM menu:
Select the SCM → New Input menu command:
use the SCM menu on the top left (the SCM logo on most platforms),
next select the New Input command from the menu.
The ADFinput module should start:
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The ADFinput window consists of the following main parts:
•
•
•
•
•
•
•

the menu bar with the menu commands (File, Edit, ...)
the drawing area of the molecule editor (the dark area on the middle left side)
the status field (lower part of the dark area, blank when the ADFinput is empty as shown above)
the molecule editor tools
many panels with several kinds of options (currently the 'ADF Main' panel is visible)
panel bar with menu commands to activate the panel of choice
a search tool (at the right of the panel bar)

Undo
ADFinput has an Undo command, which works on your molecule (thus not on your input options).
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If you make a mistake while making changes to your molecule, just use the Edit → Undo menu command to
go back in time. You can Undo more than one step, or Redo a step (with Edit → Redo) if you wish to do so.

Step 2: Create your molecule
Create a molecule
The molecule we are going to create is ethanol.
First we will draw the two carbon atoms, next the oxygen atom, and after that we will add all hydrogen atoms
at once. Finally, we will pre-optimize the geometry within ADFinput.
Create the first carbon atom
To create an atom, you need to select an atom tool.
Select the C-tool by clicking on the button with the 'C'
Back glow is added to the 'C' button to indicate that you are using the C-tool. Also, the status field in the left
bottom corner shows 'C tool, create single bond' to indicate that you are using the C-tool.
Now create the first carbon atom:
Click somewhere in the drawing area
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One carbon atom has been created.
Note that:
• If you move the mouse you will see a white line from that carbon atom to the current mouse
pointer position: this shows you are in 'bonding' mode, and that the bond will be made to the atom
just created.
• The 'C' button has a different color, indicating you are still using the C-tool.
• The carbon atom is selected (the green glow), which indicates that the carbon atom is the current
selection.
• The status field contains information about the current selection: it is a Carbon, number 1, with 4
'connectors'
• The status field also shows the current tool (C), and that a single bond will be made.
Create the second carbon atom
Click somewhere in the drawing area to create the second carbon atom
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A second carbon atom has been created, bonded to the first atom.
The atom will be created along the 'bonding line', at a distance that corresponds to a normal C-C single
bond distance. That is, the bond length is constrained while drawing.
The newly created atom becomes the new selection, and you are still in bonding mode. The next bond will
be created to the carbon atom just created. And you are still using the C-tool.
Create the oxygen atom
To create the oxygen atom you need to switch to the O-tool:
Select the O-tool by clicking on the button with the 'O'
With the O-tool, create an oxygen atom bonded to the second carbon;
Click somewhere in the drawing area
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The oxygen atom has been added.
For now, we are done using atom tools, so go back to the select tool:
Select the select-tool by clicking on the button with the arrow (or press the
Esc key)
Add the hydrogens
Now many hydrogen atoms need to be added. You can do this using the H-tool, but a much easier method
is to use the Atoms → Add Hydrogen menu command:
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The 'Add Hydrogen' menu command works on the selection only, when present. Thus, only one hydrogen
atom would be added to the oxygen atom. This is not what you want. So first we make sure that nothing is
selected by clicking in empty space.
Click in empty (drawing) space
Now no atoms are selected any more.
Select the Atoms → Add Hydrogen command
Many menu commands have shortcuts. In this case you can also use the shortcut (ctrl-H or cmd-H,
depending on your platform) as an alternative. The shortcuts are indicated in the menu commands.

All atoms will be saturated with hydrogen atoms. And you have created an ethanol molecule, though the
geometry is still far from perfect.
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Pre-optimize the geometry
Now use the optimizer that comes with ADFinput to pre-optimize the geometry.
Click on the pre-optimizer button (the rightmost 'cog wheel' button of the
menu bar)

The geometry of the molecule will be pre-optimized, using UFF by default. Note you can select another preoptimizer via the Preferences, or use a different pre-optimizer by right-clicking on the cog wheel and
selecting the method to use from the pop-up menu.
In the status field below the drawing area you can follow the pre-optimization iteration number and the
energy relatively to the starting configuration.
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Viewing the molecule
Rotate, translate, or zoom
You can rotate, translate, and zoom your molecule using the mouse.
You need to drag with the mouse: press a mouse button, and while holding it down move it. Which mouse
button, and which modifier key you press at the same time, determines what will happen:
Rotate
Left
Rotate in-plane ctrl-Left
Translate
Middle, or Alt-Left
Zoom
Mouse wheel, Right, or cmd-Left (drag up or down)
The rotate, translate, and zoom operations change how you look at the molecule, they do not change the
coordinates.
Click once somewhere in empty space to make sure nothing is selected.
Click with the left mouse button, and drag:
your molecule will rotate.
Click with the left mouse button with the ctrl-key, and drag:
your molecule will rotate in-plane.
Click with the right mouse button, and drag:
your molecule will be translated.
Click with the right Middle button (if available), and drag up and down:
you will zoom closer to or away from your molecule.
Click with the left mouse button with the alt-key, and drag:
you will zoom closer to or away from your molecule.
Use the mouse wheel, if you have one:
you will zoom closer to or away from your molecule.
Using all these options, try to position the ethanol as closely as possible as
in the
following image:
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Atom colors
The atoms of your molecule will have a pre-defined color, as visible in the molecule editor. You can change
these colors in two ways: either change the global default color per element, or override the default color for
a specific atom. The first method uses the Preferences command, the second method uses the 'Atom
Details panel' via the Atoms → Details (Color, Radius, Mass, ...). In this tutorial we will change the default
color of all Carbon atoms using the Preferences command:
Use the SCM → Preferences menu command to start the preferences module
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In the preferences window, go to the 'Atom Colors' panel (use the panel bar
Color menu)
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Click on the '+' button, and select C (Carbon) from the periodic table that
pops up.
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You can now change the color for the carbon atoms either by clicking on the colored block next to the C
label

Click on the colored C-block
Select your favorite color, and dismiss the Color dialog (click the OK button
on most platforms)
Click the Preview button in the bottom of the GUIprefs panel.
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In ADFinput the colors of the carbon atoms will now be adjusted to the color that you have selected.
The 'Preview' button shows the effect of your new preferences in all open GUI modules, but without saving
them. Once you are content with your changes, you can use the 'Save' button to store the new defaults.
If you close the Preferences window without saving, your original settings will be restored in the open
modules.
To revert to the default value of carbon, you can remove the carbon color in Preferences window by
pressing the - button in front of the C color line:
Click the '-' button in front of the C color line
Click the 'Preview' button
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In ADFinput, your carbon atoms now should have their default color again (dark gray).
Use the File → Close menu command to close the GUIprefs module (the Preferences
window)
When quitting the Preferences module without saving, any changes made visible via the Preview button will
be undone.
Save picture
You can save a picture of your molecule using the 'Save Picture ...' command from the File menu.
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The format used is the PNG format. You can change this using the File → Picture Format menu command.
You can also change the resolution. A smaller resolution will result in a smaller file, but will reduce the
quality.
Via the Preferences command it is possible to save your preferred format.
Select the File → Save Picture ... command
Enter the name for your picture: ethanol
Click the 'Save' button
A picture will be saved to disk containing the image of your molecule. Only the drawing area is saved in the
picture, not all the input options.

Molecular conformation
Rotate such that you look along the C-C axis
Rotate your molecule into the following position:
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Select the top CH3 group
Click once on the top carbon atom
Use the Select → Select Connected menu command
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As you will notice, all atoms directly connected to the selected atom are added to the selection. Alternatively,
you can also make a selection by shift-clicking on the elements you want to select.
Click in empty space
Click on the top carbon atom
Shift-Click once (without moving) on each of the top hydrogen atoms
This has almost the same effect (in this case you have not selected the second carbon atom).
Rotate the selection
We are now trying to make an eclipsed geometry.
ctrl-Click with the left mouse button in one of the selected hydrogens,
and drag around to rotate the selection in-plane.
Rotate the hydrogen atoms in an almost eclipsed position.
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You can move the selection by clicking in a selected object, and dragging with the mouse. All usual
operations are possible: rotate, rotate in-plane, translate and zoom. Zoom in this case means moving the
selection perpendicular to the screen.
In the status field you see the current rotation angle.
You have to click and start dragging at a selected item. If you click and drag in space you will move the
entire molecule.
Back to Staggered Geometry
Click in empty space to clear the selection
Click on the pre-optimize button
The optimizer will bring the structure back to the original staggered geometry. If it does not complete, repeat
this step until it does.
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Getting and setting geometry parameters
Bond length
First select the oxygen atom and the connected hydrogen atom.
This time we make the selection by dragging a rectangle around all objects that we want to select.
Using the left mouse button together with the shift key, drag a rectangle
around the oxygen and hydrogen atom.

Release the mouse button (and the shift key)
The oxygen atom and the hydrogen atom are selected.
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In the status area you see the distance between the selected atoms, information about the bond, and a
slider.
You can set the distance to any value you wish by editing it, or (most conveniently) by using the slider.
Normally the smallest group of atoms will move to create the requested distance. If you press the control key
while using the slider the last atom selected will be in the group of atoms to move.
Use the slider to move the H atom
Bond angle
Select first one of the top hydrogens by clicking on it
Next, extend the selection (shift key) by clicking on the top carbon atom
Finally, extend the selection (shift key) by clicking on another top hydrogen
atom
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In the status area information about the bond angle of the selected three atoms is given, and the slider is
again visible. You can change this value to a value you like, most conveniently using the slider.
Dihedral angle
By selecting four atoms we get information about the dihedral angle. And of course you can also change it,
again most conveniently using the slider.
Move the molecule such that you can see all atoms
Select first one of the top hydrogens by clicking on it
Next, extend the selection (shift key) by clicking on the top carbon atom
Next, extend the selection (shift key) by clicking on the next carbon atom
Finally, extend the selection (shift key) by clicking on the oxygen atom
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Coordinates
To view the coordinates we have to go to a different input panel. The input panels can be selected using the
panel bar on the top of the input panels, the right half of the window.
In the right side of the ADFinput window:
Click on the Model tab in the panel bar
Select the Coordinates command

35

You get a list of all Cartesian coordinates. They will be updated in real time when you make changes to the
molecule, and you can also edit the values yourself. In that case, the picture of the molecule will be updated
automatically.
Note that some atoms are highlighted. These are the currently selected atoms.
The 'Move Atom(s)' buttons will move the selected atoms up or down. In this way you can re-order the
atoms.
You may, in some cases, wish to use Internal coordinates. These will be updated in real time as well, and
you can also edit the values yourself. If you re-order the atoms while using the Internal coordinates, the Zmatrix will be recalculated from scratch. The Z-matrix panel is in the Details tab, but we will use the search
option to get to it:
Click the search icon at the right of the panel bar
Enter the text "z-ma" in the search field

Note that in the search results the Z-Matrix panel is highlighted, and note that the search is not case
sensitive.
Click on the selected option (Z-Matrix), or use the return key
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Extending and changing your molecule
Before making some changes, let's re-optimize. We first select the 'Main' panel so the coordinates will not be
visible during the pre-optimization. Otherwise this may slow down the pre-optimization.
Click on the "Main" tab
Click on the pre-optimize button
Let's try to change the CH2OH group in a COOH group.
Thus, we need to:
• remove one hydrogen
• change one hydrogen into an oxygen
• change a single bond into a double bond
After this, we will revert to the ethanol molecule.
Delete an atom
First: delete one hydrogen
Click in empty space to clear the selection
Click once on the hydrogen to delete, it will be selected
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Press the backspace key
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The selected atom is removed.
Change the type of an atom
Next, we will change a hydrogen into an oxygen atom
Select the O-tool (or press the 'O' key)
Double-click on the hydrogen that should change into an oxygen
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Change the bond type of an existing bond
Now the oxygen atom is singly bonded to the carbon, we need to change this into a double bond.
Click on the bond between the carbon and the new oxygen
Use the Bonds → Bond Order → Double menu command (or just press the '2' key)
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The single bond has changed into a double bond.
Another way to modify a bond type is to click on the bond once which will select this bond. Then click on the
bond tool in the menu bar ('ball and stick' logo to the right of the start), and select the proper bond type.
The fastest way to change the bond order is to use the keyboard shortcuts. If you have selected a bond,
press 1 for a single bond, 2 for a double bond, 3 for a triple bond and 4 for an aromatic bond.
To get a reasonable geometry optimize the structure:
Click in empty space to deselect the bond
Press the pre-optimize button
If not converged, press pre-optimize again
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Add new (bonded) atoms
Now, to revert to the ethanol molecule, we first remove the new doubly-bonded oxygen atom, and then add
one hydrogen atom.
Click once on the doubly-bonded oxygen atom to select it
Press the backspace key to delete it
Select the H-tool (or press the 'H' key)
Click once on the carbon atom connected to the oxygen
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Note that this way you started bonding mode again, as indicated by the bond to the mouse position.
Click once in empty space to make a hydrogen atom (connected to the carbon!)
Click once on the just created atom to stop bonding
Repeat this to add a second hydrogen to the carbon atom
Pre-optimize the molecule
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Once again you have created an ethanol molecule.

Step 3: Select calculation options
Preset
You should always start by choosing the proper preset.
ADF has many different modes of operation. ADFinput presents the correct settings for some common
calculations together as 'presets'.
So to optimize the geometry of the ethanol molecule we choose the proper preset:
Select the 'Geometry Optimization' preset from the 'Preset' menu.
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Presets might change any number of input options. In this particular example, the main Task will change
from 'Single Point' to 'Geometry Optimization'. You can easily see what fields have been updated by a
preset: they are colored green.
If you would use this preset again later, the input values that are set by this preset will revert to the default
values. If you made changes to those fields you will lose those changes.

Title
This field, currently empty, has no special meaning for the calculation routine. It will be used as an identifier
for your convenience in the result files of the ADF calculation. In this case, let's set the title to the name of
the molecule:
Enter 'Ethanol' without quotes in the 'Title' field.
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Note that as soon as you start typing in the title field, the color of the field changes to yellow. The yellow
color here and in other cases indicates that you have made a change with respect to the default value for
this field.

XC functional
An important input option is the XC functional to use.
For this tutorial the default potential during the SCF is sufficient. So just leave this at the default value. For
more accurate results you should select a better XC potential.
By selecting the LDA+GGA+METAGGA option for the XC energy ADF will print a table at the end of the
calculation showing the energies with many different functionals:
Select the 'LDA+GGA+METAGGA' option for the XC energy after SCF
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Again, since you made a change with respect to the default value the change is highlighted with a yellow
color.

Basis set
With the 'Basis Set' pull-down menu you select the basis set you want to use.
The menu gives access to the basis sets regularly used.
For this tutorial we will choose a very small basis set. This will yield less accurate results, but the calculation
runs much faster. Obviously, if you want more accurate results you should use a better quality basis set.
Thus:
Select 'SZ' from the 'Basis Set' pull-down menu
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Integration
The ADF software package uses a numerical integration scheme for virtually everything it may calculate. A
numerical integration scheme generates some kind of grid (and corresponding weights). ADF and BAND
have always been using the teVelde (Voronoi) integration scheme. For many calculations the Becke
integration grid works better, so in ADF2013 the Becke integration grid method has been added. It now is
the default method, and normally you should use the Becke grid option.
In the integration pull-down menu you select what kind of grid to use. For Becke grids you can use the
default, or request a specific quality. For teVelde grids you can specify the integration accuracy parameter.
That number is roughly the number of significant digits in your results.
Increasing the quality of the grid, or the accuracy parameter makes the results more accurate, but will
require substantially more computation time.
Similarly, decreasing the quality will result in less accurate results, but you may get results faster. A too low
integration accuracy often leads to convergence problems if the convergence criteria are too strict.
The default value will in most cases be fine, certainly for this tutorial.
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Other input options
The panels on the right side contain many more input options. You select a panel with the menus in the
panel bar, or by searching for a particular option (as we did to locate the Z-Matrix panel). When searching
for an option, any text in the panels will match, as well as from the help balloons. Also the corresponding
ADF input keys will match.

The menu items use a color coding to show you which panels have been affected by a preset (green), by
the user (yellow), or both (red).
As we will not do anything special right now, you do not need to change anything in other panels.

Step 4: Run your calculation
Save your input and create a job script
Finally you will want to save your input.
Select the File → Save command.
Enter the name 'ethanol' in the Filename field.
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Click on Save
ADFinput will now present a warning dialog:

So the requested option to print meta-GGA results after the final SCF will produce incorrect results when
using frozen cores. Normally you would not accept this, but for the tutorial let's just continue with this set-up:
Click OK to dismiss the warning dialog
A new dialog pops up asking you if you really want to save the run script even though it will not be correct:
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The run script will not be correct because we use the frozen core option together with metaGGA's, as we
were told before. Accept this and save it anyhow:
Click Yes to save the run script
Now you have saved your current options and molecule information. The file will automatically get the
extension '.adf'.
ADFinput has also created a corresponding script file. This script file has the same name, but with an
extension '.run' instead of '.adf'.
In the ADFjobs module you can see what files have been created:
Click once in the ADFjobs window to activate it
Click once on the triangle in front of the name of the job (ethanol)
You will see the .adf and .run files, and a .pid file that ADFjobs uses to store information. You might also see
the picture that you saved, if you used the name 'ethanol' for it. Only the extensions are listed, so the real
filenames are ethanol.adf, ethanol.run and ethanol.pid. Notice the job status icon (the open circle on the
right) that ADFjobs uses to indicate a new job.

Run your calculation
To actually perform the calculation (the geometry optimization of the ethanol molecule), use the Job → Run
menu command in ADFjobs:
Make sure the ethanol job is selected in ADFjobs (it is if you followed the
tutorial)
Select the Job → Run command
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This will execute the run script that has just been created. If you have never made changes in the ADFjobs
setup, the default behavior is to run the job in the background on your local computer, using the Sequential
queue. This queue will make sure that if you try to run more then one job at the same time, they will be run
one after another.
Once your job starts running, ADFjobs will show the progress of the calculation: the last few lines of the
logfile:

Note that while running, the job status symbol in ADFjobs changes.
If you wish to see the full logfile while the calculation is running, just click on the logfile lines displayed in the
ADFjobs window:
Click on the logfile lines in the ADFjobs window
Now the logfile is showing in the ADFtail window:
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Step 5: Results of your calculation
Logfile: ADFtail
The logfile is saved and extended by ADF as it is running. Normally it is most convenient to view it only in
the ADFjobs window to prevent screen clutter.
Right now it is already showing in the ADFtail window, and in the ADFjobs window, but you could have used
any text editor.
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Wait for the calculation to finish:
Wait until ADFtail shows 'Job ... has finished' as last line
In the dialog that pops up, click 'Yes' to update the geometry

Now close ADFtail by using the File → Close menu command:
In the window showing the logfile (the ADFtail window):
Select the File → Close command
In the ADFjobs window, note that the job status icon has changed to indicate that the job is ready:
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Files
ADF has created a couple of data files and a couple of text files. You can check this in the ADFjobs window:
Click on the ADFjobs window
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Note that the Local files are visible because earlier in the tutorial you already clicked on the triangle opening
the details for this job.
The .adf file is the input as saved by ADFinput.
The .run file is the run script, also saved by ADFinput.
To enable specific options of your ADF job, changes to the text of the .run script can be made opening it via
double-click. A separate text editor window pops up after the double-click (the non-default text editor
program can be defined via the $EDITOR variable passed to ADF-GUI). When you run your job, your edited
.run file will be used. Note that when you save your input via ADFinput again, your .run file will be
overwritten (and thus you lose any changes you made when editing the .run file).
The .job file is a script file based on the .run file, and is created by ADFjobs. It contains all commands
required to run your job, and is actually run by ADFjobs when you use the Run command.
The .pid file is a file that contains your job status and configuration. It is used by ADFjobs.
The other files are produced by ADF. The .err file contains error messages, the .logfile shows the progress
of the calculation, the .out file is the main (text) output file, and the other files are binary files that store
results of the calculation.
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Geometry changes: ADFmovie
ADF has optimized the geometry, and we can use the ADFmovie module to visualize the progress of the
optimization. So let's start ADFmovie using the SCM menu in your ADFinput window:

Select the SCM → Movie command in ADFinput
The ADFmovie module will display a movie of the geometry optimization.
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To step through the different geometries, use the slider below the picture. Clicking in the slider will single
step through the frames. Alternatively you can grab the slider and move to the frame you wish, or you can
use the left and right arrow keys to single step through the frames.
You control playing with the buttons. When your mouse pointer is above any of the buttons, and not moving,
a balloon will pop up showing what that particular button will do.
It is often nice to have a graph of the energy as function of the geometry step. ADFmovie can show such
graphs easily:
Use the Graph → Energy menu command
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You can even show several graphs for different properties at the same time:
Use the Graph → Add Graph menu command
Select two carbon atoms by shift-clicking on them
Use the Graph → Distance, Angle, Dihedral menu command

Now you have two graphs. One of them is the 'active' graph. When you make a new graph it will always be
the active graph. You can also make a graph active by clicking on it.
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When you select a property from the Graph menu (Energy, Distance and so on) that property will be plotted
in the active graph.
You can also multiple curves in one graph, if possible: one property per Y-axis. You may have several
curves on the same Y axes if they are using the same unit (all Angstroms for example):
Select two carbon atoms and one oxygen atom by shift-clicking on them
Use the Graph → Distance, Angle, Dihedral menu command

Another feature is that you can click on a point in one of the graphs. It will be marked, the movie will jump to
that particular step, and if you have more then one graph the corresponding point(s) will also be marked in
the other graphs.
To rotate, translate, or zoom the picture, use your mouse, just as in ADFinput.
Use the slider to go to a frame in the middle of the optimization
Selecting atoms provides information about atoms, bonds, etc. The information will be updated when you go
to another point in the movie (a different geometry). You can see examples of these in the pictures above.
You can also show this information in the 3D window:
Use the View → Geometric Info → Angle menu command
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The angle will be visually added to your molecule :
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In the ADFmovie window: select File → Close

Orbital energy levels: ADFlevels
Select your job in the ADFjobs window by clicking on the job name
Select the SCM → Levels command
ADFlevels will start and show a diagram of the energy levels of the ethanol molecule.
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In the diagram you can see from what fragment types the molecular levels are composed.
Move the mouse around, above different levels, without clicking
Balloons will pop up with information about the level at the mouse position: The MO number, eigenvalue,
occupation, and how it is composed of SFOs (fragment orbitals).
Click and hold on the HOMO level of the molecule

In the pop-up that appears, select 'Show Labels'

63

Click and hold on the HOMO of the O fragment type
In the pop-up, select 'Show Labels'

To actually see the orbital, select the orbital from the top of the pop-up menu:
Click and hold on the HOMO level of ethanol
Select the '10A' command
A window with a picture of the orbital should appear.
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You can move (rotate, translate and zoom) the orbital with your mouse.
Close the window showing the orbital: File → Close (in the window displaying the
orbital)

Electron density, potential and orbitals: ADFview
Select SCM → View
ADFview will start up and show a picture of your molecule:

65

You can use ADFview to visualize all kinds of 'field' related properties: densities, orbitals, potentials, etc. You
actually have already used it before: the picture of the orbital that was created using ADFlevels was shown
by ADFview.
Use the mouse to rotate, translate or zoom, as in ADFinput.
In the Properties menu there are some pre-defined things to visualize: density, spin-density, HOMO, LUMO
and more. If you select one of these, you will see the corresponding item immediately. However, ADFview
can do much more and gives you lots of control.
For example, lets show a density isosurface, colored by the electrostatic potential:
Select the Add → Isosurface: Colored command
Below the picture a control line will be created. ADFview creates one such line for all visual items and
special fields (surfaces, cut planes, calculated fields, etc.) that you add.

In this particular case the control line contains two pull-down menus that you use to select the fields that you
want to visualize.
From the first pull-down menu in the control line, select Density → SCF
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From the second pull-down menu in the control line, select Potential → SCF

To demonstrate some other possibilities of ADFview, do the following:
Select the Properties → HOMO command
Click on the check box in the FIRST control line to hide the density
Rotate the molecule to get a good view
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Select the Add → Cut plane: Colored command
In the new control line, press on the pull-down menu and select Density → SCF
Click the check box in front of the 'Isosurface: Double' line to hide the HOMO
Select the Carbon and Oxygen atoms (three atoms)
Click the 'with atoms' button next to the 'Position plane' option (thus the
button, not the check box)
Click the check box in front of the 'Isosurface: Double' line to show the HOMO
Select the Fields → Grid → Medium command
Click Yes to recalculate the fields
Rotate your molecule to get a good view
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You can save the picture you create using the Save Picture menu command:
Select File → Save Picture ...
Enter the name (without extension) of the file you want to create
Click Save
A picture with the (file)name you specified has been created.
You might want to explore some more of the possibilities of ADFview on your own. Many different properties
can be visualized as you probably have noticed in the pull-down menus. Be careful with activating Anti-Alias:
it makes the pictures even better, but also slows ADFview down significantly.

Browsing the Output: ADFoutput
The output file (tutorial.out) is a plain text file. You can view it with your favorite text editor (or text viewer).
You can also use the ADFoutput GUI module which provides a convenient way to check the results:
Select the SCM → Output command
Select the Iterations → Geometry Cycles command
The ADFoutput program will start showing the results of your calculation, and via the menu you jumped to
the first section with geometry details:
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You can use the menus to go to different parts of the output file, or you can just use the scroll bar. If a menu
option is shaded, this means that no corresponding section of the output is available.
Clicking an output section title highlighted in blue will skip to the next section with the same title, if present.
As we are now done with tutorial 1, close all windows that belong to this tutorial:
Select the SCM → Quit All command in any ADF-GUI window
All open windows from the ADF-GUI will be closed.

Tutorial 2: Building Molecules
In the first tutorial you have learned how to construct a molecule by building it out of atoms. That may be a
complex task for bigger molecules. ADFinput has other ways to build molecules.
The quickest is to search for a molecule inside ADFinput, and use it if it is available.
Another way is to search for the molecule on the Internet, and use either the xyz coordinates or the SMILES
string
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Or you can build it using the structure tool in ADFinput. As a more realistic example using the structure tool,
you will build a small peptide chain. Then you will learn how to use the predefined metal complex structures.
You will also learn how to set up your own structures library.
Finally, you can combine the crystal tools to cut molecular systems out of crystals. As an example we will
make a sphere of Cu atoms.

Step 1: Start ADFinput
For this tutorial we again prefer to work in the Tutorial directory:
cd $HOME
Start ADFjobs
Click on the Tutorial folder icon
Start ADFinput via SCM → New Input

Step 2: Search for ethanol
The quickest solution: search (and find) ethanol.
Press ctrl/cmd-F to activate the search box (or click the search icon in the
panel bar)
Enter 'ethanol' as search text (without quotes)
Click on the 'Ethanol (ADF)' match
Rotate to get a good view

Your ethanol is ready. The (ADF) in the search results mean that the molecule has already been optimized
by ADF, using the BP86 XC potential with a TZP basis set and small core.
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For the next demonstration we need a file with the xyz coordinates of ethanol. You can make such a file
using the Export Coordinates option:
Use the File → Export Coordinates... menu command
Enter 'example.xyz' as filename
Click Save

Step 3: Import XYZ for ethanol
To import a molecule if you have its structure as xyz file (with element types), you can either use the File →
Import Coordinates... or the Edit → Paste command.
Use the File → New menu command in ADFinput
Click 'No' when asked if you want to save your changes
Click in the ADFjobs window to activate it
Use the Job → Refresh List menu command (or press F5)
Click the triangle in front of example to show the example.xyz file
ctrl-double click on the .xyz file (listed in Local files)

This will open a text editor showing the contents of the the example.xyz file. The editor used depends on
your operating system, but normally you will be able to select and copy text.
Select all text in the ethanol.xyz file
Copy it
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Click in the ADFinput window to activate it
Paste the xyz coordinates (ctrl/cmd-V or Edit → Paste)

You should again get the ethanol molecule, just as you have saved it.

Step 4: Import SMILES string
ADFinput can also interpret SMILES strings (via OpenBabel). As a demonstration, lets try again with
Ethanol:
Use the File → New menu command in ADFinput
Click 'No' when asked if you want to save your changes
Open a web browser
Search for ethanol on wikipedia.org
At the right side of the page, click the 'Show' link to show the SMILES
Copy the SMILES string ( CCO )
Click in the ADFinput window to activate it
Paste the SMILES string (ctrl/cmd-V or Edit → Paste)
Click in empty space in the drawing area to clear the selection

73

Again we have an ethanol molecule. SMILES strings do not contain the 3D structure, it was generated by
OpenBabel and is NOT an ADF optimized structure. So normally the next step would be to pre-optimize with
UFF (via the cog wheel), and to optimize the geometry with ADF.
SMILES strings work often, but there are also many examples where the resulting structure does not make
sense.

Step 5: Build ethanol using the structure tool
As a demonstration on how to use the structure tool, we start by building a methane molecule:

Use the File → New menu command in ADFinput
Click 'No' when asked if you want to save your changes
Select the C-tool
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Click somewhere in the drawing area to make a carbon atom
Select Atoms → Add Hydrogen , or faster: press the shortcut (ctrl-H or cmd-H)
If your cmd-H shortcut does not work (on a Mac), probably you need to fix your X11 preferences.

The next step is to add a methyl group, using the structures tool:
Select the Structures tool → Alkyl Chains → Methyl structure (the structures tool is
the benzene-like icon on the toolbar)
Notice that the button of the structures menu is glowing, which means that the structure-tool is in use.
Double-click on one of the hydrogen atoms
Zoom out if needed (with right mouse button or mouse wheel)
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You will see that the hydrogen is replaced by a methyl group.
Note that:
• The methyl is orientated along the newly formed C-C bond and the new hydrogens point away
from the existing ones.
• The double-clicked hydrogen is replaced by the carbon atom, since this atom is the 'replacing'
atom.
This atom is defined through having xyz-coordinates (0,0,0).
• The background glow moved from the 'Structures' tool to the 'Pointer' tool button; the 'Pointer' tool
is active again.
To create ethanol, we need to add a hydroxyl group:
Select the Structures tool → Ligands → OH structure
Double-click on one of the hydrogen atoms
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Again, the hydrogen is replaced by the structure. In this case, the oxygen replaces the double-clicked atom.
The hydrogen is precisely aligned along the C-O bond and points away from the rest of the molecule. This
shows you the very general way in which the structures will align according to the bonds in the original
molecule and those in the structure. In this case, the hydroxyl group is not immediately orientated as it
normally would be in an ethanol molecule:
Pre-optimize: click on the cog wheel
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And again we have constructed an ethanol molecule.
ADFinput comes with a many predefined structures. Among them are some typical solvent molecules, so
that you can easily add solvent molecules around your system. One of these 'Solvent' structures is Ethanol.
Now add this molecule in empty space:
Select the Structures tool → Solvents → Ethanol structure
Left-click in empty space near the hydroxyl group
Note that the oxygen is selected. Again, this oxygen is defined through having xyz-coordinates (0,0,0). Next
we select the new molecule and orient it with the mouse to a reasonable position:
Use the Select → Select Molecule menu command (or ctrl/cmd-M)
Use the mouse to rotate and translate the ethanol molecule to your favorite
orientation

78

This way you can easily add explicit solvent molecules.

Step 6: Building a peptide chain using the structures tool
Now we will build a small peptide chain as another example using the structures tool.
Select File → New
Click 'No' as we do not want to save the setup
Select the Structures tool → Amino Acids → AA Backbone structure
Place it in the drawing area
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There appears a subunit (or actually two) of a basic peptide chain. Notice that one of the atoms is selected,
namely the terminal nitrogen. This atom is, again, the 'replacing' atom. In order to extend the peptide
backbone, you now have to choose the right atom to be replaced. The obvious choice is the (non doublebonded) terminal oxygen.
Click in empty space to deselect the nitrogen
Press the space bar, which activates the last used option of the 'Structure'
tool ('AA backbone' here).
Double click on the terminal oxygen.
You may want to use View → Reset View.
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In a similar fashion, you can now replace the hydrogens on the backbone by amino acid side groups of your
choice. These can be found in the Structures tool → Amino Acid → AA Side Groups sub-menu.

Step 7: Metal complexes and ligands
In the sub-menu 'Metal Complexes' you can find a set of predefined complexes corresponding to commonly
encountered geometries. Furthermore, there are a number of ligands to be found, which can be easily used
with these metal complexes.

Predefined Metal Complex Geometries
Select the File → New command
Click No (do not save changes)
Select Structures tool → Metal Complexes → ML6 Octahedral tool and place it in the
drawing area
Notice that six dummy ("Xx") atoms have been placed around the metal center in an octahedral fashion.
Select one of the dummy atoms by clicking on it
Select Select → Select Atoms Of Same Type menu command
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The Ligands structure sub-menu contains a number of ligands which can be used to replace the dummy
atoms. The Structure menu can, however, also be reached via the Atoms menu.
Select the Atoms → Replace By Structure → Ligands → CN command
Click in empty space to clear the selection
Reset the View if needed

Notice that all dummy atoms in the selection are replaced by CN ligands.

Bidentate Ligands
In order to use the bidentate ligands, we must start with a bare metal center.
Select the File → New command
Click No (do not save changes)
Place an iron atom in the drawing area (click the X button in the toolbar to
get a menu with all elements)
Select the Structures tool → Ligands → Bidentates → Ethylenediamine structure
Double-click on the metal atom
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You can see that, in this case, the metal atom is not replaced by an atom of the structure, contrary to
previous experience, but that the bidentate ligand is simply attached to the central metal atom.
This works because the 'replacing' atom in all bidentate structures is a dummy atom, which has the property
that it won't replace an existing atom. The metal atom will simply take over the bonds that existed on the
dummy atom in the structure. You can easily verify this when you would place the structure in empty space.
Other multidentate ligands are defined in a similar fashion.
Press space bar and double-click on the metal atom
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Notice that the second ligand appears opposite the existing one.

Modifying the Plane Angle
To change the relative orientation of two bidentate ligands, we can change the plane angle. The planes are
defined by two sets of three atoms, the central one being present in both sets. In this case this will, of
course, be the metal atom.
Select, in order, the two nitrogens on ligand one, the metal atom, and the
nitrogens on the second ligand.
Change the plane angle to 90 degrees using the slider
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In this way, you can easily change the environment around the metal from square planer to tetrahedral. This
feature works as long as you choose the atoms in right order, and if the defined planes can freely rotate
relative to each other.

Step 8: Your own structures library
You can make your own structure library very easily.
By default, user defined structures will be stored in the .scm_gui/Structures directory.
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Defining your structures
To be able to actually use the structures as described earlier, it is necessary to define one of the atoms as
having xyz-coordinates (0,0,0). This will then be the atom that will actually appear at the spot of the atom
that is replaced by the structure. If you use the Save As Structure command this will be done for you.
Select the File → New command
Click No (do not save changes)
Build methane
Replace three of the hydrogens by chloride atoms and pre-optimize
Delete the remaining hydrogen
Select the central carbon atom
Use the Structures tool → Save As Structure ... command
Enter a name like trichloromethyl
Note that the selected atom (currently the C atom) will be used as anchor

The new structure will appear in the structures menu and can be directly used.

Using dummy atoms
Dummy ("Xx") atoms are treated a little different when used in structures. A dummy atom will not replace an
existing atom when it is defined as the 'replacing atom'. Instead, the double-clicked atom will remain and will
accept the bonds that the dummy atom had in the structure.
Build a methane molecule
Replace the carbon atom by a nitrogen atom
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Select one of the hydrogens and replace it by a dummy atom (the Xx atom type,
in the periodic system)
Select the dummy atom
Save the structure using the Structures tool → Save Structure As... command

Now you can select the structure from the structures menu and directly use it.
Select your new structure from the structures menu
Double-click on one of the hydrogens
Notice that the hydrogen atom is not removed and that the NH3 group is attached to it. Similar behavior has
been demonstrated with the bidentate ligands, where the dummy atoms are also used.
If you want to clean up your structures, you can use the Structures tool → Manage Structures...
command. If you use it, ADFjobs will open and show the contents of your Structures directory. As the
structures are just (simplified) .adf files, you can open them using ADFinput. And using ADFjobs you can
rename them or delete them.
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Step 9: A sphere of Cu atoms, cut out of the crystal
We start making a Cu crystal, using a super cell so we have many real Cu atoms.
To build the crystal, we need to use the periodic tools. These will work only for programs supporting
periodicity, like DFTB.
Start ADFinput (or use File → New in the currently open ADFinput window)
Switch to DFTB mode (panel bar ADF → DFTB)
Select 'Periodicity: Bulk'
Edit → Crystal → Cubic → fcc
Click OK in the pop-up-window
Edit → Crystal → Generate Super Cell...
Click OK in the pop-up-window
Uncheck View → Periodic → Repeat Unit Cells, so only one unit cell will be shown

Now we have a block of Cu, with explicit Cu atoms (that is using a super cell). Next we will center this block,
and select a sphere of atoms around the origin.
Make sure the origin is in the center of the block: Edit → Set Origin
Select → Select Atom Close To Origin
Select → Select Within Radius
Click OK
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Select → Invert Selection
Press the Backspace key to delete the selected atoms
If it does not respond: click once in the drawing area to focus on it, and
press the Backspace key again
Switch to ADF: panel bar DFTB → ADF
Rotate a little
As you can see, you have a (very small) sphere consisting of Cu atoms in the molecular ADF program:
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Obviously, by making a bigger super-cell and selecting atoms within a larger radius you can make bigger
spheres.

Step 10: A carbon nanotube
A small piece of nanotube is included in the molecule database, so you can just search for it and use it.
However, typically one wants some specific nanotube structure. And make it infinite (periodic in one
dimension). This can conveniently be done by importing the structure as found on the web:
Use a web browser to go to the TubeGen nanotube structure generator
Request CIF format as output, leave other options at the default values
Click generate
In the browser windows we get the nanotube structure in CIF format, something like the following:
data_nanotube
_audit_creation_method
University of Delaware'
_cell_length_a
_cell_length_b
_cell_length_c
_cell_angle_alpha
_cell_angle_beta
_cell_angle_gamma

'(3,3) Nanotube -- TubeGen 3.3, J T Frey,

7.4762
7.4762
2.4643
90.00
90.00
120.00

_symmetry_space_group_name_H-M

'P 1'
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_symmetry_Int_Tables_number
loop_
_atom_site_label
_atom_site_fract_x
_atom_site_fract_y
_atom_site_fract_z
C
0.7762
C
0.8138
C
0.7762
C
0.6077
C
0.5000
C
0.2939
C
0.2238
C
0.1862
C
0.2238
C
0.3923
C
0.5000
C
0.7061

0.5000
0.7061
0.7762
0.8138
0.7762
0.6077
0.5000
0.2939
0.2238
0.1862
0.2238
0.3923

1

0.0000
0.0000
0.5000
0.5000
0.0000
0.0000
0.5000
0.5000
0.0000
0.0000
0.5000
0.5000

Next we want to get this structure into ADFinput:
Select the CIF information in your browser
Copy
Start ADFinput
Edit → Paste.
View → Axes
Rotate to get a good view
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We see a piece of nanotube, repeated in all directions. Actually nine nanotubes are visible.
Notice that the nanotubes are oriented along the Z-axes.
The GUI can handle one-dimensional systems. However, in case of a one dimensional system (a chain) the
lattice vector is always along the X direction. So to change our nanotube in a nice periodic one-dimensional
structure we need to rotate it (including the lattice vectors) such that the tube is along the X-axes.
Use the Edit → Rotate 90 menu command to make the nanotube lie along the X-axes
(hint: rotate around the Y-axes)
Switch to a one-dimensional system (chain)
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The Rotate 90 command did not only rotate the coordinates of the atoms, but also the lattice vectors. Now
we have a small piece of nanotube (remember it already is repeated 3 times for visualization purposes). This
might be sufficient for your purposes, but it is easy to make a bigger piece:
Edit → Crystal → Generate Super Cell
Click OK to repeat the unit cell 5 times

93

Switch to some non-periodic code (like ADF) if you wish to treat this piece of nanotube without infinite
symmetry.

Tutorial 3: Building Crystals and Slabs
In this tutorial we demonstrate the working of several tools that combined give you great flexibility to build
periodic structures.
If you are not interested in periodic structures (for example, if you only use ADF), you can skip this tutorial.
The instruments at your disposal are:
•
•
•
•
•
•

The crystal structures tool.
The predefined crystal structures in the database (via the search field).
CIF file importer.
Crystal builder from space group information.
Super cell tool to enlarge the unit cell
Slice tool to cut out slabs from any crystal.
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To use these tools you need to use ADFinput in periodic mode. For example, by switching to the BAND
mode, or by switching to DFTB or Mopac and next changing the periodicity.

The Crystal Structures Tool
If you are lucky your crystal structure is already included in ADFinput. Most of the common structures are
there. NaCl is one of them.
Start ADFinput and switch to BAND (or to DFTB, and switch the periodicity to
'Bulk')
Click on the snowflake like pictogram on the toolbar.
Select a "Cubic" lattice and then NaCl

Next a dialog pops up where you can change the parameters of the structure, such as lattice constants
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In this case there is no need to change anything.
Click OK
Sometimes a crystal is not directly in the list. An example is LiF. It has the same crystal structure as NaCl,
but other elements and a different lattice constant, namely 4.01:
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Open again the NaCl dialog
Change the lattice constant and the elements as shown
Click OK
The NaCl crystal structure will be replaced by the new LiF crystal structure.
Some crystal structures have more parameters.
Select "Tetragonal" and then "rutile" from the snowflake tool
Click OK
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As you can see, it has two lattice parameters that need to be specified. But now also the positions of the
oxygens have a parameter "x"
After clicking 'Ok' your screen will look like this
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The Crystal Structures Database
All crystal structures known to the crystal structures tool are also available via the search tool.
Just as you can search for a molecule, you can search for a crystal. So lets make NaCl again:
File → New
Click on the search icon, or press control or command - F
Type 'NaCl' (without the quotes)
You should get a couple of matches:
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Select the NaCl crystal result (not the molecule!):
Click on the 'NaCl' search result (in the Crystals section)
You now should have a NaCl crystal again.
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Currently the structures of many simple crystals are included, as well as a few complex structure (optimized
by MOPAC). The zeolite frameworks are also included as a starting point to make your zeolite structure.

Crystal builder (from space group information)
The structure database is very convenient but by necessity incomplete. A more powerful approach is to build
3D crystals from the space group information. Here we give an example on how to build TiO2 (rutile) again,
now from its space group.
Open the crystal builder:
Click on the snowflake tool and select "From Space Group"
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And the following window pops up
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Rutile has the symmetry of space group 136
in the "Number" field, and press return (enter key on Windows).

103

Note how the Browser reflects the change and also how the "Name" and "Lattice" values change
Now set the two lattice parameters as below

We still need to define the atomic coordinates. For starters click on the plus below "Coordinates"

104

In a book on crystal structures you can find that rutile has two sites occupied. The Ti atom is on the "a" site
Select the Ti atom and select the "a" site

The oxygens occupy the "f" site.
Click on the plus to add a site
Change the atom type to "O" and the site to "f"

As you can see in the "Coords" column and the "Parameters" column, this site has an undetermined
parameter "x". (It represents a symmetry line for this space group.) In the book you can find that for TiO2
"x=0.3".
Set "x" to 0.3
The final dialog looks like
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Press "Apply" and if that looks any good press "Close"
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Slicer: building slabs
The slicer is a very easy, yet powerful tool to make slabs from any crystal structure.

A three layer slab of the Cu(111) surface
Select fcc from the "Cubic" crystals
The element and lattice constant are already correct for Cu.
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Press "OK" to generate the Cu lattice
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Let us invoke the slicer tool to cut out the slab. The slice tool icon looks like this:
Click on the slicer tool icon in the toolbar
The following dialog appears

Set the Miller indices to (1,1,1)
Select Cartesian
Set the number of layers to 3

The "Cartesian" option is needed because the Miller indices are usually (with cubic lattices) thought in the
conventional unit cell rather than the primitive (minimal) unit cell.
Press OK
After pressing OK you will see (from the top)
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You may want to rotate it or press the side view buttons in the toolbar to convince yourself that it is a three
layer slab.
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Enlarging the unit cell
Thus far, we have always created primitive unit cells: the smallest possible. Quite often you want to use a
larger, less symmetric unit cell. You can do this for chains, slabs, and crystals, but we will demonstrate how
it works for a slab.
We will continue to work with the 3-layer Cu slab:
Select the Edit → Crystal → Generate Super Cell... command
Thus invoking the Super Cell Tool
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Here you see how new lattice vectors are expressed in terms of old ones. Because we have a slab this is a
2x2 matrix.
Select the "sqrt(3) x sqrt(3)" option from the "Preset" menu

The matrix has now changed into 2,-1,-1,2.
Press OK
and you get a unit cell with three atoms per layer:
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Close ADFinput

Tutorial 4: Excitation energies and UV/Vis spectrum of ethene
First you will construct an ethene molecule and optimize its geometry. As this is basically the same
procedure as in Tutorial 1, only short instructions will be given.
Next you will set up the calculation of excitation energies, and let ADF perform the calculation.
Finally, using ADFlevels, ADFspectra and ADFview, you will examine the results.

Step 1: Start ADFinput
For this tutorial we again prefer to work in the Tutorial directory.
You know how to start ADFjobs (in your home directory), and move to the Tutorial directory:
cd $HOME
Start ADFjobs
Click on the Tutorial folder icon
Next start ADFinput using the SCM menu:
Select the SCM → New Input command
Note that if you start ADFinput via the SCM menu you will start ADFinput without loading a job. If you wish to
open ADFinput for a particular job, click on the 'ADF' button in front of it.
For the View command (and Movie, Levels, and so on) the behavior is different: it will immediately load the
job that is selected in ADFjobs.

Step 2: Create your ethene molecule
First we construct an ethene molecule, and pre-optimize its geometry:
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Select the C-tool by clicking on the button with the 'C'
Select the Double bond mode Bond tool → Double
(or use the shortcut: press the '2' - key)
Click somewhere in the drawing area to create a carbon atom
Click again to create a second carbon atom (with a double bond)
Click on the just created Carbon atom to stop bonding
Select the Atoms → Add Hydrogen command
Click the cog wheel to pre-optimize
Your ethene molecule should look something like this:

Step 3: Optimize the geometry
The next step is to optimize the geometry using ADF:
Enter a title in the Title field (like 'Ethene')
Select the 'Geometry Optimization' preset
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With the proper options selected, now run ADF:
Select the File → Run command
Click 'Yes' in the pop-up to save the current input
In the file select box, choose a name for your file
(for example 'ethene') and click 'Save'
Now ADF will start automatically, and you can follow the calculation using the logfile that is automatically
shown.
Wait until the optimization is ready (should take very little time)
The following dialog should appear:
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Click 'Yes' to update the coordinates

Step 4: Calculate the excitation energies
Select calculations options
To set up the calculation of the excitation spectrum:
Adjust the title to something like 'Ethene excitations'
Select the 'Single Point' preset
Use the panel bar Properties → Excitations, CD command to go to the Excitations
panel
For the 'Type of excitations' option, Select 'Singlet and Triplet'
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For the tutorial this set up is fine, normally you would also need to select an XC potential that gives better
results, for example SAOP.

Run the calculation
Now everything is ready to actually run ADF. Before running we will save the current input in a different file
(though this is not really required):
Select File → Save As...
Enter a filename (ethene-exci) and click 'Save'
Select File → Run
Wait for the calculation to finish

Step 5: Results of your calculation
Logfile: ADFtail
The logfile shows you that the calculation has finished, and that indeed the excitation code has been
running:
Select SCM → Logfile
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Energy levels: level diagram and DOS
Select SCM → Levels
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In this level diagram you can see that the HOMO and LUMO consist mainly of carbon p orbitals. It is also
easy to see what orbitals the hydrogens take part in.
Note that the carbon and hydrogen stacks show all carbon and hydrogen atoms at once: they show the
fragment type. ADFlevels can also show the individual fragments but when using atomic fragments you will
get too many fragments. In this particular case symmetry is used, and since there is only one symmetry
unique carbon atom and only one symmetry unique hydrogen atom you still would see only one stack per
atom type.
Select SCM → DOS
In the ADFdos window:
View → Add Graph
Select one hydrogen atom
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In these plots you can see that the partial DOS for the hydrogen atoms have no contribution to the HOMO.
By right clicking on an atom you can also show partial DOS graphs with contribution from selected atoms
and selected L-values only.

Excitation spectrum: ADFspectra
Select SCM → Spectra
ADFspectra will start and show the calculated excitation spectrum.

When moving the mouse above a peak a pop-up will give you more information about that peak:
Move the mouse above the largest peak and hold it there
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The composition of the excitation in terms of orbital transitions is listed in the pop-up. If you move the mouse
inside the pop-up and click on a line the corresponding orbitals will be shown using ADFview:
Move the mouse inside the pop-up and click on the line with the major
contribution

Close the two windows showing the orbitals using File → Close in both windows

Orbitals, orbital selection panel: ADFview
We will now use ADFview to examine the orbitals. Not just one, but have a look at many of them. To do that
ADFview has a simple method to make something similar to an 'orbital selection' panel: you can tear off the
orbital menus!
Select SCM → View
Select Properties → HOMO
Click on the field selector pull-down in the control bar for the HOMO (reading
SCF_B1.u 1: ...),
select Orbitals (occupied)> → 1 → - - - - - - - - (the dashed line)
The menu will tear off, place it at a convenient location
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Now you can just click on the different orbitals in the torn-off menu, and very quickly examine those orbitals:
Click on all of the orbitals in the torn-off menu, one by one, and observe the
orbitals
Click again on them
When you click the first time on an orbital, its values need to be calculated and then the orbital is shown.
When you click for a second time on an orbital in the list, it has already been calculated (indicated by the
check mark). And thus it shows immediately.
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Close the torn off menu by clicking in its close box
In the same way you can tear off many menus in the GUI, for example to select virtual orbitals. Not only in
the ADFview control bars, but also from the main menu bar. Anywhere you see the dashed menu line.
Close ADFview: File → Close

Transition density: ADFview
You can use ADFview to view orbitals etc, but also to have a look at the transition density. At this moment
ADFview cannot generate this field automatically, it needs to be calculated first using DENSF. The ADFinput
defaults are such that if you perform an excitation calculation, DENSF will automatically calculate the
corresponding transitions densities. So we will start ADFview and next load the .t41 file generated by
DENSF:
Select SCM → View
Select File → New
Select File → Open
In the file-select pop-up, choose to see all .t41 files using the pop-up menu
at the bottom
Select the .t41 file from your calculation (ethene-exci.t41)
Click 'Open'
Select Add → Isosurface: Double (+/-)
In the field pull-down menu (in the control line for the double isosurface) you will now find an entry 'Transition
Density', and if you select that you will find all transition densities that are available.
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In this case lets select the transition density that belongs to the biggest peak: the Singlet-Singlet 1B3u
excitation:
Select the Transition Density → TransDens_SS_B3.u_Fitdensity_1 field
Change the iso value to 0.003
Rotate the molecule a little
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The resolution is rather coarse, you can use interpolation to get a better picture. Changing the grid has no
effect in this case as you are visualizing a .t41 file, which is just data on a grid (in binary form).
Fields → Interpolated
Select the Transition Density → TransDens_SS_B3.u_Fitdensity_1 field in the I-1 line
In the Isosurface: Double line, change the field to I-1 (in the Other category
in the field selector)
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ADF Output
Using the output browser you can find all details about your excitation calculation. Use the menu to jump to
the relevant part of output:
Select SCM → Output
Select Response Properties → All Singlet-Singlet Excitation Energies
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KFBrowser
Most result of the calculation are saved to the KF result file (the .t21 file for an ADF calculation). As of
ADF2013 you can inspect the contents of KF files using the KFBrowser. The KFBrowser is a very recent
development, feedback and bug reports (there will be bugs ...) are welcome!
The KFBrowser gets the raw data out of the result file, and presents a selection of that might be of interest
for users. Over time more results will probably be added to newer versions of the KFBrowser.
It also gives access to all raw data in the result files. This feature is intended for developers only.
Select SCM → KFBrowser
In the KFBrowser window that appears:
Click on the arrow in front of Excitations
Click on the arrow in front of Energies (Hartee) (in the Excitations section)
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If you click on the name of the property you can select it. Next you can copy it, and paste it for example in
Excel:
Click on "Energies (Hartree)"
Copy (from the Edit menu or the usual shortcut)
Open Excel or some text editor
Paste
After pasting you should have your results nicely formatted in Excel or in some text document. Note that the
values are tab-separated, so pasting into Excel will automatically put the data (energies) in cells.
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In a similar way you can copy/paste other results. Or even all results:
In the KFBrowser window:
Edit → Select All
Edit → Copy
In the Excel or text editor window:
Paste
All results should be nicely formatted in your text document or spreadsheet:
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Another feature of the KFBrowser is that it can show results in simple graphs:
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Close the KFBrowser window
Open it again SCM → KFBrowser
Open the Charges section
Click on Mulliken (e)
Shift-click on MDC-Q (e)
Use the Graph → Selection As Graph command (or double click on the selection)
A window should appear that shows the selected results, charges in this case:

You can use the Graph style buttons to switch to different graph types (XY, Bars or Piechart).
Switch to the KFBrowser window
Open the Energies section
Select all energies (click on first, shift-click on last energy)
Double click on the selection
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Finally two features that are intended for developers and expert users: the KFBrowser module can also
show the raw data on the result file, and it can dump a KF file as a plain text file. To activate the expoert
mode, use the File → Expert Mode menu command. To save the contents of the result file as a text file
using the File → Save As ASCII... command.

Closing the ADF-GUI modules
To close all modules for your excitations calculation at once, use the Close command from the SCM menu:
Select SCM → Quit
Close will close all open modules that have your current job loaded, except ADFjobs. The Close All
command will close every ADF-GUI module, including ADFjobs:
Select SCM → Quit All
All ADF-GUI modules (and BAND-GUI modules if any) should be closed.

Tutorial 5: Vibrational frequencies and IR spectrum of ethane
Step 1: Start ADFinput
For this tutorial we again prefer to work in the Tutorial directory:
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cd $HOME
Start ADFjobs
Click on the Tutorial folder icon
Start ADFinput using the SCM menu

Step 2: Create your ethane molecule
Next we create an ethane molecule. This is almost identical to making ethanol:
Select the C-tool
Click once to make a carbon atom
Click again to make a second carbon atom
Select Atoms → Add Hydrogens
And do it again: ... add hydrogens
Click the pre-optimize button (the cog wheel)
Click the Symmetrize button (the button with the star, on the bottom toolbar)
You need to add hydrogen twice: the first time one carbon atom was selected. Thus, the 'Add Hydrogen'
command added the hydrogen to that selected atom only. By repeating the 'Add Hydrogen' command the
hydrogens are added in all possible places.
Alternatively, you can, after placing the second atom, click on that atom to finish using the C-tool. In this
case none of the carbon atoms will be selected and you can easily add all the hydrogens at the same time.
The symmetrization should have enforced perfect D3d symmetry, using the Symmol program. The Symmol
program has been developed by Pilati and Forni, see the balloon help on that button for details..

Step 3: Optimize the geometry
Now optimize the geometry using ADF, as in the second tutorial:
Enter a title (like 'Ethane')
Select the 'Geometry Optimization' preset
Select File → Run
Save your input with a nice name ('ethane')
Wait for the calculation to finish (check the logfile)
In the dialog that appears, click Yes to import the optimized geometry
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Step 4: Calculate the vibrational frequencies of ethane
Now we will set up and run the frequencies calculation. It is important to start with the optimized structure, so
make sure you did import the optimized coordinates (the last step of the previous instructions).
Select the 'Frequencies' preset
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For the tutorial we will use the default XC potential. For better results you should select a better XC
potential.
Select File → Run
Click 'OK' to save over the previous version
Click 'Yes' when ADFjobs warns that results are already present
Wait for the calculation to finish

Step 5: Results of your calculation
Logfile: ADFtail
When the calculation is finished the end of your logfile will look something like this:
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At the end ADF calculates the force constants for the vibrations.

IR-spectrum (vibrational spectrum): ADFspectra with normal mode selector and
ADFmovie
Select SCM → Spectra
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On the left side of the window the molecule (Ethane) is shown.
On the right side the IR spectrum is shown. You can save a picture (of the IR spectrum) to use in other
programs using the 'Save Postscript' command from the 'File' menu. Alternatively, you may export the xy
coordinates of the spectrum to a plain text file for you own graphing application.
If you move the mouse pointer above the spectrum you will get more information about the peaks in pop-up
windows:
Move the mouse pointer above the largest peak and keep it there
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The list of normal modes contributing to the IR peak will show up. By clicking the mouse button at this point,
the first of these modes will be showb by animating the ethane molecule on the left. Alternatively, pressing
and holding the mouse button down, a list of these modes with their symmetry labels will show up:
Press and hold down the mouse on the largest peak

Choosing one of the modes from the the pop-up list, you can visualize only the corresponding mode.
Select one of the modes in the pop-up menu (not the Show All)

The corresponding normal mode should be shown on the left.
To view another normal mode, most conveniently use the left and right arrow keys to move through them.
Alternatively, you can show another mode just as you showed the first mode (click on a peak, or use the
pop-up menu).
You can make the displacements larger or smaller via menu commands. Or, more conveniently, use the up
and down arrow keys on the keyboard. And you can show the normal mode as vectors:
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Use arrow up key repeatedly to make the displacements larger
Use arrow down key repeatedly to make the displacements smaller
Use the left and right arrow keys to switch between modes
Use the View → Displacement Vectors to visualize the normal mode with vectors

You can make the vectors larger or smaller using the same ctrl/cmd-L/K, or arrow up and down.
Another option is to show the normal mode in ADFmovie:
Use the View → Open Mode In ADFmovie
If you use the 'Show All' command from the pop-up list (instead of one specific mode) all modes in the popup list will be shown in ADFmovie windows.
If a mode is visible in ADFmovie you have some extra advanced options. For example, to make a mpg
movie showing the mode.
Sometimes you wish to examine many different normal modes. Obviously you can do this as just described,
but another way is by selecting the mode of interest from the menu. And to make it more convenient to
check many of them, you can tear off these menus, just as you did with the orbital selector menu in
ADFview.
In ADFspectra: File → Close, to close all normal modes that might be showing
Start ADFspectra again SCM → Spectra
Click on the E1u-1 menu, and select the dashed bar (- - - -), thus NOT one of
the modes
Position the torn off menu in a convenient location
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Click on each of the modes in the torn of menu in turn
Observe the movie windows showing the normal modes
We are done with this tutorial, so close all open ADF-GUI windows:
SCM → Quit All
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Advanced ADF-GUI tutorials
Tutorial 6: HCN Isomerization Reaction
This tutorial consists of several steps to study the isomerization reaction of HCN:
•
•
•
•
•
•

Geometry optimization
Linear transit
Quick frequency calculation
Transition state search
Accurate frequency calculation
IRC

Step 1: Prepare the HCN molecule
cd $HOME
Start ADFjobs
Click on the Tutorial folder icon
Start ADFinput using the SCM → New Input menu command
Draw an HCN molecule (first the N, next the C and finally an H atom)
Select the C-N bond and make it a triple-bond
Pre-optimize the geometry
You should get a linear molecule:

Select the "Geometry Optimization" preset
Select the DZP basis set
Select File → Run, give it the name HCN_GO
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The geometry will be optimized, using a DZP basis set.
Click "Yes" when asked to read new coordinates from the HCN_GO.t21 file
Check the C-N and C-H distances
They should be about 115 and 108 pm (1.15 and 1.08 Angstrom), respectively.
Write down the value of the bonding energy printed
at the end of the calculation in the ADFtail window

Step 2: Create a rough approximation for the transition state geometry
The HCN molecule has an CNH isomer. There is an energy barrier between these two states. We are going
to find the transition state and calculate its height.
To find a better starting point for the transition state search we will perform a linear transit calculation as a
rough approximation of the reaction path. We will vary the H-C-N angle in steps between 40 and 140
degrees and let ADF optimize bond lengths at each angle.
To set up the linear transit calculation:
Select the 'Linear Transit' preset
Click on the "..." button next to the GeometryOptimization task to go to the
'Geometry Constraints and Scan' panel
Select all the atoms
You should see '+ N(1) C(2) H(3) (angle)' note in the right panel now:
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Click the '+' button to add the angle constraint
Now '- N(1) C(2) H(3)' and the two fields as limits for the degree parameter appear.
Enter '140' and '40' in the 'degrees' fields

ADF will have trouble running the current set up because the HCN molecule is perfectly linear. So we will
help ADF by changing the angle to 140 degrees, the same as the first point of the LT scan.
Use the slider to change the HCN angle to 140 degrees
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The set up is complete. Now we will run the LT calculation, but we will save it with a new name as we wish
to keep the results of the HCN_GO calculation:
Use File → Save As to save the file as 'HCN_LT'
Run the calculation
Running might take a few minutes. When the run is finished:
Click "Yes" when asked to read new coordinates
You will see the last geometry, close to CNH. To see how geometry was changing during the LT run, use
ADFmovie:
Select the SCM → Movie command
Select all atoms (use shift-drag to make a rectangle around the atoms)
Use the View → Align Screen command to make sure you can see all atoms
Select the Graph → Energy command
Select the Graph → Distance, Angle, Dihedral command (to get the angle graph, as
three atoms are still selected)
Use the View → Converged Geometries Only command
Zoom in to get a better view of the molecule
Press the Play button (the right-pointing triangle in the controls at the left
bottom of the ADFmovie window)
You will see the hydrogen atom moving from C to N. You will also see a graph of the energy as function of
the LT steps. As the movie is playing a dot shows the corresponding position in the graph.
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Somewhere along the path, there is a transition state we are looking for. Remember that you needed to use
the 'Optimized Geometries Only' command to filter out all the intermediate geometry step, so that you get
only the converged geometries for each LT step.
In the graph, click (without moving!) on the top of the energy graph
Alternatively, use the arrow keys (cursor keys) to move between different
steps, or use the slider
Check which geometry has the maximum energy
You should find that at around an angle of 60-75 degrees the maximum energy is reached. This is Frame 6
(the 7th LT step):

You can find this information also in the output file:
Select the SCM → Output menu command
In the ADFoutput window select the Other Properties → 'LT Path command

You will see that indeed the geometry number 7 (corresponding to Frame 6 in ADFmovie) has the highest
energy. In this particular example the choice of the angle is not very important, but in general you will always
want to get the best approximation for the transition state available.
We will now prepare the search for the transition state starting from this geometry:
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Click in the ADFmovie window
Make sure frame 6 is selected
Use the File → Update Geometry In Input command
The geometry of HCN in your ADFinput window will be updated to match the geometry currently selected in
the ADFmovie window:

Step 3: Finding the transition state: prepare approximate Hessian
In general, it is important to have a good starting Hessian with one imaginary frequency when performing a
TS search. We are going to create such a Hessian by doing a quick frequencies calculation:
Select the "Frequencies" preset (from the Main panel)
Make sure the integration method is set to 'Becke'
Select the 'Geometry Constraints and Scan' panel (via the ... button or via
the panel bar)
Remove the Angle Constraint: click on the '-' in front of the angle constraint
Save the molecule with as 'HCN_Freq1' (Save As)
Run the calculation
The frequency calculation is now in progress and will run very fast. When it has finished:
Select the SCM → Spectra command
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If everything was done correctly, you should see a spectrum with three peaks: two in the range of 2000 3000 1/cm and one peak in the range of negative or very low positive values. A negative frequency value
actually means that it is an imaginary frequency.
Click with your mouse on the peak corresponding to the imaginary frequency
The normal mode corresponding to that frequency will show on the left side. Check that the frequency
indeed corresponds to the H atom moving parallel to the C-N bond.

Step 4: Search for the transition state
The result file, HCN_Freq1.t21, has an initial geometry for our transition state search. It also contains a
Hessian matrix (produced with the frequencies calculation) that can be used to kick-start the TS procedure.
Bring ADFinput with the HCN_Freq1 calculation to the foreground
Select the 'Transition State Search' preset
ctrl/cmd-F and search for 'restart', select the 'Files (Restart)' panel
Click the file select button (looks like a folder) in front of the empty
'Restart file:' field
Select the HCN_Freq1.t21 file and click 'Open':
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Save the set up as HCN_TS (Save As)
Run the calculation
After the calculation has finished (again very fast), you will be asked to read the new geometry from the
results file HCN_TS.t21:
Answer "Yes" to import the latest geometry
Make a note of the bond energy for the transition state (visible in the
logfile)
ADFinput will now display the transition state geometry.
If you compare the bond energy with the bond energy of the optimized HCN molecule from the first
calculation, the difference should be about 1.9 eV. Also check that the geometry makes sense: the C-H and
C-N distances should be around 1.20 and 1.19 Angstrom and the H-C-N angle should be about 70 degrees.

Step 5: Calculating frequencies at the transition state
After every transition state search it is good practice to verify that you indeed have one and only one
imaginary frequency. For this we will repeat the frequency calculation at the TS geometry:
Make sure you have HCN_TS open in ADFinput
Select the "Frequencies" preset (from the 'Main' panel)
Save with name HCN_Freq2
Run
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The calculation is running, should not take much time. After the calculation has finished:
Select the SCM → Spectra command
You will be presented with an IR spectrum of the molecule featuring three bands roughly located at 2550,
2050, and (imaginary) -1040 1/cm.

Click on the band at -1040
The visualization of the normal mode corresponding to this frequency should make it clear that this is indeed
the reaction coordinate we are studying.

Step 6: Following the reaction coordinate
ADF can follow the minimum-energy path from the transition state to one or the other product. The method
used in ADF for this is called Intrinsic Reaction Coordinate (IRC). You may want to skip this part as the
calculation might take some time to complete.
Bring HCN_Freq2 in ADFinput to the front
Select the "IRC" preset
Go to the 'Intrinsic Reaction Coordinate (IRC)' panel (in Model, or via the
search, or by clicking on the '...' button)
This panel allows you to specify various parameters for the IRC method. The most important parameter is
the direction to follow. The choice is more or less arbitrary. By choosing "Forward path" or "Backward path"
will lead you to one or the other product but it's hard to tell which of the two in what case. We will calculate
both paths at once, so we do not need to change the default.
Save as HCN_IRC
Run
After some minutes the calculation will finish. You can use ADFmovie to view the IRC path. Of course you
need again to make sure to show the converged geometries only:
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Select the SCM → Movie command
Select the View → Converged Geometries Only command
Click OK when the warning message appears (about the changed order of steps)
Select the Graph → Energy command
Select all atoms
Select the Graph → Distance, Angle, Dihedral command

From this movie you can see the IRC path, and the energies at the most interesting points. As we have
calculated the forward and backward path in one run, the order of the forward path needs to be reversed to
get a proper energy graph.
You can also examine some properties along the IRC path by studying the output file:
Select SCM → Output (this might take a while, be patient)
Use the Other Properties → IRC Path menu command
You will see a table with the properties along the forward path. To get the backwards path:
Click on the blue header 'Dist from TS ...'
The output browser should jump to the next section with that header, which is the table for the backward IRC
path.
Finally, at the end of this tutorial you will have many open windows. To close all ADF-GUI related windows
at once, you may use the SCM → Quit All command.

Tutorial 7: TlH (thallium hydride) Spin-Orbit Coupling
This tutorial consists of several steps:
• TlH spin-orbit fragment analysis
• Separate calculations for Tl and H
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• Visualization of the energy diagram
• Visualization of spinors
• Calculate the atomization energy

Step 1: Prepare molecule
First create a TlH (thallium hydride) molecule with a bond length of 1.87 Angstrom (the experimental bond
length):
Open ADFinput and draw a TlH molecule.
Select the Tl and H atoms
Use the slider to set the distance between the atoms 1.87 Angstrom

Step 2: Set calculation options
Next we will set up the calculation. The following details need to be set:
Clear the selection (click in empty drawing space)
Set the title to 'TlH spin-orbit coupled'
Select the GGA → BP as XC potential in SCF
Select the 'Spin-Orbit' relativistic option
Select the basis set 'TZ2P'
Set Frozen core to 'None'
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The Main panel will now look like:

We are going to perform a fragment analysis as a trick to get a diagram that makes it very easy to compare
scalar and spin-orbit relativistic results.
Fragment calculations are based on regions, which are just collections of atoms. So we start by making a
region:
Select both atoms
Use the panel bar Model → Regions command
Click the '+' button to add a new region
Change the name of the new region (Region 1) to TlH_SR
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You have now defined a region containing all atoms, with name TlH_SR.
Use the panel bar Multilevel → Fragments menu command
Click the 'Use fragments' check box

Step 3: Run your calculation
Use the File → Save menu command
Enter the name 'TlH_SO' in the 'Filename' field
Click 'Save'
Now you have saved your current options and molecule information.
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As we have set up a fragment calculation, also the .adf and .run files for the fragment have been saved. Lets
study what options are used for the fragment in ADFinput:
Make sure the 'Fragments' panel is still the current panel
Click on the 'Open' button (the dot) for the TlH_SR fragment
A new ADFinput window will also appear with the name 'ADFinput: TlH_SO.TlH_SR.adf'. This is the name of
the molecule, a dot, and the name of the fragment. The fragment should have the 'Scalar' relativistic option
selected, as that is required when the results will be used as a fragment. The other options are identical to
what you set for the main molecule.
Now close this ADFinput window:
Select the ADFinput window with the name 'ADFinput: TlH_SO.TlH_SR.adf'
Select File → Close
We are now ready to run the calculation:
Select the ADFinput window with the name 'TlH_SO.adf.
Select File → Run
Now two calculations will run: first the building fragment (using the scalar relativistic option), and next the
version including spin-orbit coupling. You will see the two logfiles. Wait until both calculations have finished:
Wait until ADFtail shows 'Job ... has finished' as last line
Select File → Close
Repeat for the second ADFtail, thus closing both logfiles

Step 4: Results of the calculation
TlH energy diagram
To see the effect of the spin-orbit coupling we will first look at the energy level diagram:
Select the ADFinput window with the name 'TlH_SO.adf.
SCM → Levels
Select View → Labels → Show
Press and hold the Right mouse button on the stack name 'TlH_SO',
Click on 'Zoom HOMO-9 .. LUMO+9'.
Next try to zoom using a drag with the right mouse button, or using the scroll
wheel.
Do this such that only levels between -0.1 and -0.7 eV are shown.
You can move the levels vertically by dragging with the left mouse button.
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You can see that the spin-orbit coupling is important to split energy levels.
Especially for the Tl core levels the spin-orbit coupling is more important than the ligand field splitting.
Compare the 8pi, 13sigma, 4delta orbitals (close to 5d atomic Tl orbitals) with the 11j3/2, 20j1/2 spinors
(close to 5d3/2 atomic Tl spinors) and 5j5/2, 12j3/2, and 21j1/2 spinors (close to 5d5/2 atomic Tl spinors).
If you press and hold the right mouse button on one of the levels, you can select a spinor. That spinor will be
shown. You can also show all spinors (in the case of a degenerate level) at once.
The energy diagram of the scalar relativistic fragment calculation shows the atomic contributions to the
scalar relativistic levels.
Bring ADFjobs to the front
Select the TlH_SO.TlH_SR job (the scalar relativistic fragment)
Use the SCM → levels command
Select View → Labels → Show
Press and hold the Right mouse button on the stack name 'TlH_SO.TlH_SR',
Click on 'Zoom HOMO-4 .. LUMO+4'.
Next zoom and move the levels using a right mouse drag and or scroll wheel.
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Visualization of spinors
Visualization of spinors is conceptually more difficult than visualization of orbitals.
A spinor Ψ is a two-component complex wave function, which can be described with four real functions φ:
real part α φαR, imaginary part α φαI, real part β φβR, imaginary part β φβI:

Ψ=(

φ αR + i φ αI
φ βR + i φ βI

)

The density ρ is:
ρ = Ψ† Ψ
The spin magnetization density m is:
m = Ψ† σ Ψ
where σ is the vector of the Pauli spin matrices. A spinor is fully determined by the spin magnetization
density and a phase factor eiθ, which both are functions of spatial coordinates.
In ADFview one can visualize the (square root of the) density and spin magnetization density, however, the
phase factor eiθ is summarized only with a plus or minus sign.
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For this tutorial we have a small molecule, and a fine grid is chosen for better visualization.
Select
Select
Rotate
Select
Select

the ADFinput window with the name 'TlH_SO.adf.
SCM → View
the molecule, such that one can see both atoms.
Fields → Grid → Fine
Add → Spinor: Spin Magnetization Density

In the new control line at the bottom, use the field select pull-down menu and
Select Orbitals (occupied) → 3 → SCF_J1/2:1 22: 1.0 ....

The arrows in this picture are in the direction of the spin magnetization density m. All arrows are
approximately in the same direction, which means that this spinor is an eigenfunction of spin in this direction
of the arrows. In fact this 22 j1/2 spinor is almost a pure α orbital. The arrows are drawn starting from points
in space where the square root of the density is 0.03. The color of the arrows is red or blue by default,
indicating minus or plus for the phase factor eiθ.
The (square root of the) density and the approximate phase vector eiθ can also be viewed separately:
Select Add → 'Isosurface: Double (+/-)
Select Orbitals (occupied) → 3 → 'SCF_J1/2:1 18: 1.0 ..
Hide the spinor (uncheck the check box at the left of the Spinor label)
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This spinor 18j1/2 is almost a pure 5p1/2 Tl spinor. A p1/2 atomic orbital has a spherical atomic density, but
a spin magnetization density which is not the same in each point in space.
In the control line with 'Spinor', press on the pull-down menu and
Select Orbitals (occupied) → 3 → SCF_J1/2:1 18: 1.0 ...
Show the 'Spinor' (check the left check box for the spinor line)
Hide the 'Double Isosurface' (uncheck the left check box for the double iso
line)
Hide the atoms: View → Molecule → Sticks
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Step 5: Calculate the atomization energy including spin-orbit coupling
The calculation of the atomization energy is not a simple problem in DFT. Spin-orbit coupling is an extra
complication. In this paragraph a way is presented how to calculate the atomization energy using spinpolarized calculations in the non-collinear approximation.
If you wish, you can skip the rest of this tutorial.

The Tl atom
To calculate an atomization energy we need to calculate the atoms also including spin-orbit coupling. The
easiest way is to start with the TlH_SO.adf file and change this to an atomic file.
Since the Tl atom is an open shell atom for an (accurate) atomization energy we need to do an unrestricted
calculation. The best theoretical method is the non-collinear method. Note that the 'Spin polarization' field is
not used in the non-collinear method.
Select the ADFinput window with the name 'TlH_SO.adf
Delete the H atom (select it and press the backspace key)
Use the panel barMultilevel → Fragments command
Uncheck the 'Use fragments' option
Use the panel barModel → Regions command
Remove the TlH_SR region (click on the - button in front of it)
Select 'Main' panel
Enter the name 'Tl spin-orbit coupled' in the 'Title' Menu'
Check the 'Unrestricted:' box
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Select the Relativity panel (search for relativity)
Select 'NonCollinear' from the 'Unrestricted Options' Menu
Select File → Save As
Enter the name 'Tl_SO' in the 'FileName' field
Click on 'Save'
Click OK to acknowledge the warning about fractional occupation numbers

Now we want to actually perform the calculation for the Tl atom
Run the calculation: File → Run
Wait until ADFtail shows 'Job ... has finished' as last line
In the window showing the logfile (the ADFtail window Tl_SO.logfile):
Select File → Close

The H atom
Basically we can follow the same steps as for the Tl atom, but in this case we will start with Tl_SO.adf file
and change this.
Select the ADFinput window with the name 'Tl_SO.adf
Select the 'Main' panel
Enter the name 'H spin-orbit coupled' in the 'Title' field
Select the Tl atom
Use the Atoms → Change Atom Type → H
Select File → Save As...
Enter the name 'H_SO' in the 'Filename' field
Click on 'Save'
Select File → Run
Wait until ADFtail shows 'Job ... has finished' as last line
In the window showing the logfile (the ADFtail window H_SO.logfile):
Select File → Close
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TlH atomization energy
The atomization energy including spin-orbit coupling is a combination of several terms.
Select the ADFinput window with the name 'TlH_SO.adf.
Select SCM → Logfile
Write down the value of the bonding energy printed at
calculation in the
ADFtail window. (should be around -1038.62 eV)
Select File → Open
Select the file 'TlH_SO.TlH_SR.logfile'
Write down the value of the bonding energy printed at
calculation in the
ADFtail window. (should be around -3.84 eV)
Select File → Open
Select the file 'Tl_SO.logfile'
Write down the value of the bonding energy printed at
calculation in the
ADFtail window. (should be around -1039.32 eV)
Select File → Open
Select the file 'H_SO.logfile'
Write down the value of the bonding energy printed at
calculation in the
ADFtail window. (should be around -0.95 eV)

the end of the

the end of the

the end of the

the end of the

The atomization energy including spin-orbit coupling is in this case, the bond energy printed in the
TlH_SO.logfile plus the the bond energy printed in the TlH_SO.TlH_SR.logfile minus the bond energy
printed in the Tl_SO.logfile minus the the bond energy printed in the H_SO.logfile. (approximately -1038.62 3.84 + 1039.32 + 0.95 = -2.19 eV, experimental number is close to -2.06 eV.)

Tutorial 8: Multi-Level principles: Regions, QUILD and QMMM
In this tutorial the basic concepts of setting up multi-level calculations in the ADF-GUI will be demonstrated.
In most cases one would use a multi-level method for big systems: handle the full system with a fast
method, and use ADF to study a particular region of interest with more detail. As big systems will take too
much time for a tutorial, the concepts will be shown with very small toy systems that are not typical
applications.

Step 1: Regions
For all multi-level calculations you will need to define regions.
Within ADFinput, a region is a collection of atoms. You manage your regions with the 'Regions' panel in
ADFinput. It allows you to define new regions, modify existing regions, and to apply some commands on
particular regions.
As a first example, we will work with an acetone molecule (CH3COCH3) to demonstrate how to use QUILD.

Generate regions
Start ADFinput, and build an Acetone molecule (or search for it ...)
Select one of the methyl groups
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Use the panel bar Model → Regions command
Click on the '+' button to add a new region
Change the name 'Region_1' into 'Methyl' (the label is editable)

You have just defined a new region, with a name 'Methyl'. In your molecule window you can see what atoms
are part of this region: they are highlighted with semi-transparent spheres. Note that there are now (at least)
two regions define: the region that you defined, and a region called 'All' that is always present. Obviously,
the All region includes all atoms. If you created the acetone molecule via the search command, you may
have a third region that was automatically made.
Now we will define yet another region: the rest of the molecule. One way to do this is just to select the atoms
that should be part of it, and pressing the '+' button as you did before. However, to demonstrate some of the
things you can do with regions we will do it in another way:
Make sure you have only the All and the Methyl region; if you have more, press
the '-' button in front of the region
Click the check button in the 'All' region
Click the '+' button to create a new region, as you did before
Click the check button in the 'Methyl' region
Click the '-' button in the 'Region_2' line, on the right-hand side
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Basically, what you just did: select all atoms, make a new region containing all atoms, select the atoms in
the Methyl region, remove the selected atoms from the new region. By clicking on the select buttons in the
regions you can easily verify that your regions are now as they should be.

Visualization options per region
You can easily change what regions, and atoms within that region look like:
Click in empty (drawing) space to clear the selection
Click in the check box in front of the 'Methyl' region name to uncheck it
You should observe that the ghost-like region visualization disappears. Please turn it back on:
Click in the check box in front of the 'Methyl' region name to check it
Click on the right arrow at the end of the 'Region_2' line,
and use the 'Sticks' command from the menu that appears
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Now anything in 'Region_2' will be visualized as sticks only. Obviously you could also select any of the other
display options.

Step 2: QUILD
Once you have defined your regions, it is easy to set up the QUILD calculation:
Use the panel bar ADF → Quild menu to select the Quild panel
Click the '+' button to add an action
Click the '+' button to add a second action
In the first action, select DFTB in the 'Use' field
In the second action, select ADF in the 'Use' field
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The first action ('Total') defines what to do with the full molecule. It normally will apply to the entire molecule,
and thus the 'All' region is preselected. In the 'Use' field you have specified how to treat the whole molecule:
with DFTB.
The second action ('Replace') tells QUILD to replace the DFTB result for the selected region with results
from another method. The region for which we want to do this is the 'Methyl' region, and it happens to be
automatically selected. You can use the region pull-down menu will to select another region, and it offers
you a short-cut to make a new region.
In the 'Use' field of the second action you have selected what to use as a replacement method: ADF.
In the 'Remove' field it should be specified that you wish to remove the DFTB results for this region.
ADFinput will enter this automatically when you save your job. You can also set it manually if you wish.
The Quild panel offers you to set some details for the QUILD calculation. Normally the defaults should work
fine.
Save your set up
Four tabs can be found at the bottom of the Quild panel: 'Quild', 'DFTB 1', 'ADF 1' and 'DFTB 2'. These tabs
allow you to set up the different parts of the calculation. Right now you could make adjustments of the global
QUILD settings. If you press on the 'ADF 1' tab, you will have the option to set the details of the ADF
calculation (for the 'Methyl' region). And if you click on the 'DFTB 1' tab you can set up details of the DFTB
part of the calculation. The 'DFTB 2' tab is the DFTB calculation on the 'Methyl' group that will be removed
from the full system. Normally the set up for this calculation is identical to the full system (DFTB 1), but in
some special cases you will need to modify it. See the QUILD manual for details.
Click on the 'ADF 1' tab
Look through the different panels, to see what options ADF will use. Do NOT
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make changes!
Click on the 'DFTB 1' tab
Click on the 'DFTB 2' tab
Click on the 'Quild' tab
Now let's run this calculation:
File → Run
Click 'No' when asked to update the geometry
When your calculation is finished you can view the resulting optimization using ADFmovie:
Use the SCM → Movie command
Add a graph: Graph → Energy
Add a second graph: Graph → Add Graph
Show the energy of the ADF-subsystem on the second graph:
Graph → Quild Energies → job 2 : ADF ...

You can also open the output file using the SCM → Output command. The other visualization tools can not
be applied to the full QUILD results, but they can be used to examine the result of the ADF calculation (on
the Methyl region). This is done in quildjob.2:
Show the ADFjobs window
Show the QUILD job details (click on the triangle to show the details)
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Using the View menu command you will try to open the .t21 result file for the QUILD job. That will not work,
we need to view only the .t21 file of the adf sub-system. To do this, we first open this result file in the
KFBrowser. This tool allows you to inspect details of the binary KF files. Next, use the View command in the
SCM menu of the KFBrowser to open that specific file in ADFview:
Double-click on the .results/quildjob.2.t21 file
In the KFBrowser window, SCM → View
In the ADFview window Remove and Guess bonds (this is a work-around a bug that
messes up the bond display)
Visualize the HOMO in ADFview
Click on the Isosurface:Double pull-down menu and use the Show Details command
Change the Opacity to 70
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Note that QUILD has added a dummy hydrogen to cap the broken bond.
In the ADFview window, use the SCM → Levels command
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Now you have the ADF result file for the methyl group visible in ADFview and ADFlevels. With ADFview and
ADFlevels you can examine the ADF results as usual.
SCM → Quit All

Step 3: QMMM
Generate ethanol in water
To demonstrate how to set up a QUILD calculation using ADFinput, we will use ethanol in water as an
example. This will also show you how to add explicit solvent molecules to your system:
Start ADFinput
Build an ethanol molecule
Pre-optimize the structure
Use the panel bar Model → Solvation command
Click on 'Explicit Solvent Molecules'
Change the radius of the solvent sphere to a small value,
such that 10 solvent molecules will be generated
Click on 'Add Solvent'
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As you can see, ADFinput has generated 10 water molecules around your ethanol molecule. It also has
created two regions: a Solute region containing the ethanol molecule, and a Solvent region containing the
water molecules. The visualization option for the Solvent region is such that the water molecules will only be
shown using a Wire-frame representation.

Set up the QM/MM calculation
The next step is to set up the QM/MM calculation:
ADF → QMMM: select the 'QMMM' panel
Select the 'Solute' region in the 'QM Region' pull-down menu
Change the QMMM Task to GeometryOptimization
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Now you will have three tabs: the main QMMM tab that allows you to set QMMM details, the 'ADF 1' tab that
is the setup for the ADF calculation for the Solute subsystem, and the 'MM 5' tab that sets up the MM
calculation for the full system.
ADFinput is currently not very smart in setting the proper atom types for a MM calculation. So you will need
to examine the atom types as they are generated in the MM input, and fix them if they are not correct. To fix
this, if needed, use the Atom Inspector panel to set the Tripos (or Amber) atom types as needed.
Click on the 'MM 5' tab
Activate the 'Run Script' panel (in the panel bar Details)
Check the atom types (in the run script)

Run the QMMM calculation, and see results
Run your calculation File → Run
Show the optimization movie:
In the ADFinput window: SCM → Movie
Graph → Energy
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Note that ADFmovie (and the other GUI modules) will only show the results for the QM part of your
calculation.
To get detailed information on your QMMM calculation, you can check the output file using the SCM →
Output command.

Tutorial 9: ADF Fragment Analysis
This tutorial will show you how to use the Fragment Analysis within ADF. The two examples used here are:
• Ni(CO)4
• PtCl4H22You will set up the calculations, run them, and visualize the results.
The resulting ADFinput input file (*.adf) is available in the examples directory included in the ADF
distribution. In the examples documentation you can read how to set up a similar calculation without
ADFinput.
The first example in this tutorial is Ni(CO)4. It consists of one Ni fragment and once CO fragment that is
repeated four times.
The second example is PtCl4H22-. It consists of a PtCl42- fragment, and one H2 fragment. It is a good
example on how to specify the charges of the fragments.

Step 1: Build Ni(CO)4
The structure is perfectly tetrahedral. You should be able to build the molecule yourself, using the
techniques described in earlier tutorials. One possible way:
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Start ADFinput
Build a tetrahedral metal complex: Structure Tool → Metal Complexes → ML4 tetrahedral
Change the central atom into a Ni atom
Select one ligand
Select all ligands: Select → Select Atoms Of Same Type menu command
Change them in CO ligands: Atoms → Replace By Structure → Ligands → CO
Choose the 'Geometry Optimization' Preset
Save and Run
When the run has finished, click 'Yes' to import the optimized coordinates
Save
Your molecule should look something like this:

Step 2: Define fragments
The fragments that ADF uses are based on the regions that you define. In this example we will generate four
new regions: one for each of the CO ligands. The regions for the CO ligands will get special names to make
sure that ADF recognizes them as one fragment repeated four times.
The Ni atom will not be in a region. ADFinput will automatically create atomic fragments for all atoms not in a
region.
Repeated fragments are indicated with the fragment name followed by '/n', with n the number of the copy. All
copies must match such that one fragment can be positioned exactly over another fragment by rotation and
translation. ADF checks for this, ADFinput does not. In this particular example all four CO fragments are
obviously identical by symmetry.
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Panel bar Model → Regions
Select all atoms
Click the '+' button to add another new region (containing all atoms)
Select the Ni atom
Remove the Ni atom from Region_1: click the '-' button on the right side of
the 'Region_1'
Change the name of 'Region_1' into 'CO'
Now one new region has been defined: the CO region for the ligands. The next step is to split the ligand
region into four repeated regions:
Press the triangle on the right side of the CO region line
In the pop-up menu, use the 'Split By Molecule' command
This should result in the following regions:

Step 3: set up the fragment analysis run
The next step is very easy: we will tell ADF to perform a Single Point calculation (fragment analysis in ADF
only works with a single point calculation), and we tell ADFinput to use the regions that we just defined as
fragments:
Open the 'Main' panel
Select the 'Single Point' preset
Panel bar MultiLevel → Fragments
Check the 'Use fragments' check box
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Instead you could also select the 'Fragment Analysis' preset, which is identical to the Single Point preset but
with 'Use fragments' activated.

In the Fragments panel you will see that one fragment is present, without charge: the repeated CO fragment.
ADF will use basic atomic atoms for any atoms not put in another fragment. Thus, the Ni atom will be an
atomic fragment.

Step 4: Run the fragment analysis and view the results
Next you will Save and Run the calculation. When you do this, ADFinput will actually save two different
calculations:
• The CO calculation (with matching .adf and .run file)
• The Ni(CO)4 fragment analysis calculation (with matching .adf and .run file)
You do not need to set up a separate ADF calculation for the CO fragment: when you run the fragment
analysis calculation, the run script will detect that the individual fragments first need to be calculated. It does
so automatically. Next, the fragment analysis calculation will run.
Save
Run
Observe the running of the fragment (CO), and the final fragment analysis
The CO-fragment and Ni(CO)4 calculations all have been performed.
This calculation results in the normal .t21 and .out output files. You can view them with the SCM → View
and SCM → Output commands. More interesting in the case of a fragment analysis is the interaction
diagram that you can view using ADFlevels:
In the still open ADFinput window: use the SCM → Levels command
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In the center you see the levels of the whole molecule, on the sides you see the CO fragment and the Niatom fragment. The interaction lines tell you which molecular orbitals come from which fragment orbitals.
In the output file you can find detailed information about the composition of the molecular levels in terms of
the fragment orbitals.

Step 5: Build PtCl4H22The following is a picture of the PtCl4H22- molecule, after optimization with ADF:
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To make this molecule, an easy way is to start with an octahedral complex to ensure symmetry. Next make
changes to get this molecule, ending with a geometry optimization with ADF:
Build an octahedral metal complex using the Structures button
(Structure Tool → Metal Complexes → ML6 octahedral)
Change the central atom into a Pt atom
Change four dummies in a plane into Cl atoms
Remove one of the remaining dummies
Change the remaining dummy in OH, via Structure Tool → Ligands → OH
(this will ensure the final two H's do not break symmetry)
Change the O atom into an H atom
Choose the 'Geometry Optimization' Preset
Set the total charge to -2
Select the Scalar ZORA relativistic option
Run
When the run has finished, click 'Yes' to import the optimized coordinates
Save
Note that pre-optimization using UFF will make the geometry worse, if you wish you can pre-optimize using
Mopac. But the ADF geometry optimization will also converge without pre-optimization.

Step 6: Define fragments
Define the PtCl42- and H2 fragments in the Regions panel:
Panel bar Model → Regions
Select the Pt and Cl atoms
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Use the '+' button to add a new region, and name it 'PtCl4'
Select the two H atoms
Use the '+' button to add a new region, and name it 'H2'
Clear the atom selection (click in empty space)

Now the fragments are defined. Next, we set up the fragment analysis calculation:
Select 'Main' panel
Select the 'Fragment Analysis' preset
Panel bar MultiLevel → Fragments
Change the charge of the PtCl4 fragment to -2
Save
The other changes (the overall molecule charge, and the scalar ZORA option) have already been set
previously. The Fragment Analysis preset does not change these.
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When you click on the Open button (the big dot) next to the PtCl4 fragment, you can inspect the PtCl4
fragment setup:
Click on the Open button (the big dot next to the PtCl4 fragment) in the
'Fragments' panel
Check the charge of the fragment in the newly opened ADFinput (should be -2)
Close the PtCl4 fragment ADFinput window
For more complex calculations, you could make additional changes to your fragment runs. However,
normally the set up as created by ADFinput should be fine.

Step 7: Run the fragment analysis and view the results
Next you will Run the calculation:
Run
After the calculation has finished, you can view the resulting interaction diagram:
Use the SCM → Levels command
Use the mouse (drag with left mouse, scroll wheel, drag with right mouse)
zoom in on the interesting region (roughly from -0.5 to 0.4)
Select the PtCl4H2 column (by clicking on the name at the bottom
Use the View → Interactions → Show menu command
With the pop-up menu in the H2 column, shift the H2 levels by +0.28
Only interactions between visible levels are shown. So, if you zoom out no interactions will be visible for
some of the levels. That is the reason that you will need to use the Show Interactions menu command.
We needed to shift the H2 levels to accommodate that in the final molecule the fragment experiences the -2
charge, but this is absent from the H2 fragment calculation. The interaction diagram should look something
like the following:
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In the output file you can find detailed information about the composition of the molecular levels in terms of
the fragment orbitals.

Tutorial 10: Basis Set Effects for NH3 (ammonia) Geometry
This tutorial will help you to:
•
•
•
•

pre-optimize structures using different methods, including MOPAC
starting from an existing .adf file, create a batch of similar jobs using the Prepare tool in ADFjobs
interactively submit a set of jobs using ADFjobs
using the Report tool in ADFjobs, analyze results of multiple calculations at once

Step 1: Create and pre-optimize your molecule
Start ADFinput
Create an N atom
Press Esc, and click in empty space so that nothing is selected.
Create an H atom, not too far away
Press Esc, and click in empty space so that nothing is selected.
Add 2 more hydrogen atoms this way.
You should see one nitrogen and three hydrogen atoms in the drawing area now. We intentionally did not
add bonds between the N and H atoms!
First we will try to optimize this structure using the default pre-optimizer (UFF):
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Click 'Pre-optimize' cog wheel button
Using the default pre-optimization algorithm will lead to a structure with way to big N-H distances:

Next we will try to optimize using Mopac.
Undo the previous optimization: Edit → Undo
Right-click on the cog-wheel, select Mopac to pre-optimize
The message 'MOPAC ready' will be displayed in the ADFinput window:
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Mopac will produce a good-looking pyramidal ammonia molecule, with the N-H bond length of about 1.0
Angstrom.
Additionally, it will create proper N-H covalent bonding! These bonds are based on the bond-orders as
calculated by Mopac.

Step 2: Set up a single ADF calculation
Now with our pre-optimized NH3 molecule, we will set up a series of calculation: the optimization of NH3 with
ADF, using different basis sets. The first step is to set up a simple geometry optimization:
Select the 'Main' panel
Select the 'Geometry Optimization' preset
Save as NH3
We have used all defaults for basis set and so on.
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Step 3: Set up a batch of ADF jobs
Next we will set up a series of calculations, using the Prepare tool.
Select the ADFjobs window
In ADFjobs window, locate the 'NH3' job saved earlier
Click onto 'NH3' line to select it
Use the Tools → Prepare... command

The Prepare dialog window will pop up.
Because we have selected the NH3 job earlier, NH3.adf filename (including the path) will show up in the
'Run' field (otherwise, we can select NH3 using '+' button of the 'Run' field). This means we are going to
create jobs that are identical to the NH3 job, but with some details changed (this will next be specified in the
Prepare dialog).
Go to the 'Use these input options' and click '+'
Choose 'Basis Set and Frozen Core' → 'SZ' → 'Large'
In the similar manner, add basis sets 'DZ', 'DZP', 'TZP',
.. (optionally 'TZ2P' and 'QZ4P')
Use core 'Large' for all the basis sets
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The basis set options selected will show up in the 'Use these input options' field. Note that by default the
jobs will be created in the 'autojobs' directory, as specified in the 'Produce jobs' section.
Now click 'OK' in the Prepare window
The Prepare dialog will close and ADFjobs will open the 'autojobs' directory. Using NH3.adf, the Prepare tool
created a set of jobs inside 'autojobs' named as 'NH3.SZ.Large.adf', 'NH3.DZ.Large.adf' etc. The files
naming intuitively follows the basis set options which has been used, and the rest of the options of the newly
created files are exactly the same as in NH3.adf. The original NH3.adf file has not been altered.
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Step 4: Run your set of ADF jobs
Now we are going to run the batch of ADF jobs which has been automatically prepared in the previous Step
3 of the tutorial Using ADFjobs, one can either run this set of jobs one by one, or all at once.
Click on the first job
Shift-Click on the last job
Run the jobs Job → Run
This will run the jobs in the default queue. Normally this is the Sequential queue, and the jobs will actually
run one after another.
The jobs will start running and their progress can be tracked in ADFjobs. Each ammonia optimization job
should not take more than a few minutes.

Step 5: Analyze results of several calculations at once
When all the ammonia optimization jobs are finished, we can compare the results. The main conclusion that
you will reach is that DZ (double zeta) basis set optimization, job name 'NH3.DZ.Large', leads to the
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incorrect planar ammonia molecule. As covered in the preceding tutorials, you can optionally use several
GUI modules to observe that:
- ADFmovie, which will show the geometry optimization
- ADFinput, which will open the (last) converged geometry
- ADFview, which will open the converged geometry and also would display various density maps in 3D
For example, let us use ADFview to demonstrate the results:
Clear the selection in ADFjobs (press Esc)
Select job NH3.DZ.Large in the ADFjobs window (should then be highlighted)
Select SCM → View
Select Fields → Grid → Fine
Select Properties → HOMO
In the isosurface contour value field which appeared at the bottom,
change the default '0.03' to '0.3'
Type 'ctrl/cmd-minus' several times, until the central N atom ball
does not overlap strongly with the HOMO orbital.
Repeat for this for the DZP calculation
What you will observe is that HOMO of ammonia does not have the anticipated sp3 hybridization, when DZ
basis set is used. In the following picture you can see both the DZ and DZP results:

To visualize results from several jobs automatically, you can use the Report tool within ADFjobs:
Go to the ADFjobs window
Select Tools → New Report Template...
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This will open up Report dialog.
In the 'Report' field, you can choose the name for your report file and its format ('HTML' or 'Tab separated
plain text'). The other fields ('General', 'Images', 'Results') contain various relevant options you can choose
for preparing your report.
In the 'Report'/'Template name' field, type 'MyReport'
In the 'Results' section check 'Dipole Moment' and 'Dipole Vector'
In the 'Extra ADFreport command line options' field: enter 'angle#labels#2#1#3'
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The extra command line options used instruct ADFreport to report the angle between atoms 2, 1 and 3, and
include the atom labels for this angle on output. In a similar way more angles could be requested, or
distances, or many other properties. For a description of all options please check the adfreport
documentation.
Click 'OK'
The Report dialog will close, saving our template named 'MyReport'. Now we will generate actual report
following the saved template:
In ADFjobs window, select all the finished jobs from the NH3 set
Select Tools → Build MyReport Report
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'Save As' dialog window will pop up, showing the 'report.html' default filename.
Choose your filename and location, then click 'Save'
Now ADF will work through all your selected jobs and prepare the report. Finally the browser will start
showing your report file (by default, named 'report.html'):

The Report tool created a table-like report of the results. Click on the image above to see it in detail.
We can clearly see that only for DZ basis optimization our NH3 molecule is planar (check the last row of the
report table). The dipole data are also shown in the report. Obviously the dipole moment is zero only for the
planar NH3 structure.
Congratulations, we are done with the ammonia optimization tutorial!
If you want to exit all the GUI modules at once: select SCM → Quit All
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Tutorial 11: Caffeine Bader (AIM) analysis, Benzene NBO
visualization and Occupations
Step 1: Setup and optimize Caffeine
Start ADFinput
Next we need a reasonable guess for the structure of Caffeine. The quickest way to do this is to search for it
in the database of molecules included with the ADF-GUI, and optimize it:
Press cmd-F or ctrl-F to activate the search box
Type 'caffeine' in the search box
Move your mouse pointer on top of the 'Thein' search result

As you can see, there are several matches. If you position your mouse over the results (without clicking) a
balloon will appear showing the details of that match. For this tutorial we use the second match "Thein", from
the NCI database. Thein is one of the common names for caffeine (and as you can see there are may
alternative names),
Click on the 'Thein' search result
Click somewhere in empty space in the molecule drawing area to deselect the
atoms
Switch to DFTB mode (panel bar ADF → DFTB)
Select model: SCC-DFTB
Make sure the parameter set is "Dresden" (normally you would want to use
better parameters like the included 3OB set)

191

Note that only those parameter sets known to be able to handle your system will be shown in the menu.
If you move your mouse over the parameter field, the information balloon will also show references
applicable to the selected set of DFTB parameters. More detailed information and references will be
displayed if you click on the 'i' button next to the parameter input field.
Click the 'Run' button
If the message says 'NOT converged', press 'Run' again.
The DFTB program should have created something similar to this structure:
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Step 2: Calculation setup
Next we will calculate the AIM critical points and paths for the current structure.
Switch to ADF mode (panel bar DFTB → ADF)
Now we want to activate the Bader AIM analysis to find the critical points and bond paths. To find where this
option is located, search for it:
Activate the search box (cmd/ctrl-F)
Type 'criti' in the search box
Use the Return key to accept the highlighted match (Other...)
ADFinput will activate the panel that displays the option you are looking for (to calculate the AIM critical
points and paths). The matching input options will be marked with blue italic text. Note that we first had to
activate the ADF mode, the input option search will restrict the search to panels that belong to the current
method (ADF, BAND, DFTB, ...)
Check the box to calculate Bader (AIM ) Critical points, bond paths and atomic
properties
Check the box to calculate AIM atomic energies
Check the box to save the Bader basins
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Run this setup: File → Run
A dialog will pop up in which you must specify a filename to use for your job, for example caffeine:
Enter 'caffeine' as a Filename, press the Save button
After hitting the save button the calculation will start. You will get two extra windows: first a window for
ADFjobs that allows you to manage your jobs and keep track of their state (for example, queued or running).
You will also get a window showing the ADF log file. This shows you what is going on in the current
calculation.
Depending on your computer, the calculation should be ready after a few minutes at most:
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Step 3: Orbitals, Potential and AIM results
Start ADFview SCM → View
Show the HOMO Properties → HOMO
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Hide the HOMO by unchecking the check box at the lower left corner of the
ADFview window
Add → Isosurface: Colored
In the first field selector (to the right of the 'Isosurface: Colored' text at
the bottom), select Density → SCF
In the second field selector (to the right of the '0.03' text in the same
line), select Potential → SCF
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Hide the surface with the potential energy: uncheck the check box at the lower
left corner of the window
Properties → AIM (Bader)
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The critical points and bond paths are shown (the molecule balls and sticks representation is hidden). The
different types of critical points (atom CP, bond CP, ring CP and cage CP) are indicated by different colors.
The atom CPs are scaled by density by default, which makes them look like atoms. The bond paths are
colored by density, by default.
You can also visualize the Hessian of the Density in the critical points:
Uncheck the 'Scale By Density' check box in the AIM line at the bottom of the
window
Properties → AIM: Hessian of Density at CPs
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To get a rough display of the Bader basins, use the Bader sampling option:
Properties → Bader Sampling
Zoom in
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The different colored points show the different basins.
ADFview has many options to visualize the results, the options just used are mainly to show off some
features. Play around with the different options, for example try out what the check boxes do on the left side.
Or try other fields, or colored cut planes, or ...
This finishes the Caffeine Bader (AIM) tutorial, close all its windows:
SCM → Quit

Step 4: Benzene Bader charge analysis and NBOs
Start ADFinput
Make a benzene molecule (for example by searching for it with cmd/ctrl-F)
Set up a Single Point calculation without frozen cores
Panel bar Properties → Other: Etot, Bader, Charge Transport
Check the 'Atomic energies' option
Check the 'Save Bader atomic basins' option
Panel bar Properties → Localized Orbitals, NBO
Check the 'Perform NBO analysis' option
Request Boys-Foster localized orbitals
Run this setup (File → Run)
When the calculation is done (it should run very fast), we use ADFview to examine the Bader charges and
compare them with Mulliken charges:
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Open the results with ADFview
Show the Bader atomic charges (Properties → Atom Info → Bader Charge → Show)
Color the atoms by Bader charges (Properties → Color Atoms By → Bader Charge)
Show the Mulliken charges (Properties → Atom Info → Mulliken Charge → Show)

Next we inspect the NBOs and Boys-Foster localized orbitals. To remove the charge display we close and
open ADFview, but you could also have used the View menu to remove them by hand:
Close ADFview
Open the results again with ADFview
Add a Double Isosurface
Use the field menu in the new control line, and
observe the labels present with the NBOs and NLMOs
Open NBO number 15 (should be similar to C6-H12)
Improve the grid by using Fields → Grid → Fine
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Obviously, you can also visualize the NLMOs or the Boys-Foster localized orbitals (which are just called
Localized Orbitals in the fields menu.
Next we inspect the Bader atomic basins. The numerical integration points are used for this purpose. The
color indicates to which atomic basin the numerical integration point belongs to.
Close ADFview
Open the results again with ADFview
Properties → Bader Sampling
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One can also select one or more atoms, to see only the Bader atomic basins of the selected atoms.

Step 5: Occupations
Now we will remove one electron from a selected orbital (by symmetry) using ADFinput again.
Open your benzene calculation in ADFinput
Model → Spin and Occupation
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In the Spin and Occupation panel you see which orbitals are available (by symmetry, and spin if the current
set up is unrestricted). The numbers are the occupations. Next to the ADFinput window ADFlevels will also
have opened, and is showing a level diagram of your current molecule. This helps you to select the proper
occupation.
The level diagram is based on the existing result file (.t21) found. If none, ADFinput will suggest to do a
guess-calculation: a hopefully fast calculation using an inaccurate integration grid, and stopping after a few
SCF cycles. The level diagram shown in that case will not be accurate obviously but will still be helpful in
selecting the proper occupation.
Now, just as an example, we make a hole in the 3E2.g orbital. Note that this is NOT the HOMO.
Change the 4.0 to 3.0 in the 3 E2.g column (the third row)
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Close the guess adflevels
File → Save
Close the ADFinput window
Run (via the Job → Run command in ADFjobs
When the run is complete:
Open ADFlevels using the SCM → Levels command
In the ADFlevels window, use the View → Labels → Show command
Zoom in to the region of interest (for example using your mouse wheel)
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In the levels diagram you will observe that the HOMO (the 1E1.g) is completely filled, while the orbital below
it has a hole. You can easily see this by the color. Note that we have performed a restricted calculation, so in
effect the hole is averaged over the E orbitals.

Tutorial 12: Spin Coupling in Fe4S4 Cluster
This tutorial will help you to:
• build the structure of iron-sulfur cubane,
• control the spin coupling in multi-center radical systems in two different ways (SpinFlip and
ModifyStartPotential),
• tweak the SCF convergence in the iron-sulfur cubane case,
• visualize the distribution of spin densities in 3D.

Step 1: Create and pre-optimize the Fe4S4 cubane model
Embedded into proteins and coordinated by cysteine ligands, iron-sulfur cubanes are often used by nature in
electron transfer and catalysis. While their native structures can be extracted from protein data bank (PDB)
files, we will use ADFinput module to build a model of the Fe4S4 cubane from scratch in this example.
Start ADFinput
Select the Structure tool → Polyhedra → Cube structure:
Click anywhere in the empty structure drawing area.
This should place a cube in the building area of ADFinput.
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The cube built is constructed of carbon atoms. We will now change four of these atoms to iron (Fe), and next
the remaining four atoms into sulfur (S).
Via Shift-click, select four carbon atoms in the corners of the cubane

Atoms → Change Atom Type → Fe: change the four atoms into Fe
Selection → Invert Selection
Atoms → Change Atom Type → S: change the other atoms into S
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Now you should see the Fe4S4 cubane in the structure drawing area of ADFinput. The proper coordination
to Fe atoms is important in modeling their electronic structure. In proteins, iron-sulfur cubanes are
coordinated by cysteine ligands to the Fe sites. Here, we will model these four cysteines by -SH ligands. The
procedure to add these ligands is described below.
Select all Fe atoms (for example by inverting the selection)
Use the Atoms → Details (Color, Radius, Mass, ...) menu command
Change the number of connectors for all Fe atoms from 10 into 4

208

Switch to the Main panel
Add hydrogens to the still selected Fe atoms using the Atoms → Add Hydrogen
menu command
Select the (newly added) hydrogens
Use the Atoms → Replace By Structure → Ligands → OH menu command:
This will replace hydrogen atoms into OH ligands.
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Select one of the O atoms
Use the Select → Select Atoms Of Same Type command to select them all
Use the Atoms → Change Atom Type → S to change them into S
The next step is to optimize this structure. It is a difficult system, and the pre-optimizers will fail. So we will
use ADF to optimize the geometry.
Set the charge to -2
Select the Geometry Optimization preset
Click the Symmetrize button (the star) to check the symmetry (should be Td)
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File → Run (enter FeS as name)
When ready, click OK to use the optimized geometry in ADFinput
SCM → Movie
In the Movie window: Graph → Energy
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Close the movie window: File → Close

Step 2: Obtain the solution for the high-spin (HS) state of the cubane
In Fe4S4 systems, the iron sites are commonly high-spin ferrous (Fe3+, S = 5/2) or ferric (Fe2+, S = 2). For
the present example, we will use the iron-sulfur cubane oxidation state where the two sites are ferric and the
remaining two are ferrous. This oxidation level of Fe4S4 is well-defined and occurs, for example, in
rubredoxin and high-potential iron-sulfur proteins (HIPIPs). For our model system, Fe4S4(SH)4, this implies
the total charge of -2.
The relative directions, or coupling, of the individual site spin vectors is a very important issue in obtaining
the desired density functional solution in Fe4S4, as well as many other systems which display a multi-center
radical character.
Within the common open-shell approach, the spin vectors are either parallel or anti-parallel. The case when
all the spins are parallel is called high-spin (HS). Obtaining self-consisted field (SCF) solution for the HS
case is normally simpler because the program does not need to resolve the ambiguity of distribution the
sites spin vectors. While the ferromagnetic HS solution commonly does not correspond to the lowest energy
electronic state, this solution can be used to obtain the electron density corresponding to the lower energy
spin-coupled state. In this step, we will obtain the HS solution for the iron-sulfur cubane, which will be used
later in the tutorial. The HS solution for the [Fe4S4(SH)4]2- model corresponds to S = 2 × 5/2 + 2 × 2 = 9.

Select the ADFinput window
Select the Single Point preset
Keep the total charge to -2
Set the spin polarization to 18 (corresponds to S = 9)
Check the unrestricted box
File → Save As...
Enter FeS_HS as filename and save
File → Run
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ADFtail window will pop up showing the progress of the job:
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The logfile shows that the convergence has been obtained in 17 SCF cycles.

Step 3: Couple the spins in Fe4S4 using the SpinFlip option
While SCF solution for the high-spin (HS) state of a multi-center spin system can often be easily found, this
solution does not necessarily correspond to the lowest energy state.
To generate the solution with the desired collinear spin arrangement, one option is to use the 'SpinFlip'
concept that has been earlier introduced by L. Noodleman and coworkers. In this two step procedure:
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• first the spin-unrestricted HS solution is generated with all the site spins ferromagnetically coupled
in one direction (all spins up, ↑).
• Next the α (↑) and β (↓) electron densities centered at the sites which are expected to be
antiferromagnetically coupled (spins down, ↓) to the total spin vector are exchanged for the earlier
obtained HS solution, using the SpinFlip option, and the calculation is restarted.
Because this approach often results in lowering the electronic symmetry of the system while retaining its
structural symmetry, a solution obtained in such way is often called the broken symmetry (BS) state. In such
cases you will need to make sure that your BS calculation is done with lower symmetry.
The concept of SpinFlip and BS state can be illustrated considering our iron-sulfur cubane case with two
ferrous (Fe3+, S = 5/2) and two ferric (Fe2+, S = 2) sites. One of the well-characterized BS states for this
level of Fe4S4 oxidation corresponds to S = (5/2 + 2) - (5/2 + 2) = 0, 2↑:2↓.

Select the ADFinput window with your FeS_HS calculation
Make sure the 'Main' panel is visible
Change the spin polarization from 18 to 0
This spin polarization setting corresponds to S = 0 zero spin of the BS electronic state.

Panel bar Model → Spin and Occupation
ADFlevels will show the levels from your previous calculation. As we are not changing the occupations this
info is not needed for this tutorial.
Close the window showing the energy level diagram (ADFlevels ...)
Select the two (out of four) arbitrary Fe sites in the drawing area
Click + next to the Spin Flip on Restart For: line.
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To achieve the desired BS solution, the SpinFlip procedure should be applied to 2 out of 4 Fe sites of Fe 4S4.
In the above example, we selected sites Fe(2) and Fe(7). This will instruct SpinFlip algorithm to interchange
α (↑) and β (↓) electron densities associated with these two Fe sites when the job will be restarted, changing
the HS 4↑:0↓ spin state to the BS 2↑:2↓ spin state.
The Spin Flip option only works when restarting, so set up the restart calculation from the HS results:

Panel bar Details → Files (Restart)
Click folder icon in front of the 'Restart file:' field,
Select the Fe_HS.t21 file (it should already be selected, so just press the
Open button)
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The above will instruct ADF to read the converged HS solution we obtained in the previous step of the
tutorial. This solution has been saved in the Fe_HS.t21.
Panel bar Details → Symmetry
Set the symmetry symbol to NOSYM
File → Save As, save the job as FeS_BS_SPINFLIP
File → Run
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As you see, our FeS_BS_SPINFLIP job converges in 21 cycles.

Step 4: Coupling the spins using the ModifyStartPotential option, use
ARH SCF convergence method
There is an alternative to SpinFlip available in ADF, which is aimed to achieve a specific spin-coupled
solution in a single calculation only. This is done using the MODIFYSTARTPOTENTIAL key in ADF: it allows
you to create a spin-polarized potential at the very start of the calculation.
Please read the page of ADF user's guide on MODIFYSTARTPOTENTIAL key prior to proceeding with this
step of the tutorial. As follows from the MODIFYSTARTPOTENTIAL description, this key allows to control
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the ratio of spin-α and spin-β electrons associated with fragments via 'alpha' and 'beta' numbers. For the
purpose of the present tutorial, we will consider the four Fe sites as fragments. Apparently, 'alpha' and 'beta'
numbers will correspond to the number of spin-α and spin-β electrons, correspondingly, associated with a
Fe site.
So follow these instructions to obtain the BS solution via the MODIFYSTARTPOPTENTIAL option:
Open your FeS_HS calculation in ADFinput
Change the spin polarization from 18 to 0
Panel bar Details → Symmetry
Set the symmetry to NOSYM
Panel bar Model → Spin and Occupations
Close the ADFlevels window
Select the four Fe atoms
Click the '+' in front of 'Modify Start Potential'
Set the alpha and beta occupations, for the four Fe atoms:
14 alpha and 10 beta
14 alpha and 9 beta
10 alpha and 14 beta
9 alpha and 14 beta

For the spin-up Fe3+, S = 5/2, the alpha and beta numbers would be 14 and 9, correspondingly, and for the
spin-up Fe2+, S = 2, these numbers are 14 and 10. For the spin-down Fe sites, alpha and beta numbers
should be apparently transposed. Also, our desired BS state for this level of Fe4S4 oxidation corresponds to
S = (5/2 + 2) - (5/2 + 2) = 0, 2↑:2↓ .
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Note that SCF procedure might be problematic.
You can play with several options to help the convergence. In the SCF panel (in Details) you can experiment
with several mehods like LISTi, A-DIIS, E-DIIS and ARH. In the SCF convergence details panel further
options are available, like mixing, level shifting, orbital freezing and DIIS details.
In this particular case, the ARH method (in the SCF panel) works, although it needs a lot of iterations.
Panel bar Details → SCF
Select the ARH convergence method
Set the maximum number of SCF cycles to 1000

File → Save As: save the job as FeS_BS_MODIFYSTARTPOTENTIAL
File → Run
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Hopefully you will be able to converge the job, to the same energy and state as the SpinFlip job.
Thus both the SpinFlip and the ModifyStartPotential option allow you to obtain a desired Fe spin coupling
pattern in the Fe4S4 case. While SpinFlip is a two-step approach and ModifyStartPotential works as in a
single step, the SpinFlip approach shows a better performance during SCF (much better and faster SCF
convergence).

Step 5: View the spin density of the broken symmetry (BS) solutions
In the two previous steps of this tutorial, we have generated the broken symmetry (BS) solution for the
Fe4S4 cubane using alternatively the SpinFlip and ModifyStartPotential options. Here, we will analyze this
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BS solution viewing the Fe spin densities using ADFview, and confirm that the spin alignment of the iron
sites is 2↑:2↓ This type of analysis can also be powerfully used during presentations and for scientific
illustrations.
Select your FeS_BS_SPINFLIP calculation in ADFjobs
Use the SCM → View menu command to activate ADFview
You should see the [Fe4S4(SH)4]2- system in the ADFview window.
The spin-density is available as a short-cut in the Properties menu:
Properties → Spin Density
You should see now the two Fe ions surrounded by blue blobs (spin up,↑) and the other two by red blobs
(spin down,↓):
Change the iso value to 0.03

Note that you now have two visualizaion lines: one is a calculated field that actually calculates the difference
between the alpha and beta spin density. The other is a double isosurface that visualized the calculated
field. You can use thse calculated fields for many purposed. For example, by changing the '-' into a '+' you
are visualizing the total density instead of the spin difference density.
In the same way you can also check the spin densities for the FeS_HS and
FeS_BS_MODIFYSTARTPOTENTIAL results.
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BAND-GUI tutorials
This section contains tutorials that show you how to use BAND via the BAND-GUI. As the BAND-GUI is very
similar to the ADF-GUI, we will focus here on BAND specific features.
If you are not familiar with the ADF-GUI (or the BAND-GUI), please have a look at the Introduction and ADFGUI Overview tutorials.
For example, it will show you how to start the BAND-GUI.
The Building Crystals and Slabs tutorial in the overview section is especially important for BAND users.

Tutorial 1: with a grain of salt
According to any freshman chemistry textbook, in NaCl one electron is transferred from the Sodium to the
Chlorine. The occupied 3p states form the valence band, while the empty sodium states hybridize into a
conduction band. We will put these idealized ideas to the test.
This tutorial will teach you how to:
•
•
•
•
•
•
•

define the geometry of a NaCl crystal
run the calculation
view the band structure
view an orbital for a particular band and k-point
view the (partial) density of states
view the deformation density
view the atomic charges

The BAND-GUI has been designed to be a lot like the ADF-GUI. This makes it much easier for people to
use both programs. To avoid repetition, the BAND-GUI tutorial assumes that you are familiar with some
basic usage of the ADF-GUI. If you do not know how to rotate, translate, zoom etc within the ADF-GUI,
please read through the first ADF-GUI tutorial before starting with this BAND-GUI tutorial. Even better: try
using the ADF-GUI yourself. You can get a demo-license for this purpose if needed.

Step 1: Start ADFinput
Start ADFjobs
We prefer to run the tutorial in a new, clean, directory. That way we will not interfere with other projects.
ADFjobs not only manages your jobs, but also has some file management options. In this case we use
ADFjobs to make the new directory:
Select the File → New Directory command (thus, the New Directory command from the
File menu)
Rename the new directory by typing 'BandTutorial' and a Return
Change into that directory by clicking once on the folder icon in front of it
Now we can start BANDinput using the SCM menu:
Use the SCM → New Input menu command
Switch to BAND mode (panel bar ADF → BAND)
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The BANDinput window consists of the following main parts:
•
•
•
•
•
•
•

the menu bar with the menu commands (File, Edit, ...)
the drawing area of the molecule editor (the dark area on the middle left side)
the status field (lower part of the dark area, blank when the ADFinput is empty as shown above)
the molecule editor tools
many panels with several kinds of options (currently the 'BAND Main' panel is visible)
panel bar with menu commands to activate the panel of choice
a search tool (at the right of the panel bar)

In the drawing area you see the lattice vectors, with three repetitions of the unit cell along each vector. The
first lattice vector is red, the second green, and the third blue. Using the View Periodic menu you can
change the display of the periodic images:
View → Periodic → Repeat Unit Cells
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If you look in the toolbar with molecular editor tools, you see that the rightmost button is no longer glowing.
You can also use this button to toggle the display of the periodic images:
Click once on the rightmost button in the toolbar (the four dots)
Now you should see the periodic repetitions again.

Step 2: Set up the unit cell
Salt has an fcc lattice. First we need to set the lattice vectors:
Panel bar Model → Lattice
Enter the lattice vectors, as shown below
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Step 3: Add the atoms
Now we will add the Na and Cl atoms. It is convenient to turn of the periodic display while doing this:
Uncheck View → Periodic → Repeat Unit Cells
Click on the X tool, and select Na
After this you see at the bottom of the screen "Na tool" in the status field:
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Click once in the drawing area, near the origin
Click once on the created atom to stop bonding
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As you can see the atom is not exactly in the origin. This can be fixed if you wish:
Edit → Set Origin
To add the Cl atom you can proceed the same way:
Select the Cl tool (via the X button again)
Click once somewhere in the unit cell
Click on the new Cl atom to stop bonding

Next you should edit the Cl coordinates and change the Cl color:
Select the coordinates panel: panel bar Model → Coordinates
Change the Cl coordinates to be (2.75,2.75,2.75)
Check View → Periodic → Repeat Unit Cells
Now your system looks like:
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Step 4: Running the calculation
If you wish so, you can give your calculation a title:
Panel bar Main
Enter NaCl in the "Title" field
File → Save, name it "NaCl" and press Save.
File → Run
The progress of the BAND calculation is visibale in the ADFjobs window (a few lines of the 'logfile'). (the
'logfile'). After a few minutes the calculation has finished, and it looks like:
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Wait for the text 'Job NaCl has finished'
The calculation has produced two important result files: "NaCl.out", which contains the result of the
calculation in text format, the second is"NaCl.runkf" which is a binary result file.

Step 5: Examine the band structure
SCM → BAND Structure
This will open the bandstructure window:
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It consists of a plot and a picture of the Brillouin zone. In the plot the red line is the Fermi level. Below the
Fermi level are four occupied bands. You can see this more clearly by vertical zooming:
Click on the right mouse button, and drag the pointer up to zoom vertically
When the region of interest gets out of view, drag it into view (with the left
mouse button)
The bottom part of the plot will look like:
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In most k-points you see now four bands below the Fermi level. In some k-points you see fewer because
they are degenerate.
Now you may wonder about the path taken through the Brillouin zone. This is where the bottom part comes
in handy. You can zoom and rotate, just as with molecules in BANDinput.
Zoom in a bit, by using the scroll wheel on your mouse or pressing the Middle
button and moving upwards

232

Toggle the button to display the k-points

Now click on the line from 11 (via 12) to 1
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Note how the line lights up, and also how the corresponding segment is indicated in the plot by a gray
background. You can also click on the plot to select line segments.
Rotate the Brillouin zone a bit to convince yourself that the line (from k-point 11 to 1) runs from the center to
the center of a hexagonal face.

Step 6: Visualizing the results
Plotting the orbitals
Now what is the character of the bands? Let us first examine this narrow band at about -0.5 Hartree.
SCM → View
In ADFview: Add → Isosurface Double (+/-)
In the bar at the bottom of the window, you can select which field to show.
Select the lowest band (k=0,0,0)

234

From the label you can see that it has an energy of -0.8908 and the coordinates are (0,0,0).
A progress bar will appear, and after a while you will see the orbital:
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If you rotate it a bit and toggle the isosurface on and off (with the check box in front of it), you can convince
yourself that this orbital is located around the small atom, which is the Chlorine.
Toggle the periodic view (the menu View → Periodic → Repeat Unit Cells)
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Obviously this is the 3s band of Cl. The strange truncated spheres are due to contributions of neighboring
cells.
Let us now take a look at the orbital with the lowest energy of the second band (the first one with an energy
not around -0.88):
Select the lowest orbital of the second band (with energy about -0.5)

This orbital looks like:
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and it clearly consists of a p orbital on the Cl. The part near the Na comes from Chlorine atoms in
neighboring cells.
It is generally easier to interpret orbitals at k=(0,0,0). Going up in energy we encounter a degenerate triple at
e=-0.49. Note you can tear of the menus to make orbital selection easier:
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Tear off the 'Occupied orbital menu, group 1
Select the first orbital around e=-0.49
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Take a look at all three of them.
From these orbital pictures we can conclude that the valence band is indeed mainly of Chlorine-p character.
You may want to check the lowest orbitals of the (unoccupied) conduction band.
Check the lowest orbitals of the conduction band
Do you see a strong Na character in them?
Actually it looks a lot like an s function on the Cl atom. However in this case the iso-surface is misleading.
With a contour plot you can make it look like this:
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so the orbital has a bit of a muffin-tin shape, the maximum is between the atoms. For such states an iso
surface looks misleading. The maximum is closer to the Na atom, so it is really a Na state.
At the end of this step, we will demonstrate how to create such a plot.

Plotting the partial density-of-states
There is in fact a much more easy way to conclude that the valence band is mainly of Chlorine-p character.
Open the DOS module: SCM → Dos
and a window like this will appear:
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The Fermi energy is around -0.43, and there is clearly a gap. Just below it there is a valence band, and at
-0.2 Hartree starts the conduction band.
Select the View → Add Graph command
(Now you see two plots of the total DOS)
Select with the mouse the Chlorine atom (the small green one)
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It is already immediately clear that the valence band comes from the Chlorine, and the conduction band from
the Sodium.
Right-click with the mouse on the selected Cl atom and
check the 'P-DOS' check box in the pop up menu.

This shows that the valence band is clearly made of Chlorine p-orbitals.

Plotting the deformation density
Intuitively you might expect that the charge of Na should be +1 and from the Cl -1. This can be best seen by
making a cut plane:
Go to ADFview (SCM → View)
Delete the double isosurface with the 'Isosurface: Double'
pull-down menu in the bar on the bottom and select 'Delete'
Add → Cut Plane: Contours (+/-)
Select the deformation density in the fields menu (in the Fit density sub-menu)

The result is a bit disappointing, because the plane is perpendicular to the atoms
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To get it right enable at the bottom the "Position plane" toggle:

You will now see a white frame. Drag it to the right until you see an arrow in it
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Now you can "grab" the arrow head and turn it to make the plane go through the atoms
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Indeed we see that charge is added (blue) near the Cl and removed (red) from the Na atom. The trend is
good, but what is the total amount of charge transferred?

Creating the density contour plot
Delete the cutplane 'Cutplane: (+/-) Cont'
pull-down menu in the bar on the bottom and select 'Delete'
Add → Cut Plane: colored
Select the unoccupied orbital with the lowest energy, around -0.2413
Uncheck 'log'
Check 'bar'
As the plane is perpendicular to the atoms, you need to reposition it.
click the "Position plane" toggle
position the plane through the atoms
turn of the "Position plane" toggle
You should now have a picture that looks a lot like this:

Step 7: Check the charges
Use the "Properties → Atom Info → Hirshfeld Charges → Show menu command
This will show you
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So the amount of charge transferred is only about 0.2. This is of course due to the fact that the Cl p-band
overlaps quite significantly with the Na region.
The conclusion of this tutorial: we should take the idea that one electron is transferred from Na to Cl with a
grain of salt.

Tutorial 2: a transition state search
This tutorial will teach you how to:
•
•
•
•
•
•

do a geometry optimization
watch the geometry optimization as a movie
do a frequency calculation
examine the eigen modes
perform a transition state search
make a few mistakes and fix them

Throughout we will consider the toy system of a periodic chain with three atoms in the unit cell.

Step 1: Create the H3 toy system
We are going to enter the geometry manually, just as in the first tutorial.
Start ADFinput
Switch to BAND mode (panel bar ADF → BAND)
Set periodicity to Chain
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Panel bar Model → Lattice
Set the lattice constant to 10.0

Add with the mouse three hydrogen atoms somewhere in the cell
Panel bar Model → Coordinates
Change the coordinates of the H atoms to match the following picture
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You have now created the cylinder symmetric toy system.

Step 2: Optimize the geometry
Go back to the 'BAND Main' panel
Choose as preset 'Geometry Optimization'
File → Run, save the job with name H3_geo
After it has finished the program asks you
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Answer 'Yes'
Now let us look at the progress as a movie.
SCM → Movie
A small movie pops up ending like this
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The geometry looks a bit odd. Now take a look how the energy changed during the optimization.
Choose the Graph → Energy menu command
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It shows the energy at the four steps: 0, 1, 2, and 3. Since the energy does not change anymore from step 2
to three it should be OK? Well, maybe, but maybe not. Let us check whether we were fully converged.
Open the logfile: SCM → Logfile
Scroll from the end a bit upwards and you will see
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You see the final geometry and status of the five convergence criteria. Because they are all satisfied you
see the log message 'Geometry Converged'
Maybe we are dealing with a shallow minimum. Let us retry with a more strict criterion.
Close the logfile and movie windows and go back to 'BANDinput'
Go to the 'Geometry Optimization' details panel (click on the "..." button
next to GeometryOptimization)
Set the gradient convergence criterion to 0.0001
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File → Run (click Yes twice to accept overwriting the previous job
After the optimization, click Yes to accept the new geometry in BANDinput
Open ADFmovie and show the energy

Now that looks more like an optimal geometry!
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Step 3: Calculate the Hessian
Go to BANDinput
Select in the 'BAND Main' panel the 'Frequencies' preset

File → Save As...
Save the project as H3_freq
File → Run
When it is done, click Yes to accept the new coordinates
After the calculation has finished
SCM → Spectra
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There appear to be three peaks, whereas you would expect 3N degrees of freedom. With three atoms (N=3)
we should have nine modes. We can examine this a bit closer
click on the 'NormalMode' menu.

So there are indeed nine vibrational modes. Only two are nonzero because only symmetrical modes are
calculated by default. To see what a mode looks like
Select the mode at 1662 cm-1, either from the 'NormalMode' menu,
or by clicking on it directly in the graph.
The vibrational mode will be shown on the left:
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Step 4: Search the transition state
A minimum has vanishing gradients and only positive eigen modes. A transition state (first-order saddle
point) is characterized by having one negative mode. With a transition state search the optimizer will go
uphill in the direction of the lowest (nonzero) eigen-mode and downhill in all other degrees of freedom. In our
example it would follow mode 8. Let us give it a try from the minimum.
Choose in the 'BAND Main' panel the preset 'Transition State Search'
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We have just calculated a Hessian (with the frequency run) so we'd better use it.
Use the panel bar Details → Geometry Convergence command
Click on the folder button next to 'Initial Hessian From:'
Select with the file dialog 'H3_freq.runkf'
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File → Save As, use name H3_ts
File → Run
After it has finished:
Update the coordinates in BANDinput
SCM → Movie
Graph → Energy
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The third H atom ends up exactly in the middle of the (repeated) H1 and H2 atoms. Let us finally check that
we are indeed in the transition state.
In the 'BAND Main' panel select the task 'Frequencies'
Save the project as 'H3_ts_freq' and run it.
When the calculation is ready:
open ADFspectra and click on the 'NormalModes' menu
You should see:

We have found a geometry with vanishing gradients with one weak negative vibrational mode. We have
succeeded in finding a transition state.
SCM → Quit All
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Tutorial 3: a transition state search with a partial Hessian*
This tutorial will teach you how to:
• calculate a partial Hessian
• do a constrained TS search using the partial Hessian
In this "advanced" tutorial we consider a slightly more realistic system. Some of the calculations may require
20 minutes to run on a two core machine.

Step 1: Create the system
We are going to make a one layer Li (001) slab with a 2x2 unit cell, assuming familiarity with the build tools
Start ADFinput and switch to BAND mode.
From the structure tool select 'Cubic' and 'bcc'
Set 'Element' to Li
Set the lattice parameter to 3.49
Press 'OK'
Invoke the Slice tool
Set the Miller indices to 001, select 'Cartesian', and enter 1 layer.
Press 'OK'
Use the Edit → Crystal → Generate Super Cell... command
Select the preset '2x2' and press 'OK'
Panel bar Model → Coordinates
Your screen should look like this:
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Add with the mouse two hydrogen atoms anywhere in the screen
Set in the table the coordinates of the first hydrogen atom to (0, -0.5, 2)
Set the second H atom coordinates to (0, 0.5, 2)
The final geometry looks like this
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Step 2: Calculate a partial Hessian
Select the 'BAND Main' panel
Select the Frequencies preset
Set 'Basis Set' to 'SZ'
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Go to the 'Frequencies' details panel (click on the '...' button)
Select with the mouse the two tiny Hydrogen atoms (zoom in to make selecting
them easier)
Click on the '+' button next to 'Partial Hessian For:'
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File → Run, name the job H2onLi_freq
Say 'No' when asked to update the coordinates
Let us examine the eigen-modes that we have found for the Hydrogen molecule
Select the SCM → Spectra menu command
Open the 'NormalMode' menu
Now you will see that there is an eigen-mode at 452 cm-1 and one at 2428 cm-1. Convince yourself that the
452 mode moves the H2 perpendicular to the service and that the 2422 mode is essentially an H2 stretch
mode. The lowest mode looks like a promising start to find the transition state for dissociation over the Li
surface.

Step 3: Transition state search with a frozen substrate
We have just found the vibrational modes of the Hydrogen molecule, assuming that the Li substrate remains
fixed. Let us now find the transition state under the same assumption.
Close the 'ADFspectra' window and go back to BANDinput.
Select the 'BAND Main' panel and select the 'Transition State Search' preset
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Panel bar Model → Geometry Constraints and Scan
The two hydrogen atoms are still selected, if not select them again
Use the Select → Invert Selection command
Click on the '+' button next to 'freeze selected atoms'
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Panel bar Details → Geometry Convergence
Set the initial Hessian to 'H2onLi_freq.runkf'
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File → Save As..., use name H2onLi_ts
File → Run
After the run has completed:
SCM → Movie
In the movie window: Graph → Energy
View → View Direction → Along x axis
Reorient to get a good look
It should look like
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DFTB-GUI tutorials
DFTB provides accurate results at a fraction of the cost of a DFT evaluation. The tutorials in this section
show you how to use DFTB via the DFTB-GUI. Since the DFTB-GUI is very similar to the ADF-GUI, we will
focus here on DFTB specific features.
If you are not familiar with the ADF-GUI (or the DFTB-GUI), please have a look at the Introduction and ADFGUI Overview tutorials.
The DFTB-GUI can be launched from ADFJobs or by changing the program from the pull-down menu to
DFTB. As such, one can switch seamlessly between different programs, for instance to use DFTB as a preoptimizer for an ADF or BAND calculations.
The tutorials use DFTB parameter sets that are available for any user who has a DFTB license. For your
convenience als the DFTB parameter sets from DFTB.org have been included. They often give much better
results. In general we would advise you use one of the 3OB parameter sets with DFTB3 if possible.
To use the DFTB.org parameters as included with the ADF package you need the option to use them
enabled in the license file. For acacdemic users this is free of charge. Please contact us if you want this
option enabled. Alternatively, you can download them from the DFTB.org web site (after registration).

Tutorial 1: DFTB charges, frequencies and dynamics (MD)
This tutorial will walk through the main features currently provided by the DFTB engine, using the GUI.
DFTB achieves evaluation accuracy at a much lower computational cost than DFT, making it suitable for
molecular dynamics evaluations, even on large systems.
We will walk through three different steps in this tutorial. The first step aims at pre-optimizing a simple
molecule with DFTB. The second step will evaluate IR frequencies, spectrum and vibrational modes. Finally,
the third and last step will perform a simple molecular dynamics evaluation.

Step 1: DFTB: Pre-optimization and Charges
Start ADFjobs
SCM → New Input
Select the DFTB panel: panel bar ADF → DFTB
In the ADFinput panel:
cmd/ctrl-F, find benzene
Select the entry Benzene(ADF) in the Molecule section of the search result
Select the Main panel
Make sure the GeometryOptimization task is selected
Make sure the model is DFTB
Make sure the parameter set is "Dresden" (normally you would want to use
better parameters like the included 3OB set)
Move your mouse over the parameter set option, and note the references in the
help balloon
Click 'Run' in the DFTB panel to optimize the molecule.
When done (DFTB Ready in the lower left corner of the window):
Use the View → Atom Info → Atomic charge: Net (dftb) → Show menu command to show the
DFTB charges on each atom
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A Self Consistent Charge (SCC) evaluation allows atomic Mulliken charges to vary in an iterative procedure.
This influences the DFTB Hamiltonian until self consistence of these charges is reached.
Enabling SCC requires higher computational cost due to the iterative procedure taking place for each energy
evaluation, but higher accuracy of the final result. If SCC is disabled, the resulting final charges are not self
consistent, thus the procedure will be faster, but less accurate.
Set the model to SCC-DFTB
Click 'Run' again in the DFTB panel to optimize the molecule.
Note how both equilibrium geometry and atomic charges are affected by the SCC evaluation:
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Step 2: Frequency evaluation
This example will show how to compute vibrational frequencies and modes using DFTB.
Choose Frequencies as the Task to perform.
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File → Run, use DFTBFrequencies as name when asked for a name
When the calculation is ready (Job DFTBFrequencies has finished in the
logfile):
Close the logfile (File → Close)
In ADFjobs:
Select the "DFTBFrequencies" job
SCM → Spectra
Click on each individual frequency band to show the associated vibrational
mode.
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Step 3: Molecular dynamics
DFTB supports a Velocity Verlet algorithm for Molecular Dynamics. It also supports two types of
thermostats. In this example, we will perform a simple molecular dynamics evaluation using DFTB.
In the ADFinput window, choose MolecularDynamics as the Task to perform.
Make sure the model SCC-DFTB option is selected, and the parameter set is
Dresden (normally you want to use better parameters like the included 3OB set)
Click on the Details button (...) to the right of the Molecular Dynamics task
Set the Number of steps to 2000, the Time step to 0.5, and the Sampling frequency to
5
Make sure the thermostat is set to Berendsen, and adjust the temperature to
500.0 kelvin.
Save your input choosing File → Save as ..., with name "DFTB-MD"

274

File → run
You can monitor the calculation in real-time:
While the calculation is running: SCM → Movie
In the ADFmovie window: Graph → Energy
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Tutorial 2: Periodic DFTB, Lattice Optimization, DOS, band
structure and phonons
This tutorial will walk through the use of periodic DFTB to optimize the lattice parameters. The density of
states and band structure of the optimized structures will be displayed.

Step 1: Lattice optimization - input setup
To perform geometry optimization of a lattice, we will start from a diamond crystal with incorrect lattice
values, and let DFTB optimize this value. Next, we will proceed to display additional information obtained
during the evaluation.
Start ADFinput
Select the DFTB panel: panel bar ADF → DFTB
Choose Bulk to enable periodicity.
Click the structure tool (the snowflake next to the X tool),
Choose Cubic → Diamond
Set the cell parameter a to 6.0 and click OK
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Click the Details button (...) for the GeometryOptimization task
Check the Optimize Lattice box
Go to the Main panel
Make sure model is set to DFTB, and that the Dresden parameter set is selected
(normally you would want to use better parameters like the included 3OB set)
Choose File → Save as... and save the input as "DFTB-Diamond".

Step 2: Lattice optimization - execution
File → Run.
While the optimization is running, you can watch the progress by clicking SCM
→ Movie
When asked to read the new coordinates (when the calculation finishes), click
Yes
From the movie, you can observe how the unit cell shrinks as it is optimized.

Step 3: DOS and Band Structure
You can visualize the density of states (DOS) directly from the converged optimization.
SCM → DOS (in the ADFmovie or ADFinput window)
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Similarly, you can visualize the band structure
SCM → Band Structure
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Step 4: Phonons
Activate the ADFinput window with the DFTB-Diamond input
Select "Phonons" as Task
File → Save as..., use "DFTB-Phonons" as filename
File → Run
When completed: use SCM → Band Structure in the ADFtail window (showing the
logfile)
A window will appear showing the phonons diagram. Clicking on the curves at the location of the vertical red
bars will show the actual crystal vibrations.
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Tutorial 3: Proton affinities with third order DFTB (DFTB3)
In this tutorial we will calculate a proton affinity, defined as the negative gas phase enthalpy for the
protonation reaction A- + H+ → AH. Gaus, Cui and Elstner have shown that third-order terms (DFTB3)
generally improve the proton affinities with respect to second order self-consistent charges (SCC).
We will calculate the proton affinity of the acetate anion, CH3COO-. In the first step of this tutorial, we will
optimize acetic acid at the DFTB3 level. The second step will perform the computation on the anionic
species, and compute its proton affinity.
Contact us to enable parameter files from DFTB.org, including the ThirdOrder set for DFTB3, needed to run
this tutorial. For non-profit users there is no additional charge for this.

Step 1: Optimization of the neutral molecule
Start ADFjobs
SCM → New Input
Switch to DFTB mode (panel bar ADF → DFTB)

280

Use the Structure tool, select Solvents → Acetic acid
Click anywhere in the visualization pane. The acetic acid molecule will appear.
Make sure the GeometryOptimization task is selected and charge is set to 0.0
Select DFTB3 as the model.
Select the ThirdOrder parameter set.
Click 'Run' in the DFTB panel to optimize the molecule.
When the optimization is complete (DFTB Ready in the lower left corner of the window), note the final
energy (for the paramenter set used in this example, E(HAc) = -11.57557462 Hartree)

Step 2: Optimization of the acetate and the hydrogen ions
In order to perform the calculation on the acetate ion, we will remove the hydrogen ion from the previously
computed acetic acid molecule.
Select the hydrogen in the COOH group by clicking on it.
Press the Backspace key on your keyboard. This will delete the hydrogen atom.
Select the Main panel
Set the charge to -1.0
Click 'Run' in the DFTB panel to optimize the molecule.
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At the end of the procedure, note the final energy (for the parameter set used in this example, E(Ac -) =
-11.280518 Hartree).
Additionally, the energy of the lone proton must be obtained.
Select and delete every atom of the molecule, except one hydrogen atom.
Select the Main panel
Make sure the GeometryOptimization task is selected. Although this is effectively
a single point calculation, the GeometryOptimization task reports the energy
directly in the molecule window, facilitating the read out of the energy.
Set the charge to 1.0
Click 'Run' in the DFTB panel.
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Finally, annotate the value for E(H+) = 0.236417 Hartree. The proton affinity is computed as PA = E(Ac-) +
E(H+) - E(HAc), resulting in a final Proton Affinity of 0.566798 Hartree, or 355.67 kcal/mol.
We leave it as an example to calculate the PA with DFTB2 (SCC), and compare it with the high-level ab
initio results that are also quoted in the DFTB3 paper.
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MOPAC-GUI tutorial
This section contains tutorials that show you how to use MOPAC via the MOPAC-GUI. As the MOPAC-GUI
is very similar to the ADF-GUI, we will focus here on MOPAC-specific features.
If you are not familiar with the ADF-GUI (or the MOPAC-GUI), please have a look at the Introduction and
ADF-GUI Overview tutorials.
For example, it will show you how to start the MOPAC-GUI.
MOPAC (Molecular Orbital PACkage) is a semiempirical quantum chemistry program based on Dewar and
Thiel's NDDO approximation. It is available from OpenMOPAC. The documentation for MOPAC is also
available on that site.
MOPAC is included with the ADF distribution. However, it needs to be enabled in your license file. If it is not
enabled, please contact SCM to get more information. Note that MOPAC is free for academic users. The
MOPAC that is included with the ADF distribution is just the standard MOPAC from OpenMOPAC, and is
updated frequently.
If you wish to use a MOPAC version different from the one included with the ADF distribution, you can do
this by setting the SCM_MOPAC environment variable, either in your shell startup script or via the SCM →
Preferences command:
• do not set SCM_MOPAC when you want to run the MOPAC included with the ADF pacakage, in
most situations this is the easiest solution
• set SCM_MOPAC to the complete path to the Mopac executable
• set SCM_MOPAC to some command if want to run MOPAC on a different machine, the command
must pass the arguments and standard input, and should start the mopac.scm script on the other
machine (located in $ADFHOME/bin)

Tutorial 1: Toluene charges, movies, frequencies and normal
modes
The MOPAC-GUI is basically the same set of programs as the ADF-GUI. we suggest you start with the ADFGUI tutorials if you are not familiar with the ADF-GUI.
When saving a job and running, MOPAC will be executed. The MOPAC results (output and AUX file) will be
converted to a .rkf result file, that allows visualization of the results with the GUI modules like ADFview,
ADFmovie and ADFspectra. Results that may be visualized include geometry, optimization changes (with
energy), charges, bond orders, frequencies and normal modes. Obviously the MOPAC output file is also
available
This tutorial will give you an example how to use MOPAC via the MOPAC-GUI from SCM.

Set up Toluene in MOPACinput
Start ADFjobs
SCM → New Input
Switch to MOPAC mode (panel bar ADF → Mopac)
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We will now make a Toluene molecule. Most conveniently this is done by simply searching for it within the
MOPAC-GUI:
Control/Command-F
Enter 'toluene' as search text
Select 'Toluen' (the second match) from the list of matches
Click once in the drawing area in empty space to clear the selection
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Run interactively
In the Mopac Main panel you can see what options for MOPAC have been selected: by default a Geometry
optimization will be performed, using the PM7 method. MOPAC will also calculate the bond orders, and the
GUI will automatically update the molecular bonds using these calculated bond orders. To show this, we will
first remove the bonds and then run MOPAC by pressing the Run button:
Bonds → Remove Bonds
Press the 'Run' button
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The geometry has been optimized, but as the starting geometry was very reasonable this did not lead to big
changes. In the status area you can see that MOPAC used 17 iterations, and you can see the final heat of
formation. And obviously the bonds reappeared. These bonds are actually based on the bond orders as
calculated by MOPAC.
You can now also show the calculated atomic charges:
View → Atom Info → Mopac Charges → Show
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To see the MOPAC output, check the 'Show output' check box. And there is another way to run MOPAC
interactively: use the pre-optimizer button (the cog wheel).
Check the 'Show output' check box
Right-click on the cog-wheel (the pre-optimizer button), and select Mopac from
the menu
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As the geometry already had been optimized, nothing much happens. Except the MOPAC output file will be
opened and appear in a new window. This file actually starts with the AUX file, followed by the output file.
Close all windows except ADFjobs (no need to save your setup)

Save job and results: charges and movies
The previous section showed how to run MOPAC interactively, typically to be used as a pre-optimizer.
However, you can also run the MOPAC calculation as a 'real' job. Then the result files will be saved, and you
can analyze them with the GUI tools.
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SCM → New Input
Panel bar ADF → Mopac
Control/Command-F
Enter 'toluene' as search text
Select 'Toluen' (the second match) from the list of matches
Click once in the drawing area in empty space to clear the selection
Check the 'Show output' check box
Once again we have our Toluene molecule. Now to run it as a job simply use the Save and Run command
from the menu:
File → Save, save the job with name 'Toluene'
File → Run
When asked to read the new coordinates (when the calculation finishes), click
Yes
SCM → Logfile
The logfile will show the progress of the calculation:
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SCM → View
Properties → Atom Info → Atom Charge: Net (mopac) → Show
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As the 'Show Output' check box has been checked, the Mopac output is available:
Close the ADFview window
SCM → Output
Scroll to the end
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Now for a geometry optimization it might be interesting to see a movie of the progress of the optimization:
Close the ADFoutput window
SCM → Movie
Graph → Energy

293

You can also use ADFmovie to get detailed information about the geometry (distances, angles and so on),
just as for an ADF geometry optimization. If you don't know how, check the ADF-GUI tutorials.
Close all windows except ADFjobs and the ADFinput window showing your MOPAC
input

IR spectrum and normal modes
Now we will modify our MOPAC job to perform a frequencies calculation:
Activate the ADFinput window (MOPACinput)
In the Mopac Main panel, change the Task to 'Frequencies'
File → Run
Answer 'Yes' to save your setup
Answer 'Yes' to acknowledge that you are saving over a previous job
The logfile will be shown, and will very soon show the job is ready,
SCM → Spectra
The calculated IR spectrum will be shown:
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Right-click on the peak around 2762 cm-1, and select mode A_37 (with the
maximum intensity)
The selected mode will be shown:

Browse through the normal modes using the left and right arrow key
Try the alternative method:
In ADFspectra: tear off the A menu by selecting the dashed line (A → - - - - )
Use the torn-off menu to examine some more modes
SCM → Quit All
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ReaxFF-GUI tutorials
This section contains tutorials that show you how to use ReaxFF via the ReaxFF-GUI. As the ReaxFF-GUI
is very similar to the ADF-GUI, we will focus here on ReaxFF specific features.
If you are not familiar with the ADF-GUI (or the ReaxFF-GUI), please have a look at the Introduction and
ADF-GUI Overview tutorials.
For example, it will show you how to start the ReaxFF-GUI, and how to manually edit molecules.
The first tutorial provides you with an overview over all relevant GUI modules. It will create a mixture of
methane and oxygen, and burn it. This will clearly demonstrate that ReaxFF can handle reactions.
The second tutorial will show you how to set up a more complex system and how to use some of the
advanced features of ReaxFF. In setting up the system you will also find out how to create an aluminum
surface.

Tutorial 1: Burning methane
This tutorial will help you to:
•
•
•
•

create a simple mixture (methane and oxygen)
set up to burn it quickly (set up your ReaxFF simulation)
burn it: perform the actual ReaxFF simulation
visualize what is happening during and after the simulation

Step 1: Start ReaxFFinput
Start ADFjobs
SCM → New input
Switch to ReaxFF mode (panel bar ADF → ReaxFF)
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Step 2: Create a methane / oxygen mixture
Next we will make the methane - oxygen mixture. For full combustion we need at least 2 oxygen molecules
for each methane molecule. So we will use 100 methane molecules and 250 oxygen molecules.
Edit → Builder
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The Builder allows you to build your system, and set some things like the cell vectors that define the
computation cell. ReaxFF always uses periodic boundary conditions. The default cell is a cube with sides of
100 Angstrom.
You can use the Builder to add many molecules, randomly distributed. In the list of molecules to be added
the Current molecule is already present. If you have any molecules already, the new molecules will be
added. Right now we have no molecules yet, so we can remove that entry.
Click the '-' button in front of 'Current'
Click the + button in front of 'Molecules' once (so now we can specify two
kinds of molecules to add)
Change the box to a cube of 25.0 Angstrom
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Click in the entry field of the first line
Type 'me' (without the quotes) to search for methane
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As you can see, a search box appears to find your molecule, very similar to the search box in the panel bar.
Select the 'Methane (ADF)' match
Click the file select button on the other 'Fill box with' line
Click in the entry field of the second line
Type 'o', to search for O2
Select the 'O2 (ADF)' match
Change the 100 copied of O2 into 250 copies
You now have specified how the builder should build your system: 100 methane molecules with 250 oxygen
molecules added.
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At the bottom of the Builder panel you can see that the current density is zero. The new density, after adding
methane and oxygen, will be around 1 g/mL, which is obviously very high for this mixture. For this tutorial
that is fine as it means things will happen faster.
Next we will actually generate the molecules:
Click the 'Generate Molecules' button
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The molecules are generated at random positions and orientations, with constraint that all atoms (between
different molecules) are at least the specified distance (2.5 Angstrom) apart.
The system looks good, we can now close the Builder:
Click the Close button at the bottom of the Builder window

Step 3: Prepare for burning: set up the simulation
The next step is to set up the details of the simulation. For this tutorial we will perform an MD simulation, at
very high temperature and density. This is to make things happen quickly. Obviously it is not a realistic
system.
Select the 'Molecular Dynamics' task
Click the 'i' on the right side of the Force field line
A new window should appear describing what force fields are available, including a short description and
references. For this particular example we will use the CHO force field for hydrocarbon oxidation.
Close the window describing the force fields
Click on the folder-like button in the Force field line
Select the CHO.ff force field
Enter 50000 as number of iterations
Enter 10000 as number of non-reactive iterations
Specify a temperature of 3500 K
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Step 4: Burn it: run the simulation
Now we will run your set-up:
Use the File → Run command
When asked to save your input, save it with the name 'Methane'
ADFjobs should come to the foreground, and your job should be visible at the top. On the right side you can
see that the job is running (this is indicated by the gear-icon). When running, also a window will appear
showing the progress of your simulation (the logfile):
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As you can see in the logfile, the simulation is running.
To see more details, we now will use ADFmovie. Note that you can do this while the simulation is still
running!
Start ADFmovie: SCM → Movie in the logfile window

ADFmovie will show you the trajectory of your system. Note that it will automatically read new data as soon
as it becomes available.
It can also show graphs of the properties that ReaxFF calculates:
In the ADFmovie window:
Use the Properties → Temperature command
Use the Properties → Temperature (Set) command
Use the Properties → Potential Energy command
Make the window bigger to make viewing the graph easier
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Note that the two temperatures (the actual temperature, and the set temperature) are both plotted on one
axes. The other axes is used for the second property (in this case the potential energy).
You can go to a particular point in the simulation using the slider below the window showing your system, or
you can click somewhere on one of the curves plotted. You can also use the arrow keys (left and right) to
move through the simulation.
Click on the temperature curve, move around in the movie
Jump to the end of the movie to follow the progress
As ReaxFF is a reactive force field, reactions may take place. In this particular example the methane should
react with the oxygen, eventually producing H2O and CO2.
You can make graphs that show how many of the different molecule types are present. The following
instructions often work, but it depends on what molecules are present in your simulation. You might try this
step again after waiting some time. Remember that we requested 10000 non-reactive iterations, so just
leave it running for 30000 iterations or so. Especially the production of H2O and CO2 take some time.
After about 30000 iterations:
Use the Properties → Molecule Fractions command
In the window that pop-ups, select H2O
Click Add / Remove
Repeat these three steps for CH4, and for CO2 if any present yet.
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Obviously, no reactions take place in the first 10000 iterations.
You can put one of the curves on a different axes if you wish:
Click once on the curve showing the number of CH4 molecules, this makes it the
'active' curve
Use the Graph → Curve On Right Axes command
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Clicking on the curve also had two other effects (besides making it the active curve): you jumped to the
iteration in the movie corresponding to the point where you clicked, and the molecules that belonged to that
curve are selected.
The selected molecules are shown with Balls and Sticks, instead of wire-frame only, to make it easier to spot
them. Flying to the selection also makes it easier to spot them:
Use the Properties → Molecule Fractions command to add a CO2 curve if you have not
yet done so
Click on the curve showing the CO2 production
Use the View → Fly To Selection command a few times

When you now go forward or backwards in time, it is easier to see how the reactions actually take place.
Note that the atoms remain selected, even if they are no longer part of a CO2 molecule. In a similar way you
can focus on H2O produced:
Click on the curve showing the H2O production
Use the View → Fly To Selection command if needed
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Wait until the calculation is ready
Select the CO2 curve (click on it)
Move it to the left axes: Graph → Curve On Left Axes

To prepare for the next tutorial, quit everything:
Bring the ADFjobs window to the foreground
Use the SCM → Quit command to close all windows for this job
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Tutorial 2: Water on an aluminum surface
This tutorial will help you to:
• create an aluminum slab
• add a solvent (water)
• run the simulation and see what happens

Step 1: Start ReaxFFinput
Start ADFjobs
Use the SCM → New input menu command
Switch to ReaxFF mode (panel bar ADF → ReaxFF)

Step 2: Creating the surface
Bulk aluminum has an fcc crystal structure, with a lattice constant of about 4.0 Angstrom.
To create the surface, we first build bulk aluminum:
Edit → Crystal → Cubic → fcc
In the dialog that appears:
Select the preset Al
Click the 'OK' button
View → Periodic → Repeat Unit Cells
In your molecule editor screen you should see a picture of the bulk aluminum structure. The unit cell
contains one atom. As ReaxFF input by default does not show repeated cells, it had to be turned on
explicitly. Otherwise you see only the single atom in the unit cell.
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Now create the surface:
Edit → Crystal → Generate Slab...
In the Dialog window:
Check the 'cartesian' check box
Set the number of layers to 3
Click OK
View → Periodic → Repeat Unit Cells
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You will see three atoms as it is a three-layer slab.
In this case we do not want just one unit cell, but a much bigger piece of the slab:
Turn off periodic view:
View → Periodic → Repeat Unit Cells
Edit → Crystal → Generate Super Cell...
Put 10, 10, 1 on the diagonal
Click OK
Rotate get a better view
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Now we have a real slab of aluminum, three layers thick. Note that the Generate Super Cell command
adjusted the lattice vectors to match the new unit cell.

Step 3: Add solvent
The next step is to add water to the system, and make sure that the slab is in the center of the simulation
box:
Edit → Builder
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Change the third dimension of the lattice vectors to 100.0
Check the 'Move to center of box' box on the line for the Current molecule
Type 'wa' in the line with 'Fill box with'
Select 'Water (ADF)' from the search results
Specify 2500 copies
Specify a distance of 1.0 Angstrom (this is the minimum distance between the
molecules)
Click the 'Generate Molecules' button on the bottom
Use the View → Periodic → Show Unit Cell command to visualize the box
Rotate to your favorite view
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Step 4: Set up the simulation, including a temperature regime
Now we will set up the MD-simulation. We will use the Al-water force field:
Close the Builder by clicking the Close button on the bottom
Select the 'Molecular Dynamics' Task
Click on the folder icon to select a force field
Select Other.. -> Al-H2O.ff
Specify 100000 iterations
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In the simulation we would like something to happen. So we will use a high temperature for water, but try to
keep the aluminum cool. Also, we will start with a low temperature MD to relax the initial set-up. This can all
be accomplished using a temperature regime, specifying different temperatures for different regions.
For this we first need to define two new regions: one for the aluminum slab, and one for the water. Regions
in ReaxFFinput are the same as in the ADF-GUI: they are defined as a collection of atoms. Via the Regions
panel you can define the regions:
panel bar Model → Regions
Click once on the select button (the V like button) in the Auto-Generated region
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By pressing the select button you have selected all atoms in the 'Auto-Generated' region. This region will
always contain the atoms that are added by the Builder. Thus, as you can see, all water molecules are
selected.
We are going to set up a region for the water molecules, and a region for the aluminum surface:
With the water molecules still selected, press the + button in front of the
Regions label
Click and select the text 'Region_2' and change it into 'Water'
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Now we have a region defined that contains all water molecules. Note that the selected atoms (in this case
all water molecules) where automatically added to the new region. The + and - buttons add or remove the
selected atoms to a region.
Click in the drawing area so it has focus (otherwise the next will select the
region name)
Select → Select All
Press the + button in front of the Regions label again to add a new region
(containing everything as everything was selected)
Change the name Region_3 to Al
Click the select button in the Water region to select all water molecules
Click the '-' button in the Al region to remove the water from the Al region
Click in empty space to clear the selection
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The different regions are shown with colors. This does make the display a lot slower. You can turn off (or on)
this display with the check box in front of the Region names, and you can set visualization style per region:
Uncheck the check box at the left of the Water region line
Press the triangle on the right side of the Al region line,
and choose for the 'Balls And Sticks' visualization option
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Now we have defined the regions that we need, now set up the temperature regime:
Panel bar Model → Temperature Regime
Press the '+' button in front of the Regime label twice to add two temperature
steps
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At iteration 0, we start with an MD simulation at T=0 K:
change the first 298.0 to 0.0 (note this applies to region All which is
everything)
At iteration 20000, we set the water temperature to 2000 K, while keeping the aluminum temperature at 0 K:
Change the number of iterations from 10000 to 20000
Press the + button on the right side of the line starting with 20000
Change the first All on the 20000 step to Al, and change its temperature to
0.0 K
Change the second All on the 20000 step to Water, and change its temperature
to 2000.0 K
Your temperature regime setup should look like this:
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Step 5: Run the simulation
Now we can run our set up:
File → Run
When asked to save, specify Al-water as filename
Let it run for some time (until iteration 500 or so)
SCM → Movie
View → Molecule → Balls And Sticks
Rotate and zoom to get a good view of the surface
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If you look around, you will most likely see many water molecules attaching to the aluminum surface. After
some time, you might also see hydrogen atoms distracted from the water molecules, which are now moving
around the surface on their own.
You might leave the simulation running to see what will happen. It will take a lot of time though.
If you do not want to wait for the simulation to finish, kill the job:
Bring the ADFjobs window to the front
Make sure your Al-water job is selected (click once on it if not)
Kill it Job → Kill
Close all GUI modules: SCM → Quit All
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COSMO-RS GUI Tutorials
This part will provide a hands-on tutorial demonstrating the COSMO-RS GUI. Its purpose is to give a quick
tour of the main features of the COSMO-RS GUI.
The first tutorial describes how to create COSMO result files that are needed as input for the COSMO-RS
calculation. The second tutorial describes some analysis tools (sigma profile, sigma potential), and shows
how to set COSMO-RS parameters. The third tutorial describes how to calculate properties, such as solvent
vapor pressures, solvent boiling points, partition coefficients (log P), activity coefficients, solvation free
energies, Henry's law coefficients, solubilities, vapor liquid diagrams binary mixture (VLE/LLE), and excess
energies. The fourth tutorial describes how to use the COSMO-RS compound database ADFCRS-2010 of
COSMO result files. The fifth tutorial describes how to calculate pKa values
Additional information may be found in the COSMO-RS part of the GUI Reference manual and COSMO-RS
manual

Tutorial 1: COSMO result files
If you already have COSMO result files for all the compounds that you are interested in you can skip this
tutorial, without problems of continuity. For example, ADF has a database of COSMO result files, the
COSMO-RS compound database ADFCRS-2010.
The purpose of this tutorial is to teach you how to make data for a compound using the ADF program such
that it can be read by COSMO-RS. COSMO-RS expects so called COSMO result files, which are results of
quantum mechanical calculation using COSMO. In ADF such a COSMO result file is called a TAPE21 (.t21)
file, or a COSKF (.coskf) file. For example the COSMO-RS compound database ADFCRS-2010 consists of
.coskf files. In other programs such a file can be a .cosmo file. For example, at http://www.design.che.vt.edu/
VT-Databases.html a database of .cosmo files can be found, which were made with a different program.
Note that the optimal COSMO-RS parameters may depend on the program chosen.
Please read through the first ADF-GUI tutorial before starting with this tutorial, see the ADF-GUI tutorials.
Even better: try using the ADF-GUI yourself, especially Tutorial 1
In this tutorial an ADF COSMO result file and a MOPAC COSMO result file is made. For ADF COSMO-RS
calculations the recommended choice is to use ADF COSMO result files.

Step 1: Start ADFinput
For this tutorial we prefer to work in a separate directory, for example a directory called Tutorial, as was
explained in ADF-GUI Tutorial 1.
You know how to start ADFjobs (in your home directory), and move to the Tutorial directory:
Start adfjobs
Click on the Tutorial folder icon
Next start ADFinput using the SCM menu.
Select the SCM → New input menu command.
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Step 2: Create the molecule
First we construct a water molecule, and preoptimize its geometry:
Select the O-tool by clicking on the button with the 'O'
Click somewhere in the drawing area to create an oxygen atom
Select the select-tool by clicking on the button with the arrow
Click once in empty space so nothing is selected
Select Atoms → Add Hydrogen
Click the optimizer button
Your water molecule should look something like this:

Step 3: ADF COSMO result file
The next step is to optimize the gas geometry using ADF, and perform the ADF COSMO calculation at the
optimized gas phase geometry.
Enter a proper title in the Title field (like 'water')
Select Preset → COSMO-RS Compound

324

For your information, the proper settings for the gas phase geometry optimization are: the Becke Perdew
exchange correlation functional (GGA:BP), use of the scalar relativistic ZORA Hamiltoninan, a TZP small
core basis set (for Iodine a TZ2P small core basis set), and an integration accuracy of 6. Like for Iodine for
heavier elements than Krypton, a TZ2P small core basis set is recommended. Note that these settings were
used for the optimization of the COSMO-RS parameters.
With the proper options selected, now run ADF:
Select File → Run
In the file select box, choose a name for your file
(for example 'water_gasphase' to make a distinction in the
names of the gas phase molecule and the solvated molecule)
and click 'Save'
Now ADF will start automatically, and you can follow the calculation using the logfile that is automatically
shown.
Wait until the optimization and ADF-COSMO calculation are ready (should take
very little time)
Click 'Yes' in the pop-up to read the coordinates from a .t21 file.
Now the geometry of the water molecule is the optimized one, and the ADF COSMO calculation has been
performed. The result file water.coskf, which is an ADF COSMO result file, can be used as input for a
COSMO-RS calculation.
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Note that a .coskf file is not a complete .t21 file. For example, if one has such a .coskf file, only the COSMO
surface charge density can be viewed with ADFview. Thus a .coskf file is mostly useful for COSMO-RS
calculations.

Expert details
If you do not want to optimize the geometry, set 1 to the number of geometry iterations in Details →
Geometry Convergence. More details on parameters used in the COSMO calculation can be found in
Model → Solvation, and Details → COSMO. See also the COSMO-RS manual.

Step 4: MOPAC COSMO result file
A MOPAC COSMO result file can be created in almost the same way as an ADF COSMO result file. In this
step we will skip the first steps of creating the water molecule. We will change the program from ADF to
MOPAC, and select the COSMO solvation method.
Select ADF → Mopac
Select Solvation Method → COSMO-CRS

For sake of clarity we will save the COSMO calculation under a different name, and run the calculation
Select the 'Save As..' command from the 'File' menu
In the file select box, choose 'water_mopac' as name for your file and click
'Save'
Select File → Run
Wait until the optimization is ready (should take very little time)
Click 'Yes' in the pop-up to read the coordinates from a .rkf file.
After the calculation has finished the file water_mopac.coskf, which is a MOPAC COSMO result file, can be
used as input for a COSMO-RS calculation.
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Expert details
Note that MOPAC is a semi-empirical quantum chemistry program, whereas ADF is based on density
functional theory (DFT). Thus the MOPAC COSMO result files will not be of the same quality as the ADF
COSMO result files.
Part of the COSMO parameters that are set can be found if one selects Details → Run Script. Technically
ADFinput will add some keywords to the input for MOPAC (see also http://www.openmopac.net) in case of a
MOPAC COSMO calculation:
PM7 EPS=9999.9 RSOLV=1.3 COSWRT NSPA=362

Tutorial 2: COSMO-RS overview: parameters and analysis
Step 1: Start ADFcrs
For this tutorial it is convenient to start with an empty directory, for example, with the name Tutorial.
On a Unix-like system, enter the following command:
$ADFBIN/adfcrs &
On Windows, one can start ADFcrs by double-clicking on the ADFcrs icon on the Desktop:
double click the ADFcrs icon on the Desktop
On Macintosh, use the ADF2013.01 program to start ADFcrs:
double click on the ADF2013.01 icon which will start ADFjobs
Select SCM → COSMO-RS
Alternatively if you know how to start ADFjobs (in your home directory), and move to the Tutorial directory:
cd $HOME
Start adfjobs
Click on the Tutorial folder icon
Select SCM → COSMO-RS
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This ADFcrs window consists of the following main parts:
• the menu bar with the menu commands
• on the left: a list of compounds
• on the right: some properties for the selected compound
This is the so called List of Added Compounds, which is the window you will get if you select Compounds
→ List of Added Compounds.
If you run the COSMO-RS GUI the first time, you will be asked if you would want to download and install the
COSMO-RS compound database:

If you have the permission to write such directory (in $ADFHOME/atomicdata/ADFCRS-2010), it is
recommended to download this COSMO-RS compound database. You may need to have administrator
priveleges to do so. On the other hand, for this tutorial, it is not necessary that the COSMO-RS compound
database is downloaded.

Step 2: Add Compounds
In tutorial 1 it was shown how to make ADF COSMO result files. In this tutorial we will use some ADF
COSMO result files that were made before. These files can be found the directory $ADFHOME/examples/
crs/Tutorial2. Copy these COSMO result files (water.coskf, methanol.coskf, ethanol.coskf, and
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benzene.coskf) to the directory Tutorial. As the name suggests these are COSMO result files of water,
methanol, ethanol, and benzene, respectively.
Note that these COSKF (.coskf) files contain only the part of an ordinary TAPE21 (.t21) file which is needed
in a COSMO-RS calculation. These COSKF files can only partly be used in ADFview, for example.
Select Compounds → Add Compound(s)

A file select box will open, that looks like (may look different on different platforms)

or

Select Files of type (or Filter) → COSMO kf file (*.coskf)
Select muliple files: benzene.coskf ethanol.coskf methanol.coskf and
water.coskf
Click 'Open'
On the right side of the List of Added Compounds one finds some data that was written from the last file
that was opened, in this case water.coskf. Here it is also possible to add some pure compound input data.
We will not do so now since there is no need. For some other types of compounds user input is required at
this point, however. We will encounter an example of that in the next step.
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Step 3: Set pure compound parameters
In the COSMO-RS model (see Ref.[2] in the COSMO-RS manual) there is a ring correction term. This is
important for, for example, the benzene molecule, which has 6 ring atoms. However, it is really required only
when the vapor pressure of the compound is going to be computed (either because that is explicitly
requested or because it is used in predicting partial vapor pressures in a mixture or gas/liquid partitioning
coefficients).
For some properties, like solubility of a solid, one can or one has to include some pure compound properties
in the left window of the List of Added Compounds for a selected compound.
It is possible to save this pure compound data in as a new COSKF file (or COSMO file).
Click in the left window (in the List of Added Compounds) benzene
Enter '6' without quotes in the 'Nring' field in the right window
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To save this data in a .coskf file
Click in the left window (in the List of Added Compounds) benzene
Select Compounds → Save Data Selected Compound As
Enter the name 'benzene' in the 'Filename' field
If you have followed this tutorial from the start then you will overwrite an existing benzene.coskf file. You will
be asked if you want to to that, click 'Yes'. The writing can take some time, especially for larger compounds.
During this time the COSMO-RS GUI is not available for other actions.

Step 4: COSMO-RS and COSMO-SAC parameters
One can easily change between the COSMO-RS or COSMO-SAC method that is going to be used in the
calculation by selecting Method → COSMO-RS or Method → COSMO-SAC. Here we will use COSMO-RS,
since ADF was parametrized for this method.
Select Method → COSMO-RS
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Expert option: set COSMO-RS parameters
Select Method → COSMO-RS
Select Method → Parameters

Default 'ADF combi2005' COSMO-RS parameters are selected, which are ADF optimized COSMO-RS
parameters. See also a discussion of the COSMO-RS parameters in the COSMO-RS manual. If one selects
the 'Klamt' option for 'Use: ... COSMO-RS parameters', the optimized parameters are chosen, which are
optimized by Klamt et al., see Ref. [2] in the COSMO-RS manual.

Expert option: set COSMO-SAC parameters
Select Method → COSMO-SAC
Select Method → Parameters
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Only the activity coefficients are calculated according to the COSMO-SAC method. Vapor pressure will be
approximated using ideas from the COSMO-RS method, and not using the COSMO-SAC method. In order
to do that some COSMO-RS parameters can be set that are used in an ADF COSMO-SAC calculation. See
also a discussion of the COSMO-SAC parameters in the COSMO-RS manual.
For the rest of the tutorial the COSMO-RS method will be used:
Select Method → COSMO-RS

Step 5: Visualize the COSMO surface: ADFview
You can use ADFview to have a look at the COSMO surface, and the COSMO surface charge density. This
is possible if the COSMO result file of the compound is a .coskf file or a .t21 file.
Select Compounds → List of Added Compounds
Click on the left side water
Select Compounds → Show Selected Compound
An ADFview window should pop-up
Select ADFview → Add →
COSMO: Surface Charge Density → on COSMO surface (reconstructed)
Select ADFview → View → Background → White
Then you will see something like:
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The red part represents positive COSMO charge density (the underlying molecular charge is negative), the
blue part negative COSMO charge density (the underlying molecular charge is positive). You can also look
at the COSMO surface points themselves.
Select Add → COSMO: Surface Charge Density → on COSMO surface points

The small spheres represent the COSMO surface points that are used for the construction of the COSMO
surface.
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Next we will close this ADFview window.
Select the ADFView window 'water'
Select File → Close
Select the COSMO-RS GUI window
ADFview has many options to change the look of the picture.
Select Compounds → Compounds
Click on the left side methanol
Select Compounds → Show Selected Compound
An ADFview window should pop-up
Select ADFview → Add →
COSMO: Surface Charge Density → on COSMO surface (reconstructed)
Select ADFview → View → Background → White
Check ADFview → View → Anti-Alias
Increase the size of the ADFView window, such that a control line
at the bottom of the ADFview window is visible
In the control line click on the 'Cosmo surface' pull-down menu and
use the Show Details command
Change the Opacity to 70

Next we will close this ADFview window.
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Select the ADFView window 'methanol'
Select File → Close
Select the COSMO-RS GUI window

Step 6: Analysis: The sigma profile
The σ-profile shows the amount of surface area for a given COSMO charge density.
Select Analysis → Sigma Profile Pure Compounds
Check the '+' button to add 'benzene', 'ethanol', 'methanol', and 'water'

Select File → Run
Click 'Yes' when asked to 'Save changes (required to run)?'
Enter the name 'tutorial2' in the 'Filename' field
The sigma profiles (σ-profile) of the four pure compounds will be shown in a graph and in a table in the right
part of the window. The whole window can be resized. The relative size of the left part of the window
compared to the right part can be changed if one moves the sash that is in between these parts. In the right
part of the window one can also change the relative size of the upper part compared to the lower part if one
moves the sash that is in between these parts.
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With default settings, if one clicks in the graph one can zoom (right mouse, or Command-Left (drag up or
down)), or translate (left mouse) the graph. If one clicks in the graph window at the left or below the axes, a
popup window will appear in which one can set details for the graph window.
Note that the σ-profile depends on the method (COSMO-RS or COSMO-SAC) that was used in the
calculation. Here we have used COSMO-RS. In this case the σ-profile depends on the actual value for r_av
(rav), which is one of the COSMO-RS parameters, see one of the previous steps.
One can also look at the hydrogen bonding part of the σ-profile.
Select Graph → Y axes → hydrogen bonding (HB) part sigma profile

Step 7: Analysis: The sigma potential
Select Analysis → Sigma Potential Pure Compounds
Check the '+' button to add 'benzene', 'ethanol', 'methanol', and 'water'
Press 'Run'
The sigma potentials (σ-potential) of the four pure compounds will be shown in a graph and in a table in the
right part of the window. The σ-potential depends on the temperature of a compound. Here the temperature
is set to 25 °C (298.15 K).
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In the details for the graph window the line widths for all curves were set to '3'.
Note that the σ-potential is not calculated for values of the COSMO charge density that are non-existent on
the COSMO surface of a certain compound.
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Tutorial 3: COSMO-RS overview: properties
How the properties are calculated and definitions used can be found in the section Calculation of properties
in the COSMO-RS manual.

Step 1: Start ADFcrs
For this tutorial we assume that you know how start ADFcrs and how to add compounds. Like in tutorial 2
we ask you to add the compounds water, methanol, ethanol, and benzene. One can do this, for example, by
opening the .crs file that was created in tutorial 2. Save the file as tutorial3.crs.
Start ADFcrs
Select File → Open...
Select 'tutorial2.crs' in the 'Filename' field
Select File → Save As
Enter the name 'tutorial3' in the 'Filename' field
Alternatively on a Unix like system one may copy the COSMO result files (water.coskf, methanol.coskf,
ethanol.coskf, and benzene.coskf) in the directory $ADFHOME/examples/crs/Tutorial2 to an empty directory
and enter the following command in this directory where the COSMO result files are present:
$ADFBIN/adfcrs benzene.coskf ethanol.coskf methanol.coskf water.coskf &
Note that one has to set the number of ring atoms for the benzene compound.
Select Compounds → Compounds
Click on the left side benzene
Enter '6' without quotes in the 'Nring' field
Select File → Save As
Enter the name 'tutorial3' in the 'Filename' field
In the compounds window one can also set the vapor pressure of the pure compounds at a given
temperature, or set the Antoine parameters. If these values are not specified (if they are zero) then the pure
compound vapor pressure will be approximated using the COSMO-RS method. This is relevant, for
example, for the calculation of the (partial) vapor pressures of mixtures, calculation of boiling points of
mixtures, and calculation of Henry's law constants.

Step 2: Vapor pressure
The vapor pressure of a solvent at different temperatures can be calculated with Properties → Vapor
Pressure Pure Solvents or Properties → Vapor Pressure Mixture.
Select Properties → Vapor Pressure Pure Solvents
Check the '+' button to add 'methanol'
Select unwanted solvents in the the list
Check the '-' button to remove these unwanted solvents
Press 'Run'
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In this case the result is a table with one entry:

Select Celsius for the unit of temperature
Enter '0.0' without quotes in the 'Temperature from:' field
Enter '100.0' in the 'to:' field
Press 'Run'
In this case the result is a graph and a table. If one clicks in the graph window at the left or below the axes, a
popup window will appear in which one can set details for the graph window. After some manipulation in the
details of the graph, the graph can look like:
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In this case COSMO-RS predicts a vapor pressure of about 0.61 bar (around 455 Torr) at 323.15 K (50.0
°C) for the pure liquid methanol.

Step 3: Boiling point
The boiling point of a solvent at different pressures can be calculated with Properties → Boiling Point Pure
Solvents or Properties → Boiling Point Mixture.
Select Properties → Boiling Point Mixture
Select '2 components' in the popup menu next to Solvent
Select 'methanol' for the first component in the Solvent
Select 'ethanol' for the second component in the Solvent
Enter '0.5' for the 'Mole fraction' of methanol
Enter '0.5' for the 'Mole fraction' of ethanol
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Select atm for the unit of pressure
Enter '0.1' in the 'Pressure from:' field
Enter '1.0' in the 'to:' field
Press 'Run'

In this case the result (may take several seconds) is a graph and a table.

The red curve is the total vapor pressure, the blue curve the partial methanol vapor pressure, and the green
curve is the partial ethanol vapor pressure. The table gives the numerical values.
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Thus in this case COSMO-RS predicts a boiling point of 339.8 K (66.7 °C) at 1 atm. for this mixture of 50%
mole fraction methanol and 50% mole fraction ethanol. At this temperature COSMO-RS predicts that the
vapor consists about 69% of methanol.
Using Graph → Y Axes → one can view different properties in the graph, like activity coefficients and
excess energies.
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Step 4: Flash point
The flash point of a mixture can be calculated with Properties → Solvent Flash Point, if pure compound
flash points are given as input.
Here we mix equal volumes of water (assuming a density of 0.997 kg/L) and ethanol (assuming a density
0.789 kg/L). For a flash point calculation the pure compound flash points are needed as input, since
COSMO-RS does not predict pure compound flash points. The ADF COSMO-RS module uses Le
Chatelier's mixing rule to calculate the flash point of a mixture.
Select Compounds → List of Added Compounds
Select 'ethanol'
Enter '286' for the 'Flash point' of ethanol
Select Properties → Flash Point
Change the popup menu 'Mole fraction' in 'Mass fraction'
Select 'ethanol' for the first component in the Solvent
Select 'water' for the second component in the Solvent
Enter '0.442' for the 'Mass fraction' of ethanol
Enter '0.558' for the 'Mass fraction' of water
Press 'Run'

In this case the calculated flash point will be close to 25 °C.
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Step 5: Activity coefficients, Henry coefficients, Solvation free energies
The activity coefficients a solvent and the activity coefficients of infinitely diluted solutes in a solvent can be
calculated with Properties → Activity coefficients. At the same time Henry coefficients and solvation free
energies will be calculated.
Select Properties → Activity coefficients
Select 'water' for the first component in Solvent
Add 'benzene', 'ethanol', and 'methanol' to the list of Solutes
Press 'Run'

If one does not supply a density of the solvent in the input the program calculates the density of the solvent
by dividing the mass of a molecule with its COSMO volume. Note that the calculated activity coefficients do
not depend on this density. One may improve the results for the calculation of the Henry constants, by
selecting a compound in the List of Added Compounds, and include pure a compound vapor pressure at a
given temperature.
The result of the calculation is given in the form of a table.
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Relevant for the calculation of the Gibbs free energy of solvation ΔG from the gas phase to the solvated
phase is the reference state, used here is 1 mol/L in both phases.

Step 6: Partition coefficients (log P)
Preset Octanol/Water, Benzene/Water, Ether/Water, Hexane/Water
The partition coefficients (log P) of infinitely diluted solutes in a mixture of two immiscible solvents can be
calculated with Properties → Solvent Log Partition Coefficients. There are presets for the calculation of
Octanol/Water, Benzene/Water, Ether/Water, and Hexane/Water partition coefficients. The presets use
compounds that are present in $ADFHOME/atomicdata/ADFCRS. First the preset Octanol/Water is used.
Select Properties → Partition Coefficients (LogP)
Select 'Preset Octanol-Water' in the popup menu next to Solvent
Add 'benzene', 'ethanol', and 'methanol' to the list of Solutes
Press 'Run'
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In case of partly miscible liquids, like the Octanol-rich phase of Octanol and Water, both components have
nonzero mole fractions. The preset also gives a value for the molar volume quotient of the two solvents.
The result of the calculation is given in the form of a table.

User defined
A user can also define 2 phases of a mixture of two (or three) immiscible solvents.
Select Properties → Partition Coefficients (LogP)
Select 'User Defined 2 components' in the popup menu next to Solvent
Select 'benzene' for the first component in the solvent
Select 'water' for the second component in the solvent
Click the check box 'Use input volume solvent phase 1/phase 2'
Enter '4.93' in the 'Use input volume solvent phase 1/phase 2' field
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Add 'ethanol', and 'methanol' to the list of Solutes
Press 'Run'

Here an input value is used for the volume quotient of the two solvents. If one does not include such value,
the program will use the COSMO volumes to calculate the volume quotient. The COSMO volumes can be
found by selecting a compound in the List of Added Compounds.
The result of the calculation is given again in the form of a table.
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Step 7: Solubility
The solubility of a solute in a solvent can be calculated with Properties → Solubility in Pure Solvents or
Properties → Solubility in Mixture. The solute can either be a liquid, solid, or gas.

Solubility liquid in a solvent
First the solubility of benzene in water for a range of temperatures.
Select Properties → Solubility in Pure Solvents
Check the '+' button to add 'water'
Select 'benzene' for the 'Solute'
Enter '273.15' without quotes for the temperature in the 'from:' field
Enter '373.15' in the 'to:' field
Press 'Run'

If a range of temperatures is requested a graph is shown.
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The assumption made in the solubility calculation may be invalid in case of a solubility of a liquid in a
solvent, especially if the solubility of the solvent in the liquid is high. For binary systems one may check this
by calculating the miscibility gap in the binary mixture of the two liquids. An example is given for the
calculation of the miscibility gap in the binary mixture of Methanol and Hexane.
Note that experimentally benzene is a solid below 5.5 °C, and a gas above 80.1 °C. This has not been taken
into account in this case. See the next examples.

Solubility solid in a solvent
For the solubility of a solid compound it is necessary to include the melting point, the enthalpy of fusion, and
optionally, since it is often not so important, the Δ heat capacity of fusion of the pure compound. These
values can be given for each compound if one selects Compounds → List of Added Compounds. Here,
some experimental values will be included for benzene (see, for example, http://en.wikipedia.org/wiki/
Benzene).
Select Compounds → List of Added Compounds
Click on the left side benzene
Enter '278.7' in the 'Melting point' field
Enter '2.37' in the 'Δ_fusion H' field
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Also an experimental value for the density of water will be used:
Select Properties → Solubility in Mixture
Select 'water' for the first component in 'Solvent'
Check the '+' button to add 'benzene' in the list of Solutes
Click the check box 'Use input density solvent (kg/L)'
Enter '1.0' in the 'Use input density solvent (kg/L)' field
Change one of the popup menu's 'Kelvin' in 'Celsius'
Enter '0.0' without quotes in the 'from:' field
Enter '10.0' in the 'to:' field
Select Graph → Y Axes → solubility (g/L solvent)
Change the popup menu next to Solutes from 'Liquid' to 'Solid'
Press 'Run'
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A graph (and table) is shown, which after some manipulations could look like:
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Solubility gas in a solvent
For the solubility of a gas one should the change the 'Liquid' popup menu in 'Gas' and enter a partial
pressure in the 'Pressure' field.
Select Compounds → Compounds
Click on the left side benzene
Enter '1.01325' in the 'Pure compound vapor pressure' field
Enter '353.3' in the 'at temperature' field
Select Properties → Solubility in Mixture
Select 'water' for the first component in 'Solvent'
Check the '+' button to add 'benzene' in the list of Solutes
Click the check box 'Use input density solvent (kg/L)'
Enter '1.0' in the 'Use input density solvent (kg/L)' field
Use 'Kelvin' as unit for the temperature
Enter '353.3' without quotes in the 'from:' field
Enter '373.15' in the 'to:' field
Change the popup menu next to Solutes from 'Solid' to 'Gas'
Use 'atm' units for the pressure
Enter '1.0' for the partial vapor pressure of benzene
Select Graph → Y Axes → solubility (mol/L solvent)
Press 'Run'
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A graph (and table) is shown, which after some manipulations could look like:

The solubility of a gas in a solvent can also be calculated using Henry's law, which is valid for ideal dilute
solutions,
Select Properties → Activity coefficients
Select 'water' for the first component in Solvent
Click the check box 'Use input density solvent (kg/L)'
Enter '1.0' in the 'Use input density solvent (kg/L)' field
Use 'Celsius' as unit for the temperature
Enter '90.0' for 'Temperature'
Select only 'benzene' in the list of 'Solutes (infinite dilute)'
Press 'Run'
The calculated Henry constant for benzene (infinite dilute) in water will be close to 0.049 mol/(L atm) at 90
°C.
Note that for benzene in the compounds window the vapor pressure of benzene at 353.3 Kelvin was
entered. If these values are not specified (if they are zero) then the vapor pressure will be approximated
using only the COSMO-RS method. This is relevant for all properties where the vapor pressure plays a role,
thus it is relevant for the calculation of Henry's law constants and relevant for the calculation of the solubility
of a gas in a solvent.
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Step 8: Binary mixtures VLE/LLE
A phase diagram of a mixture of two components can be calculated with Properties → Binary Mixture
VLE/LLE. The binary mixture will be calculated for a list of molar fractions between zero and one. This can
be done at constant temperature (isothermal) or at constant vapor pressure (isobaric).

Isothermal
A binary mixture is calculated in which the pure compound vapor pressures are approximated using the
COSMO-RS method.
Select Properties → Binary Mixture VLE/LLE
Select 'water' for the first compound
Select 'methanol' for the second compound
Use 'Kelvin' as unit for the temperature
Enter '298.14' in the 'Temperature' field
Press 'Run'

An activity coefficient plot for water(1) and methanol(2) will be shown.
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The results of the calculation are also given in the form of a table, which shows the molar (and mass)
fraction of each compound in the liquid, the activity coefficients, the activities, the temperature, the total and
partial vapor pressures, the molar fraction of each compound in the vapor (Y), the excess Gibbs free energy
GE, the excess enthalpy HE (calculated with the Gibbs-Helmholtz equation), the excess entropy of mixing TSE, the Gibbs free energy of mixing Gmix, the enthalpy of vaporization ΔvapH (calculated with the ClausiusClapeyron equation).

357

These values can also be shown in a graph. The property for the x- and y-axes can be selected from the
'Graph' Menu. For example, a graph of the excess energies can be shown by:
Select Graph → Y Axes → excess energies
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A plot of the excess energies will be shown.

The red curve is the excess Gibbs free energy GE, the blue curve is the excess enthalpy HE, and the green
curve is -T times the excess entropy SE.

Isothermal, input pure compound vapor pressure
A binary mixture is calculated with input data for the pure compound vapor pressures. These can be, for
example, experimentally observed pure compound vapor pressures. Note that the calculated partial and
total vapor pressures will now depend on these input pure compound vapor pressures.
Select Compounds → List of Added Compounds
Click on the left side water
Enter '0.123416' in the 'Pure compound vapor pressure:' field
Enter '322.45' in the 'at temperature:' field
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Click on the left side ethanol
Enter '0.294896' in the 'Pure compound vapor pressure:' field
Enter '322.45' in the 'at temperature:' field
Select Properties → Binary Mixture VLE/LLE
Select 'water' for the first compound
Select 'ethanol' for the second compound
Enter '322.45' in the 'Temperature' field
Select Graph → X Axes → x2: molar fraction 2
Select Graph → Y Axes → partial and total vapor pressures
Press 'Run'
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A vapor liquid equilibrium (VLE) diagram for water(1) and ethanol(2) will be shown.

The red curve is the total vapor pressure, the blue curve is the partial water vapor pressure, and the green
curve is the partial ethanol vapor pressure. One can also change the x and y axes, for example:
Select Graph → X Axes → x2, y2
Select Graph → Y Axes → total vapor pressure

Isothermal, miscibility gap, LLE
Water and benzene do not mix well, thus there will be a miscibility gap.
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Select Properties → Binary Mixture VLE/LLE
Select 'water' for the first compound
Select 'benzene' for the second compound
Use 'Celsius' as units for the temperature
Enter '50.0' in the 'Temperature' field
Enter '100' for 'Number of mixtures'
In this case a a liquid-liquid equilibrium (LLE) is calculated. The number of mixtures for which the binary
mixture is calculated should be not too small, otherwise the properties of the 2 immiscible liquids phases will
not be so accurate.

If the check box Graph → X axes → force 1 liquid phase within possible miscibility gap is deselected,
then results will be shown in the graph and table only for those compositions of the mixture, which are
outside of the miscibility gap. If the check box Graph → X axes → force 1 liquid phase within possible
miscibility gap is selected, then results will be shown also within the miscibility gap, with the unphysical
conditions that the two liquids are forced to mix.
Deselect check box
Graph → X axes → force 1 liquid phase within possible miscibility gap
Select check box
Graph → X axes → force 1 liquid phase within possible miscibility gap
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Isobaric
A binary mixture is calculated in which the pure compound vapor pressures are approximated using the
COSMO-RS method if the input values for the pure compound vapor pressures are zero. Alternative one
can click a check box in the 'Method' Menu.
Select Method → Parameters
Click on the check box 'use input (Compounds Menu) pure compound vapor
pressures(s)'
to deselect it

Select Properties → Binary Mixture VLE/LLE
Select 'methanol' for the first compound
Select 'ethanol' for the second compound
Enter '10' for 'Number of mixtures'
Select Isotherm, isobar, flash point → isobar
Select Graph → X Axes → x1: molar fraction 1
Select Graph → Y Axes → temperature
Press 'Run'

The calculated boiling points (may take several seconds) for a binary mixture of methanol(1) and ethanol(2)
will be shown.

363

If one clicks in the graph window at the left or below the axes, a popup window will appear in which one can
set details for the graph window. In the graph above the 'Units' for the 'Left Y Axes' were chosen to be
'Celsius'.
Next the same binary mixture is calculated in which experimental pure compound vapor pressures are used.
Select Method → Parameters
Click on the check box 'use input (Compounds Menu) pure compound vapor
pressures(s)'
to select it

Select Compounds → Compounds
Click on the left side methanol
Enter '1.01325' in the 'Pure compound vapor pressure:' field
Enter '338' in the 'at temperature:' field
Click on the left side ethanol
Enter '1.01325' in the 'Pure compound vapor pressure:' field
Enter '351' in the 'at temperature:' field
Select Properties → Binary Mixture VLE/LLE
Press 'Run'
The calculated graph will look not very different, but it will be more accurate.

Step 9: Ternary mixtures VLE/LLE
A phase diagram of a mixture of three components can be calculated with Properties → Ternary Mixture
VLE/LLE. The ternary mixture will be calculated for a list of molar (or mass) fractions between zero and one,
for each of the compounds. This can be done at constant temperature (isothermal) or at constant vapor
pressure (isobaric).
In this step we will use experimental boiling points as input.
Select Compounds → Compounds
Click on the left side water
Enter '1.01325' in the 'Pure compound vapor pressure:' field
Enter '373.15' in the 'at temperature:' field
Click on the left side methanol
Enter '1.01325' in the 'Pure compound vapor pressure:' field
Enter '338' in the 'at temperature:' field
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Click
Enter
Enter
Click
Enter
Enter

on the left side benzene
'1.01325' in the 'Pure compound vapor pressure' field
'353.3' in the 'at temperature' field
on the left side ethanol
'1.01325' in the 'Pure compound vapor pressure:' field
'351' in the 'at temperature:' field

Isothermal
Select Properties → Ternary Mixture VLE/LLE
Select 'methanol' for the first compound
Select 'ethanol' for the second compound
Select 'benzene' for the third compound
Use 'Mole fraction'
Enter '10' for 'Number of mixtures'
Select Graph → X Axes → x1: molar fraction 1
Select Graph → Y Axes → x2: molar fraction 2
Select Graph → Z Colormap → total vapor pressures
Select Isotherm, isobar, flash point → isotherm
Use 'Celsius' as units for the temperature
Enter '70.0' in the 'Temperature' field
Press 'Run'

The result will be a graph and a table. In the table one can find the results of the calculation at 55
(=(n+1)(n+2)/2, with n=10) different compositions. At those compositions the table shows the molar (and
mass) fraction of each compound in the liquid, the activity coefficients, the activities, the temperature, the
total and partial vapor pressures, the molar fraction of each compound in the vapor (Y), the excess Gibbs
free energy GE, the excess enthalpy HE (calculated with the Gibbs-Helmholtz equation), the excess entropy
of mixing -TSE, the Gibbs free energy of mixing Gmix, the enthalpy of vaporization ΔvapH (calculated with the
Clausius-Clapeyron equation).
These quantities can also be shown in the graph as a colormap, in which the color represents the value of
the quantity at a certain composition. On the X axes of the graph one can choose the molar (or mass
fraction) of one of the compoumds, on the Y axes one can choos the molar (or mass fraction) of another
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compoumd. The molar (or mass) fraction of the third compound is then fixed, since the sum of the fractions
is 1.
In this case the colormap shows the total vapor pressure:

One can improve the quality of the graph by increasing the number of compositions. Note that the number of
different compositions for n=20 is 231 (=(n+1)(n+2)/2).
Enter '20' for 'Number of mixtures'
Press 'Run'
If one clicks in the graph window at the left or below the axes, a popup window 'Graph details' will appear in
which one can set details for the graph window. If one chooses in the 'Z Colormap' part of this popup
window as the minimum color magenta, as maximum color red, use 100 as number of colors, and change
the minimum and maximum values, then the graph could look like this:
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Isobaric
Note that isobaric calculations are more expensive than isothermal calculations. Thus the following example
takes quite some time, since again for n=20 the number of different compositions is 231.
Select Properties → Ternary Mixture VLE/LLE
Select 'water' for the first compound
Select 'ethanol' for the second compound
Select 'benzene' for the third compound
Use 'Mole fraction'
Enter '20' for 'Number of mixtures'
Select Isotherm, isobar, flash point → isobar
Use 'bar' as units for the pressure
Enter '1.01325' in the 'Pressure' field
Select Graph → X Axes → x1: molar fraction 1
Select Graph → Y Axes → x2: molar fraction 2
Select Graph → Z Colormap → temperature
Press 'Run'
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The result will be a graph and a table. Note that this may take some time, since isobaric calculations are
more expensive than isothermal calculations. Click in the graph window at the left or below the axes. If one
chooses in the 'Z Colormap' part of the 'Graph details' as the minimum color blue, as maximum color red,
use 5 as number of colors, change the unit to Celsius, and change the minimum and maximum values, then
the graph could look like this:

In addition to the colormap of the temperature, an approximate miscibility gap of the ternary mixture is
shown in the graph. In this case, within the miscibility gap there are two immiscible phases of the liquid in
equilibrium. The composition of the two phases, which are in equilibrium, can be found at the end points of
the tie line that are drawn. The calculated temperatures within the miscibility gap are calculated with the
unphysical condition that the three liquids are forced to mix, thus these calculated temperatures (and other
quantities) within the miscibility gap should not be used. By inspection of the graph, one can observe that
the calculated minimum boiling point (azeotrope) is around 68 °C.
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Step 10: A composition line between solvents s1 and s2
A phase diagram of a mixture of two solvents, which both could be mixtures, can be calculated with
Properties → Solvents s1 - s2 Composition Line. The mixture will be calculated for a list of molar (or
mass) fractions of the solvents between zero and one, and the compositions of solvent 1 and solvent 2 are
linearly interpolated. This can be done at constant temperature (isothermal) or at constant vapor pressure
(isobaric).
In this step we will try to investigate one of the tie lines of the ternary mixture of water, ethanol, and benzene
in more detail. An attempt is made to use the tie line on which ends the calculated minimum boiling point is
found, see the tie line which is below the black line in the next picture:

The compositions of solvents s1 and s2 are chosen where the black line in the picture above crosses the
boundary of possible compositions. This means that solvent s1 and solvent s2 are mixtures of 2 compounds.
Again experimental boiling points are used in the calculation.
Select Properties → Solvents s1 - s2 Composition Line
Use 'Mole fraction'
Select '3 components' in the popup menu next to
Select 'water' for the first compound
Select 'ethanol' for the second compound
Select 'benzene' for the third compound
Enter '0.0' for the mole fraction of compound 1
Enter '0.9' for the mole fraction of compound 1
Enter '0.3' for the mole fraction of compound 2
Enter '0.1' for the mole fraction of compound 2
Enter '0.7' for the mole fraction of compound 3
Enter '0.0' for the mole fraction of compound 3
Enter '100' for 'Number of mixtures'
Select Isotherm, isobar, flash point → isobar
Use 'bar' as units for the pressure
Enter '1.01325' in the 'Pressure' field
Select Graph → X Axes → s1_x: molar fraction s1
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Select Graph → Y Axes → pure compound activities
Press 'Run'

The result will be a table and a graph.

The activities of the pure compounds should be equal at the end point of a tie line a 1 = a1',a2 = a2', and a3 =
a3'. If we look at the graph with close inspection this is approximately true for the molar fraction of solvent s1
with (approximately) s1_x = 0.007 and s1_x' = 0.91. At a molar fraction of 0.91 of solvent s1 the calculated
temperature is approximately 67.9 °C.
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Next we will use this temperature of 67.9 °C and look at the Gibbs free energy of mixing. This will also give
information about the miscibility gap.
Select Isotherm, isobar, flash point → isotherm
Use 'Celsius' as units for the temperature
Enter '67.9' in the 'Temperature' field
Select Graph → X Axes → s1_x: molar fraction s1
Select Graph → Y Axes → Gibbs energy of mixing wrt pure compounds
Press 'Run'
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The black line was added to show the miscibility gap more clearly. Indeed at 67.9 °C for molar fractions
between s1_x = 0.007 and s1_x' = 0.91, the Gibbs free energy of mixing will be lower if the liquid has 2
phases.
Note, that one should use isothermal conditions, if one wants to use the calculated Gibbs free energy of
mixing to determine whether there is a miscibility gap. Note also, that no miscibility gap is calculated if one
uses Properties → Solvents s1 - s2 Composition Line, even if there is one, like in this case. This is
because with the calculated values for only 1 composition line between 2 solvents, that involve more than 2
compounds, in general one does not have enough information to determine the exact miscibility gap.

Tutorial 4: Examples using the COSMO-RS compound
database
ADF has a database of COSMO result files, the COSMO-RS compound database ADFCRS-2010.

4.1: Install and use the COSMO-RS compound database
Step 1: Install database
For this tutorial we assume that you know how start ADFcrs. Next we will install the ADFCRS-2010
database.
ADFcrs → Compounds → Install COSMO-RS databse...
Follow the instructions
The downloading and reading of some information about all compounds may take a minute. More
information this database can be found on this page. You must have the permission to write this database
(in $ADFHOME/atomicdata/ADFCRS-2010). You may need to have administrator priveleges to do so. For
this tutorial it is necessary that the COSMO-RS compound database is downloaded in the correct directory
$ADFHOME/atomicdata/ADFCRS-2010.

Step 2: Add or search compounds
There are several ways to select a compound from the database and add it too the List of Added
Compounds. The easiest way is to use the search button. A separate search window will popup if one
clicks the search button. In the List of Added Compounds this search button looks like:

In other windows it can look like:

(to select 1 compound) or

Select Compounds → Compounds
Click on the search button
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(to add multiple compounds).

Click
Click
Click
Click
Click
Click
Enter
Click
Click

on 'CAS' to sort by CAS registry number
again to reverse the order
on 'Nr' to sort by number
on 'dNr' to sort by database number
on 'Name' to sort by name
on 'Formula' to sort by formula
'pentanol' in the 'Search' field
on 'Cyclopentanol'
'OK'

Now Cyclopentanol is added to the List of Added Compounds. If the search button is used again
Cyclopentanol will have number 1.

In the COSMO-RS databse there is a file called 'all.compoundlist', which is a plain text file, in which on each
line a filename of a ADF COSMO result file is given. One could make a different .compoundlist file which
contains a only a selection of the compounds. This can be handy if one wants to add compounds to the List
of Added Compounds.
The compounds could also have been added by adding multiple .coskf files, by selecting 'COSMO kf file
(*.coskf)' for the popup menu 'Files of type' (or 'Filter'), and selecting all .coskf files. On Windows it may,
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however, fail to add more than a few hundred .coskf files at a time in this way. If that fails, one should use
the .compoundlist file.

Step 3: Set pure compound data
For the compounds in this database the number of ring atoms (Nring) is provided, which is needed in the
COSMO-RS model (see Ref.[2] in the COSMO-RS manual) in order to calculate a ring correction term.
After selecting Compounds → List of Added Compounds and selecting a compound it is also possible to
add some pure compound input data. Pure compound data could be found, for example, at Refs. [411-413].
If one wants to save the pure compound input data in a .coskf file Select Compounds → Save Data
Selected Compound As.

References
[411] Wikipedia
[412] NIST Chemistry WebBook
[413] CHERIC. Korea Thermophysical Properties Data Bank: Pure Component Properties

Step 4: Visualize the COSMO surface: ADFview
You can use ADFview to have a look at the COSMO surface, and the COSMO surface charge density. Here
we use the selected cyclopentanol of the previous step.
Select Compounds → List of Added Compounds
Click on the left side 'Cyclopentanol'
Select Compounds → Show Selected Compound
Select the ADFView window 'Cyclopentanol'
Select ADFview → Add → COSMO: Surface Charge Density →
on COSMO surface (reconstructed)
Select ADFview → Add → COSMO: Surface Charge Density →
on COSMO surface points
Select ADFview → View → Background → White
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Next we will close this ADFview window:
Select the ADFView window 'Cyclopentanol'
Select ADFview → File → Close
Select the COSMO-RS GUI window

4.2: Octanol-Water partition coefficients (log POW)
In this example the Octanol-Water partition coefficients for 7 different compounds are calculated and
compared to experiment.
In case of partly miscible liquids, like the Octanol-rich phase of Octanol and Water, both components have
nonzero mole fractions. Next an input value is used for the volume quotient of the two solvents. The values
for the nonzero mole fractions in the Octanol-rich phase and the molar volume quotient of the two solvents
were taken from Ref. [421]. If one does not include such value, the program will use the COSMO volumes to
calculate the volume quotient. The COSMO volumes can be found by selecting a compound in the List of
Added Compounds.
Select Properties → Log Partition Coefficients
Select 'Preset Octanol-Water' in the popup menu next to Solvent
Enter '298.15' for the 'Temperature' in 'Kelvin'
Check the '+' button to add 'Acetamide',
'Methanol', 'Formic acid', 'Diethyl ether', p-Dichlorobenzene,
'Hexamethylbenzene', and '2,2',4,4',5-Pentachlorobiphenyl'
Press 'Run'
Enter the name 'tutorial4' in the 'Filename' field
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The result of the calculation (may take a few seconds) is given in the form of a table. Note that not all
compounds were selected as solutes, otherwise the calculation would take much more time.

In the database the name 'Ethoxyethane' is used for 'Diethyl ether', and the name '1,4-Dichlorobenzene' is
used for 'p-Dichlorobenzene'. In the search window that popups if the search button is clicked, some
alternative names are given for some of the compounds.
Next the calculated Octanol-Water partition coefficients are compared to experiment in the following table.

1
2
3
4
5
6
7

Solute

experimental log
POW[422]

calculated
log POW

Acetamide
Methanol
Formic acid
Diethyl ether
p-Dichlorobenzene
Hexamethylbenzene
2,2',4,4',5-Pentachlorobiphenyl

-1.16
-0.82
-0.41
0.83
3.37
4.61
6.41

-1.20
-0.53
-0.26
1.82
3.20
4.96
6.47

References
[421] S.-T. Lin and S.I. Sandler, Prediction of Octanol-Water Partition Coefficients Using a Group
Contribution Solvation Model, Industrial & Engineering Chemistry research 38 (1999), 4081
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[422] Experimental numbers taken from Wikipedia at July 15, 2010, http://en.wikipedia.org/wiki/
Partition_coefficient. The experimental numbers may have been determined at a different temperature than
25 °C.

4.3: Henry's law constants
In this example Henry's law constants for 17 different compounds are calculated and compared to
experiment.
The Henry's law constants depend on the density of the solvent, Water in this case. If one does not supply a
density of the solvent in the input the program calculates the density of the solvent by dividing the mass of a
molecule with its COSMO volume. The density of Water at 20 °C (293.15 K) is approximately 0.998 kg/L.
Note that the calculated activity coefficients do not depend on the density of Water.
Remark: To only add the compounds needed in this example, one can also open a new COSMO-RS GUI
window (SCM → COSMO-RS), Select Compounds → Add Compound(s), go to the directory where the
COSMO-RS compound database is downloaded ($ADFHOME/atomicdata/ADFCRS-2010), and select
tutorial4.3.compoundlist. This is recommended. Then the added compounds are at the top of the list if one
uses the '+' button, or search button. The tutorial4.3.compoundlist is a file with a list of compounds that is
limited to the compounds needed in this example.
Select Properties → Activity coefficients
Select 'Water' for the first component in Solvent
Enter '293.15' for the 'Temperature' in 'Kelvin'
Click the check box 'Use input density solvent (kg/L)'
Enter '0.998' in the 'Use input density solvent (kg/L)' field
Check the '+' button to add
'Acetaldehyde', 'Acetone', 'Acetonitrile', 'Benzene', 'Chloromethane',
'Cyclopentane', 'Dimethyl sulfide', 'Ethanol', 'Formaldehyde',
'Methanol', 'Methyl acetate', 'Methyl bromide', 'Methyl fluoride',
'Methyl iodide', 'Pyridine', 'Thiophene', and 'Toluene'
Press 'Run'

The result of the calculation (may take a few seconds, depending on the number of compounds selected) is
given in the form of a table.
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The Henry's law constants also depend on the vapor pressure of the pure compounds in the gas phase. In
the compounds window one can also set these vapor pressures of the pure compounds at a given
temperature, or set the Antoine parameters. If these values are not specified (if they are zero) then the pure
compound vapor pressure will be approximated using the COSMO-RS method. Best is to include the
experimental vapor pressure for a pure compound at the used temperature, thus in this case at 293.15 K.
To include all experimental numbers is rather tedious, thus one could skip the following part, and only look at
the results below.
Select Compounds → Compounds
Click on the left side 'Acetaldehyde'
Enter '0.968' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Acetone'
Enter '0.246' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Acetonitrile'
Enter '0.095' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Benzene'
Enter '0.100' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Chloromethane'
Enter '4.94' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Cyclopentane'
Enter '0.346' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Dimethyl sulfide'
Enter '0.530' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Ethanol'
Enter '0.059' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Formaldehyde'
Enter '4.47' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Methanol'
Enter '0.129' in the 'Pure compound vapor pressure:' field
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Enter '293.15' in the 'at temperature:' field
Click on the left side 'Methyl acetate'
Enter '0.230' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Methyl bromide'
Enter '1.83' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Methyl fluoride'
Enter '33.7' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Methyl iodide'
Enter '0.443' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Pyridine'
Enter '0.021' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Thiophene'
Enter '0.082' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Toluene'
Enter '0.029' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Click on the left side 'Water'
Enter '0.02536' in the 'Pure compound vapor pressure:' field
Enter '293.15' in the 'at temperature:' field
Select Properties → Activity coefficients
Press 'Run'
For some of the compounds the Henry's law constants differ quite substantially.

Experimental determined Henry's law constants might, for example, be found at http://www.henrys-law.org,
where a 'compilation of Henry's Law constants for inorganic and organic species of potential importance in
environmental chemistry' were listed by R.Sander, and where also an explanation can be found of the many
different definitions and units for Henry's law constants.
The calculated Henry's law constants will be compared to experimental values in the next graph and table.
The experimental numbers were taken from Ref. [431], where the experimentally determined dimensionless
Henry's law constant Hcc is the inverse of the dimensionless Henry's law constant kHcc, that is used in the
COSMO-RS module.
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Hcc = kH, invcc = 1/(kHcc)

Solute

experimental Hcc@20°C [431]

calculated Hcc@20°C

1

Methyl_bromide

2.01 10-1

2.05 10-1

2

Chloromethane

3.05 10-1

3.80 10-1

3

Methyl_fluoride

6.04 10-1

9.86 10-1

4

Methyl_iodide

1.70 10-1

1.04 10-1

5

Cyclopentane

5.25 100

3.27 100

6

Benzene

1.91 10-1

1.65 10-1

7

Toluene

2.09 10-1

1.89 10-1

8

Methanol

1.37 10-4

2.43 10-4

9

Ethanol

1.48 10-4

3.70 10-4

10 Formaldehyde

8.61 10-6

2.22 10-2

11 Acetaldehyde

2.21 10-3

3.72 10-3

12 Acetrone

1.10 10-3

0.78 10-3

13 Methyl_acetate

4.02 10-3

4.89 10-3

14 Acetonitrile

6.35 10-4

6.35 10-4

15 Pyridine

1.14 10-2

2.03 10-4

16 Dimethyl_sulfide

6.35 10-2

1.82 10-1

17 Thiophene

7.46 10-2

6.23 10-2
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In most cases the calculated Henry's law constants are quite close to the experimental ones, except for
Formaldehyde and Pyridine.
The Henry's law constant of Formaldehyde is more than a factor of 103 wrong. The origin of this error is that
in Water solution the hydration of Formaldehyde leads to Methanediol, and Methanediol is even the
dominant form if one dissolves Formaldehyde in Water. This is not taken into account in the calculation. In
Ref. [432] a distinction is made between the apparent and intrinsic Henry's law constants, which differ from
each other by approximately a factor of 103 for Formaldehyde, and a factor of approximately 2.4 for
Acetaldehyde. In Ref. [432] the intrinsic Henry's law constant for Formaldehyde was determined to be 2.5
mol/(L atm) at 25 °C, which is close to the value of 1.9 mol/(L atm) which was calculated with COSMO-RS,
although at a different temperature of 20 °C.
The calculated Henry's law constant of Pyridine is approximately a factor of 102 different than the
experimental value in Ref. [431]. However, the experimental values for Pyridine taken from Ref. [433] are
1.1 102 mol/(L atm) and 9.0 101 mol/(L atm), which are not very different from the calculated value with
COSMO-RS of 2.1 102 mol/(L atm). Also the experimental values for Pyridine reported in Ref. [434] are in
much better agreement with the value calculated with COSMO-RS.

References
[431] J. Staudinger and P.V. Roberts, A critical compilation of Henry's law constant temperature dependence
relations for organic compounds in dilute aqueous solutions, Chemosphere 44 (2001), 561
[432] E.A. Betterton and M.R. Hoffmann, Henry's law constants of some environmentally important
aldehydes, Environmental Science & Technology 22 (1988), 1415
[433] R. Sander (1999), Compilation of Henry's Law Constants for Inorganic and Organic Species of
Potential Importance in Environmental Chemistry (Version 3), http://www.henrys-law.org
[434] M. Bernauera and V. Dohnal, Temperature dependences of limiting activity coefficients and Henry's
law constants for N-methylpyrrolidone, pyridine, and piperidine in water, Fluid Phase Equilibria 282 (2009),
100

4.4: Solubility of Vanillin in organic solvents
In this example the solubility of Vanillin in 9 different solvents is calculated and compared to experiment.
Vanillin (4-Hydroxy-3-methoxybenzaldehyde) is a solid at room temperature. For the solubility of a solid, one
should include the melting point and the enthalpy of fusion of the solid in the right window of the List of
Added Compounds for a selected compound. If known the Δ heat capacity of fusion should also be
included, although it is often less important.
Remark: To only add the compounds needed in this example, one can also open a new COSMO-RS GUI
window (SCM → COSMO-RS), Select Compounds → Add Compound(s), go to the directory where the
COSMO-RS compound database is downloaded ($ADFHOME/atomicdata/ADFCRS-2010), and select
tutorial4.4.compoundlist. Then the added compounds are at the top of the list if one uses the '+' button, or
search button. The tutorial4.4.compoundlist is a file with a list of compounds that is limited to the compounds
needed in this example.
Select Compounds → List of Added Compounds
Click on the 'Search or add compound to the list of compounds'
A search window will pop up
Enter 'Vanillin' in the 'Search' field
Click on 'Vanillin'
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Click 'OK'
The search window will disappear
Click on the left side 'Vanillin'
Enter '355' in the 'Melting point:' field
Enter '5.35' in the 'Δ_fusion H:' field
Select Properties → Solubility in Pure Solvents
Check the '+' button to add pure compound solvents
'Water', '1,2-Dichloroethane'
'1-Propanol', 'Oxolane' (THF), 'Acetonitrile',
'2-Butanone', 'Ethanol', 'Methanol', and 'Toluene'
Enter '298.15' without quotes for the temperature in the 'from:' field in
'Kelvin'
Enter '298.15' in the 'to:' field in 'Kelvin'
Select 'Vanillin' for the 'Solute'
Change the popup menu next to Solute from 'Liquid' to 'Solid'
Press 'Run'

Note that for the calculation of the solubility in units of mol/L and g/L the program uses information of the
mass and COSMO volume of the solvent and solute. Especially the COSMO volume may not always be
accurate.
These results can be put in a table. Compared to experiment there can easily be a factor of 2 deviation.
Solvent
1
2
3
4
5
6
7
8
9

1,2-Dichloroethane
1-Propanol
Oxolane
Acetonitrile
2-Butanone
Ethanol
Methanol
Toluene
Water

experimental Solubility Vanillin (mol/
L) [441]
1.175
1.820
3.594
2.360
2.138
2.470
4.160
0.302
0.070

calculated Solubility Vanillin (mol/L
solution)
2.65
3.12
4.73
3.30
4.10
3.56
4.04
0.99
0.034

References
[441] Experimentally determined solubilities of Vanillin in some organic solvents were taken at July 15, 2010,
from http://old.oru.edu/cccda/sl/solubility/allsolvents.php?solute=vanillin.

4.5: Binary mixture of Methanol and Hexane
In this example a vapor-liquid diagram of Methanol and Hexane is calculated and compared to experiment.
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First a binary mixture of Methanol and Hexane is calculated at a constant temperature of 333.15 Kelvin.
Next this binary mixture is calculated at a constant pressure of of 1.01325 bar. Experimental pure compound
properties are used.
Select Compounds → List of Added Compounds
Add 'Methanol' and 'Hexane' to this list
Click on the left side 'Methanol'
Enter '0.845' in the 'Pure compound vapor pressure:' field
Enter '333.15' in the 'at temperature:' field
Click on the left side 'Hexane'
Enter '0.77' in the 'Pure compound vapor pressure:' field
Enter '333.15' in the 'at temperature:' field
Select Properties → Binary Mixture VLE/LLE
Select 'Methanol' for the first compound
Select 'Hexane' for the second compound
Enter '100' in the 'Number of mixtures' field
Select Isotherm, isobar, flash point → isotherm
Enter '333.15' for the 'Temperature' in 'Kelvin'
Press 'Run'
Select Graph → X Axes → x1, y1
Select Graph → Y Axes → total vapor pressure

In case of a miscibility gap there are two molar fractions x1 and x1', for which both compounds have the
same activities. In the calculation one can plot the activity a1 versus a2. If there is a closed loop, there is a
miscibility gap:
Select Graph → X Axes → a1: x1*gamma
Select Graph → Y Axes → activities

Thus there is a calculated miscibility gap. The properties of the two immiscible liquid phases are given in the
table: the calculated miscibility gap is between approximately x1 = 0.275 and x1' = 0.811, with a calculated
total vapor pressure of approximately 1.48 bar. Within the miscibility gap, the liquid mixture consists of 2
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immiscible liquid phases, one is Methanol-rich, the other Hexane-rich. Note, however, that within the
miscibility gap the COSMO-RS calculation further incorrectly uses a forced 1 liquid-phase instead of 2
immiscible liquid phases. Also note that a pressure-maximum azeotrope is in the miscibility gap.
If the check box Graph → X Axes → force 1 liquid phase within possible miscibility gap is selected,
then results will be shown also within the miscibility gap, with the unphysical conditions that the two liquids
are forced to mix. If the check box Graph → X Axes → force 1 liquid phase within possible miscibility
gap is deselected, then results will be shown in the graph and table only for those compositions of the
mixture, which are outside of the miscibility gap.

Deselect the check box Graph → X Axes → force 1 liquid phase within possible miscibility gap
Select Graph → X Axes → x1: molar fraction 1
Select Graph → Y Axes → excess energies

Select Compounds → List of Added Compounds
Click on the left side 'Methanol'
Enter '1.01325' in the 'Pure compound vapor pressure:' field
Enter '337.8' in the 'at temperature:' field
Click on the left side 'Hexane'
Enter '1.01325' in the 'Pure compound vapor pressure:' field
Enter '342' in the 'at temperature:' field
Select Properties → Binary Mixture VLE/LLE
Select 'Methanol' for the first compound
Select 'Hexane' for the second compound
Enter '100' in the 'Number of mixtures' field
Select Isotherm, isobar, flash point → isobar
Enter '1.01325' for the 'Pressure' in 'bar'
Press 'Run'
Select Graph → X Axes → x1, y1
Select Graph → Y Axes → temperature
Select the check box Graph → X Axes → force 1 liquid phase within possible miscibility gap
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There is a calculated miscibility gap between approximately x1 = 0.221 and x1' = 0.835, with a calculated
temperature of approximately 323.3 Kelvin (50.1 °C). Within the miscibility gap, the liquid mixture consists of
2 immiscible liquid phases, one is Methanol-rich, the other Hexane-rich. Note that if the check box 'force 1
liquid phase within possible miscibility gap' is selected, within the miscibility gap the COSMO-RS calculation
further incorrectly uses a forced 1 liquid-phase instead of 2 immiscible liquid phases. Also note that a
temperature-minimum azeotrope is in the miscibility gap.

Experimental results for the Methanol-Hexane mixture were taken from Ref. [451]. These are compared with
the calculated ones in the next graph. More experimental VLE data might also be found at Ref. [452].

References
[451] Wikipedia Hexane data page: http://en.wikipedia.org/wiki/Hexane_(data_page)
[452] CHERIC. Korea Thermophysical Properties Data Bank: Binary Vapor-Liquid Equilibrium Data

4.6: Large infinite dilution activity coefficients in Water
In this example infinite dilution activity coefficients of 31 organic compounds in Water are calculated and
compared to experiment.
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Remark: To only add the compounds needed in this example, one can also open a new COSMO-RS GUI
window (SCM → COSMO-RS), Select Compounds → Add Compound(s), go to the directory where the
COSMO-RS compound database is downloaded ($ADFHOME/atomicdata/ADFCRS-2010), and select
tutorial4.6.compoundlist. This is recommended. Then the added compounds are at the top of the list if one
uses the '+' button, or search button. The tutorial4.6.compoundlist is a file with a list of compounds that is
limited to the compounds needed in this example.
Select Properties → Activity coefficients
Select 'Water' for the first component in Solvent
Check the '+' button to add infinite dilute solutes:
'1,1,1-Trichloroethane', '1,2-Dichloroethane', '1-Bromobutane',
'1-Bromopropane',
'1-Chlorobutane', '1-Chlorohexane', '1-Chloropentane', '1-Chloropropane',
'1-Propoxypropane', '2-Bromobutane', '2-Bromopropane', '2-Chloropropane',
'Benzene', 'Bromoethane', 'Chloroform', 'Cumene', 'Dichloromethane',
'Diisopropyl_ether', 'Di-n-butyl_ether', 'Ethylbenzene', 'Ethyl_iodide',
'Mesitylene', 'm-Xylene', 'n-Butylbenzene', 'n-Propylbenzene',
'n-Propyl_iodide',
'o-Xylene', 'p-Xylene', 'Tetrachloroethene', 'Toluene', and 'Trichloroethene',
Press 'Run'
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These results can be put in a graph and a table. Experimental results taken from Ref. [461].

Solute

experimental γ2∞ [461]

calculated γ2∞

1
2
3
4
5

Dichloromethane
Diisopropyl_ether
1,2-Dichloroethane
Bromoethane
Chloroform

253
628
641
679
903

278
2343
976
601
1474

6

2-Chloropropane

1.48 103

1.42 103

7

1-Chloropropane

1.75 103

1.73 103

8

2-Bromopropane

2.09 103

1.77 103

9

Ethyl_iodide

2.19 103

1.19 103

10

1-Propoxypropane

2.31 103

4.89 103

11

Benzene

2.48 103

2.07 103

12

1-Bromopropane

2.86 103

2.36 103

13

1,1,1-Trichloroethane

5.90 103

5.77 103

14

1-Chlorobutane

7.61 103

7.25 103

15

2-Bromobutane

8.32 103

7.81 103

16

n-Propyl_iodide

8.55 103

5.16 103

17

Trichloroethene

8.75 103

6.45 103

18

Toluene

9.19 103

8.14 103

19

1-Bromobutane

1.22 104

0.93 104

20

o-Xylene

3.05 104

2.37 104

21

1-Chloropentane

3.21 104

3.13 104

387

22

Ethylbenzene

3.27 104

3.00 104

23

m-Xylene

3.32 104

3.56 104

24

p-Xylene

3.33 104

3.30 104

25

Tetrachloroethene

3.60 104

3.81 104

26

Di-n-butyl_ether

4.72 104

8.95 104

27

Cumene

1.02 105

0.83 105

28

Mesitylene

1.17 105

1.49 105

29

n-Propylbenzene

1.36 105

1.24 105

30

1-Chlorohexane

1.41 105

1.46 105

31

n-Butylbenzene

5.66 105

5.16 105

References
[461] J. Li, A.J. Dallas, D.I. Eikens, P.W. Carr, D.L. Bergmann, M.J. Hait, C.A. Eckert, Measurement of large
infinite dilution activity coefficients of nonelectrolytes in water by inert gas stripping and gas chromatography,
Analytical Chemistry 65 (1993), 3212

4.7: Parametrization of ADF COSMO-RS: ΔGhydr, vapor pressures,
partition coefficients
In Ref. [471] the ADF COSMO-RS parameters were fitted to 642 experimental values of properties for the
set of 217 molecules from the supplementary material of Klamt et al. [472]. These properties are the ΔG of
hydration, the vapor pressure, and the partition coefficients for Octanol/Water, Hexane/Water, Benzene/
Water, and Ethoxyethane/Water. In this example all these properties will be calculated for the set of 217
compounds, and the results will be put in this table, and compared to the experimental data collected by
Klamt. et al. in Ref. [471].
• Table with the calculated and 642 experimental values
Note that these calculations in this section may take a while, because of the many compounds calculated at
once.
Open a new COSMO-RS GUI window (SCM → COSMO-RS). Select Compounds → Add Compound(s)
go to the directory where the COSMO-RS compound database is downloaded ($ADFHOME/atomicdata/
ADFCRS-2010), and select tutorial4.7.compoundlist.

ΔG of hydration
Select Properties → Activity coefficients
Select 'Water' for the first component in Solvent
Enter '298.15' for 'Temperature Kelvin'
Click the check box 'Use input density solvent (kg/L)'
Enter '0.997' in the 'Use input density solvent (kg/L)' field
Check the '+' button to add infinite dilute solutes, the first 217 from the
list
Press 'Run'
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The results for the free energy of hydration (Δ G (kcal/mol) gas → solute) can be compared with
experimental values, see this table and next graph.

Vapor pressure
Select Properties → Vapor Pressure Pure Compounds
Enter '298.15' for 'Temperature Kelvin'
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Check the '+' button to add the first 217 from the list
Press 'Run'

One should take the log10 of the calculated vapor pressure in bar. The results for the calculated vapor
pressures can be compared with experimental values, see this table and next graph. Suggestion is to do this
only for a few molecules.
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Octanol-Water partition coefficients
Select Properties → Log Partition Coefficients
Select 'Preset Octanol-Water' in the popup menu next to Solvent
Enter '298.15' for the 'Temperature' in 'Kelvin'
Check the '+' button to add the first 217 from the list
to the list of infinite dilute solutes
Press 'Run'

The results for the Octanol-Water partition coefficients can be compared with experimental values, see this
table and next graph.
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Hexane-Water, Benzene-Water, and Ethoxyethane-Water partition coefficients
Select Properties → Log Partition Coefficients
Select 'Preset Hexane-Water' in the popup menu next to Solvent
Enter '298.15' for the 'Temperature' in 'Kelvin'
Check the '+' button to add the first 217 from the list
to the list of infinite dilute solutes
Press 'Run'
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Select Properties → Log Partition Coefficients
Select 'Preset Benzene-Water' in the popup menu next to Solvent
Enter '298.15' for the 'Temperature' in 'Kelvin'
Check the '+' button to add the first 217 from the list
to the list of infinite dilute solutes
Press 'Run'

Select Properties → Log Partition Coefficients
Select 'Preset Ether-Water' in the popup menu next to Solvent
Enter '298.15' for the 'Temperature' in 'Kelvin'
Check the '+' button to add the first 217 from the list
to the list of infinite dilute solutes
Press 'Run'

The results for the Hexane-Water, Benzene-Water, and Ethoxyethane-Water (Ether-Water) partition
coefficients can be compared with experimental values, see this table and next graph.
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Tutorial 5: pKa values
In the literature one can find several strategies to calculate pKa values. Some of these strategies involve the
inclusion of explicit solvent molecules, in combination with a continuum model, like COSMO. The strategies
described in the next examples do not take into account explicit solvent molecules, only the continuum
model is included.

5.1: Empirical pKa calculation method
In Refs. [511,512] one can find several strategies to calculate pKa values. The strategy described in this
example does not take into account explicit solvent molecules, only the continuum model is included. Like in
Ref. [512] an empirical fit is used to correlate calculated values with experimental pKa values, to account for
systematic errors. The largest errors are probably present in the calculation of the solvation energies of the
charged species. In these cases one probably should include explicit solvent molecules, however, that may
introduce other sources of errors, and this will not be investigated here. The calculation of pKa values of
acids (HA) and bases (B) is based on the following reaction model:
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(acids) HA (aq, 1M) + H2O (l, 1M) → H3O+ (aq, 1M) + A- (aq, 1M)
(bases) HB+ (aq, 1M) + H2O (l, 1M) → H3O+ (aq, 1M) + B (aq, 1M)

(5.1.1)
(5.1.2)

The free energy of dissociation for acids and bases is calculated as
(acids) ΔG*diss = G(A-) - G(HA) + G(H3O+) - G(H2O)
(bases) ΔG*diss = G(B) - G(HB+) + G(H3O+) - G(H2O)

(5.1.3)
(5.1.4)

The * denotes a standard state of 1M (1 mol/L). The pKa can then be calculated as (see for example Refs.
[511,512])
pKa = ΔG*diss/(RT ln(10)) - 1.74

(5.1.5)

At T = 298.15, 1/(RT ln(10)) = 0.733 mol/kcal. The term -1.74 is to correct for the standard state of liquid
water, which is 55 mol/L.
Emperical fit
Like in Ref. [512] instead of this equation (5.1.5), a linear fit has been made by correlating the calculated
ΔG*diss values with experimental pKa values, to account for systematic errors that are present in this
method. For acids and bases a different empirical adjusted equation will be used, optimized for the ADF
COSMO-RS implementation:
(acids) pKa = 0.62 ΔG*diss/(RT ln(10)) + 2.10

(5.1.6)

(bases) pKa = 0.67 ΔG*diss/(RT ln(10)) - 2.00

(5.1.7)

These fitted parameters are not so far from the fitted parameters in Ref. [512]. Zero-point vibrational
energies have not been taken into account in the calculation of the free energy of dissociation. H 3O+
(Hydronium ion) is the conjugate acid of Water. Molecules can have two or more equivalent sites for
protonation or deprotonation are also not taken into account, which can have an effect on the pKa value.
However, such effects are not taken into account here. Like for neutral compounds, one should optimize the
anions and cations in the gas phase, and use this geometry also in the COSMO calculation. It is important to
choose the lowest energy conformer. In the example below the molecules have a single relevant
conformation for the protonated and deprotonated form.
Acids
Copy the .coskf files which are listed in $ADFHOME/examples/crs/Tutorial5/tutorial5.1_acid.compoundlist
and the file tutorial5.1_acid.compoundlist the directory Tutorial. The tutorial5.1_acid.compoundlist is a file
with a list of acids and their conjugate bases that is limited to the compounds needed in this example. In
these .coskf files already the correct number of ring atoms is included.
Open a new COSMO-RS GUI window
Add the compounds listed in tutorial5.1_acid.compoundlist
Select Properties → Activity coefficients
Select 'Water' for the first component in Solvent
Enter '298.15' for 'Temperature Kelvin'
Check the '+' button to add the first 12 compounds from the list
Press 'Run'
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Using equation 5.1.6 (pKa = 0.62*0.733*ΔGdiss+2.10), with ΔGdiss = G(conjugate_base_acid) - G(acid) +
G(conjugate_acid_Water) - G(Water) in kcal/mol, results can be put in a table.

1
2
3
4
5

Acid
Methanol
Ethanol
Phenol
Acetic acid
Benzoic acid

experimental pKa [512]

calculated pKa

15.5
15.9
9.82
4.75
4.27

16.27
15.97
10.32
3.64
4.28

Bases
Copy the .coskf files which are listed in $ADFHOME/examples/crs/Tutorial5/tutorial5.1_base.compoundlist
and the file tutorial5.1_base.compoundlist the directory Tutorial. The tutorial5.1_base.compoundlist is a file
with a list of bases and their conjugate acids that is limited to the compounds needed in this example. In
these .coskf files already the correct number of ring atoms is included.
Open a new COSMO-RS GUI window
Add the compounds listed in tutorial5.1_base.compoundlist
Select Properties → Activity coefficients
Select 'Water' for the first component in Solvent
Enter '298.15' for 'Temperature Kelvin'
Check the '+' button to add the first 16 compounds from the list
Press 'Run'

Using equation 5.1.7 ((pKa = 0.67*0.733*ΔGdiss-2.00), with ΔGdiss = G(base) - G(conjugate_acid_base) +
G(conjugate_acid_Water) - G(Water) in kcal/mol, results can be put in a table.

1

Base
Aniline

experimental pKa [512]

calculated pKa

4.6

5.75
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2
3
4
5
6
7

1H-Imidazole
Pyrazine
Pyrazole
Pyridine
Quinoline
Guanidine

7
0.7
2.5
5.14
4.80
13.8

5.65
0.85
2.55
4.62
4.43
14.09
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5.2: Relative pKa calculation method
The method described in this example is based on one of the strategies in Ref. [521]. This method uses the
experimental pKa value of a reference compound, experimental gas phase deprotonation energies, and
COSMO-RS solvation free energies. A suitable reference compound (HRef) should be chosen, which is
similar to the actual compound (HA) one is interested in. For example, the deprotonation reaction could be
similar in both compounds. The calculation of pKa values is based on the following reaction model:

HA(aq, 1M)

↓ -ΔG*solv (HA)
HA(g, 1M)

+ Ref -(aq, 1M)

ΔG*soln

→

↓ -ΔG*solv (Ref -)
+ Ref -(g, 1M)

HRef(aq, 1M)

↑ ΔG*solv (HRef)
→
ΔG*gas

HRef(g, 1M)

+ A-(aq, 1M)

↑ ΔG*solv (A -)
+ A-(g, 1M)

The * denotes a standard state of 1M (1 mol/L). The free energy of solvation is then calculated as
ΔG*soln = ΔG*gas + ΔG*solv(HRef) + ΔG*solv(A-) - ΔG*solv(HA) - ΔG*solv(Ref -)
The pKa can then be calculated as (see for example Ref. [521])
pKa = ΔG*soln/(RT ln(10)) + pKa(HRef)
The success of this method relies on the availability of a suitable reference compound with an accurately
known experimental pKa value. Instead of experimental gas phase deprotonation energies one might
calculate the gas phase reaction free energy ΔG*gas, using DFT or some high level ab initio method.
Example Ethanol
In this example the pKa value of Ethanol will be calculated. As reference compound Methanol is chosen,
which has an experimental pKa value of 15.5. Experimental deprotonation energies are taken from Ref.
[521, supporting information], for Methanol this is ΔrG0 = 1569 kJ/mol, and for Ethanol ΔrG0 = 1555 kJ/mol,
see also, for example, Ref. [522]. The COSMO-RS solvation free energies of Methanol, Methoxide (the
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conjugate base of Methanol), Ethanol, and Ethoxide (the conjugate base of Ethanol) have already been
calculated in the previous tutorial 5.1. At T = 298.15, 1/(RT ln(10)) = 0.733 mol/kcal. The free energy of
solvation (kcal/mol) and the pKa of Ethanol are then calculated as
ΔG*soln = (1555-1569)/4.184 - 4.97 - 86.56 + 4.79 + 90.14 = 0.05 kcal/mol
pKa (Ethanol) = 0.733*0.05 + 15.5 ≈ 15.5
The calculated pKa of Ethanol of 15.5 is close to the experimental value of 15.9.
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