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Overview of the workshop
Use ParAMS to train ReaxFF and machine learning potentials
Morning (3 h)

General introduction of AMS (30 min)
The graphical user interface [Demo] (30 min)

15 minutes break
Theory background (40 min)
Introduction to ParAMS (40 min)
Tour of the ParAMS GUI [Demo] (20 min)

Lunch break (45 min)
Afternoon (3 h)

Optimize ReaxFF with ParAMS [Hands-on] (1 h)
15 minutes break

Optimize MLPotentials with ParAMS [Hands-on] (1 h)
Active Learning [Hands-on] (1 h)
Conclusions
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Get ready to run AMS
Download and install AMS2024

https://www.scm.com/support/downloads/
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Comments

We will teach you how to use the software but don’t expect to have a
production Force Field by the end of the day
We will leave time for questions at the end of each presentations
If you think your question is important and should be answered during
the presentation you should ask it
During [Demo], we will demonstrate how to perform various tasks
with the software
During [Demo], you can also try to reproduce some tasks but we
recommend you follow the demonstration in priority
During [Hands-on], we will ask you to perform some tasks with the
software
During [Hands-on], we will demonstrate the solution
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Software for Chemistry & Materials
History
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The Amsterdam Modeling Suite
Multiple engines to bridge the scales
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The Amsterdam Modeling Suite
A unified driver to explore PES
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Applications
Battery modeling

Diffusion coefficients
Diffusion path
Activation energies
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Applications
Polymer modeling

Polymer structure ⇔ properties
Side reactions
Mechanical properties
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Applications
Semiconductor modeling

Understand the formation of defects
Reactive interfaces
Diffusion, oxidation
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Applications
Catalysis

Understand heterogeneous catalysis
Binding sites energies
Transition states energies and structures

Sugiyama, Kanami, et al. PCCP 21.26 (2019): 14366-14375
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Applications
Summary

All this is great with accurate model potentials..
Below some examples of model improved via training & active
learning with ParAMS
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The GUI
AMSjobs

Manage jobs, set queues, number of processors, monitor job status,
etc.
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The GUI
AMSinput

Build molecule, crystals, select engine, task, settings, etc.
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AMSinput
Build a molecule

Build 1-butanol, add a ring
Pre-optimize the molecule
Rotate molecule, move it, Zoom-in/out
Orient it within xy, xz, yz plane
Vary distance, angle, dihedral
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AMSinput
Build a crystal

Search for NaCl, convert to conventional cell, show the unit cell
Clear the area, Edit → Crystal → Cubic → NaCl
Clear, Edit → Crystal → Hexagonal → MoS2 → WTe2
Clear, Edit → Crystal → Cubic → Diamond, Si
Generate slab, 111, 4 layers, generate supercell 4×4
Explore periodic views, and more on crystals and slabs
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https://www.scm.com/doc/Tutorials/BuildingStructures/BuildingCrystalsAndSlabs.html#crystalbuilding


AMSinput
Build a liquid mixture

Edit → Builder..
Fill box with 20 water, check density
Add 2 methanol, check density
Generate molecule..
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AMSinput
Geometry optimization

Build your favorite molecule with C, H, O, N, Si
Select Task → Geometry Optimization
Switch to ReaxFF engine, select the Glycine.ff Force Field
Save and run the optimization
SCM → movie to appreciate the relaxation
Select an angle, Graph → Distance, Angle, Dihedral
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AMSinput
Molecular dynamics

Build a box of methane and oxygen (15×15×15 Å, 15 CH4, 30 O2)
Switch to Task → Molecular Dynamics
Switch to ReaxFF, select the CHO.ff Force Field
Click > next to MD, set 50000 steps, initial temperature 3500 K
Click > next to Thermostat add NHC at 3500 K @ 100 fs
Save and run, watch the movie, add graph, plot some molecules, etc.
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AMSinput
PES scan

Build a methane molecule, periodicity None
Switch to Task → PES Scan
Click > next PES Scan, select C, H atoms, click + next CH distance
Input 20 points, from 0.8 to 3.0 Å, check for all PES points
Enable Nuclear gradients from the Properties → Gradients
Save and run, watch the movie
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AMSinput
Equation of states

Build NaCl, convert to conventional cell
Switch to Task → PES Scan
Switch to MLPotential engine and select M3GNet model
Click > next PES Scan, and click + Volume and scan from 0.9 to 1.1
Save and run, watch the movie
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15 min break
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Hierarchy of interatomic potentials
Why do we need complex potentials?

Summary of interatomic potentials.

#
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Empirical
potential type

Usage Feature Names

Pair-potential Noble gaz E ∝ Z LJ, Morse,
Buckingham

Pair-functional Metals E ∝
√

Z EAM
Many-body
potentials

Opened structures
Organic molecules

Angles,
dihedral, etc.

OPLS,
DREIDING

Reactive
potentials

Chemistry, charge
transfer/polarization

Many-body
+BO, QEq

Tersoff, ReaxFF,
REBO, COMB

and Machine Learning Potentials..
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ReaxFF: functional form
Potential energy, bond order, bond energy

Total potential energy: ReaxFF parameters documentation

Epot = Ebond + Eang + Etor + Eover︸ ︷︷ ︸
f[BO]

+EvdW + Ecoul + · · ·

Bond order & bond energy

BOij = exp
[
pbo1

( rij
rσ0

)pbo2]
+ exp

[
pbo3

( rij
rπ0

)pbo4]
+ exp

[
pbo5

( rij
rππ0

)pbo6]
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ReaxFF: functional form
Valence angle, over coordination

Valence angle energy

Eang ≈
[
1− exp

(
−pval3BOpval4

ij

)] [
1− exp

(
−pval3BOpval4

jk

)]
×
[
pval1 − pval1 exp

(
−pval2 (Θijk −Θ0)

2
)]

Over/under coordination penalties

etc.
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ReaxFF: functional form
Non-bonded interactions

vdW ∼ Morse
Coulomb

Shielded Coulomb calculated between all pairs of atoms
Charges are calculated at every step with the charge equilibration
(QEq, ACKS2)
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ReaxFF: force field
Structure

General parameters (apply to every types of atom): GEN (in ParAMS)
Atomic parameters (for each type of atoms): ATM
Bond parameters (for each pairs/bonds defined): BND
Off-diagonal parameters (for each pairs/non-bonded defined): OFD
Angle parameters (for each triplets/angles defined): ANG
Torsion parameters (for each quadruplets/torsion defined): TOR
Hydrogen bond parameters (for each pairs/hydrogen bonds defined): HBD
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ReaxFF: training set
Recommendations to create a dataset to optimize ReaxFF

What do we need to include to the training set?
Equilibrium, out-of-equilibrium structures
PES Scan of dissociation, angle bend, torsion
Transition states, equation of states, defects, etc.
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Theory of Machine Learning Potentials
Goal of ML Potentials

goal is to find f(atom positions, atom types,PBC, other) = EPot

derivatives automatic with ML frameworks −∂EPot
∂x = −∂f(x,...)

∂x = F
Swap with an engine in AMS (e.g. ReaxFF or DFTB) and do MD/GO
Fit f based on reference data
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Theory of Machine Learning Potentials
Embeddings

Atom number to vector description
Periodic table of elements is human embedding
Improved scaling w.r.t. number of atom types
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Theory of Machine Learning Potentials
Locality

Predict properties for each atom based on environment

H3C

N

O

N
CH3

ON

CH3

N

Sum or average atomic properties to obtain global properties
Scales well with number of atoms and computational resources
Physical interpretation
Short range interactions dominate
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Theory of Machine Learning Potentials
Equivariant Graph

Molecule as a graph
Rotate graph -> rotate prediction
Permutation of atoms
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Theory of Machine Learning Potentials
Fitting Procedure

The goal is to fit a potential energy surface (PES) using machine
learning models.
This procedure involves training a model to predict the energy of a
system based on atomic positions and types.

Mathematical Formulation
The energy E of a system can be approximated by a function f
parameterized by θ, learned from training data:

E ≈ f(r; θ)
where r represents the positions of atoms.
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Theory of Machine Learning Potentials
Fitting Procedure

Objective Function
The fitting involves minimizing the loss function L, typically the mean
squared error between predicted and true energies:

L(θ) = 1

N

N∑
i=1

[f(ri; θ)− Ei]
2

where Ei and ri are the true energies and atomic positions for eachtraining example.

Optimization by Gradient Descent
Update rules based on the gradient of the loss function:

θ ← θ − η∇θL(θ)
where η is the learning rate.

ParAMS Workshop 2024 | 37/122
Machine Learning Potential
Theory background



Theory of Machine Learning Potentials
Transfer Learning

”Transfer learning is a ML method where knowledge from one model is
transferred to enhance another model”

Start with a pre-trained model
Fine-tune by fitting few parameters
Saves time and computational resources
Often achieves superior results
Particularly effective when new data is scarce
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Theory of Machine Learning Potentials
Committee Uncertainty

Fit multiple models
fi(x)

Prediction is the average

µ(x) = 1

N

N∑
i

fi(x)

Uncertainty is standard deviation

σ(x) =

√√√√ 1

N− 1

N∑
i
(fi(x)− µ(x))2
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Theory of Machine Learning Potentials
M3GNet

Universal pre-trained parameters available
93 elements
Transfer learning
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Theory of Machine Learning Potentials
NequIP

State-of-the-art accuracy
Relatively slow
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ParAMS
Features
Selected features:

Import reference data from AMS, VASP, Quantum ESPRESSO,
Gaussian, or experiment
Use a validation set to prevent overfitting
Submit jobs to remote machines using the GUI
Results updated on-the-fly in the GUI with many diagrams
Many properties: reaction energies, forces, bond lengths, angles, cell
parameters, stress tensors, charges and user defined.
Use single points, geometry optimizations, or PES scans during the
parametrization
Set custom weights
Choose which parameters to optimize, and set allowed ranges
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Preparametrized models in AMS

AMS comes with many published ReaxFF force field and DFTB
parameters.
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Industry Example
ReaxFF and DFTB Problems

They are not always accurate enough for ”unseen” structures or
molecules
Example from an AMS industry customer: lithium
bis(fluorosulfonyl)imide in organic solvent COCC

Published ReaxFF predicts that a fluorine atom dissociates from the
anion
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Industry Example
Published ReaxFF predictions
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Industry Example
AMS: Easily verify/disprove ReaxFF prediction with DFT
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Industry Example
AMS and ParAMS make it easy to fix the issue

For this example:
Set up new DFT calculations: 1 hour
Run DFT calculations: 1 hour
Set up ParAMS 20: 20 minutes
Reoptimize ReaxFF parameters: 10 seconds
Validate the new ReaxFF: 1 hour

0 lines of code! All steps supported by the graphical user interface.
Start from one of the many tutorials and modify as needed.
Note: Most parametrization projects will take longer
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Industry Example
Reoptimized ReaxFF predictions

ParAMS Workshop 2024 | 49/122
Optimization principle and workflow
Introduction to ParAMS



ParAMS conclusions
Typical Workflow

Validate an initial ReaxFF parameters (if it exists)
Set up new DFT calculations
Run DFT calculations
Set up ParAMS
Run parameter optimization
Validate new ReaxFF parameters

iterative
improvement
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ParAMS Conclusion
Best practices

Which parameters to optimize?
Choose as few as possible
Fist try parameters in the ”standard” category
If a parameter value is close to min/max, change the range and
continue

Which optimization algorithm?
CMA-ES recommended for most optimization problems
Details about this algorithm in previous seminar
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ParAMS Conclusion
Sensitivity

Too few parameters might make it difficult to find a good fit.
Too many parameters will make the optimization harder, slower, and
increase the risk of overfitting.
Sensitivity is calculated using the Hilbert-Schmidt Independence
Criteria (HSIC)
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ParAMS Conclusion
Sensitivity

Obtain estimate of change of loss with change of parameters
Larger influence on the loss means a parameter is more important
Sample different parameters and obtain loss function
Obtain HSIC using (gaussian) kernel
Easy to interpret: sum is 1 and larger means more important
Not needed for ML since partial derivatives are similar
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Data Model
Overview

Dataset: Reference or inference values
JobCollection: Input settings required for reference/inference

Training Set
Validation Set
Test Set

EngineCollection: Engine settings (e.g. DFT functional)
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Data Model
Types of Reference Values

Anything that can be extracted from a job can be a reference value
Forces, atomic charges
Optimized bond lengths or angles
PES scans: Energy vs bond length, angle or cell volume

Values from multiple jobs:
Reaction: Adsorption energy, surface energy, formation energy, ..

Job1 forces

charges

energy

Job2 energy
− Reaction energy

charges

forces

Job Extractor Ref. value
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Data Model
Example reference values: Forces and Charges
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Data Model
Example reference values: Optimized bond lengths and angles

For bond lengths and angles, add geometry optimization jobs!
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Data Model
Example reference values: Bond scan, angle scan, lattice scan

For PES scans, add PES Scan jobs!
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Data Model
Example reference values: Reaction energy

Propane Combustion:C3H8(g) + 9
2O2(g)→ 3CO2(g) + 3H2O(g)

Automatically balanced stoichiometric coefficients!
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Data Model
Differences for Machine Learning Models

Machine learning requires partial derivatives
Can only include direct predictions

Single Point jobs
Energies
Forces
Stresses
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Active Learning
Automatic Training Workflow
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Active Learning
Overview

The workflow:
Trains an initial ML Potential
Runs the MD simulation with ML
Pauses the MD simulation and runs reference calculations
Retrains the ML Potential to the new reference data
Rewinds the MD simulation to the last point where it was known to
be accurate
Continue the MD simulation
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Active Learning
Input

Input System. This is the initial system for the MD simulation. The input
is exactly the same as for any other AMS simulation.
Molecular dynamics settings. It can be equilibrium or non-equilibrium
MD. The settings/input are exactly the same as for any other AMS
simulation.
Reference engine settings. This can be any engine, primarily DFT
engines: ADF, BAND, or Quantum ESPRESSO. The settings/input are the
same as for any other AMS simulation. This determines the level of theory
to which the ML potential is trained.
ParAMS ML training settings. You can train any ML potential that is
supported by ParAMS, for example, M3GNet. The settings/input are exactly
the same as for running standalone ParAMS with Task MachineLearning.
Active learning settings. These settings determine, for example, how
frequently to launch new reference calculation, and how to judge if the ML
potential is accurate enough.
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Active Learning
Rewind Molecular Dynamics
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Active Learning
Uncertainty
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Active Learning
Advantages vs Disadvantages
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Tour of the ParAMS GUI
Lennard-Jones Gas

The Lennard-Jones potential is a simple model that describes the
interaction between a pair of neutral atoms or molecules.
It is particularly noted for its ability to capture the balance between
attractive and repulsive forces experienced by particles:

V(r) = 4ϵ

[(σ
r
)12
−
(σ

r
)6

]
(1)

where:
ϵ is the depth of the potential well,
σ is the finite distance at which the inter-particle potential is zero,
r is the distance between particles.

This potential is used extensively in molecular dynamics simulations
of gases, liquids, and solids.
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Tour of the ParAMS GUI
Workflows

GUI: Recommended main interface allowing you to easily setup tasks,
visualize results, and submit local or remote jobs.
Scripting: Python/PLAMS interface to ParAMS allowing you to
integrate it into data workflows and easily setup multiple
configurations. Use the $AMSBIN/amspython program to execute
python scripts.
Command-line: Console interface for systems without GUI support
(e.g. submitting jobs on a cluster). This is not discussed today.
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Tour of the ParAMS GUI
Required Files

copy $AMSHOME/scripting/scm/params/examples/LJ_Ar
For this example the reference data has already been computed
Open with $AMSBIN/params
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ParAMS Input
Parameter Interface

Parameters tab
value and allowed ranges
active: fit or not
val%: how close to min/max

ParAMS Workshop 2024 | 71/122
ParAMS Input
Tour of the ParAMS GUI [Demo]



ParAMS Input
Job Collection

periodic view
jobs tab
Job-ID
Detail
Ref Engine
ParAMS Engine
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ParAMS Input
Training set

Training tab
Energy
Forces
Detail (clickable)

expression
sigma
weight
unit
balance

value
predicted
Loss%: contribution to the loss function
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ParAMS Input
ParAMS Settings

Main panel
Optimizers
Time limit
Max optimizers converged
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Run ParAMS
Run

Save as
Run
AMSJobs
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ParAMS Results
Best Parameter

parameters tab
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ParAMS Results
Correlation Plots

Graphs Panel
Loss function
RMSE
Scatterplot - select points to view outliers
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ParAMS Results
Error Plots

Stats - Forces
MAE/RMSE
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ParAMS Results
Parameter Plots

active parameters
eps
rmin
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ParAMS Results
Editing and saving plots

double click
axis
general
File: save graph as
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ParAMS Results
Predicted values

Training set panel
Prediction column
info panel to see all
Results Panel
loss contributions
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ParAMS Results
Summary statistics

Results panel
Training best: stats
MAE and RMSE
N
loss contributions
find ”bad” parts
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ParAMS Results
Output structure
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Lunch
Hands-on in the afternoon
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Train ReaxFF with ParAMS
Simple water molecule example

In this example we will fit a ReaxFF force field
The goal is to reproduce DFT bond dissociation and angle curves of
water in the gas phase
You will learn how to:

1. Generate the reference data
2. Import the data into ParAMS
3. Evaluate the sensitivity of the parameters [optional]
4. Optimize the parameters
5. Analyze the results

ParAMS Workshop 2024 | 86/122Optimize ReaxFF with ParAMS [Hands-on]



Reference data
PES Scans

Create a water molecule
Use ADF engine and keep the default settings
Perform a PES Scan to dissociate H from O from 0.85 to 2.0 Å in 11
steps
Perform a PES Scan to bend the H-O-H angle from 70 to 150 degrees
in 11 steps
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Import data into ParAMS
Training set

Import the PES Scans into ParAMS as Single Job PES Scans
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Sensitivity analysis [optional]
Which parameters to optimize?

Switch to ReaxFF parameters (Parameters → ReaxFF)
Load the Water2017.ff Force Field (Parameters → Load ReaxFF
ForceField..)
Select all bond and angle parameters corresponding to H.O and
H.O.H, respectively
Switch to task Sensitivity, check Run sampling, and set repeat the
calculation to 5 with 500 samples per repeat
Save the job and run the sensitivity analysis
From this morning’s lesson, try to guess which parameters will be the
most sensitive
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Sensitivity analysis [optional]
Analysis

Appreciate the sensitivity of the parameters in the Results tab
You should be able to understand the most sensitive parameters from
the theory background lesson of this morning
From the Parameters tab, unselect the non-active parameters to
display only the active parameters
From the Sensitivity tab, sort the parameters by decreasing order
We will only optimize parameters with large sensitivity
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Parameters optimization
Let’s optimize ReaxFF!

Select the 4 parameters to optimize: H.O:D_e^sigma, H.O:p_bo1,
H.O:p_bo2, H.O.H:Theta_0,0
Setup an optimization with CMAES optimizer
Set the max loss function calls to 100
In Options → Optimizer set (σo, Popsize, Min sigma) to (0.1, 10,
0.0001)
Save the job and run the parameters optimization

ParAMS Workshop 2024 | 91/122Optimize ReaxFF with ParAMS [Hands-on]



Parameters optimization
Analysis

During the optimization you can appreciate the loss function being
minimized
Compare the dissociation and angle bend PES with the initial
prediction
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Optional (1)
Reaction energy

Optimize the geometry of H2O, O2 (triplet) and H2 molecules with ADF
Open a new ParAMS window, File → New to clear it up
Import the 3 molecules as Single Job, Geometry Optimization, Energy

We can now define the reaction energy corresponding to H2O → H2 + 1
2O2

Select the H2O entry and duplicate it with Training Set → Add → Energy
Double click on the new H2O entry
Type energy("water")-energy("hydrogen")-energy("oxygen") in the
Energy box replacing water, hydrogen, oxygen with the name of your
respective jobs (written in the Details column)
Click the Balance button to balance the equation automatically
Delete the value in the Values box and click OK

Run a Single Point task to evaluate the reaction energy with ReaxFF
Load the Water2017.ff Force Field
Select Single Point task and run with the defaults settings
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Optional (2)
Already finished?

If you were to create a ReaxFF for water, what other interactions are
important?
What can you add to the training set to describe these additional
interactions?
Build the additional systems, perform the DFT calculations, run the
sensitivity and the optimization again
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Overview of the workshop
Use ParAMS to train ReaxFF and machine learning potentials
Morning (3 h)

General introduction of AMS (30 min)
The graphical user interface [Demo] (30 min)

15 minutes break
Theory background (40 min)
Introduction to ParAMS (40 min)
Tour of the ParAMS GUI [Demo] (20 min)

Lunch break (45 min)
Afternoon (3 h)

Optimize ReaxFF with ParAMS [Hands-on] (1 h)
15 minutes break

Optimize MLPotentials with ParAMS [Hands-on] (1 h)
Active Learning [Hands-on] (1 h)
Conclusions
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Train M3GNet with ParAMS
Simple liquid Ar example

In this example we will fit a M3GNet force field
The goal is to optimize M3GNet to describe liquid Ar
You will learn how to:

1. Generate some reference data
2. Import the data into ParAMS
3. Optimize M3GNet and committees
4. Analyze the results
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Reference data
Load the data

Start ParAMS, clear it with File → New, if needed
Load the dataset for Argon using one of this procedure:

File → Open and navigate to
$AMSHOME/scripting/scm/params/examples/M3GNet/params.in
or download the file from here and import it with File → Open and
navigate to the params.in file you just downloaded
or from a Terminal type params -gui
$AMSHOME/scripting/scm/params/examples/M3GNet/params.in

This loads a few liquid argon structures and sets up some ML training
settings
For training machine learning potentials, you can only train to
single-point energy and forces
Verify from the job collection that the imported dataset will work
with MLPotentials training
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Reference data
Training and validation set

Count the number of configurations included in the training and
validation sets
Verify that the energy and forces for a given job belong to the same
data set
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Reference data
PES scan
We will add the PES corresponding to 2 Ar atoms as a function of
separation

Start AMSinput
Switch to Force Field engine, keep the defaults settings
Create 2 Ar atoms separated by 2 Å
If there is a bond, delete it (select the bond and press delete)
Switch to PES Scan
Setup a PES Scan to scan the distance between the 2 Ar from 2 to 4
Å in 11 steps
Check the box to save the results for all PES points
Enable the calculation of the nuclear gradients in Properties →
Gradients, Stress tensor
Save and run the PES Scan
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Reference data
Training and validation set

Import the PES Scan to ParAMS as Single Job, PES Scan.
Do you get one (or two) warning messages from ParAMS? if yes why?
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Training
Train M3GNet from scratch

Go over the settings for the Machine Learning task and be sure you
understand them
Save and run the optimization
During training you can appreciate the minimization of the loss
functions
Is the training ended before the 150 max epochs set? If yes why?

Note that because ML training can only take single points, the PES Scan
added before was not used during training. However, at the end of the
training, the PES Scan was evaluated with the final parameters.

Look in the dropdown menu of the graphs and find the PES Scan
prediction and reference calculations
Does it look accurate?
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Training
Train M3GNet from scratch

from the previous optimization, import the PES Scan to ParAMS as
PES Scan SinglePoints and set the Properties to energy and forces
Change units to eV and eV/Å to be consistent with the dataset
already loaded
Is the imported data added to the training set or validation set?
Save and run the ParAMS optimization
Once finished, check the PES Scan. Is it accurate now?
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Optional 1
Run MD with the optimized model

From ParAMS you can easily export the optimized model into
AMSinput
File → Open Optimized Engine in AMSinput → Best validation
Propose a way to build a box filled with Ar atoms
Setup an MD simulation with the optimized model for 10000 steps
starting with velocities at 300 K
Run the MD simulation
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Optional 2
Train a committee of M3GNet

Re-optimize the model, this time with a committee size equal to 4
Appreciate the loss for each committee
Export the model to AMSinput
Run an MD simulation with the optimized model
Appreciate the uncertainties during the MD simulation
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Overview of the workshop
Use ParAMS to train ReaxFF and machine learning potentials
Morning (3 h)

General introduction of AMS (30 min)
The graphical user interface [Demo] (30 min)

15 minutes break
Theory background (40 min)
Introduction to ParAMS (40 min)
Tour of the ParAMS GUI [Demo] (20 min)

Lunch break (45 min)
Afternoon (3 h)

Optimize ReaxFF with ParAMS [Hands-on] (1 h)
15 minutes break

Optimize MLPotentials with ParAMS [Hands-on] (1 h)
Active Learning [Hands-on] (1 h)
Conclusions
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Simple Active Learning
Input

Input System. This is the initial system for the MD simulation. The input
is exactly the same as for any other AMS simulation.
Molecular dynamics settings. It can be equilibrium or non-equilibrium
MD. The settings/input are exactly the same as for any other AMS
simulation.
Reference engine settings. This can be any engine, primarily DFT
engines: ADF, BAND, or Quantum ESPRESSO. The settings/input are the
same as for any other AMS simulation. This determines the level of theory
to which the ML potential is trained.
ParAMS ML training settings. You can train any ML potential that is
supported by ParAMS, for example, M3GNet. The settings/input are exactly
the same as for running standalone ParAMS with Task MachineLearning.
Active learning settings. These settings determine, for example, how
frequently to launch new reference calculation, and how to judge if the ML
potential is accurate enough.
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Active Learning
Input System

Open AMSInput
Switch ADF to MD Active Learning
Select File → Import Coordinates… → From SMILES, type OCC=O
and click OK
You can also use another SMILES string for a (small) molecule of
interest
Preoptimize molecule
Make any modifications you wish
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Active Learning
Reference Engine

Select a reference engine from the drop down menu.
For workshop select a fast engine like ForceField or MLPotential
Production work typically uses ADF/Band/QuantumESPRESSO etc
Click the new engine tab
Return to the main panel
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Active Learning
Molecular Dynamics settings

Go to the MD panel by clicking next to the Task
Setup 100000 steps with a time step of 0.5fs
Setup an NHC thermostat at 300K with a damping constant of 200fs
Return to the main panel
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Active Learning
Machine Learning Settings

Verify backend is M3GNet (default)
Go to the Machine Learning panel
Set up transfer learning
What does committee size do?
What does the learning rate do?
Feel free to pick different settings to compare
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Active Learning
Active Learning Settings

Initial Reference Data
Obtain initial reference data using M3GNet Universal Potential

Step sequence
Geometric increasing steps, 5 steps, 10 MD frames for first step

Success criteria
At what accuracy is a step considered successful?

Reasonable simulation criteria
Go to the Model → Reasonable Simulation Criteria panel
Why are the maximum temperature and minimum distance important?
How to ”unlock” energy and gradients uncertainty?
Why is uncertainty helpful?
What is the downside?
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Active Learning
Other Settings

Go to the Details → Active Learning panel
What to do at the end: retrain and/or rerun simulation. Why?
What data to save. Why save intermediate steps?
Determine how many attempts to make per step.
Determine how many reference calculations to perform per attempt.
Parallel settings
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Active Learning
Run the active learning

File → Save
File → Run
Log file
MD Trajectory
Training and Validation results
Open newly trained model in AMSInput
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Active Learning
Log file

The active learning loop is not deterministic, so your results are likely to
look a little different.
In the timings, we see that very little time was spent on reference
calculations, which makes sense since we used the UFF force field.
In the summary, some of the attempts are marked as FAILED. This means
that the energy/forces of the structure in the MD simulation was not
predicted accurately enough in comparison to the reference method. This
triggers a retraining of the ML model, and then the step is reattempted.
The final engine settings contains an Engine block that can be used in
AMS text input files to use your final trained model in production
simulations. Note that the units are always “eV” and “angstrom”, no matter
which units you use for the reference data in ParAMS.
You can copy-paste all the lines Engine MLPotential … EndEngine directly
into AMSinput, in order to set up a new job with your trained model.
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Active Learning
MD Trajectory

In AMSjobs, select the job and choose SCM → Movie
To open the most recent file, you may need to close AMSmovie and
start it again.
In AMSMovie, you can select File → Related files to see some of the
other available trajectory files.
If you open the trajectory files before the active learning loop finished,
you may see strange jumps or discontinuities in the plotted Energy.
This is because the ML model is retrained on-the-fly!
If the “Rerun simulation at end” option is enabled (it is enabled by
default), then the trajectory in the final_production_simulation
directory contains the entire trajectory calculated with only the final
parameters.

ParAMS Workshop 2024 | 115/122
Train M3GNet
Active Learning [Hands-on]



Active Learning
Training and validation results

In AMSjobs, select the job and choose SCM → ParAMS
What can you learn from the loss function graph?
What can you learn from the scatter plots?
In ParAMS, select File → Open Optimized Engine in AMSinput →
Best validation

ParAMS Workshop 2024 | 116/122
Train M3GNet
Active Learning [Hands-on]



Simple Active Learning
Examples page

Active learning is useful for many experiments
We have a page with examples:

https://www.scm.com/doc/Workflows/SimpleActiveLearning/PythonExamples/PythonExamples.html
Most examples take 1 day or more to run
Fit ML potential for reactions
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Simple Active Learning
Reaction before fitting
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Simple Active Learning
Reaction after fitting
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Overview of the workshop
Use ParAMS to train ReaxFF and machine learning potentials
Morning (3 h)

General introduction of AMS (30 min)
The graphical user interface [Demo] (30 min)

15 minutes break
Theory background (40 min)
Introduction to ParAMS (40 min)
Tour of the ParAMS GUI [Demo] (20 min)

Lunch break (45 min)
Afternoon (3 h)

Optimize ReaxFF with ParAMS [Hands-on] (1 h)
15 minutes break

Optimize MLPotentials with ParAMS [Hands-on] (1 h)
Active Learning [Hands-on] (1 h)
Conclusions

ParAMS Workshop 2024 | 120/122
Train M3GNet
Conclusions



Overview of the workshop
Use ParAMS to train ReaxFF and machine learning potentials
Morning (3 h)

General introduction of AMS (30 min)
The graphical user interface [Demo] (30 min)

15 minutes break
Theory background (40 h)
Introduction to ParAMS [Demo] (1 h)

Lunch break (45 min)

Afternoon (4 h)
Optimize ReaxFF with ParAMS [Hands-on] (2 h)

15 minutes break
Optimize MLPotentials with ParAMS [Hands-on] (1 h)
Active learning [Hands-on] (1 h)
Conclusions
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What next?
Learn more about AMS

Get a trial license www.scm.com/trial
Explore more ParAMS examples www.scm.com/ParAMS
Get a license: contact your local reseller
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